Subject: [EToSat] [IETF106] Proposed workshop on QUIC performance over high BDP

From: Kuhn Nicolas <[email-masked]>
Date: Tue, 5 Nov 2019 08:57:10 +0000

Hi,

There are multiple drafts related to the performance of QUIC over large BDP networks (draft-kuhn-quic-4-sat, draft-kuhn-quic-0rtt-bdp, draft-ietf-quic-recovery) or related to the performance of encrypted protocols in general (draft-fairhurst-tsvwg-cc).
The objective of this workshop is to gather people interested in such activity and discuss the best way towards better end user experience in this use case.

Details : https://trac.ietf.org/trac/ietf/meeting/wiki/106sidemeetings
Time : 3pm30 - 4pm30 on Wednesday
Where : Bras Basah https://datatracker.ietf.org/meeting/106/floor-plan?room=bras-basah#raffles-city-convention-center

Proposed agenda:
Introduction : contributions that showed performance issues with QUIC over satellite links
draft-kuhn-quic-0rtt-bdp : solution to let both client and server know the path characteristics
draft-kuhn-quic-4-sat : what can be done once both client and server have this information
draft-fairhurst-tsvwg-cc : generalization to any transport and best current practice on internet congestion control at end points
If time permits: sharing experimental results (interaction between transport and high BDP systems)

If there is anything you would like to present please let us know.

Kind regards,

Nico, Gorry and Emile

---

From: Joerg Ott <[email-masked]>
Date: Tue, 5 Nov 2019 10:38:06 +0100

Hi guys,

great activity -- we also did extensive emulation studies for QUIC
over satellites in a controlled environment.  Would be happy to
share those findings if room.

Cheers,
Jörg

On 05.11.19 09:57, Kuhn Nicolas wrote:
> Hi,
> 
> There are multiple drafts related to the performance of QUIC over large 
> BDP networks (draft-kuhn-quic-4-sat, draft-kuhn-quic-0rtt-bdp, 
> draft-ietf-quic-recovery) or related to the performance of encrypted 
> protocols in general (draft-fairhurst-tsvwg-cc).
> 
> The objective of this workshop is to gather people interested in such 
> activity and discuss the best way towards better end user experience in 
> this use case.
> 
> Time : 3pm30 – 4pm30 on Wednesday
> 
> Where : Bras Basah 
> https://datatracker.ietf.org/meeting/106/floor-plan?room=bras-basah#raffles-city-convention-center 
> 
> 
> Proposed agenda:
> 
> draft-fairhurst-tsvwg-cc : generalization to any transport and best 
> current practice on internet congestion control at end points
>

---

From: Gorry Fairhurst <[email-masked]>
Date: Tue, 5 Nov 2019 10:11:53 +0000

Yes, that sounds fun! - which QUIC implementation were you using, just 
so we can make sure we compare like-with-like, and did you use an 
operational satellite system or an emulation, or something in-between?

Gorry

On 05/11/2019 09:38, Joerg Ott wrote:
>> There are multiple drafts related to the performance of QUIC over 
>> large BDP networks (draft-kuhn-quic-4-sat, draft-kuhn-quic-0rtt-bdp, 
>> activity and discuss the best way towards better end user experience 
>> in this use case.
>>

---

From: Joerg Ott <[email-masked]>
Date: Wed, 6 Nov 2019 20:46:18 +0100

We used quicly as QUIC implementation and built our own little
qperf (https://github.com/rbruenig/qperf) for running our experiments.

We did not use a full-blown satellite simulator but rather focused on
latency and capacity caps as well as (random) packet losses.  We just
used tc/netem qdisc for link emulation.

Jörg