Subject: [EToSat] Integrated VPN/PEP software

From: Joerg Deutschmann <[email-masked]>
Date: Wed, 17 Mar 2021 21:29:18 +0100

Dear all,

with the increased demand for home office, the problem of VPNs and the 
non-applicability of geostationary satellite PEPs has shown up more 
frequently. Can you give me some hints regarding software and/or 
tutorials which combines VPN client/server and "user-provided" PEPs?

As illustrated by "C" here:
https://www7content.cs.fau.de/~deutschmann/Figure-VPN-PEP.png

Please mention open source as well as proprietary software (although the 
former is preferred). Pointers to papers are also highly appreciated.

Thanks and best regards,
Joerg

-- 
Computer Science, Chair for Computer Networks and Communication Systems
Universität Erlangen-Nürnberg
Martensstr. 3, D-91058 Erlangen, Germany
e-mail: [email-masked]

---

From: Kuhn Nicolas <[email-masked]>
Date: Thu, 18 Mar 2021 07:33:22 +0000

Dear Joerg, 

We are currently running experiments using VPN and PEP. 
Our current approach is to combine PEPSal [https://wiki.net4sat.org/doku.php?id=pepsal:index] and OpenVPN [https://openvpn.net/].

We propose an experimental open-source orchestrator, OpenBACH, to run all our tests [https://wiki.net4sat.org/doku.php?id=openbach:index].
It can currently be used to orchestrate the tests you are describing using PEPSal [https://wiki.net4sat.org/doku.php?id=openbach:exploitation:jobs:pep_1.1] and OpenVPN [https://wiki.net4sat.org/doku.php?id=openbach:exploitation:jobs:openvpn_1.0].
An example on how to use OpenBACH on a simple platform can be found here : https://forge.net4sat.org/kuhnn/openbach-example-4-agent 
Let me know if you are interested in having more information. 

Cheers, 

Nicolas

-----Message d'origine-----
De : EToSat <[email-masked]> De la part de Joerg Deutschmann
Envoyé : mercredi 17 mars 2021 21:29
À : [email-masked]
Objet : [EToSat] Integrated VPN/PEP software

Dear all,

with the increased demand for home office, the problem of VPNs and the non-applicability of geostationary satellite PEPs has shown up more frequently. Can you give me some hints regarding software and/or tutorials which combines VPN client/server and "user-provided" PEPs?

Please mention open source as well as proprietary software (although the former is preferred). Pointers to papers are also highly appreciated.

Thanks and best regards,
Joerg

--
Computer Science, Chair for Computer Networks and Communication Systems Universität Erlangen-Nürnberg Martensstr. 3, D-91058 Erlangen, Germany
e-mail: [email-masked]

---

From: Joerg Deutschmann <[email-masked]>
Date: Thu, 18 Mar 2021 09:31:59 +0100

Dear Nicolas,

that combination was also what I had in mind: PEPsal (/the/ open source PEP) and OpenVPN (commonly used VPN software). And thanks for pointing to the net4sat project (which I'm aware of, great work).

A skilled computer or networking professional probably could set this up on his own. However, IMHO an average system administrator may need some more user-friendly setup. Maybe a compiled PEPsal package and some scripts to administrate PEPsal considering the OpenVPN configuration. And some documentation/HowTo. Ideally, OpenVPN would integrate the PEPsal code so that one could simply turn on the PEP functionality via a configuration switch.

I'd be very interested in your results. Maybe I'll find some time or volunteers to repeat your experiments and/or create a similar setup. In the meantime, also pointers to proprietary software would be interesting.

Thanks,
Joerg

On 18.03.21 08:33, Kuhn Nicolas wrote:
> _______________________________________________
> EToSat mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/etosat
>

---

From: "Su, Chi-Jiun" <[email-masked]>
Date: Mon, 22 Mar 2021 13:14:41 +0000

One software from github if you have not seen this yet....

github: https://github.com/ssloxford/qpep

NDSS paper and video:
https://www.ndss-symposium.org/ndss-paper/qpep-an-actionable-approach-to-secure-and-performant-broadband-from-geostationary-orbit/

"1Source code and documentation for both our QPEP implementation and our OpenSAND-based testbed environment are available publicly (https://github. com/ssloxford/qpep). Example python scripts used to run all of the simulation scenarios presented in this paper are provided."

________________________________
From: EToSat <[email-masked]> on behalf of Joerg Deutschmann <[email-masked]>
Sent: Thursday, March 18, 2021 4:31 AM
To: Kuhn Nicolas <[email-masked]>
Cc: [email-masked] <[email-masked]>
Subject: Re: [EToSat] Integrated VPN/PEP software

**EXTERNAL EMAIL**

Dear Nicolas,

Thanks,
Joerg