Subject: Re: [EToSat] TCP over satellite links

From: "Aaron Falk" <[email-masked]>
Date: Mon, 16 Aug 2021 12:24:37 -0400

cc: etosat

Hi Gabe-

You’ll find a bunch of information in the RFCs published by the 
[TCPSAT](https://datatracker.ietf.org/wg/tcpsat/documents/) and 
[PILC](https://datatracker.ietf.org/wg/pilc/documents/) working groups.  
I’ve cc’ed this response to a new mailing list discussing satellite 
performance issues 
([etosat](https://www.ietf.org/mailman/listinfo/Etosat)) and if you 
still have questions (eg, if you are looking at performance issues 
around LEO constellations, you might find help there.  Regarding 
reference implementations, I think it will depend on which performance 
optimizations you are interested in and that, in turn, will depend on 
the characteristics of your satellite network.

Best,

--aaron

On 16 Aug 2021, at 12:12, Gabriel Black wrote:

> Hello,
>
>
>
> I am trying to accelerate TCP over satellite links and have found
> documentation about SCPS-TP and other aspects of the TCP protocol that 
> can
> be modified to improve the performance over satellite links. However, 
> I'm
> finding it extremely difficult to find any sort of reference 
> implementations
> of the protocol or any extensions to accomplish that.
>
>
>
> I was wondering if you might be aware of any reference implementations 
> or
> any extensions to tcp (if they have already been implemented), that 
> would be
> best suited to accelerating TCP through satellite links.
>
>
>
> Thank you for your time.
>
>
>
> Very respectfully,
>
> Gabe Black

---

From: Gabriel Black <[email-masked]>
Date: Mon, 16 Aug 2021 17:06:38 +0000

Thank you for the reply.

I think for now, the characteristics we are targeting is satcom (e.g.,  ~500+ ms latency (GEO) and static ground station -- less of the variability you’d find in LEOs). I’ve come across pepsal for a reference implementation, but it seems very old and I question its performance. I was wondering if since that time there were perhaps standard extensions/options to TCP that could now be used instead that would perform well in GEOs or if there were new implementations of a PEP that would perform well. For now, I’m not worrying about header encryption (e.g., ipsec) – just want to accelerate tcp connections. If any know of any reference implementations or of extensions/tcp options that would give me the best bang for the buck, I’d very much appreciate it.

Thanks again. 

Gabe

From: Aaron Falk <[email-masked]> 
Sent: Monday, August 16, 2021 10:25 AM
To: Gabriel Black <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: [External] - Re: TCP over satellite links

CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you recognize the sender and know the content is safe.

cc: etosat

Hi Gabe-

You’ll find a bunch of information in the RFCs published by the  <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_wg_tcpsat_documents_&d=DwMFaQ&c=zeCCs5WLaN-HWPHrpXwbFoOqeS0G3NH2_2IQ_bzV13g&r=YnQ9DMJpb9J9GXU9h7_df_bzYNqCkodpRCL5l24fu74&m=zpJsKH-twIdq68wcDkXBkRPT-v9F-5pZOtaOg7HGYd8&s=T9SgSdod0Hg-FPqr8U1NdupW2K2L0f4JmO-kSZ0NJfQ&e=> TCPSAT and  <https://urldefense.proofpoint.com/v2/url?u=https-3A__datatracker.ietf.org_wg_pilc_documents_&d=DwMFaQ&c=zeCCs5WLaN-HWPHrpXwbFoOqeS0G3NH2_2IQ_bzV13g&r=YnQ9DMJpb9J9GXU9h7_df_bzYNqCkodpRCL5l24fu74&m=zpJsKH-twIdq68wcDkXBkRPT-v9F-5pZOtaOg7HGYd8&s=ovwcfmh-m6OIhDtPGQq6oGcjpLjFV1STv__U7d7hfng&e=> PILC working groups. I’ve cc’ed this response to a new mailing list discussing satellite performance issues ( <https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_Etosat&d=DwMFaQ&c=zeCCs5WLaN-HWPHrpXwbFoOqeS0G3NH2_2IQ_bzV13g&r=YnQ9DMJpb9J9GXU9h7_df_bzYNqCkodpRCL5l24fu74&m=zpJsKH-twIdq68wcDkXBkRPT-v9F-5pZOtaOg7HGYd8&s=RaPojR1iX1qLXBKs5ZtZTt-VDV9PQVLf9Nx1yfxOTDg&e=> etosat) and if you still have questions (eg, if you are looking at performance issues around LEO constellations, you might find help there. Regarding reference implementations, I think it will depend on which performance optimizations you are interested in and that, in turn, will depend on the characteristics of your satellite network.

Best,

--aaron

Hello,

I am trying to accelerate TCP over satellite links and have found documentation about SCPS-TP and other aspects of the TCP protocol that can be modified to improve the performance over satellite links. However, I’m finding it extremely difficult to find any sort of reference implementations of the protocol or any extensions to accomplish that.

I was wondering if you might be aware of any reference implementations or any extensions to tcp (if they have already been implemented), that would be best suited to accelerating TCP through satellite links.

Thank you for your time.

Very respectfully,

Gabe Black