Subject: [Extra] [Technical Errata Reported] RFC8579 (5877)

From: RFC Errata System <[email-masked]>
Date: Fri, 18 Oct 2019 01:55:59 -0700 (PDT)

The following errata report has been submitted for RFC8579,
"Sieve Email Filtering: Delivering to Special-Use Mailboxes".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid5877

--------------------------------------
Type: Technical
Reported by: Stephan Bosch <[email-masked]>

Section: 6

Original Text
-------------
require "imapsieve";
require "special-use";
require "environment";
require "variables";

if environment :contains "imap.mailbox" "*" {
    set "mailbox" "";
}

if allof(
    environment "imap.cause" "COPY",
    specialuse_exists "${mailbox}" "\Junk") {
    redirect "[email-masked]";
}

Corrected Text
--------------
require "imapsieve";
require "special-use";
require "environment";
require "variables";

if environment :matches "imap.mailbox" "*" {
    set "mailbox" "";
}

if allof(
    environment "imap.cause" "COPY",
    specialuse_exists "${mailbox}" "\Junk") {
    redirect "[email-masked]";
}

Notes
-----
The final example is using the ":contains" match type to extract a match variable, which will not work. It should use ":matches" instead.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC8579 (draft-ietf-extra-sieve-special-use-05)
--------------------------------------
Title               : Sieve Email Filtering: Delivering to Special-Use Mailboxes
Publication Date    : May 2019
Author(s)           : S. Bosch
Category            : PROPOSED STANDARD
Source              : Email mailstore and eXtensions To Revise or Amend
Area                : Applications and Real-Time
Stream              : IETF
Verifying Party     : IESG

---

From: Ned Freed <[email-masked]>
Date: Fri, 18 Oct 2019 09:20:31 -0700 (PDT)

The issue and fix are both correct, however, there's an error in both
the original and corrected text, noted below.

				Ned

> if environment :contains "imap.mailbox" "*" {

This line should read:

     set "mailbox" "${1}";

> if environment :matches "imap.mailbox" "*" {

Same thing:

     set "mailbox" "${1}";

> _______________________________________________
> Extra mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/extra

---

From: Barry Leiba <[email-masked]>
Date: Fri, 18 Oct 2019 21:55:02 -0400

> the original and corrected text, noted below.

There's no error there: the problem is in the errata system, in that
it turns the "dollar-brace-1-brace" into a null string in the email
message.  The correct string does appear in the errata report.

I will mark it Verified now.

Barry

---

From: "Stan Kalisch" <[email-masked]>
Date: Sat, 19 Oct 2019 14:38:50 -0400

> I will mark it Verified now.

This happened when I reported https://www.rfc-editor.org/errata/eid5015 two years ago:

https://mailarchive.ietf.org/arch/msg/sieve/kyeol9Rd_d7bWSkenIrrJgQX8nM

At the time, I searched the archives to see if this had impacted messages about any other errata but couldn't uncover any.

Thanks,
Stan