Subject: [Extra] [Technical Errata Reported] RFC9051 (6826)

From: RFC Errata System <[email-masked]>
Date: Wed, 2 Feb 2022 00:06:32 -0800 (PST)

The following errata report has been submitted for RFC9051,
"Internet Message Access Protocol (IMAP) - Version 4rev2".

--------------------------------------
You may review the report below and at:
https://www.rfc-editor.org/errata/eid6826

--------------------------------------
Type: Technical
Reported by: Hontvári Levente <[email-masked]>

Section: GLOBAL

Original Text
-------------
   18.  RFC822, RFC822.HEADER, and RFC822.TEXT FETCH data items were
        deprecated.  Clients should use the corresponding BODY[]
        variants instead.

Corrected Text
--------------
   18.  RFC822, RFC822.HEADER, and RFC822.TEXT FETCH data items were
        removed. Clients should use the corresponding BODY[]
        variants instead.

Notes
-----
Contrary to the original text, these data items are not deprecated but they were completely removed from the text of the RFC. As far as I see other deprecated items are not removed completely but moved to a '...obsolete...' token in the formal syntax.

Instructions:
-------------
This erratum is currently posted as "Reported". If necessary, please
use "Reply All" to discuss whether it should be verified or
rejected. When a decision is reached, the verifying party  
can log in to change the status and edit the report, if necessary. 

--------------------------------------
RFC9051 (draft-ietf-extra-imap4rev2-30)
--------------------------------------
Title               : Internet Message Access Protocol (IMAP) - Version 4rev2
Publication Date    : August 2021
Author(s)           : A. Melnikov, Ed., B. Leiba, Ed.
Category            : PROPOSED STANDARD
Source              : Email mailstore and eXtensions To Revise or Amend
Area                : Applications and Real-Time
Stream              : IETF
Verifying Party     : IESG

---

From: Alexey Melnikov <[email-masked]>
Date: Wed, 2 Feb 2022 11:00:56 +0000

I think I would change this to Editorial, because pure IMAP4rev2 clients 
wouldn't use items whether they are marked as deprecated or as removed.

I think "hold for update" is the best disposition for this erratum.

On 02/02/2022 08:06, RFC Errata System wrote:
> _______________________________________________
> Extra mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/extra

---

From: Barry Leiba <[email-masked]>
Date: Wed, 2 Feb 2022 07:51:31 -0500

I’d actually go with “rejected” rather than HFDU, as it’s saying exactly
what we meant it to say.  But it’s up to Murray.  In any case, definitely
make it editorial.

Barry

On Wed, Feb 2, 2022 at 6:01 AM Alexey Melnikov <[email-masked]>
wrote:

> > Contrary to the original text, these data items are not deprecated but
> they were completely removed from the text of the RFC. As far as I see
> other deprecated items are not removed completely but moved to a
> '...obsolete...' token in the formal syntax.
> >
> > Instructions:
> > -------------