Subject: Re: Capabilities Request

From: MAEDA toru <[email-masked]>
Date: Mon, 26 Oct 1998 10:29:40 +0900

Wing-san

I am saying we need a dummy message for MDN request.
Your message is non-sence message.

The dummy message should be standerized in RFC.
Also the message must be machine processable.

Message exapmle:

"The message is Interent FAX capability request.
Please return MDN with IFAX capabilities"

At 08:50 98/10/25 -0700, [email-masked] wrote:
> YADDAYADDAYADDA

Regrads

Toru MAEDA
CANON INc.

----------------------------
キヤノン株式会社
映像事務機システム推進プロジェクト
映像事務機３５設計部
前田 徹
郵便番号１４６
東京都大田区下丸子３−３０−２
電話   ０３−３７５７−９７３８
ＦＡＸ ０３−３７５７−８２０５
E-mail [email-masked]
----------------------------

---

From: Brian Stafford <[email-masked]>
Date: Mon, 26 Oct 1998 09:51:44 +0000

It strikes me that a better approach than a dummy message to solicit a
MDN response might be to implement something along the lines of a mailing
list server, such as majordomo.

A mailbox could be assigned to the "capabilities server" and the body of a
mail sent to that mailbox would contain capabilities server commands.
For example, assume a mailbox "[email-masked]" that
can be used to request the capabilities of my mailer.

The following message could be sent
	...
	To: <[email-masked]>
	Subject: Capabilities Request
	...

	capabilities [email-masked]
	end
	<<EOF>>

The reply message might be a MIME formatted email where at least one part
is machine readable conneg syntax, describing my mailer's capabilities.

This would avoid the need for dummy messages or MDN being used in ways for
which it was not intended.  Obviously this mechanism would be in addition
to other proposals for capabilities reporting.

Having said all that, I would prefer to wait for some output from mailcap
before we start inventing mechanisms that preempt their work.  I believe
that preserving the integrity and interoperability of the email infrastructure
is more important than quick and dirty solutions that convenience only fax
implementors.

-- 
Brian Stafford
OfficeLogic International Ltd.
Suite 1, Craven Hall
Sackville Street
Skipton
North Yorkshire
U.K

EMail: [email-masked]
Phone: +44 1756 702940
Fax: +44 1756 796406