Subject: Re: Capabilities Request

From: Dan Wing <[email-masked]>
Date: Sun, 25 Oct 1998 20:23:26 -0800

>I am saying we need a dummy message for MDN request.
>Your message is non-sence message.
>
>The dummy message should be standerized in RFC.
>Also the message must be machine processable.
>
>Message exapmle:
>
>"The message is Interent FAX capability request.
>Please return MDN with IFAX capabilities"

Aber was tun wir, wenn der Benutzer versteht nicht Englisch?

-Dan Wing

---

From: MAEDA toru <[email-masked]>
Date: Wed, 28 Oct 1998 20:52:26 +0900

Wing-san

I have checked RFC about human readable.

Onece upon a time, only English reading people are human in IETF.
But now days, Internet access people are human.

In the begining of IETF, human readable means English, 
but world's wirting systems are supported now days.

(1)RFC753, human readable is only English.

	error-string: TEXT

        This is a human readable character string describing the error.
 
    	Possible errors:

              error-string                  error-class

      	No errors                                  0
      	Command not implemented                    2
      	Syntax error, command unrecognized         3
      	Syntax error, in arguments                 3
      	Server error, try again later              4
      	No service available                       5
      	User requested abort                       6

(2)Recent RFS2284 says UTF-8
   	displayable message
             This is interpreted to be a human readable string of
              characters, and MUST NOT affect operation of the protocol.
             The message encoding MUST follow the UTF-8 transformation
             format [5].

	"UTF-8, a transformation format of Unicode and ISO
         10646"RFC 2044, October 1996.

  	 The Unicode Standard, version 1.1, and ISO/IEC 10646-1:1993 jointly
   	define a 16 bit character set which encompasses most of the world's
   	writing systems.

The message should have Japanese.
これは能力交換の要求のメッセージです

Regards.

Toru MAEDA
CANON Inc.

> Aber was tun wir, wenn der Benutzer versteht nicht Englisch?
----------------------------
キヤノン株式会社
映像事務機システム推進プロジェクト
映像事務機３５設計部
前田 徹
郵便番号１４６
東京都大田区下丸子３−３０−２
電話   ０３−３７５７−９７３８
ＦＡＸ ０３−３７５７−８２０５
E-mail [email-masked]
----------------------------