Subject: RE: IPP> IPP2IFAX BOF - HI-FI DOCS Tuesday 16

From: "Hastings, Tom N" <[email-masked]>
Date: Thu, 4 Mar 1999 15:56:38 -0800

For the BOF agenda, I'd like to hear about the concern about using the "FAX"
word in the name of the project (and resulting standard).

It seems to me that there is a great benefit of immediate understanding of
using the name "FAX" (or some obvious derivative of it, such as IFAX or PFAX
or some other letter prefix).  Also, it seems that it would help get the ITU
involved as well.

If the concern is with overlap with Full Mode IFAX, the Full Mode IFAX has a
number of advantages and the IFAX over IPP has a number of advantages.
Can't there be two "transport" bindings of the same "FAX-like" semantics?
One using SMTP transport and the other using IPP transport?

Thanks,
Tom

> -----Original Message-----
> From: Richard Shockey [mailto:[email-masked]]
> Sent: Thursday, March 04, 1999 01:07
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> Subject: IPP> IPP2IFAX BOF - HI-FI DOCS Tuesday 16
> 
> 
> It seems that we have a room and a schedule for the IPP2IFAX 
> BOF  ..soon to
> be called HI-FI DOCS or whatever the consensus is ....
> 
> I will try to have a draft agenda/charter etc ready by Monday 
> of next week
> since I am in transit.
> 
> If there are any items or suggestions folks would like to make for the
> agenda please email me or the list and I'll be delighted to 
> include them.
> 
> ciao ---
> 
> ###################
> 
> 
> 
> TUESDAY, March 16, 1999
> 
> 0800-1700  IETF Registration - Ballroom Foyer
> 0800-0900  Continental Breakfast - Ballroom Foyer
> 0900-1000  Morning Sessions I
> 
> Rochester          APP  ipp2ifax  Internet Print Protocol and 
> Internet Fax
> BOF
> Duluth             APP  sieve     Sieve Mail Filtering Language BOF
> Salon G            OPS  ngtrans   Next Generation Transition WG
> Hennepin/Carver    OPS  rps       Routing Policy System WG
> Salon D            RTG  mobileip  IP Routing for 
> Wireless/Mobile Hosts WG *
> Marquette/LaSalle  SEC  xmldsig   XML Digital Signatures BOF
> Salon A            TSV  malloc    Multicast-Address Allocation WG *
> Salon EF           TSV  megaco    Media Gateway Control WG
> 
> 1015-1115  
> 
> 
> >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
> Richard Shockey
> Shockey Consulting LLC                  
> 8045 Big Bend Blvd. Suite 110    
> St. Louis, MO 63119
> Voice 314.918.9020
> Fax   314.918.9015
> INTERNET Mail & IFAX : [email-masked]
> eFAX 815.333.1237  
> <<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<
>

---

From: Graham Klyne <[email-masked]>
Date: Fri, 05 Mar 1999 12:52:30 +0000

At 15:56 04/03/99 -0800, Hastings, Tom N wrote:
[...]
>One using SMTP transport and the other using IPP transport?

I think this is an excellent approach.

But I do think there are *three* kinds of fax under consideration:

(a) Fax data over-e-mail (Ifax, EIfax, ITU T.37):
    Some aspects of the traditional fax model cannot be fully realized (IMO).

(b) Fax protocols over IP (ITU T.38):
    This is very specific to carriage of traditional fax over the Internet.
    Does not integrate well with Internet messaging.

(c) Fax service over IP (IPP/FAX, "session mode" I-fax):
    I see this as the best current approach to provide a truly fax like
service
    that can integrate well with Internet messaging.

I think that (a) and (c) can be developed in the way you suggest, adding
further semantics in a way that is common to both.

But I find it difficult to see how (b) fits into this larger picture.  One
advantage I do see with approach (b) within this framework is T.30 fax
onramp/offramp flexibility:  it allows us to separate the Ifax/T.30
interface from the IP/GSTN interface.

#g

------------
Graham Klyne
([email-masked])

---

From: "Hastings, Tom N" <[email-masked]>
Date: Fri, 5 Mar 1999 16:05:11 -0800

I meant to say Extended IFAX (EIFAX), not Full Mode FAX.  So here is my
suggestion for an agenda item again.  Sorry for the confusion.

Thanks,
Tom

-----Original Message-----
From: Hastings, Tom N [mailto:[email-masked]]
Sent: Thursday, March 04, 1999 15:57
To: Richard Shockey
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: IPP> IPP2IFAX BOF - HI-FI DOCS Tuesday 16

It seems to me that there is a great benefit of immediate understanding of
using the name "FAX" (or some obvious derivative of it, such as IFAX, EIFAX,
or PIFAX
or some other letter prefix(es)).  Also, it seems that it would help get the
ITU
involved as well.

If the concern is with overlap with EIFAX (Extended IFAX), the EIFAX has a
number of advantages and the IFAX over IPP has a number of advantages.
Can't there be two "transport" bindings of the same "FAX-like" semantics?
One using SMTP transport and the other using IPP transport?

Thanks,
Tom