Subject: combining "simple mode" and "extended mode" documents

From: "Larry Masinter" <[email-masked]>
Date: Wed, 10 Mar 1999 10:53:04 PST

I think that as we move to Draft Standard, we should
combine the two documents of "simple mode" and
"extended mode", in order to clarify a misunderstanding.

Apparently some groups believe that "simple mode"
devices cannot request DSNs or MDNs, even though those
mechanisms are, in fact, still optional.

So I'd like to have a single document which points out
a "minimal compliance" which corresponds to "simple mode"
but which contains all of the recommended mechanisms
that constitute "extended mode".

This won't break any current implementations, as far
as making them non-compliant, but it will encourage
additional fuller implementations.

Along the way, I do think it is useful to consider the
results of interoperability testing, as we move from
"proposed" to "draft".

There was an enormous pressure to complete "simple mode"
by only including those facilities that we could agree
on quickly. 

As we move forward, though, let's consider the full
goals of Internet Fax, and recommend those components
that actually accomplish the goals. I don't want to
make current "simple mode" implementations non-compliant,
but I think that a combined draft that recommends
confirmation and capability exchange when feasible
would improve the functionality of "Internet Fax".

Larry

---

From: Dave Crocker <[email-masked]>
Date: Sat, 13 Mar 1999 00:12:09 -0800

>I think that as we move to Draft Standard, we should

If you pursue integrating the documents now, then Simple mode will not be 
able to move to Draft.  It will have to wait for extended mode to qualify 
for draft.  (And when Simple mode is ready for Full Standard, the same 
problem will recur, since Extended mode will only be ready for Draft.)

Since the basic problem you cite is that some readers of 2305 assume that 
it prohibits behaviors it does not, then small additions of text to 2305bis 
should be sufficient to correct this misunderstanding.

In the long run, yes, it is nicer to have fully integrated 
documents.  However integrating them is an effort, as has been demonstrated 
by the DRUMS effort.  Worse, I believe that pursuing integration, now, will 
create more instability than stability.

d/

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Dave Crocker                                         Tel: +1 408 246 8253
Brandenburg Consulting                               Fax: +1 408 273 6464
675 Spruce Drive                             <http://www.brandenburg.com>
Sunnyvale, CA 94086 USA                 <mailto:[email-masked]>

---

From: "Herman R. Silbiger" <[email-masked]>
Date: Sat, 13 Mar 1999 12:15:49 -0500

In addition, any changes to 2305 would mean that T.37 would have to be
revised.  I concur that a note added to 2305 would suffice.

Herman