Subject: HI-FI DOCS Charter and Agenda [was IPP2IFAX]

From: Richard Shockey <[email-masked]>
Date: Tue, 09 Mar 1999 13:11:29 -0600

I've taken a stab here at a revised charter and agenda for the BOF Next
week in Minneapolis.

The revisions are based on suggestions from some of you as well as our AD.

Please inform me ASAP of any revisions, comments or agenda items that need
to be included. 

Sorry about the short time frame, but I was in transit all of last week.

####################

Agenda for IPP2IFAX, now HI-FI DOCS [TBD]

44 IETF Minneapolis MN

Tuesday March 16, 1999

9:00-10:00 AM  -  Rochester 

Bash the Agenda 10 min

Reason for name change 5 min

Reason for Work Group  5 min

Proposed charter 10 min

Drafts: 10 min

draft-ietf-shockey-ipp2ifax-00.txt

Open floor for discussion.

################################

Proposed Charter:

Was IPP2IFAX  To Be Determined - High Integrity 
Document Distribution  (HI-FI DOCS)

Chair(s):   Richard Shockey  
<[email-masked]>  [PROPOSED]
     
 Applications Area Director(s):
	Keith Moore  	<[email-masked]>
     	Patrik Fältström 	<[email-masked]>

 Area Advisor
   	Keith Moore  <[email-masked]>

 Mailing lists:
     	General Discussion:	[email-masked]
     	
To Subscribe:

[email-masked]

        	In Body: subscribe ifx  [your-email-address]

	The subject line should be blank	

Archive:          
<http://www.pwg.org/hypermail/ifx>

Description of Working Group:

The transmission and reception of non-alterable 
documents is an essential communications medium.

Several protocols and services have been 
developed over the years to facilitate document 
transmission, including the GSTN Fax service [ITU -
T.30].  Within the IETF several protocols have been 
developed that facilitate document transmission, 
including RFC2305 [Store and Forward Internet Fax] 
and the Internet Print Protocol [IPP].

Each of these services has one or more severe 
limitations or restrictions that may not be suitable for 
all document transmissions.

Among those limitations that could be applied to one 
or more of the above services:

1. Limitations on Quality (resolution or color 
transmission)
2. Ability to repudiate request for receipt 
confirmation (MDN  DSN)
3. Lack of clear and unambiguous identification of 
sender or recipient
4. Lack of ability to monitor progress of document 
transmission in real time
5. Inability to establish reliable knowledge or 
negotiation of recipient capabilities
6. Inability to satisfy legal as well as general 
custom and practice for document transmission 
technologies. (Typically these are applied to 
GSTN Fax)
7. Least Common Denominators for Document
Transmission
8. Inability to establish security and confidentiality 
of document transmission

The purpose of the work group will be to investigate 
current work within the IETF and identify protocols, 
procedures and policies that can satisfy the 
requirements for document transmission with 
a high degree of fidelity and reliability.

It is believed that elements of the Internet Print 
Protocol 1.1, if extended and amended may 
overcome many if not most of the limitations 
described above. Work would define an appropriate 
“super set” of existing IPP 1.1 functionality to satisfy
these requirements.

The work group may consider attribute extensions 
and additional service requirements to IPP 1.1 that 
would permit IPP to intreoperate with other 
document transmission services such as RFC2305 
[Fax over SMTP] and traditional T.30 fax on the 
GSTN.

The WG will not propose any revisions or extensions 
to IETF Internet Fax standards [RFC2305] and its 
successors.

The group will take note of other areas within the 
IETF that may have direct bearing on reliable 
document delivery.

Relevant areas include:  

- Security, Authentication and Encryption (SSL3 -
TLS)
- Sender Identification (vCard)
- RFC2301 File Formats
- Digital Signatures and Certificates
- Third Party Receipt Confirmation

The working group will coordinate its activities with 
the Internet Print Protocol working group [IPP] and 
the Internet Fax working group [FAX] as well other 
document transmission related standards bodies 
and related work groups, notably the ITU-T Study 
Group 8.   

Goals and Milestones:  
  
May  1999 : Submit Internet Draft of Goals and 
Requirements for High Reliability Document 
Distribution

August  1999 : Submit Internet Draft for IPP High 
Reliability Document Mode

September  1999 : Submit Internet Draft of Reliable 
Gateway Services between IPP, SMTP and GSTN 
Facsimile

Richard Shockey
Shockey Consulting LLC                  
8045 Big Bend Blvd. Suite 110    
St. Louis, MO 63119
Voice 314.918.9020
Fax   314.918.9015
INTERNET Mail & IFAX : [email-masked]
eFAX 815.333.1237  
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

---

From: James Rafferty <[email-masked]>
Date: Tue, 09 Mar 1999 16:59:08 -0500

Rich,  

Thanks for the posting.    This BOF on "high fidelity" documents over IPP
(a.k.a. Fax over IPP) should be of interest to many in the fax and IPP
communities.   

As some of you may recall, at one time we considered session based Internet
fax protocols in our WG.   This work goes forward in a related direction,
but using IPP as the base protocol.   

James

>INTERNET Mail & IFAX : [email-masked]
*------------------------------------------------*
James Rafferty			
President, Human Communications LLC	
12 Kevin Drive			
Danbury, CT  06811-2901		
USA					
Voice/Fax:  +1-203-746-4367
Email/Internet Fax:  [email-masked]
	 [email-masked]
     [email-masked]

HC Web Site:  http://www.humancomm.com  
*---------------------------------------------------