Subject: Re: draft-ietf-fax-coverpage-01.txt

From: Graham Klyne <[email-masked]>
Date: Wed, 14 Apr 1999 11:45:19 +0100

At 15:53 13/04/99 -0700, Michael J. Ruhl wrote:

>At this point it should be noted that I am not trying to
>define what an application should do with this information. 

I agree that defining recipient application behaviour is out of scope, but
I think it might be helpful to indicate the kind of processing decisions
that would be based on the cover page information;  e.g.
- does a user agent display additional information?
- does an offramp add cover page information to a fax?

I think that (maybe) the underlying idea here is what happens when a
message leaves the e-mail environment (i.e. when the content is separated
from the e-mail headers):  is additional 'cover' information, based on the
e-mail headers, added to the message?

Or is there more?

>I am planning on making the following changes to my
>document:
>
>1) change the header from content-coverpage to content-cover
>2) Change "probable" to "implicit"
>3) Remove "yes" and add "separate" and "embedded"
>4) Add a Internationalization section to briefly discuss the
>issue of information given in the content-description
>header.

What should be the content-disposition of a cover page?  Chris Newman is
proposing that his 'Content-disposition:ancillary' draft be considered as a
proposed standard.  Is this an appropriate disposition for a fax cover page?

#g

------------
Graham Klyne
([email-masked])

---

From: "Michael J. Ruhl" <[email-masked]>
Date: Wed, 14 Apr 1999 15:26:14 -0700

> - does an offramp add cover page information to a fax?

Those are very good questions.  I think the answer to both
is, "maybe". :)

> e-mail headers, added to the message?

Those are also good questions.  One of the things that I was
hoping would happen was that my ID would be used to answer
these questions.  Would it be useful to add a few sections
on "Suggested Uses For Coverpage Stuff"?  This section would
be my suggestions on how to deal with coverpage information
(and attempt to answer the above questions)?  Or should that
be in a separate document?
 
> proposed standard.  Is this an appropriate disposition for a fax cover page?

/sigh.  You seem to be getting all the good questions today.
:)  Currently I have the disposition labeled "attachment". 
In my mind a coverpage is "attached" to a message, so
"attachment" works for me.  I will take a look at the
ancillary draft and see if I agree with it. :)

Mike