Subject: I-D ACTION:draft-ietf-fax-feature-T30-mapping-01.txt

From: [email-masked]
Date: Thu, 24 Jun 1999 07:23:40 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Internet Fax Working Group of the IETF.

	Title		: Internet fax T.30 Feature Mapping
	Author(s)	: G. Klyne, L. McIntyre
	Filename	: draft-ietf-fax-feature-T30-mapping-01.txt
	Pages		: 37
	Date		: 23-Jun-99
	
This document describes how to map Group 3 fax capability
identification bits, described in ITU-T.30 [6], into the Internet
fax feature schema described in 'Content feature schema for
Internet fax' [4].
This is a companion to the fax feature schema document [4], which
itself defines a profile of the media feature registration
mechanisms [1,2,3], for use in performing capability identification
between extended Internet fax systems [5].

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-fax-feature-T30-mapping-01.txt

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-fax-feature-T30-mapping-01.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-fax-feature-T30-mapping-01.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Yukikazu Mori <[email-masked]>
Date: Mon, 28 Jun 1999 10:58:58 +0900

This is Mori of Ricoh.

I have a concern on the following subclause.

----------------------------------------
6.1.1 Corresponding Internet fax capabilities

  In the case of an Internet fax device, additional capabilities not
  described by the T.30 DIS frame should be included;  e.g. the
  supported TIFF file structure:

     (& (color=binary)
        (image-file-structure=[TIFF-S,TIFF-F])
        (image-coding=[MH,MR,MMR])
        (MRC-mode=0)
        (| (& (dpi=20320/100) (dpi-xyratio=20320/9779) )
           (& (dpi=20320/100) (dpi-xyratio=20320/19558) )
           (& (dpi=200) (dpi-xyratio=200/100) )
           (& (dpi=200) (dpi-xyratio=1) )
           (& (dpi=300) (dpi-xyratio=1) ) )
        (size-x<=2150/254)
        (Paper-size=[A4,Letter]) )
----------------------------------------

Now is it possible to say

  (& (image-file-structure=[TIFF-S])
        (image-coding=[MH,MR,MMR]) )

?

To my understanding, TIFF-S is a SET of attributes such as A4/MH/IFD order
/LSB first/200*100,200*200dpi and so on... 

So the above capablity means that the receiver side is able to handle only
TIFF-S file except that the coding scheme is only extentible to MR and MMR.
And other features of TIFF-S shall be kept.

In the same manner,
(&  (image-file-structure=[TIFF-S])
        (image-coding=[MH,MR,MMR])
             (Paper-size=[A4,Letter,B4,A3]) )

Is this still valid?

I hope this is valid because I believe some fax machines will still have a
difficulty 
to fully support TIFF-F structure but rather easy to suport MR/MMR/B4/A3
within the range of TIFF-S structure.

What about this?
(&  (image-file-structure=[TIFF-S,TIFF-F])
        (image-coding=[MH,MR,MMR])
             (Paper-size=[A4,Letter,B4,A3]) )

It must be probable that the receiver can handle every file structure
within TIFF-F.
So there will be no problem although we accept the first two cases.

Then what about this?
(&  (image-file-structure=[TIFF-S])
        (image-coding=[MMR]))

Is this equivalent to saying
(&  (image-file-structure=[TIFF-S])
        (image-coding=[MH,MMR]))
?

A little debatable. I would like to hear your opinions.
To my feeling it should be regarded as equivalent.

My point is only to make a provision that Internet fax machine can send
MR/MMR/
B4/A3 with TIFF-S structure LEGALLY and to confirm such application will cause
no problem.

Thanks,
Best regards,
Yukikazu MORI

***************************************************************
RICOH COMPANY, LTD.  Toda Technical Center
Yukikazu MORI
TEL:+81-462-28-1743
FAX:+81-462-28-7500(Subaddress(SUB) 5720)
Email:[email-masked]
***************************************************************