Subject: RE: Unsolicited Success MDN

From: Graham Klyne <[email-masked]>
Date: Mon, 18 Oct 1999 21:19:25 +0100

Hi Vivian,

Message_ID MAY be generated separately from MDN request.

If no Message-ID is present, the 3rd part of multipart/report containg
headers and optional content from the original message may be sifficient to
allow a user to identify the offending message.  I see the main goal of
failure messages (unsolicited or not) is to alert the user to a problem.

#g

At 10:18 18/10/99 -0700, Cancio, Vivian wrote:
>If the sender did not request the MDN, and therefore did not generate a
>message ID to tied the response to the original message, how can an
>automated device connect the unsolicited MDN to the original message?
>Vivian
>
>> -----Original Message-----
>> From: Graham Klyne [mailto:[email-masked]]
>> Sent: 18 October, 1999 2:33 AM
>> To: Hiroshi Tamura
>> Cc: [email-masked]
>> Subject: Re: Unsolicited Success MDN
>> 
>> 
>> At 08:25 18/10/99 +0900, Hiroshi Tamura wrote:
>> 
>> >Simple-mode I-fax device(RFC2305) does not issue
>> >"Disposition-Notification-To" header.
>> >
>> >If simple-mode I-fax device receives MDN response,
>> >although it does not request(normally, it doesn't have
>> >the capability to request MDN),
>> >irrespective of whether it is positive or negative,
>> >it can not understand what's happened.
>> >Because it cannot understand the format of MDN.
>> 
>> I think this is another important point -- an unsolicited MDN
>> acknowledgment could be perceived as an "administrative non-message".
>> 
>> Unsolicited negative acknowledgements, by virtue of being 
>> relatively rare
>> (one hopes :-), and allowing that there is information 
>> contained that can
>> be rendered by the receiving party, I think would probably be OK.
>> 
>> #g
>> 
>> ------------
>> Graham Klyne
>> ([email-masked])
>> 
>
------------
Graham Klyne
([email-masked])

---

From: Richard Shockey <[email-masked]>
Date: Mon, 18 Oct 1999 16:32:28 -0500

>failure messages (unsolicited or not) is to alert the user to a problem.

Good point ... some time back I seem to recall I pointed this out as well. 
It was a issue that I thought merited some discussion in a Implementers 
Guide..namely that the client SHOULD generate a Message_ID if there was the 
expectation of some response required or expected.

The reason for this was to facilitate the logging of MDN/DSN mesages with 
the original by matching the two ID's.

If I recall correctly  ... If a Message_ID is generated by the client then 
each successive SMTP hop will not alter that ID... it just that if there is 
NO ID available .. one will then be inserted at the first hop. Correct?

Richard Shockey
Shockey Consulting LLC
8045 Big Bend Blvd. Suite 110
St. Louis, MO 63119
Voice 314.918.9020
eFAX Fax to EMail 815.333.1237 (Preferred for Fax)
INTERNET Mail & IFAX : [email-masked]
GSTN Fax 314.918.9015
MediaGate iPost VoiceMail and Fax 800.260.4464
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<