Subject: I-D ACTION:draft-ietf-fax-gateway-protocol-07.txt

From: [email-masked]
Date: Wed, 27 Mar 2002 07:16:34 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the Internet Fax Working Group of the IETF.

	Title		: Internet FAX Gateway Functions
	Author(s)	: K. Mimura, K. Yokoyama, T. Satoh, C. Kanaide
	Filename	: draft-ietf-fax-gateway-protocol-07.txt
	Pages		: 10
	Date		: 26-Mar-02
	
An Internet FAX Gateway provides functions which translate facsimile
between the general switched telephone network (GSTN) the Internet.
This document provides information on recommended behaviors for 
Internet FAX Gateways Functions for email-based Internet fax. 
In this context, an Offramp means facsimile data transmission to the
GSTN from the Internet, and onramp means facsimile data transmission 
to Internet from the GSTN. This document covers the delivery-process 
of the data among equipment which may include Internet Fax terminals,
PCs on the Internet and FAX terminal on GSTN.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-fax-gateway-protocol-07.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-fax-gateway-protocol-07.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-fax-gateway-protocol-07.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 27 Mar 2002 09:55:29 -0800

Section 4.1 says:

   An onramp gateway MUST have the function that the onramp gateway
   receive facsimile data from facsimile device over GSTN, then
   generated Internet fax is sent to appropriate IFAX devices or PC by
   the onramp gateway. How to transmit data from an onramp gateway to
   IFAX devices MUST based on [3].

Note that no onramp actually follows this MUST requirement.
Specifically, the onramp does not "send to appropriate ifax
device or PC".  Rather, the onramp sends the message to a
mail transfer agent, and the mail transfer agent itself (or
several of them) are involved in eventually transferring the
mail to the ifax device.  If a PC, the mail transfer agent
isn't involved in this final transfer, but the mail retrieval
program is involved (POP server or IMAP server).

Please clarify the text in the I-D.

In section 4.2.0, I suggest that the following be added:

  If a GSTN number transmitted as part of the local-part
  of the email address, it SHOULD be in the global-phone
  format.

Myself, I would prefer MUST, but such a strict requirement may
be too difficult to agree on in this working group.

Regarding authorization, is section 5 normative, or is
section 3.3 normative?

In section 3.3, you need to clearly describe the "X-Header".
You also need to provide a reference to S/MIME -- it is
mentioned here in section 3.3, but there needs to be a
normative or informational reference to S/MIME.

-d

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On
> Behalf Of [email-masked]
> Sent: Wednesday, March 27, 2002 4:17 AM
> To: IETF-Announce:
> Cc: [email-masked]
> Subject: I-D ACTION:draft-ietf-fax-gateway-protocol-07.txt
>
>

---

From: Yokoyama <[email-masked]>
Date: Thu, 28 Mar 2002 13:37:36 +0900

Wing-san

Thank you for your comments.

> Please clarify the text in the I-D.

We will change the sentence as follows.
from
     generated Internet fax is sent to appropriate IFAX devices or PC by
     the onramp gateway.
to
     generated Internet fax is sent to appropriate IFAX devices or PC
     via mail transfer agents by the onramp gateway.

> be too difficult to agree on in this working group.

We will chang the sentence as follows.
from
     4.2 Address designation
          An onramp gateway SHOULD have the function that onramp gateway
          analyze destination address from address data sent by facsimile
          device over GSTN.
to
     4.2 Address designation
          An onramp gateway SHOULD have the function that onramp gateway
          analyze destination address from address data sent by facsimile
          device over GSTN. If a GSTN number transmitted as part of the local-part
          of the email address, it SHOULD be in the global-phone format.

> Regarding authorization, is section 5 normative, or is

Section 3.3 and 4.5 are normative.
We will change 5 Security Considerations like this.
     Refer to sention 3.3 User authorization  for the authentication
     about an offramp gateway. Refer to sention 4.5 User authorization
     for the authentication about an onramp gateway.

> normative or informational reference to S/MIME.

"X-Header" is one of the examples.
Therefore, we are discussing whether it is removed.
We will provid a reference to S/MIME.

--
K.Yokoyama

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 27 Mar 2002 20:59:57 -0800

> Therefore, we are discussing whether it is removed.

We (Cisco) support using an X- header for authorization, but
such use isn't standardized.  In fact, X- headers cannot be
standardized.  How about rewording to talk about something
like "a special vendor-defined header might be used ..."
or something like that?

> We will provid a reference to S/MIME.

Thanks,
-d

---

From: Yokoyama <[email-masked]>
Date: Thu, 28 Mar 2002 15:05:00 +0900

Wing-san

> like "a special vendor-defined header might be used ..."

We decided to remove X-Header from the sentence
more than reword,
because X- headers cannot be standardized.

--
K.Yokoyama

---

From: "Dan Wing" <[email-masked]>
Date: Thu, 28 Mar 2002 00:19:00 -0800

Thank you,
-d

> From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of Yokoyama
> Sent: Wednesday, March 27, 2002 10:05 PM
> To: Dan Wing
> Cc: [email-masked]
> Subject: Re: I-D ACTION:draft-ietf-fax-gateway-protocol-07.txt
> 
> 
> 
> Wing-san
> 
>