Subject: Re: [fdt] Proposed charter text & meeting

From: Stephane Bortzmeyer <[email-masked]>
Date: Sun, 6 Sep 2020 15:23:32 +0200

On Mon, Aug 17, 2020 at 09:00:25AM +0100,
 Stephen McQuistin <[email-masked]> wrote 
 a message of 88 lines which said:

> I've produced draft charter text:
> 
>     https://hackmd.io/@fdt/S1wTyI-fv <https://hackmd.io/@fdt/S1wTyI-fv>

I would delete the "The incremental, distributed, and consensus-driven
standards development process adopted by the IETF can lead to" because
there is no proof (or even hint) that the problem of "inconsistencies
and ambiguities" would be solved by a more formal and bureaucratic
top-down process.

Also, may be we could add in the charter references to relevant RFC
(RFC 4977) and existing work
such as draft-mcquistin-augmented-ascii-diagrams or to past work such
as the FSM BoF at IETF 68 in Prague
<https://www.ietf.org/proceedings/68/fsm.html>?

---

From: Marc Petit-Huguenin <[email-masked]>
Date: Sun, 6 Sep 2020 07:36:29 -0700

Hi Stephane,

> and ambiguities" would be solved by a more formal and bureaucratic

Right, although I would argue that in this case we are not using the word "formal" in the same sense (i.e., as opposed to "informal", meaning using the English language as a description technique).

Maybe a study of a bureaucratic top-down standard development process vs an incremental, distributed, and consensus-driven development process on the generation of inconsistencies and ambiguities in standards could be added to the charter?

> (RFC 4977) and existing work

Why RFC 4977?

-- 
Marc Petit-Huguenin
Email: [email-masked]
Blog: https://marc.petit-huguenin.org
Profile: https://www.linkedin.com/in/petithug

---

From: Stephane Bortzmeyer <[email-masked]>
Date: Sun, 6 Sep 2020 16:54:54 +0200

On Sun, Sep 06, 2020 at 07:36:29AM -0700,
 Marc Petit-Huguenin <[email-masked]> wrote 

> > (RFC 4977) and existing work

Sorry, 4997.

---

From: Stephen McQuistin <[email-masked]>
Date: Mon, 7 Sep 2020 08:54:15 +0100

Hi,

> On 6 Sep 2020, at 14:23, Stephane Bortzmeyer <[email-masked]> wrote:
> 

It wasn’t intended to imply that the incremental, distributed, and consensus-drive elements of the standards process are, on their own, causes of inconsistencies and ambiguities. I meant it to be taken to with the next sentence, to imply that:

incremental, distributed, consensus-driven approach → use of natural language → inconsistencies and ambiguities

Will bash on these two sentences.

> <https://www.ietf.org/proceedings/68/fsm.html>?

Agreed.

Thanks,

Stephen

---

From: David Kemp <[email-masked]>
Date: Mon, 7 Sep 2020 07:44:09 -0400

>
> The use of natural language and unstructured diagrams to describe
> protocols, both in the development process, and in the documents
> themselves, can lead to standards documents that contain inconsistencies
> and ambiguities.
>

Is this situation more likely to occur, or less likely to be corrected,
when applied in "The incremental, distributed, and consensus-driven
standards development process adopted by the IETF"?

I don't know the answer, it's something to consider.

On Mon, Sep 7, 2020 at 3:54 AM Stephen McQuistin <[email-masked]> wrote:

> It wasn’t intended to imply that the incremental, distributed, and
> consensus-drive elements of the standards process are, on their own, causes
> of inconsistencies and ambiguities. I meant it to be taken to with the next
> sentence, to imply that:
>
> incremental, distributed, consensus-driven approach → use of natural
> language → inconsistencies and ambiguities
>
> FDT mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/fdt
>