Subject: clarifications needed on FACT

From: Robert Haas <[email-masked]>
Date: Tue, 19 Nov 2002 20:10:34 +0100

Hi,
In my attempt to understand the FACT proposal, I would appreciate a few 
clarifications from the authors:

1) how are CE-sets meant to be used, and why is there no FE-set equivalent ?
2) why rely on the message type to infer in which direction the message 
is going (FE-to-CE or CE-to-FE) ?
3) why is the association SETUP message not described in the draft ?
4) are FE-CE associations (or logical connections) always made of one FE 
and one CE only ?

With many thanks,

-- 
Robert Haas
IBM Zurich Research Laboratory
Säumerstrasse 4
CH-8803 Rüschlikon/Switzerland
phone +41-1-724-8698  fax +41-1-724-8578  http://www.zurich.ibm.com/~rha

---

From: "(Ram Gopal )" <[email-masked]>
Date: Fri, 22 Nov 2002 16:39:43 -0500

Hello Roberts,

I want to add to Alex comments for first question.
Comments are inline.

> 1) how are CE-sets meant to be used, and why is there no 

CE-set is a logical grouping. One or more CE's can control a FE. 
CE-Set is a major number and CE-Id is a minor number. CE-Tag represents
CE-set and CE-ID. 

One or more CE  belonging to a CE-set controls a FE.  FE's will not respond 
to a CE's request if that CE is not belonging to a CE-set. There is no need 
for FE-set. What CE-set can control FE is part of pre-configuration for this protocol.

Regards
Ramg