Subject: Re: XML experience/learning in FACT/TIPC implementation

From: "Rachid Nait Takourout (LMC)" <[email-masked]>
Date: Fri, 28 Mar 2003 12:54:31 -0500

Hi,

        As Jon said, our XML experience was a test in order to prove the possibilities of this choice. In fact, the performances for each add-route were lower with XML, but the XML parser (it is Expat) was not created specificly for this type of application.  So, if we would design an advanced router, the use of different types of NP (Intel, EzChip...) poses the problem of the management of the heterogeneity. XML could provide a generic way to express command that could be independant of APIs like the NPF API. It could be interesting to have a XML based FE Model and protocol which are coherent.

Rachid Nait Takourout

-----Message d'origine-----
De : Alan DeKok [mailto:[email-masked]]
Envoyé : Friday, March 28, 2003 12:30 PM
À : [email-masked]
Objet : Re: XML experience/learning in FACT/TIPC implementation

Jon Maloy wrote:
>
> Hi,
> Our experiences with XMLas representation language are generally
> very positive. XML is well fit to express the commands and queries
> needed in the protocol.

  There was also an 'xmlconf' or 'netconf' BOF, which met at IETF-56 on
Monday.  If we decide to use XML as a ForCES protocol, it would seem
that there may be significant overlap between the two groups.

> Our main concern from the beginning was performance, but our
> experiments indicate that this is not  a big problem.

  Assuming that the machines involved are powerful, and have sufficient
memory.  As Moore's law shows, this is probably a reasonable assumption,
given the timescales involved with creating a new protocol in a working
group.

> With XML each add-route item is around 10 times larger than the
> corresponding items in the FLEX protocol, and we have indications
> that  this will cause the the whole transfer/parsing process to be an
> order of magnitude slower than with 'native' FLEX or FACT.

  The question is then whether this slowdown is significant.  If the
total bandwidth devoted to ForCES is minimal, then increasing it by a
factor of 10 is probably acceptable.

> So the question we must answer is the following: Is a performance
> degradation of ~10 times worth the price, given the extra flexibility
> that XML provides over FLEX/FACT?

  And given the extra cost of implementing more complicated parsers.

  For now, it looks expensive to me, but not outlandish.

  Alan DeKok.

---

From: "Yang, Lily L" <[email-masked]>
Date: Fri, 28 Mar 2003 10:26:47 -0800

Rachid -- Could you clarify sth for me? What do you mean when you said "the
performances for each add-route were lower with XML"? Lower comparing with
what? What performance metric you were refering to here?

Thanks,
Lily

-----Original Message-----
From: Rachid Nait Takourout (LMC)
[mailto:[email-masked]]
Sent: Friday, March 28, 2003 9:55 AM
To: [email-masked]
Subject: Re: XML experience/learning in FACT/TIPC implementation

Hi,

        As Jon said, our XML experience was a test in order to prove the
possibilities of this choice. In fact, the performances for each add-route
were lower with XML, but the XML parser (it is Expat) was not created
specificly for this type of application.  So, if we would design an advanced
router, the use of different types of NP (Intel, EzChip...) poses the
problem of the management of the heterogeneity. XML could provide a generic
way to express command that could be independant of APIs like the NPF API.
It could be interesting to have a XML based FE Model and protocol which are
coherent.

Rachid Nait Takourout

-----Message d'origine-----
De : Alan DeKok [mailto:[email-masked]]
Envoyé : Friday, March 28, 2003 12:30 PM
À : [email-masked]
Objet : Re: XML experience/learning in FACT/TIPC implementation

  Alan DeKok.