Subject: [issue49] Sec 6.1.1.1.6 SET and GET Relationship

From: Robert Haas <[email-masked]>
Date: Fri, 10 Jun 2005 08:19:58 +0000

New submission from Robert Haas <[email-masked]>:

Sec 6.1.1.1.6 SET and GET Relationship
[...]
2. When dumping a whole table in a GET, the GET-RESPONSE, merely editing the T 
to be SET will endup overwritting the table.

I had a syntax error reading the sentence above ...

----------
category: Editorial
draft: draft-ietf-forces-protocol
messages: 106
nosy: rha
priority: Should fix
status: No discussion
title: Sec 6.1.1.1.6 SET and GET Relationship

___________________________________________________
Forces issue tracker <[email-masked]>
<http://www.mip4.org/issues/tracker/forces/issue49>
___________________________________________________

---

From: Jamal Hadi Salim <[email-masked]>
Date: Fri, 10 Jun 2005 07:53:28 -0400

> I had a syntax error reading the sentence above ...

The intent was to describe the exception to the rule of converting the
GET-RESPONSE to a SET.

1. If you are dump a table using a GET
2. The GET-RESPONSE will contain a path to the table
3. Merely editing the GET-RESPONSE to be a SET would imply overwritting
the existing table defined in the path.

Perhaps we should provide an example for clarity?

Joel, can you look at example 4 in the appendix in relation to this?

cheers,
jamal

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 10 Jun 2005 09:23:34 -0400

The example looks right.
The path indicates the whole table.
Therefore the whole table will be replaced with one where the entries are 
the same as they were at the time of the get.
Yours,
Joel