Subject: Re: [issue 9] Fix LFB definition

From: "Deleganes, Ellen M" <[email-masked]>
Date: Thu, 18 Aug 2005 07:46:53 -0700

I am also fine with this definition.

Regards, 
Ellen

-----Original Message-----
From: Forwarding and Control Element Separation
[mailto:[email-masked]] On Behalf Of Wang,Weiming
Sent: Tuesday, August 16, 2005 8:38 AM
To: [email-masked]
Subject: Re: [issue 9] Fix LFB definition

----- Original Message -----
From: "Jamal Hadi Salim" <[email-masked]>
> BTW, I am really suprised at the weak definitions of LFB; i just
glanced
> at model and framework docs.
>
> Probably you want to emphasize the following:
> - it resides at the FE (since we killed CE based LFBs)
> - it _may_ process packets
> - it is managed/controlled by the CE
>
> i.e something along:
> "LFB classes are the basic building blocks that are operated on by the
> Forces protocol. The LFB is a well defined, logically separable
> functional block that resides in the FE and is controlled by the CE
via
> forces protocol. The LFB may reside at the FEs datapath and process
> packets or may be purely a control entity that is operated on by the
CE"

I'm fine with the definition. How about model team thought? We need to
be consistent between the protocol and the team on the definition.

Jamal, when it is solved, I will immediately modify the definition in
the protocol draft.

Thanks,
Weiming

> cheers,
> jamal

---

From: "Wang,Weiming" <[email-masked]>
Date: Thu, 18 Aug 2005 23:40:58 +0800

Hi,

The LFB class definition has been modifed in the protocol draft as
below:

LFB (Logical Functional Block) Class (or Type) -- the basic building
blocks that are operated on by the  Forces protocol. The LFB is a well
defined, logically separable functional block that resides in the FE and
is controlled by the CE via ForCES protocol. The LFB may reside at the
FE's datapath and process packets or may be purely a control entity that
is operated on by the CE.

Thanks,
Weiming

----- Original Message -----
From: "Deleganes, Ellen M" <[email-masked]>

Regards,
Ellen

----- Original Message -----
glanced
via
CE"

Thanks,
Weiming