Subject: minor changes: introduction section

From: Jamal Hadi Salim <[email-masked]>
Date: Tue, 13 Sep 2005 14:24:51 -0400

I made some small changes to the introduction for readability - please
comment on attachment.

cheers,
jamal

---

From: Jamal Hadi Salim <[email-masked]>
Date: Tue, 13 Sep 2005 14:28:04 -0400

Please ignore previous attachment and use this instead.

cheers,
jamal

---

From: "Wang,Weiming" <[email-masked]>
Date: Wed, 14 Sep 2005 10:12:47 +0800

Jamal,

I appreciate your review. 

A tiny question is, why the sentence   "The ForCES protocol is a message exchange protocol, information exchanged between FEs and CEs is always in the form of protocol messages. " should be omitted? do you have some more consideration? My thought is we may need to notify that the protocol is a messaging protocol rather than a header protocol like TCP/IP. 

Thanks,
Weiming

---

From: Jamal Hadi Salim <[email-masked]>
Date: Wed, 14 Sep 2005 07:03:37 -0400

On Wed, 2005-14-09 at 10:12 +0800, Wang,Weiming wrote:
> A tiny question is, why the sentence   "The ForCES protocol is a message 
> exchange protocol, information exchanged between FEs and CEs is always in 
> the form of protocol messages. " should be omitted? do you have some more 
> consideration? My thought is we may need to notify that the protocol is a 
> messaging protocol rather than a header protocol like TCP/IP. 
> 

Weiming,
I thought the description was redundant from an ietf perspective, i.e

- A protocol _already_ means there is message exchange (all IETF
protocols have message exchanges).
- message exchange _already_ means there is information exchange.
- "protocol messages" also repeats the above two points.

Terms like Request/Response protocol may be more fitting except we in
addition have asynchronous events.

If you feel strongly i could change it back.

Note, i reviewed that text as part of going over the draft from the
begining.

cheers,
jamal

---

From: Weiming Wang <[email-masked]>
Date: Wed, 14 Sep 2005 23:46:13 +0800

Jamal,

As I mentioned, it's a tiny question. I can live with it, especially after your explaination. We'd better not mention 'request/response protocol', I think, for current messages do not strictly follow it.

Thanks,
Weiming