Subject: Re: About the Model Library

From: "Khosravi, Hormuzd M" <[email-masked]>
Date: Mon, 6 Feb 2006 23:28:10 -0800

Hi Xiaoyi

I reviewed this, looks good. Just to clarify, this LFB doesn't have a
table per se that it uses since its only doing IPv4 header validation.
There is a separate IPv4 prefix LFB that will maintain a table of
prefixes, correct?

Thanks
Hormuzd

-----Original Message-----
From: Forwarding and Control Element Separation
[mailto:[email-masked]] On Behalf Of Guo, Xiaoyi
Sent: Monday, January 23, 2006 8:01 PM
To: [email-masked]
Subject: [FORCES] About the Model Library

hi, folks 

I and Joel work for one of the LFB Library in LFB library draft some 
days and now i think we need the workgroup comments. 

The following is the LFB library of the section 5.1.  IPv4 Validator
LFB[1] .
And please comments.

cheers,
xiaoyi

[1].
   <LFBLibrary provides="IPv4ValidatLFB">
     <load library="Base"/>
     <metadataDefs> 
        <metadataDef> 
          <name>ErrorId</name> 
            <synopsis>Error Types.</synopsis> 
          <atomic> 
            <baseType>int32</baseType> 
            <specialValues> 
              <specialValue value="0x00020001"> 
                <name>WrongIpVersion</name> 
                <synopsis>the IP version wrong</synopsis> 
              <specialValue value="0x00020002"> 
                 <name>WrongLength</name> 
                 <synopsis>
                  the packet length is not as long as 
                  the header indicates
                 </synopsis> 
               <specialValue value="0x000200FF"> 
                  <name>otherError</name> 
                  <synopsis>The errors we not defined now</synopsis> 
                </specialValue>
              </specialValues> 
          </atomic> 
        </metadataDef> 
     </metadataDefs>     
     <LFBClassDefs>
       <LFBClassDef LFBClassID="0x00010003">
         <name>IPv4Validat</name>
         <synopsis>
           An LFB Class definition for validates the IPv4 packet.
         </synopsis>
         <version>1.0</version>
         <inputPorts>
           <inputPort>
             <name>ValidatIn</name>
             <synopsis>
               Normal packet input.
             </synopsis>
             <expectation>
               <frameExpected>
                 <name>IPv4<name>
               </frameExpected>
               </expectation>
           </inputPort>
         </inputPorts>
         <outputPorts>
           <outputPort>
             <name>ValidatOut</name>
             <synopsis>
               Normal packet Output.
             </synopsis>
             <product>
               <frameProduced>IPv4 packet</frameProduced>
               </product>
           </outputPort>
           <outputPort>
             <name>FailOutput</name>
             <synopsis>
               The port to send packets that do not match any entries.
             </synopsis>
             <product>
               <frameProduced>
                 <ref>taggedFrame</ref>
               </frameProduced>
               <metadataProduced>
                  <ref>ErrorId</ref>  
               </metadataProduced> 
             </product>
      </outputPort>
         </outputPorts>
         <description>
           This LFB validates the IP version and header length
           fields, including verifying that the packet length 
           is at least as long as the header indicates.
         </description>
       </LFBClassDef>
     </LFBClassDefs>
   </LFBLibrary>

---

From: "Guo, Xiaoyi" <[email-masked]>
Date: Wed, 8 Feb 2006 09:49:36 +0800

Hi, Hormuzd,

Yes,  I think so. Perhaps we need work out more LFBs' definition. 

regards,
xiaoyi

----- Original Message ----- 
From: "Khosravi, Hormuzd M" <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, February 07, 2006 3:28 PM
Subject: Re: About the Model Library

Hi Xiaoyi

Thanks
Hormuzd

-----Original Message-----

hi, folks 

cheers,
xiaoyi

[1].