Subject: [forces] Adoption of ForCES Inter-FE LFB draft-joachimpillai-forces-interfelfb

From: Jamal Hadi Salim <[email-masked]>
Date: Wed, 10 Dec 2014 09:40:35 -0500

This is a re-initialized call for adoption.
As per last meeting discussion and charter requirements
http://tools.ietf.org/html/draft-joachimpillai-forces-interfelfb
as the WG document for the inter FE chartered work.

If there are any objections or suggestions please raise them
on the list (dont send me or DJ private email).
Silence implies consent.

The initial call for adoption was withdrawn because we wanted
to make sure we can get the code sane to the proposed ideas.
We have achieved that goal at this point.

cheers,
jamal

---

From: "Haleplidis Evangelos" <[email-masked]>
Date: Sat, 13 Dec 2014 02:15:53 +0200

Greetings to all,

I support the adoption of this draft as a wg item.
I'll soon send a mail with a few editorial mostly comments.

Regards,
Evangelos.

> -----Original Message-----
> From: forces [mailto:[email-masked]] On Behalf Of Jamal Hadi
> Salim
> Sent: Wednesday, December 10, 2014 4:41 PM
> To: [email-masked]
> Subject: [forces] Adoption of ForCES Inter-FE LFB draft-joachimpillai-
> forces-interfelfb
> 
> If there are any objections or suggestions please raise them on the
> list (dont send me or DJ private email).
> Silence implies consent.
> 
> The initial call for adoption was withdrawn because we wanted to make
> sure we can get the code sane to the proposed ideas.
> _______________________________________________
> forces mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/forces

---

From: "Haleplidis Evangelos" <[email-masked]>
Date: Thu, 18 Dec 2014 00:52:24 +0200

Greetings to the list,

I have read and support the adoption of this as a working group document.
I have the following comments which are mostly editorial:

1. Please change the abstract to describe what the document is all about.
Currently the abstract discusses the main ForCES concept and that this is a
charter item. It needs to be changed to explicitly express the gist of the
document.

2. There are a couple of spelling errors. You can use the spell checker
(https://tools.ietf.org/tools/idspell/webservice).

3. Please change (or remove) this line: "The new ForCES charter allows the
LFB links in a topology to be across multiple FE (inter-FE connectivity)." 

4. You should possibly discuss what will happen when two IFE LFBs under a
different master that will set the IFETYPE component. Since the ethertype is
the only way you can identify this kind of message, you might want to say
that it must be the same to both ends. Unless you want to limit this
document to LFBs under one master. Following on that, while you specify the
IFETYPE on the egress, you don't have a way to say what ethertype you're
expecting. Also, what will happen if you set an ethertype on an already
reserved one? Should you also have a PreviousFE component? 

5. Is it possible that you can have multiple connections between two
InterLFBs? Should this be limited to one?

Regards,
Evangelos.

---

From: Joel <[email-masked]>
Date: Fri, 19 Dec 2014 18:22:25 -0500

I support adoption of this document by the working group.  The issue 
addressed is real, and suitable for IETF standardization.  The 
mechanisms described seems appropriate to the task.

Once adopted, as Evangelos suggested, the working group should decide 
how to handle the case of inter-FE with the FEs controlled by different 
CEs.  I see two choices, either of which is reasonable.  We can declare 
that the scope is only inter-FE under control of a single CE, or we can 
declare that if there are two CEs they must agree out-of-band on the IDs 
for metadata.  (The one solution I would like to avoid is specifying a 
metadata rewrite function to transform the IDs at the border.)

Yours,
Joel

---

From: "Joachimpillai, Damascene M" <[email-masked]>
Date: Fri, 19 Dec 2014 19:34:19 -0500

I agree with Joel's proposal on the metadata rewrite function. Initial thought was to have the metadata pre-determined. One can also publish and trim based on supported (sort of like capability exchange). Should this be bounced against the SFC WG document that talks about Service chaining? Just a thought. 

-- DJ

-----Original Message-----
From: forces [mailto:[email-masked]] On Behalf Of Joel
Sent: Friday, December 19, 2014 6:22 PM
To: Jamal Hadi Salim; [email-masked]
Subject: Re: [forces] Adoption of ForCES Inter-FE LFB draft-joachimpillai-forces-interfelfb

I support adoption of this document by the working group.  The issue addressed is real, and suitable for IETF standardization.  The mechanisms described seems appropriate to the task.

Once adopted, as Evangelos suggested, the working group should decide how to handle the case of inter-FE with the FEs controlled by different CEs.  I see two choices, either of which is reasonable.  We can declare that the scope is only inter-FE under control of a single CE, or we can declare that if there are two CEs they must agree out-of-band on the IDs for metadata.  (The one solution I would like to avoid is specifying a metadata rewrite function to transform the IDs at the border.)

Yours,
Joel

---

From: Joel <[email-masked]>
Date: Fri, 19 Dec 2014 20:05:58 -0500

While we can discuss things with the SFC group, I would note that:

1) They are targeting a format that is transport independent and that 
carries a service function path ID that is easily used for forwarding. 
Metadata is necessary, supported, but distinctly secondary.  ForCES does 
not have a notion of a path-ID selected by an initial classifier.  (That 
would ahve been a very different design, and harder for us to work with.)

2) They have proposals on the table, and are having discussions.  While 
we could come in with a late complication, as a participant who has been 
trying to get agreement I can work with, I would prefer not to do so.

Yours,
Joel

On 12/19/14 7:34 PM, Joachimpillai, Damascene M wrote:
> I agree with Joel's proposal on the metadata rewrite function.
> Initial thought was to have the metadata pre-determined. One can also
> publish and trim based on supported (sort of like capability
> exchange). Should this be bounced against the SFC WG document that
> talks about Service chaining? Just a thought.
>
> -- DJ
>
> -----Original Message----- From: forces
> [mailto:[email-masked]] On Behalf Of Joel Sent: Friday,
> December 19, 2014 6:22 PM To: Jamal Hadi Salim; [email-masked]
> how to handle the case of inter-FE with the FEs controlled by
> different CEs.  I see two choices, either of which is reasonable.  We
> can declare that the scope is only inter-FE under control of a single
> CE, or we can declare that if there are two CEs they must agree
> out-of-band on the IDs for metadata.  (The one solution I would like
> to avoid is specifying a metadata rewrite function to transform the
> IDs at the border.)
>
> Yours, Joel
>
>> This is a re-initialized call for adoption. As per last meeting
>> discussion and charter requirements
>> http://tools.ietf.org/html/draft-joachimpillai-forces-interfelfb as
>> the WG document for the inter FE chartered work.
>>
>> If there are any objections or suggestions please raise them on
>> the list (dont send me or DJ private email). Silence implies
>> consent.
>>
>> The initial call for adoption was withdrawn because we wanted to
>> make sure we can get the code sane to the proposed ideas. We have
>> achieved that goal at this point.
>>
>> cheers, jamal
>>
>> _______________________________________________ forces mailing
>> list [email-masked] https://www.ietf.org/mailman/listinfo/forces
>>
>
> _______________________________________________ forces mailing list
> [email-masked] https://www.ietf.org/mailman/listinfo/forces
>