Subject: [gaia] An Internet-Draft on "Experiences with IETF Protocols in Community Networks"

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 21 Oct 2014 09:10:32 +0100

Hi,

I was talking with Leandro last night in the pub (which proves that there is
value in going to pubs) about something he said yesterday during his
presentation. The point he made was that implementations of IETF protocols (I am
assuming principally OLSR, but potentially this includes OSPF and BGP) in
community networks have diverged from the specifications documented in RFCs as
features and fixes have evolved.

It would be nice to have these things documented so that:
- new people can implement without having to discover and fix the
  same issues
- new implementations can be dropped into deployments with some
  chance of interoperation
- the IETF can learn and benefit from real-world experience

It seemed to us that three separate pieces of work would be valuable (possibly
repeated for each protocol)...

1. Deployment experiences and issues encountered.
What network characteristics and topologies were deployed? What was the network
stability and loading? What happened? 

2. Advice for configuration and deployment.
What values were selected for protocol parameters? What configurations worked
and didn't work? What advice can be given for specific applications?

3. Protocol issues and proposed solutions
In what way were existing protocol specifications deficient or unclear? (This
may relate back to 1 and 2). What solutions/hacks were implemented? What updates
to the RFCs should be made?

I have a little experience producing Internet-Drafts, in particular in
understanding the draft-publish-review-repeat cycle that may be unfamiliar to a
lot of you in this forum. So I'd be willing to help with the process and handle
the editorial side. Of course, I would still need the information from you.

Who would like to work with Leandro and me to make this happen?
Shall we start with OLSR and work from there?

Thanks,
Adrian

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Wed, 22 Oct 2014 17:44:12 +0100

Forwarding this to GAIA..
---------- Forwarded message ----------
From: "L. Aaron Kaplan" <[email-masked]>
Date: 22 Oct 2014 17:42
Subject: Re: [Confine] [gaia] An Internet-Draft on "Experiences with IETF
Protocols in Community Networks"
To: "Arjuna Sathiaseelan" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, <[email-masked]>

Arjuna and Adrian,

OLSR is being actively taken care of in the MANET WG by Frauenhofer.
So, I think that is OK there. In fact, that's where OLSR started and IMHO
we should simply help Frauenhofer/Henning to push for quicker adaption
there. There are some blockers which delayed some things for quite some
time.
With OLSR, this is the ETX metric discussion.

Concerning BGP: I don't think that community networks seriously diverged
from BGP per se. Often they use Mikrotiks implementation.

Hope this input helps.
Aaron.

On Oct 21, 2014, at 4:55 PM, Arjuna Sathiaseelan <
[email-masked]> wrote:

> this is extremely important for confine as a great outcome..anyone
interested?
>
>
> ---------- Forwarded message ----------
> From: Adrian Farrel <[email-masked]>
> Date: 21 October 2014 09:10
> Subject: [gaia] An Internet-Draft on "Experiences with IETF Protocols
> in Community Networks"
> To: [email-masked]
>
>
> Hi,
>
> _______________________________________________
> gaia mailing list
> [email-masked]
> https://irtf.org/mailman/listinfo/gaia
>
>
> --
> Arjuna Sathiaseelan | http://www.cl.cam.ac.uk/~as2330/
> _______________________________________________
> Confine mailing list
> [email-masked]
> http://www.grups.pangea.org/mailman/listinfo/confine

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Thu, 23 Oct 2014 09:20:53 +0100

Hello Adrian, all

I think this a great effort - thanks Adrian for initiating this..

This also reminds me some of the discussions I had with Gorry, Lars and you.

There could also be opportunities for working on drafts on the effect
of the protocol changes above the network layer too for e.g. the
effect of large initial windows - it will be wonderful to hear about
deployment experiences from developing regions using a large initial
window of 10 segments..Ofcourse the folks at Google (Nandita and co)
claim a large initial windows gives a performance improvement but I am
reluctant to believe this and not sure whether they have swept the
entire parameter space! Will be great to have some knowledge on this
and possibly documented..

The same holds for the Http 2.0 based on SPDY and its effects on
pushing objects anticipating the need..how does this affect on slow
links in developing regions?

There could be more..Will be great to think about this, pursue some
work on this and document them as experiences..

Regards

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Thu, 23 Oct 2014 09:36:39 +0100

---------- Forwarded message ----------
From: "Joseph Bonicioli" <[email-masked]>
Date: 23 Oct 2014 09:35
Subject: Re: [Confine] [gaia] An Internet-Draft on "Experiences with IETF
Protocols in Community Networks"
To: "Braem Bart" <[email-masked]>
Cc: "Arjuna Sathiaseelan" <[email-masked]>, "
[email-masked]" <[email-masked]>

We would be willing to relay experience and feedback from the community.
In the past we had rather unsuccessful attempts with OLSR Confederations
and one partially successful.
BGP is strongly rooted in all the Greek wifi communities mainly due to the
original well planed Hellenic Address Plan, the interconnection plans,  but
also due to the extensive use of mikrotik and UBNT equipment.
I agree that we should at least be able to produce a comparison map between
protocols, experiences sharing and come out with a story that could
potentially help others decide how to plan out a Community Network without
prejudiced and good practice per case.
It seems fair to all and something we have to give back.
I can help with BGP/OSPF, but OLSR is not my specialty although I am
willing to learn and listen. I find this originally interesting for me
personally so i suspect there will be lots of others that will like to see
something like that.

On 23 Οκτ 2014, at 11:05 π.μ., Braem Bart <[email-masked]> wrote:

> Thank Arjuna, this is certainly very interesting, let’s discuss this
further the next couple of days and weeks.
>
> For now it would be good to know the opinion of academic and community
network partners:
> - AWMN, FF and Guifi: do you think this could be something?
> - FKIE and UPC: does this align with your work?
>
> best regards,
> Bart
>
>
> On 21 Oct 2014, at 16:55, Arjuna Sathiaseelan <
interested?

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Thu, 23 Oct 2014 11:02:39 +0100

More input coming in..

---------- Forwarded message ----------
From: Renato Lo Cigno <[email-masked]>
Date: 23 October 2014 10:44
Subject: Re: [Confine] [gaia] An Internet-Draft on "Experiences with
IETF Protocols in Community Networks"
To: [email-masked], Arjuna Sathiaseelan
<[email-masked]>
Cc: Leonardo maccari <[email-masked]>, Renato Lo Cigno
<[email-masked]>

Hi Arjuna,

we also have some activities and works that impact routing standards,
and OLSR in particular. For instance this work
Leonardo Maccari, Renato Lo Cigno,
"A Week in the Life of Three Large Wireless Community Networks",
Ad Hoc Networks, Available online 7 August 2014 [*]
shows that link quality in the end has little impact on choices.

We are also working on other aspects of MPR selection (we presented
preliminar results at CNBuB 2012) and will have a full paper with
interesting results soon.

Cheers
Renato & Leonardo

[*] http://www.sciencedirect.com/science/article/pii/S1570870514001474
or my local PDF
http://disi.unitn.it/locigno/publications/2014/MaLo14_AdHoc-oneweek.pdf

On 10/23/14 10:43 AM, Arjuna Sathiaseelan wrote:
>
> That's great Joseph.
>
> I would subscribe you to the gaia mailing list so that you can work with
> the rest of interested folks on this.
>
> The list is here: http://irtf.org/mailman/listinfo/gaia
>
> Others please join and contribute too.
>
> Regards
>
> On 23 Oct 2014 09:35, "Joseph Bonicioli" <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     In the past we had rather unsuccessful attempts with OLSR
>     Confederations and one partially successful.
>     BGP is strongly rooted in all the Greek wifi communities mainly due
>     to the original well planed Hellenic Address Plan, the
>     interconnection plans,  but also due to the extensive use of
>     mikrotik and UBNT equipment.
>     I agree that we should at least be able to produce a comparison map
>     between protocols, experiences sharing and come out with a story
>     that could potentially help others decide how to plan out a
>     Community Network without prejudiced and good practice per case.
>     willing to learn and listen. I find this originally interesting for
>     me personally so i suspect there will be lots of others that will
>     like to see something like that.
>
>
>     On 23 Οκτ 2014, at 11:05 π.μ., Braem Bart <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>      > Thank Arjuna, this is certainly very interesting, let’s discuss
>     this further the next couple of days and weeks.
>      >
>      > For now it would be good to know the opinion of academic and
>     community network partners:
>      > On 21 Oct 2014, at 16:55, Arjuna Sathiaseelan
>     <[email-masked]
>     <mailto:[email-masked]>> wrote:
>      >
>      >> this is extremely important for confine as a great
>     outcome..anyone interested?
>      >>
>      >>
>      >> From: Adrian Farrel <[email-masked]
>     <mailto:[email-masked]>>
>      >> To: [email-masked] <mailto:[email-masked]>
>      >>
>      >>
>      >> Hi,
>      >>
>      >> [email-masked] <mailto:[email-masked]>
>      >> [email-masked] <mailto:[email-masked]>
>      > [email-masked] <mailto:[email-masked]>