Subject: [gaia] Dissecting Web Latency in Ghana

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 6 Nov 2014 19:01:59 +0000

IMC paper of potential interest
http://conferences2.sigcomm.org/imc/2014/papers/p241.pdf

Lars

---

From: Nick Feamster <[email-masked]>
Date: Thu, 6 Nov 2014 14:22:29 -0500

Hi Lars, all,

> On Nov 6, 2014, at 2:01 PM, Eggert, Lars <[email-masked]> wrote:
> 

Cool stuff.  A couple of the findings seem very consistent with a few of Srikanth Sundaresan’s research on Web performance:

1. "From our measurements over the past twoyears, we observed that DNS is a critical bottleneck in pageload times and even the deployment of simple ideas such as DNS caching can help improve the end-to-end performance.”

This agrees with the findings of our earlier study on improving Web performance bottlenecks in home networks:
http://conferences.sigcomm.org/imc/2013/papers/imc120-sundaresanA.pdf

See, in particular Section 6, which talks about caching DNS records (and TCP connections) in home routers.

2. "Apart from DNS, we found that because of the lack of server infrastructure within the country, every request needs to berouted to US or European countries thereby incurring a high network latency penalty.”

This agrees with our DEV paper from last year:
http://www1.icsi.berkeley.edu/~srikanth/docs/broadband-sa-dev4.pdf

Check out Section 4.2, and in particular, the paragraph with the heading “Latency to popular websites” on page 8.

-Nick