Subject: [gaia] Fwd: New Version Notification for draft-mahy-gaia-tools-00.txt

From: Rohan Mahy <[email-masked]>
Date: Mon, 1 Dec 2014 12:51:21 -0800

Hi Everyone,

I just submitted an individual draft with some of my thoughts about the
spectrum of tools that we have available.

There is also a pretty PDF (HTML from the xml2rfc tool) at
http://www.ietf.org/id/draft-mahy-gaia-tools-00.pdf

Comments are welcome.
thanks,
-rohan

---------- Forwarded message ----------
From: <[email-masked]>
Date: Mon, Dec 1, 2014 at 12:45 PM
Subject: New Version Notification for draft-mahy-gaia-tools-00.txt
To: Rohan Mahy <[email-masked]>

A new version of I-D, draft-mahy-gaia-tools-00.txt
has been successfully submitted by Rohan Mahy and posted to the
IETF repository.

Name:           draft-mahy-gaia-tools
Revision:       00
Title:          Tools to accomplish the goals of GAIA (Global Access to the
Internet for All)
Document date:  2014-12-01
Group:          Individual Submission
Pages:          11
URL:
http://www.ietf.org/internet-drafts/draft-mahy-gaia-tools-00.txt
Status:         https://datatracker.ietf.org/doc/draft-mahy-gaia-tools/
Htmlized:       http://tools.ietf.org/html/draft-mahy-gaia-tools-00

Abstract:
   This document explores the central problem of the GAIA (Global Access
   to the Internet for All) IRTF research group.  It discusses several
   possible approaches or tools that can be used to increase the number
   of people with access to the Internet.  Specifically we discuss how
   these tools can improve reach, reduce cost, and improve the quality
   of the Internet, especially in underserved areas.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Nick Feamster <[email-masked]>
Date: Mon, 1 Dec 2014 15:54:24 -0500

Nice start!  

Are you going to be at GAIA?

I read Section 2.11 and found it on target… but it’s a little short (one sentence).  This might be a good starting point for expansion:
http://www.cc.gatech.edu/~agupta80/pdfs/pam14.pdf

And, we’re actively working on next steps here to improve the state of affairs.  I would like to talk with you more about this particular section (and perhaps others).  If this is going to be a group GAIA effort, I’ll be happy to contribute.

-Nick

> On Dec 1, 2014, at 3:51 PM, Rohan Mahy <[email-masked]> wrote:
> 
> Hi Everyone,
> 
> I just submitted an individual draft with some of my thoughts about the spectrum of tools that we have available. 
> 
> There is also a pretty PDF (HTML from the xml2rfc tool) at http://www.ietf.org/id/draft-mahy-gaia-tools-00.pdf
> 
> Comments are welcome. 
> thanks,
> -rohan
> 
> 
> Title:          Tools to accomplish the goals of GAIA (Global Access to the Internet for All)
> URL:            http://www.ietf.org/internet-drafts/draft-mahy-gaia-tools-00.txt
> _______________________________________________
> gaia mailing list
> [email-masked]
> https://irtf.org/mailman/listinfo/gaia

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Mon, 1 Dec 2014 21:09:01 +0000

Great stuff Rohan..this is inline with the discussions we had at the
Dagstuhl - I will send the report across soon..

Nick - some of us (Roderick Fanou from IMDEA Networks, Gareth Tyson,
Marco Zennaro, Jon Crowcroft and I) are looking at the incentives for
IXP peering in Africa currently (with the help of Steve Song and Mike
Jensen). I am planning to talk to you about this at the GAIA..

Roderick just got a PAM paper accepted on his earlier work on
interdomain routing in africa..may be he can send it across to
you/all..

Regards

-- 
Arjuna Sathiaseelan | http://www.cl.cam.ac.uk/~as2330/

---

From: Nick Feamster <[email-masked]>
Date: Mon, 1 Dec 2014 16:11:26 -0500

> On Dec 1, 2014, at 4:09 PM, Arjuna Sathiaseelan <[email-masked]> wrote:
> 
> are looking at the incentives for

Yes, that’s a topic Arpit (the lead author on the paper I just forwarded) and I have been thinking about for some time, with inspiration from the ISOC IXP folks and economists.  Let’s talk in person about it at GAIA.

> interdomain routing in africa..may be he can send it across to

Awesome!  Looking forward to seeing it.

-Nick

---

From: Henning G Schulzrinne <[email-masked]>
Date: Mon, 1 Dec 2014 16:37:58 -0500

Interesting compilation! Realizing that this is a 00 draft, I'll note
that many of the ideas, for example, for increasing competition have
been tried out in various places, with rather mixed results (to be
polite).

For example, in the US, there is no inherent regulatory barrier for a
new facilities-based provider, but overbuilding is very rare, and
seems to require external cash (see Google), even at small scale, or a
bankruptcy laundry cycle or two (RCN). Generally, any
telecommunication carrier can get non-discriminatory access to poles
and ducts, for example.

Similarly, there have been "designated entity" and regional licenses
in US spectrum auctions since the beginning. The main result appears
to be that they either "flip" the spectrum or become rural roaming
partners of large mobile providers.

There is a very large telecom policy research community outside the
IRTF, and they may have valuable real-world input on the economics and
policy issues, and the results of natural experiments conducted since,
at least, the mid-90s. For example, some approaches would require
changing national laws, which, as US-based participants of the list
know, is not for the faint of heart or wallet. This is at least as
much about economics and law as about technology or "why has nobody
thought of *that* before?".

For the US, the annual TPRC conference contains related tracks that
also cover international issues.

The draft omits ideas that involve spending government money, although
those have actually shown some success, e.g., in building neutral
middle mile networks (BTOP grants) and, possibly, in deploying rural
fiber networks (on-going FCC pilot program). There are other examples
from Sweden, Korea and Japan.

Given the experiences, it may be as helpful to ask "why haven't these
ideas worked out in practice?" (or have been less successful than
hoped) as compile them as if they were new.

I'm not endorsing the conclusions, but you can see some of that debate
at non-expert level at
http://www.vox.com/2014/12/1/7290669/you-can-have-faster-internet-or-more-competitive-internet-but-getting

Henning

---

From: Jane Coffin <[email-masked]>
Date: Mon, 1 Dec 2014 22:23:29 +0000

Hello everyone -

This is Jane Coffin from ISOC - working on IXP projects and other with
many countries.
One element that may be missing is that some of the equipment necessary to
build Internet infrastructure is hung up in customs and subject to other
taxes.  We have a barriers report that lists various elements common in
many countries.

Another factor - ambitious government officials who want to run
infrastructure like IXPs due to incumbent issues.

I do not want to interfere, but what is the timeline and would you welcome
more info?

Best,
Jane

On 12/1/14, 16:09, "Arjuna Sathiaseelan"
<[email-masked]> wrote:

>> I read Section 2.11 and found it on targetŠ but it¹s a little short
>>(one sentence).  This might be a good starting point for expansion:
>> And, we¹re actively working on next steps here to improve the state of
>>affairs.  I would like to talk with you more about this particular
>>section (and perhaps others).  If this is going to be a group GAIA
>>effort, I¹ll be happy to contribute.
>>
>> -Nick
>>
>>
>>> I just submitted an individual draft with some of my thoughts about
>>>the spectrum of tools that we have available.
>>>

---

From: "Steven G. Huter" <[email-masked]>
Date: Thu, 4 Dec 2014 16:35:50 -0800 (PST)

> IXP peering in Africa currently

the reference mentioned during Nick's presentation at the GAIA meeting 
today.

http://nsrc.org/AFRICA/ixp/

this info is maintained with input from a number of colleagues who 
maintain the respective IXPs, and the data sources cited.

Steve Huter, Director
Network Startup Resource Center (NSRC)
http://nsrc.org/

---

From: Vint Cerf <[email-masked]>
Date: Fri, 5 Dec 2014 05:27:20 -0500

why are there not more IXPs in northern Africa?
v

---

From: Mike <[email-masked]>
Date: Fri, 05 Dec 2014 07:53:21 -0300

Vint, I suspect the reason for so few IXPs in north Africa is a
result of strong state security concerns reinforcing the positions
of the monopoly government owned incumbent operators as the sole
internet gateways out of the country, which in turn discouraged
growth of 2nd-tier ISPs needing to exchange traffic locally.

Hopefully this is now changing, following the great example of the
Tunisian IXP which emerged from the state controlled gateway after
the Jasmine revolution.

Mike

On 05-12-2014 07:27, Vint Cerf wrote:

v

On Thu, Dec 4, 2014 at 7:35 PM, Steven
G. Huter <[email-masked]>
wrote:

the reference mentioned during Nick's presentation at the
GAIA meeting today.

this info is maintained with input from a number of
colleagues who maintain the respective IXPs, and the data
sources cited.

Steve Huter, Director

http://nsrc.org/

gaia mailing list

[email-masked]

---

From: Jane Coffin <[email-masked]>
Date: Fri, 5 Dec 2014 12:01:55 +0000

Old incumbent regulatory minded regimes.
We just held an IXP workshop in Tunisia a few weeks ago, and I spoke with the Algerian Ministry last week in Beirut at the Arab IGF.
-Morocco thinking about it
-Algeria in process
-Libya - PCH trying hard there
-Egypt has CAIX (we are shipping some gear there in the next few weeks) and they are planning a few more.
-Mauritania - WB in there and that is slow, but we also have done training through the AU there and Michuki and Dawit working on it

Jane

From: Vint Cerf <[email-masked]<mailto:[email-masked]>>
Date: Friday, December 5, 2014 at 5:27
To: "Steven G. Huter" <[email-masked]<mailto:[email-masked]>>
Cc: gaia <[email-masked]<mailto:[email-masked]>>, Nick Feamster <[email-masked]<mailto:[email-masked]>>, Arjuna Sathiaseelan <[email-masked]<mailto:[email-masked]>>
Subject: Re: [gaia] Africa IXP map (was Re: Fwd: New Version Notification for draft-mahy-gaia-tools-00.txt)

On Thu, Dec 4, 2014 at 7:35 PM, Steven G. Huter <[email-masked]<mailto:[email-masked]>> wrote:
IXP peering in Africa currently

the reference mentioned during Nick's presentation at the GAIA meeting today.

this info is maintained with input from a number of colleagues who maintain the respective IXPs, and the data sources cited.

Steve Huter, Director

_______________________________________________
gaia mailing list
[email-masked]<mailto:[email-masked]>
https://irtf.org/mailman/listinfo/gaia

---

From: Jane Coffin <[email-masked]>
Date: Fri, 5 Dec 2014 12:05:52 +0000

Vint -

I also should say that on Tunisia:
PCH worked with EC on funding and was key there.  Got the IXP environment jump started after a regime that conducted DPI on anything in/out - that gear is gone.
We just sent 3 switches (in July) - 2 released for our workshop a few weeks ago and 1 in customs jail - soon to be released.  They actually brought one of the switches into the workshop to show people that the equipment was "new" and not from the old regime.  Lots of trust issues there and they are doing a good job dealing with it all.  Moez Chakchouk pretty much the rock-star there along with the team at TUNIXP.

Best,
Jaen

From: Jane <[email-masked]<mailto:[email-masked]>>
Date: Friday, December 5, 2014 at 7:02
To: Vint Cerf <[email-masked]<mailto:[email-masked]>>, "Steven G. Huter" <[email-masked]<mailto:[email-masked]>>
Cc: gaia <[email-masked]<mailto:[email-masked]>>, Nick Feamster <[email-masked]<mailto:[email-masked]>>, Arjuna Sathiaseelan <[email-masked]<mailto:[email-masked]>>
Subject: Re: [gaia] Africa IXP map (was Re: Fwd: New Version Notification for draft-mahy-gaia-tools-00.txt)

Jane

Steve Huter, Director

---

From: "Steven G. Huter" <[email-masked]>
Date: Fri, 5 Dec 2014 09:43:48 -0800 (PST)

Another information resource that is pertinent to our discussions in the 
GAIA meeting yesterday is the IXP Toolkit, which is being developed by a 
team at the Internet Society and colleagues. New content is currently 
being added, and the site is now live at:

http://ixptoolkit.org/

Steve Huter

On Thu, 4 Dec 2014, Steven G. Huter wrote:

> this info is maintained with input from a number of colleagues who maintain 
> the respective IXPs, and the data sources cited.
>
> Steve Huter, Director

---

From: Juliao Braga <[email-masked]>
Date: Sat, 06 Dec 2014 17:31:13 +0000

I do not know if it was informed in GAIA group, but the AXIS project is 
well underway and can be seen here, answering few questions:

http://pages.au.int/axis

In addition, an interesting project involving four areas of interest of 
the African community, one involving a huge backbone:

https://drive.google.com/file/d/0ByqDDJ1MqhuyR0p0UTA5ZnJGMVk/view?usp=sharing 
(in French)
https://drive.google.com/file/d/0ByqDDJ1MqhuyVkdUMzZUNTlPT2s/view?usp=sharing

[]s,

Julião