Subject: Re: [gaia] How ICN benefits AN?

From: "Xuan Liu" <[email-masked]>
Date: Thu, 23 Apr 2015 09:26:20 +0800

Hello Liang,
    It is so nice of you to point the way for the topic which I am interested in. Of course, everyone want to see much higher traffic saving in developing regions, but first of all I should analyze internet traffic in that regions, that is to say , I should find out what is main traffic,for instance ,web page or video, and then take different methods.
    So far, I haven't seen relevant papers and websites, and could you know that?

Regards,
Xuan Liu(刘旋)
Future Network Research Center, Southeast University
 
From: Liang Wang
Date: 2015-04-22 20:50
To: Arjuna Sathiaseelan
CC: Liu, Xuan; gaia
Subject: Re: [gaia] How ICN benefits AN?
Hello Xuan,

I quickly went through the discussion. ICN in developing region is more like providing a general design principle which takes advantages of named content and caching. About the questions on caching performance, there was actually an very interesting keynote in 2013 infocom discussing about the cachability of the internet traffic, you can find it here —> http://infocom.di.unimi.it/images/stories/infocom/keynote-jroberts.pdf

Besides, there is another one in ICN’14 last year —> http://conferences2.sigcomm.org/acm-icn/2014/papers/p57.pdf

In general, I am expecting to see much higher traffic saving at the edge in Africa. :)

Regards,

Liang Wang

Computer Laboratory
University of Cambridge, UK

On 22 Apr 2015, at 12:14, Arjuna Sathiaseelan <[email-masked]> wrote:

Hello Liu,
 Yes we are also working on this here at our lab. I am cc-ing Liang Wang who is my postdoc working on this topic. Feel free to discuss with him too.

Regards

On 22 April 2015 at 03:13, Liu, Xuan <[email-masked]> wrote:
Hi Arjuna,
   Thanks for your tips again, and how to do efficient NDN based routing and in-network caching on community wireless mesh is that I am going to do. I hope for some suggestions when I get an idea.
   It is my honor to communicate wtih you.

Regards,
Liu, Xuan(刘旋),
Future Network Research Center, Southeast University
 
From: Arjuna Sathiaseelan
Date: 2015-04-22 03:42
To: Liu, Xuan
Subject: Re: Re: [gaia] How ICN benefits AN?
Hello Liu,
  Yes ofcourse you can do that too..i think there has been some work exploring that - but havent seen any good papers.

It will be interesting to see how do we do efficient NDN based routing on community wireless mesh (if its on adhoc mode vs infrastructure mode)..

Regards

On 21 April 2015 at 11:58, Liu, Xuan <[email-masked]> wrote:
Hi Arjuna,
   Thanks for sharing, but if I want to do CCN/NDN with AN, what about your view?

Regards,
Liu, Xuan(刘旋),
Future Network Research Center, Southeast University
 
From: Arjuna Sathiaseelan
Date: 2015-04-21 18:11
To: Liu, Xuan
CC: [email-masked]
Subject: Re: [gaia] How ICN benefits AN?
Hello Liu - yes good questions..

some great work here from David Johnson, Elizabeth Belding, Veljko et al:
http://moment.cs.ucsb.edu/~djohnson/Files/www11.pdf (this paper talks about the <20% savings)
http://www.cs.ucsb.edu/~ebelding/txt/dev2012.pdf
http://cs.ucsb.edu/~davidj/Files/ictd_traffic_local.pdf

Nishanth's work on P2P assisted iplayer video streaming shows significant savings (around 85% - this is video though) - could be a great motivation for doing ICN especially if you want to do PURSUIT based name resolution using Rendezvous ):
http://www.inf.kcl.ac.uk/staff/nrs/pubs/INFOCOM2015-P2P.pdf

On 21 April 2015 at 10:49, Liu, Xuan <[email-masked]> wrote:
Hi Arjuna,
    Thanks for your suggestions firstly, and I think there is no good or no bad for ICN. 
It is important to quantify these benefits that ICN gives to AN, and what's more, it is 
necessary to find out what application scenarios ICN can adequate for, for instance,dense 
? sparse population in developing regions, that means how to maximize the benefits?
   In addition, why do most caching solutions reduce backhaul traffic only by <20%,
and could share related literatures? (please forgive my ignorance)

Regards,
Liu, Xuan(刘旋),
Future Network Research Center, Southeast University
 
From: Arjuna Sathiaseelan
Date: 2015-04-20 18:15
To: Liu, Xuan
CC: [email-masked]
Subject: Re: [gaia] How ICN benefits AN?
Hello Liu,
  I think this is something that still needs further exploration. We have an EU project (http://rife-project.eu/) exploring that.

I am really keen to understand how ICN in general can solve some of the fundamental issues in realising a much affordable, flexible, geographically available Internet access - there are obvious benefits as pointed by Dirk Kutchers ICNRG draft (http://tools.ietf.org/id/draft-kutscher-icnrg-challenges-02.txt) -- but again what I am keen to see (and possibly wish to do soon) is to quantify these benefits. Why is it better than putting a set of middleboxes to achieve what ICN could do - what is the cost/performance tradeoff in deploying new edge based ICN deployments compared to just putting in a few middleboxes to solve the challenges? Is it edge caching (considering most caching solutions reduce backhaul traffic only by <20%) or is it removing the whole notion of DNS resolutions which can be a killer for latencies in developing regions (http://conferences2.sigcomm.org/imc/2014/papers/p241.pdf)? 

We absolutely need to do that before deciding whether ICN is a good alternate solution or not. 

Regards

On 20 April 2015 at 10:48, Liu, Xuan <[email-masked]> wrote:
Hi,all
   I am considering how ICN  benefits Alternative Network and could you share your opinon?
   Thanks!

Regards,
Liu, Xuan(刘旋),
Future Network Research Center, Southeast University

_______________________________________________
gaia mailing list
[email-masked]
https://irtf.org/mailman/listinfo/gaia

-- 
Arjuna Sathiaseelan 
Personal: http://www.cl.cam.ac.uk/~as2330/ 
N4D Lab: http://www.cl.cam.ac.uk/~as2330/n4d

-- 
Arjuna Sathiaseelan 
Personal: http://www.cl.cam.ac.uk/~as2330/ 
N4D Lab: http://www.cl.cam.ac.uk/~as2330/n4d

-- 
Arjuna Sathiaseelan 
Personal: http://www.cl.cam.ac.uk/~as2330/ 
N4D Lab: http://www.cl.cam.ac.uk/~as2330/n4d

-- 
Arjuna Sathiaseelan 
Personal: http://www.cl.cam.ac.uk/~as2330/ 
N4D Lab: http://www.cl.cam.ac.uk/~as2330/n4d

---

From: Liang Wang <[email-masked]>
Date: Thu, 23 Apr 2015 11:28:16 +0100

No problem, Xuan, my pleasure. 

I was just about to refer you to David’s work, he is the expert on this :)

I used to do some using P2P network size to infer the traffic volume, however the precision is a problem and you cannot decompose into content level. From David’s work, you can get better first-hand experience :)

Cheers,

Liang Wang

Computer Laboratory

> On 23 Apr 2015, at 08:47, David Johnson <[email-masked]> wrote:
> 
> Hi Xuan
> 
> Have a look at some work I did at UCSB on traffic analysis in rural
> areas for some pointers
> 
> http://moment.cs.ucsb.edu/~djohnson/Files/www11.pdf
> http://moment.cs.ucsb.edu/~djohnson/Files/ictd_traffic_local.pdf
> http://moment.cs.ucsb.edu/~djohnson/Files/villageshare_2012.pdf
> 
> All the best with your research
> 
> David
> ___________________________
> 
> David Johnson
> Principal Researcher
> Networks and Media group
> Meraka, CSIR
> Adjunct Senior Lecturer
> ICT4D, Computer Science Department
> University of Cape Town
> 
> 
> On Thu, Apr 23, 2015 at 3:26 AM, Xuan Liu <[email-masked]> wrote:
>> Hello Liang,
>>    It is so nice of you to point the way for the topic which I am
>> interested in. Of course, everyone want to see much higher traffic saving in
>> developing regions, but first of all I should analyze internet traffic in
>> that regions, that is to say , I should find out what is main traffic,for
>> instance ,web page or video, and then take different methods.
>> ________________________________
>> Regards,
>> Xuan Liu(刘旋)
>> I quickly went through the discussion. ICN in developing region is more like
>> providing a general design principle which takes advantages of named content
>> and caching. About the questions on caching performance, there was actually
>> an very interesting keynote in 2013 infocom discussing about the cachability
>> of the internet traffic, you can find it here —>
>> http://infocom.di.unimi.it/images/stories/infocom/keynote-jroberts.pdf
>> 
>> Besides, there is another one in ICN’14 last year —>
>> http://conferences2.sigcomm.org/acm-icn/2014/papers/p57.pdf
>> 
>> On 22 Apr 2015, at 12:14, Arjuna Sathiaseelan
>> <[email-masked]> wrote:
>> 
>> Hello Liu,
>> Yes we are also working on this here at our lab. I am cc-ing Liang Wang who
>> is my postdoc working on this topic. Feel free to discuss with him too.
>> 
>> Regards
>> 
>>>   Thanks for your tips again, and how to do efficient NDN based routing
>>> and in-network caching on community wireless mesh is that I am going to do.
>>> I hope for some suggestions when I get an idea.
>>> ________________________________
>>> Regards,
>>> Liu, Xuan(刘旋),
>>>  Yes ofcourse you can do that too..i think there has been some work
>>> exploring that - but havent seen any good papers.
>>> 
>>> It will be interesting to see how do we do efficient NDN based routing on
>>> community wireless mesh (if its on adhoc mode vs infrastructure mode)..
>>> 
>>> Regards
>>> 
>>> 
>>>> ________________________________
>>>> Regards,
>>>> Liu, Xuan(刘旋),
>>>> Nishanth's work on P2P assisted iplayer video streaming shows significant
>>>> savings (around 85% - this is video though) - could be a great motivation
>>>> for doing ICN especially if you want to do PURSUIT based name resolution
>>>> using Rendezvous ):
>>>>> ________________________________
>>>>> Regards,
>>>>> Liu, Xuan(刘旋),
>>>>>  I think this is something that still needs further exploration. We
>>>>> have an EU project (http://rife-project.eu/) exploring that.
>>>>> 
>>>>> I am really keen to understand how ICN in general can solve some of the
>>>>> fundamental issues in realising a much affordable, flexible, geographically
>>>>> available Internet access - there are obvious benefits as pointed by Dirk
>>>>> Kutchers ICNRG draft
>>>>> (http://tools.ietf.org/id/draft-kutscher-icnrg-challenges-02.txt) -- but
>>>>> again what I am keen to see (and possibly wish to do soon) is to quantify
>>>>> these benefits. Why is it better than putting a set of middleboxes to
>>>>> achieve what ICN could do - what is the cost/performance tradeoff in
>>>>> deploying new edge based ICN deployments compared to just putting in a few
>>>>> middleboxes to solve the challenges? Is it edge caching (considering most
>>>>> caching solutions reduce backhaul traffic only by <20%) or is it removing
>>>>> the whole notion of DNS resolutions which can be a killer for latencies in
>>>>> developing regions
>>>>> (http://conferences2.sigcomm.org/imc/2014/papers/p241.pdf)?
>>>>> 
>>>>>> ________________________________
>>>>>> Regards,
>>>>>> Liu, Xuan(刘旋),

---

From: "Xuan Liu" <[email-masked]>
Date: Thu, 23 Apr 2015 18:40:50 +0800

Liang, thanks a lot.

Regards,
Xuan Liu(刘旋)
 
From: Liang Wang
Date: 2015-04-23 18:28
To: David Johnson
CC: Xuan Liu; [email-masked]; Arjuna Sathiaseelan
Subject: Re: [gaia] How ICN benefits AN?
No problem, Xuan, my pleasure. 

Cheers,

Liang Wang

Computer Laboratory

Hi Xuan

David

David Johnson
Principal Researcher
Networks and Media group
Meraka, CSIR
Adjunct Senior Lecturer

   So far, I haven't seen relevant papers and websites, and could you know
that?

From: Liang Wang
Date: 2015-04-22 20:50
To: Arjuna Sathiaseelan
CC: Liu, Xuan; gaia

In general, I am expecting to see much higher traffic saving at the edge in
Africa. :)

Regards,

Liang Wang

Computer Laboratory

Hello Liu,

Regards

Hi Arjuna,

Regards

Hi Arjuna,
  Thanks for sharing, but if I want to do CCN/NDN with AN, what about
your view?

some great work here from David Johnson, Elizabeth Belding, Veljko et al:
http://moment.cs.ucsb.edu/~djohnson/Files/www11.pdf (this paper talks
about the <20% savings)
http://www.cs.ucsb.edu/~ebelding/txt/dev2012.pdf
http://cs.ucsb.edu/~davidj/Files/ictd_traffic_local.pdf

Hi Arjuna,
   Thanks for your suggestions firstly, and I think there is no good or
no bad for ICN.
It is important to quantify these benefits that ICN gives to AN, and
what's more, it is
necessary to find out what application scenarios ICN can adequate for,
for instance,dense
? sparse population in developing regions, that means how to maximize
the benefits?
  In addition, why do most caching solutions reduce backhaul traffic
only by <20%,
and could share related literatures? (please forgive my ignorance)

We absolutely need to do that before deciding whether ICN is a good
alternate solution or not.

Regards

Hi,all
  I am considering how ICN  benefits Alternative Network and could you
share your opinon?
  Thanks!