Subject: Re: [gaia] How ICN benefits AN?

From: Arjuna Sathiaseelan <[email-masked]>
Date: Mon, 20 Apr 2015 11:15:42 +0100

Hello Liu,
  I think this is something that still needs further exploration. We have
an EU project (http://rife-project.eu/) exploring that.

I am really keen to understand how ICN in general can solve some of the
fundamental issues in realising a much affordable, flexible, geographically
available Internet access - there are obvious benefits as pointed by Dirk
Kutchers ICNRG draft (
http://tools.ietf.org/id/draft-kutscher-icnrg-challenges-02.txt) -- but
again what I am keen to see (and possibly wish to do soon) is to quantify
these benefits. Why is it better than putting a set of middleboxes to
achieve what ICN could do - what is the cost/performance tradeoff in
deploying new edge based ICN deployments compared to just putting in a few
middleboxes to solve the challenges? Is it edge caching (considering most
caching solutions reduce backhaul traffic only by <20%) or is it removing
the whole notion of DNS resolutions which can be a killer for latencies in
developing regions (http://conferences2.sigcomm.org/imc/2014/papers/p241.pdf
)?

We absolutely need to do that before deciding whether ICN is a good
alternate solution or not.

Regards

On 20 April 2015 at 10:48, Liu, Xuan <[email-masked]> wrote:

> Hi,all
>    I am considering how ICN  benefits Alternative Network and could you
> share your opinon?
>    Thanks!
>
> ------------------------------
>    Regards,
> Liu, Xuan(刘旋),
> Future Network Research Center, Southeast University
>
> _______________________________________________
> gaia mailing list
> [email-masked]
> https://irtf.org/mailman/listinfo/gaia
>
>

-- 
Arjuna Sathiaseelan
Personal: http://www.cl.cam.ac.uk/~as2330/
N4D Lab: http://www.cl.cam.ac.uk/~as2330/n4d

---

From: "Trossen, Dirk" <[email-masked]>
Date: Mon, 20 Apr 2015 10:19:25 +0000

If we were to preserve IP and HTTP at the protocol (abstraction) level, would the question on placing ICN vs “a few middleboxes” become the same? Why is it better or cheaper or ??? to place a “set of middleboxes” than placing an IPoverICN solution in place, where the ICN part is nothing else than “a few middleboxes”.

Combine that with SDN and ICN becomes largely nothing else than an SDN controller app with some nice tricks for traffic engineering ;-)

Dirk

From: gaia [mailto:[email-masked]]

Dirk Trossen
Principal Engineer
InterDigital UK, Inc.
Shoreditch Business Center
64 Great Eastern Street
London,  EC2A 3QR
T: +44 20 7749 9178
[email-masked]
www.InterDigital.com<http://www.interdigital.com>

This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

On Behalf Of Arjuna Sathiaseelan
Sent: 20 April 2015 11:16
To: Liu, Xuan
Cc: [email-masked]
Subject: Re: [gaia] How ICN benefits AN?

Hello Liu,
  I think this is something that still needs further exploration. We have an EU project (http://rife-project.eu/) exploring that.

I am really keen to understand how ICN in general can solve some of the fundamental issues in realising a much affordable, flexible, geographically available Internet access - there are obvious benefits as pointed by Dirk Kutchers ICNRG draft (http://tools.ietf.org/id/draft-kutscher-icnrg-challenges-02.txt) -- but again what I am keen to see (and possibly wish to do soon) is to quantify these benefits. Why is it better than putting a set of middleboxes to achieve what ICN could do - what is the cost/performance tradeoff in deploying new edge based ICN deployments compared to just putting in a few middleboxes to solve the challenges? Is it edge caching (considering most caching solutions reduce backhaul traffic only by <20%) or is it removing the whole notion of DNS resolutions which can be a killer for latencies in developing regions (http://conferences2.sigcomm.org/imc/2014/papers/p241.pdf)?

We absolutely need to do that before deciding whether ICN is a good alternate solution or not.

Regards

On 20 April 2015 at 10:48, Liu, Xuan <[email-masked]<mailto:[email-masked]>> wrote:
Hi,all
   I am considering how ICN  benefits Alternative Network and could you share your opinon?
   Thanks!

________________________________
Regards,
Liu, Xuan(刘旋),
Future Network Research Center, Southeast University

_______________________________________________
gaia mailing list
[email-masked]<mailto:[email-masked]>
https://irtf.org/mailman/listinfo/gaia

---

From: Liu, Xuan <[email-masked]>
Date: Tue, 21 Apr 2015 17:49:25 +0800

Hi Arjuna,
    Thanks for your suggestions firstly, and I think there is no good or no bad for ICN. 
It is important to quantify these benefits that ICN gives to AN, and what's more, it is 
necessary to find out what application scenarios ICN can adequate for, for instance,dense 
? sparse population in developing regions, that means how to maximize the benefits?
   In addition, why do most caching solutions reduce backhaul traffic only by <20%,
and could share related literatures? (please forgive my ignorance)

Regards,
Liu, Xuan(刘旋),
 
From: Arjuna Sathiaseelan
Date: 2015-04-20 18:15
To: Liu, Xuan
CC: [email-masked]
Subject: Re: [gaia] How ICN benefits AN?
Hello Liu,
  I think this is something that still needs further exploration. We have an EU project (http://rife-project.eu/) exploring that.

Regards

Regards,
Liu, Xuan(刘旋),

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Tue, 21 Apr 2015 11:11:33 +0100

Hello Liu - yes good questions..

some great work here from David Johnson, Elizabeth Belding, Veljko et al:
http://moment.cs.ucsb.edu/~djohnson/Files/www11.pdf (this paper talks about
the <20% savings)
http://www.cs.ucsb.edu/~ebelding/txt/dev2012.pdf
http://cs.ucsb.edu/~davidj/Files/ictd_traffic_local.pdf

Nishanth's work on P2P assisted iplayer video streaming shows significant
savings (around 85% - this is video though) - could be a great motivation
for doing ICN especially if you want to do PURSUIT based name resolution
using Rendezvous ):
http://www.inf.kcl.ac.uk/staff/nrs/pubs/INFOCOM2015-P2P.pdf

On 21 April 2015 at 10:49, Liu, Xuan <[email-masked]> wrote:

> *From:* Arjuna Sathiaseelan <[email-masked]>
> *Date:* 2015-04-20 18:15
> *To:* Liu, Xuan <[email-masked]>
> *CC:* [email-masked]
> *Subject:* Re: [gaia] How ICN benefits AN?
> Hello Liu,
> developing regions (
> http://conferences2.sigcomm.org/imc/2014/papers/p241.pdf)?
>

---

From: Henning Schulzrinne <[email-masked]>
Date: Tue, 21 Apr 2015 07:44:14 -0400

Many years ago, we looked at a very simple mechanism to use
opportunistic networks for local content distribution (using
Bonjour/mDNS). This assumes a very large cost or availability step
between the local network and wide-area connectivity. See the 7DS work
at

http://dl.acm.org/citation.cfm?id=501433

and related papers.

(There's also a related thesis and book, and a slightly more updated
implementation by Suman Srinivasan that incorporates email delivery.)

CDN-style delivery of content does not necessarily imply DNS.

I would argue that, just by the theory that just about anything that
can be done at the network layer can be done at higher layers, that
ICN can't be inherently more efficient. After all, you are not going
to be storing TB of data on commodity routers - it's going to be a
server sitting next to a router...

On Tue, Apr 21, 2015 at 6:11 AM, Arjuna Sathiaseelan
<[email-masked]> wrote:
>> Kutchers ICNRG draft
>> (http://tools.ietf.org/id/draft-kutscher-icnrg-challenges-02.txt) -- but
>> developing regions
>> (http://conferences2.sigcomm.org/imc/2014/papers/p241.pdf)?
>>