Subject: [gaia] Is DTN dead for under-serviced area communication

From: David Johnson <[email-masked]>
Date: Wed, 10 Jun 2015 13:02:03 +0200

What are your thoughts on this - surveying the literature it seems
like most of work and active deployments like DakNet and KioskNet are
mostly historical and that its no  longer considered as a serious
contender for poorly connected regions ... there are some
interesting new developments that mix social networks and delay
tolerant networks - but they seem mostly like playful ideas than
something to take seriously.  Rhizome store-and-forward on a Serval
Overlay Mesh seemed to be the most interesting recent work ... but I'm
no expert in this area.

Thanks
David
___________________________

David Johnson
Principal Researcher
Networks and Media group
Meraka, CSIR
Adjunct Senior Lecturer
ICT4D, Computer Science Department
University of Cape Town

---

From: Jane Coffin <[email-masked]>
Date: Wed, 10 Jun 2015 13:18:37 +0000

Hi Everyone,

I want to share 2 case-books with all of you.  These casebooks are from a
project called Wireless for Communities:
http://defindia.org/wforc/
http://wforc.in/ 
http://www.internetsociety.org/what-we-do/where-we-work/asia/south-asia/wir
eless-communities
http://www.apc.org/en/news/wireless-communities-w4c-programme-connecting-re
mo

These are efforts to build more connectivity/create sustainable networks
in India among DEF, ISOC, APC, and local partners.  Three more
remote/rural Indian villages will go on line, soon.

Our APAC team (Asia Pacific team) also is working to extend similar
projects to other countries in the APAC region, and we are thinking about
where to take these projects in other regions.

Videos available on some of the above sites.

Jane

On 6/10/15, 7:02 AM, "David Johnson" <[email-masked]> wrote:

>_______________________________________________
>gaia mailing list
>[email-masked]
>https://irtf.org/mailman/listinfo/gaia

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Wed, 10 Jun 2015 15:01:41 +0000

My hypothesis is that deploying DTN for communication in under-serviced areas has seemed less compelling as big corporations have undertaken to build satellite constellations that would provide Internet service to those areas.

Lately, though, some of those initiatives seem to be ending (http://qz.com/422775/facebook-and-google-are-out-of-the-space-race/), so DTN-based solutions may regain some appeal.  Ideas for providing delayed network service via a very-low-cost constellation of orbiting data mule satellites have been around for several years, and I think advances in Cubesat technology are making that concept more attractive every month.  I think a case can even be made that many of the network applications people use every day would work at least as well over delayed service as over end-to-end Internet service.

Scott

-----Original Message-----
From: gaia [mailto:[email-masked]] On Behalf Of David Johnson
Sent: Wednesday, June 10, 2015 4:02 AM
To: gaia
Subject: [gaia] Is DTN dead for under-serviced area communication

What are your thoughts on this - surveying the literature it seems like most of work and active deployments like DakNet and KioskNet are mostly historical and that its no  longer considered as a serious contender for poorly connected regions ... there are some interesting new developments that mix social networks and delay tolerant networks - but they seem mostly like playful ideas than something to take seriously.  Rhizome store-and-forward on a Serval Overlay Mesh seemed to be the most interesting recent work ... but I'm no expert in this area.

Thanks
David

David Johnson
Principal Researcher
Networks and Media group
Meraka, CSIR
Adjunct Senior Lecturer

---

From: Vint Cerf <[email-masked]>
Date: Wed, 10 Jun 2015 11:08:04 -0400

elon is back in the race with a large cloud of satellites; i spoke with his
tech team and they do not see a need for DTN given the relatively low delay
orbital mechanics.

v

On Wed, Jun 10, 2015 at 11:01 AM, Burleigh, Scott C (312B) <
[email-masked]> wrote:

> My hypothesis is that deploying DTN for communication in under-serviced
> areas has seemed less compelling as big corporations have undertaken to
> build satellite constellations that would provide Internet service to those
> areas.
>
> Lately, though, some of those initiatives seem to be ending (
> http://qz.com/422775/facebook-and-google-are-out-of-the-space-race/), so
> DTN-based solutions may regain some appeal.  Ideas for providing delayed
> network service via a very-low-cost constellation of orbiting data mule
> satellites have been around for several years, and I think advances in
> Cubesat technology are making that concept more attractive every month.  I
> think a case can even be made that many of the network applications people
> use every day would work at least as well over delayed service as over
> end-to-end Internet service.
>
> Scott
>
> What are your thoughts on this - surveying the literature it seems like
> most of work and active deployments like DakNet and KioskNet are mostly
> historical and that its no  longer considered as a serious contender for
> poorly connected regions ... there are some interesting new developments
> that mix social networks and delay tolerant networks - but they seem mostly
> like playful ideas than something to take seriously.  Rhizome
> store-and-forward on a Serval Overlay Mesh seemed to be the most
> interesting recent work ... but I'm no expert in this area.
>
> Thanks
> David

---

From: Nalini Elkins <[email-masked]>
Date: Wed, 10 Jun 2015 15:12:51 +0000 (UTC)

We have just put in a proposal to provide broadband to underserved areas in Africa (specifically, the Ebola-affected countries).   Do not know if it will be accepted.  But, what I can say is that satellite is available but it is VERY expensive.
I think DTN is a reasonable solution for some applications.   In fact, Scott, I was going to start the conversation with you about this.   Also looking at TV White Space but it is not regulated in quite a few countries. Thanks,
Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

      From: "Burleigh, Scott C (312B)" <[email-masked]>
 To: David Johnson <[email-masked]>; gaia <[email-masked]> 
 Sent: Wednesday, June 10, 2015 8:01 AM
 Subject: Re: [gaia] Is DTN dead for under-serviced area communication

Scott

-----Original Message-----
From: gaia [mailto:[email-masked]] On Behalf Of David Johnson
Sent: Wednesday, June 10, 2015 4:02 AM
To: gaia
Subject: [gaia] Is DTN dead for under-serviced area communication

Thanks
David

David Johnson
Principal Researcher
Networks and Media group
Meraka, CSIR
Adjunct Senior Lecturer

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Wed, 10 Jun 2015 15:16:03 +0000

No, certainly if you can deploy a large constellation of cross-linked satellites in low-Earth orbit you can support standard end-to-end Internet service.  Iridium has been doing this for years, though at relatively low data rates and high operational costs.

The real question, I think, is cost.  If Space X can deploy and operate an Internet service constellation that they find affordable, excellent – problem solved!  But I am pretty sure that orbiting data mules will always be much cheaper.  If cost matters, I think in the long run DTN has got a better chance of providing service to under-served communities.

Scott

From: Vint Cerf [mailto:[email-masked]]
Sent: Wednesday, June 10, 2015 8:08 AM
To: Burleigh, Scott C (312B)
Cc: David Johnson; gaia
Subject: Re: [gaia] Is DTN dead for under-serviced area communication

elon is back in the race with a large cloud of satellites; i spoke with his tech team and they do not see a need for DTN given the relatively low delay orbital mechanics.

v

On Wed, Jun 10, 2015 at 11:01 AM, Burleigh, Scott C (312B) <[email-masked]<mailto:[email-masked]>> wrote:
My hypothesis is that deploying DTN for communication in under-serviced areas has seemed less compelling as big corporations have undertaken to build satellite constellations that would provide Internet service to those areas.

Scott

-----Original Message-----
From: gaia [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of David Johnson
Sent: Wednesday, June 10, 2015 4:02 AM
To: gaia
Subject: [gaia] Is DTN dead for under-serviced area communication

Thanks
David

David Johnson
Principal Researcher
Networks and Media group
Meraka, CSIR
Adjunct Senior Lecturer

_______________________________________________
gaia mailing list
[email-masked]<mailto:[email-masked]>
https://irtf.org/mailman/listinfo/gaia

_______________________________________________
gaia mailing list
[email-masked]<mailto:[email-masked]>
https://irtf.org/mailman/listinfo/gaia

---

From: Panayotis Antoniadis <[email-masked]>
Date: Wed, 10 Jun 2015 17:31:49 +0200

Hi,

This ongoing project in Africa by Disney Research might be of interest:

A. Galati et al. "System Architecture for Delay Tolerant Media 
Distribution for Rural South Africa", WiNTECH 2014.
http://www.disneyresearch.com/wp-content/uploads/win08f.pdf

Adriano Galati (cc'ed) could perhaps provide more details about the 
on-going deployment and experimentation
and the current status of the project.

Panayotis Antoniadis
http://www.tik.ee.ethz.ch/~pantonia/

On 10.06.2015 17:12, Nalini Elkins wrote:
> We have just put in a proposal to provide broadband to underserved 
> areas in Africa (specifically, the Ebola-affected countries).   Do not 
> know if it will be accepted.  But, what I can say is that satellite is 
> available but it is VERY expensive.
>
> I think DTN is a reasonable solution for some applications.   In fact, 
> Scott, I was going to start the conversation with you about this. Also 
> looking at TV White Space but it is not regulated in quite a few 
> countries.
> Thanks,
>
> Nalini Elkins
> Inside Products, Inc.
> (831) 659-8360
> www.insidethestack.com
>
> ------------------------------------------------------------------------
> *From:* "Burleigh, Scott C (312B)" <[email-masked]>
> *To:* David Johnson <[email-masked]>; gaia <[email-masked]>
> *Sent:* Wednesday, June 10, 2015 8:01 AM
> *Subject:* Re: [gaia] Is DTN dead for under-serviced area communication
>
> My hypothesis is that deploying DTN for communication in 
> under-serviced areas has seemed less compelling as big corporations 
> have undertaken to build satellite constellations that would provide 
> Internet service to those areas.
>
> Lately, though, some of those initiatives seem to be ending 
> (http://qz.com/422775/facebook-and-google-are-out-of-the-space-race/), 
> so DTN-based solutions may regain some appeal.  Ideas for providing 
> delayed network service via a very-low-cost constellation of orbiting 
> data mule satellites have been around for several years, and I think 
> advances in Cubesat technology are making that concept more attractive 
> every month.  I think a case can even be made that many of the network 
> applications people use every day would work at least as well over 
> delayed service as over end-to-end Internet service.
>
> Scott
>
> From: gaia [mailto:[email-masked] 
> <mailto:[email-masked]>] On Behalf Of David Johnson
> contender for poorly connected regions ... there are some interesting 
> new developments that mix social networks and delay tolerant networks 
> - but they seem mostly like playful ideas than something to take 
> seriously.  Rhizome store-and-forward on a Serval Overlay Mesh seemed 
> to be the most interesting recent work ... but I'm no expert in this area.
>
> Thanks
> David
> [email-masked] <mailto:[email-masked]>
> [email-masked] <mailto:[email-masked]>

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Wed, 10 Jun 2015 16:44:34 +0100

We have two EU projects that probably would do DTN deployments but as part
of an integrated arch with ICN.

I think the usecase could be if we want to explore some time/space shifted
content provisioning and tying this up with flexble QoS and low cost access
and if the network can inherently do all this without the need for
middleboxes.

We are having talks about this at the IRTF GAIA meeting and the ISOC policy
fellows meeting at the IETF in Prague.
On 10 Jun 2015 16:32, "Panayotis Antoniadis" <[email-masked]>
wrote:

>  We have just put in a proposal to provide broadband to underserved areas
> in Africa (specifically, the Ebola-affected countries).   Do not know if it
> will be accepted.  But, what I can say is that satellite is available but
> it is VERY expensive.
>
> looking at TV White Space but it is not regulated in quite a few countries.
>
>  Thanks,
>
> Nalini Elkins
> Inside Products, Inc.
> (831) 659-8360
> www.insidethestack.com
>
>   ------------------------------
> <[email-masked]>
> *To:* David Johnson <[email-masked]>
> <[email-masked]>; gaia <[email-masked]> <[email-masked]>
> gaia mailing [email-masked]://irtf.org/mailman/listinfo/gaia
>
>
>

---

From: Nalini Elkins <[email-masked]>
Date: Wed, 10 Jun 2015 15:42:37 +0000 (UTC)

Panayotis, thanks so much!!!
Adriano, can we connect off-line?  I would love to talk to you about your experience.  We are also looking to go into Uganda. Thanks,
Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

      From: Panayotis Antoniadis <[email-masked]>
 To: [email-masked] 
Cc: Adriano Galati <[email-masked]> 
 Sent: Wednesday, June 10, 2015 8:31 AM
 Subject: Re: [gaia] Is DTN dead for under-serviced area communication

 Hi,

 A. Galati et al. "System Architecture for Delay Tolerant Media Distribution for Rural South Africa", WiNTECH 2014.
 http://www.disneyresearch.com/wp-content/uploads/win08f.pdf
 
 Adriano Galati (cc'ed) could perhaps provide more details about the on-going deployment and experimentation
 and the current status of the project.

 Panayotis Antoniadis

   

 
 Scott
 
 -----Original Message-----
 From: gaia [mailto:[email-masked]] On Behalf Of David Johnson
 Sent: Wednesday, June 10, 2015 4:02 AM
 To: gaia
 Subject: [gaia] Is DTN dead for under-serviced area communication

 Thanks
 David

 David Johnson
 Principal Researcher
 Networks and Media group
 Meraka, CSIR
 Adjunct Senior Lecturer

---

From: Joerg Ott <[email-masked]>
Date: Wed, 10 Jun 2015 18:57:35 +0300

Indeed, a key point to making DTN-style operation (not necessarily a
certain set of DTN protocols) suitable is finding the right application
and using them in a way that hides the delays from the users so that
their experience is good.  And as Nalini said, not all applications
will fit that bill.  This wasn't always in the focus of DTN projects,
especially early ones.

Cheers,
Jörg

---

From: Melissa Densmore <[email-masked]>
Date: Thu, 11 Jun 2015 09:42:01 +0200

I'll paste in my response to David from a separate thread, some additional
details and edits:

I would hesitate to say DTN is "dead" but you are right, aside from the
disney project there hasn't been that much work done recently in the space
- pretty much since Keshav (KioskNet) switched over to environmental
sensing.  Even my Ghana Telemedicine Network stuff was done back in 2008.
The main difficulty I think we struggled with was that it takes a ton of
work to get a stable DTN going - and often by the time we got something
working, mobile phones or DSL would arrive and immediately displace our
efforts.

At the same time, it's been 10 years and some parts of Africa are still
largely unconnected.  I don't think the applicability of DTN has reduced -
but the number of researchers and practitioners looking to leverage it in
isolated places has greatly reduced.  It's possible that the DTN reference
architecture is simply too much overhead for rural deployments, with no
clear benefits (e.g. interoperability, etc) for using it. Tons of people
use informal DTNs/sneakernet (flash drives, Netflix, media kiosks) without
using a formal network architecture worthy of a paper.  But documentation
on this widespread practice is still sparse - one paper is listed below.
The existence of intermediaries often co-exists with mobile coverage -
which actually reveals the possibility of DTN concurrently existing with
fully-connected networks due to quality and cost of available
infrastructure.  See bandwidth limit literature below.

My position on satellite - yes it's useful for coverage, but there's limits
to how cheap the satellites can get per megabyte, and the on-the-ground
capex is still expensive, both in terms of equipment, technical expertise
required for maintenance, and physical footprint. Satellite plans also
often suffer from the same bandwidth limit issues - either you are
constrained to a cap, or your connection is slow due to congestion.

My older papers on DTN deployments:
Luk, Rowena, Melissa Ho, and Paul M. Aoki. "Asynchronous remote medical
consultation for Ghana." *Proceedings of the SIGCHI conference on human
factors in computing systems*. ACM, 2008. http://arxiv.org/pdf/0801.1927

Ho, Melissa, and Kevin Fall. "Poster: Delay tolerant networking for sensor
networks." *Proc. of IEEE Conference on Sensor and Ad Hoc Communications
and Networks*. 2004.
http://citeseerx.ist.psu.edu/viewdoc/download?doi=10.1.1.59.3330&rep=rep1&type=pdf

The eGranary and PirateBox/LibraryBox are current projects that also
provide DTN-like functionality.  eGranary has been around since before I
started working on DTNs in 2004. Strictly speaking Netflix (where you get
dvds) is DTN without using the reference architecture.
https://www.widernet.org/egranary/
http://piratebox.cc/
http://librarybox.us/

Digital Study Hall was also originally a DTN-based system, most
recently presented in 2012, but focus has shifted to questions of
interaction rather than content delivery
Richard Anderson, Chad Robertson, Esha Nabi, Urvashi Sahni, and
Tanuja Setia. 2012. Facilitated video instruction in low resource schools.
In Proceedings of the Fifth International Conference on Information and
Communication Technologies and Development* (ICTD '12). ACM, New York, NY,
USA, 2-12.
DOI=10.1145/2160673.2160675 http://doi.acm.org/10.1145/2160673.2160675

There's also dtn stuff on SaamiNet (2009), which was contemporary with
KioskNet and DakNet
Doria, Avri, Maria Uden, and D. Pandey. "Providing connectivity to the Saami
nomadic community." *generations* 1.2 (2009): 3.

On intermediated interactions:
Smyth, Thomas N., et al. "Where there's a will there's a way: mobile media
sharing in urban india." *Proceedings of the SIGCHI Conference on Human
Factors in Computing Systems*. ACM, 2010.

On bandwidth limitations from a user perspective:
Chetty, Marshini, et al. "Why is my internet slow?: making network speeds
visible." *Proceedings of the SIGCHI Conference on Human Factors in
Computing Systems*. ACM, 2011.
Wyche, Susan P., et al. "Deliberate interactions: characterizing technology
use in Nairobi, Kenya." *Proceedings of the SIGCHI Conference on Human
Factors in Computing Systems*. ACM, 2010.

On Wed, Jun 10, 2015 at 5:57 PM, Joerg Ott <[email-masked]> wrote:

>>> *To:* David Johnson <[email-masked]>; gaia <[email-masked]
>>> >

---

From: Jon Crowcroft <[email-masked]>
Date: Thu, 11 Jun 2015 09:48:32 +0200

really useful mesage/references - thanks!

I'd just note that if you looked at the IP Internet 10 or 15 years in,
you'd say it was "failing to thrive" - just stuff takes a long time to
deploy, at first...

i'd agree the classic DTN arch is probably not quite the right one (we
didn't use it in Haggle for various similar reasons, way back
http://www.haggleproject.org/
but something might happen surprisingly (like firechat did, for example) -
various infrastructureless projects are starting to take off, and one could
imagine a new emergent system appearing if we manage to tease out the right
way to present things to people (the main barrier is encountereed like
arjuna and others have said, when you try and present a DTN service as a
way to do the internet for 2nd class citizens - it isn't the internet and
caling your customers 2nd class is a surefire way to not have any:)

On Thu, Jun 11, 2015 at 9:42 AM, Melissa Densmore <
[email-masked]> wrote:

> My position on satellite - yes it's useful for coverage, but there's
> limits to how cheap the satellites can get per megabyte, and the
> on-the-ground capex is still expensive, both in terms of equipment,
> technical expertise required for maintenance, and physical footprint.
> Satellite plans also often suffer from the same bandwidth limit issues -
> either you are constrained to a cap, or your connection is slow due to
> congestion.
>
> Communication Technologies and Development* (ICTD '12). ACM, New York,
> NY, USA, 2-12.
> Wyche, Susan P., et al. "Deliberate interactions: characterizing
> technology use in Nairobi, Kenya." *Proceedings of the SIGCHI Conference
> on Human Factors in Computing Systems*. ACM, 2010.
>
>
>

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Thu, 11 Jun 2015 08:54:00 +0100

not dtn specific but relevant:
http://techcrunch.com/2015/06/08/messaging-app-jott-is-blowing-up-among-junior-high-and-high-schoolers/#.chu5ci:Wje6

On 11 June 2015 at 08:48, Jon Crowcroft <[email-masked]> wrote:

>> I'll paste in my response to David from a separate thread, some
>> additional details and edits:
>>
>> Ho, Melissa, and Kevin Fall. "Poster: Delay tolerant networking for
>> sensor networks." *Proc. of IEEE Conference on Sensor and Ad Hoc
>> Communications and Networks*. 2004.
>>
>> Smyth, Thomas N., et al. "Where there's a will there's a way: mobile
>> media sharing in urban india." *Proceedings of the SIGCHI Conference on
>> Human Factors in Computing Systems*. ACM, 2010.
>>

-- 
Arjuna Sathiaseelan
Personal: http://www.cl.cam.ac.uk/~as2330/
N4D Lab: http://www.cl.cam.ac.uk/~as2330/n4d

---

From: Joerg Ott <[email-masked]>
Date: Thu, 11 Jun 2015 11:30:07 +0300

Great points.

Let me add a pointer to some work we've been doing recently
to enable localized communication anywhere (out of a box).
http://www.liberouter.mobi

Jointly with Cambridge and others, we are exploring extending
this to enable flavors of content and network access.  This
goes beyond remote areas and we are trialing our "Here & Now"
local experience sharing app for events, currently at Expo 2015
with CNR.  (This app isn't in the liberouter distritbution yet.)

We have recently also had a little student project to explore
self-sufficient operation with some energy harvesting using
mostly cheap materials and simple tools to allow do-it-yourself
construction (well, aside from the computation platform).

And there are other bits ongoing, but many of them may not
generate as much noise.

Cheers,
Jörg

On 11.06.2015 10:42, Melissa Densmore wrote:
> disney project there hasn't been that much work done recently in the
> space - pretty much since Keshav (KioskNet) switched over to
> environmental sensing.  Even my Ghana Telemedicine Network stuff was
> done back in 2008.  The main difficulty I think we struggled with was
> that it takes a ton of work to get a stable DTN going - and often by the
> time we got something working, mobile phones or DSL would arrive and
> immediately displace our efforts.
>
> largely unconnected.  I don't think the applicability of DTN has reduced
> - but the number of researchers and practitioners looking to leverage it
> in isolated places has greatly reduced.  It's possible that the DTN
> reference architecture is simply too much overhead for rural
> deployments, with no clear benefits (e.g. interoperability, etc) for
> using it. Tons of people use informal DTNs/sneakernet (flash drives,
> Netflix, media kiosks) without using a formal network architecture
> worthy of a paper.  But documentation on this widespread practice is
> still sparse - one paper is listed below. The existence of
> intermediaries often co-exists with mobile coverage - which actually
> reveals the possibility of DTN concurrently existing with
> consultation for Ghana." /Proceedings of the SIGCHI conference on human
> factors in computing systems/. ACM, 2008. http://arxiv.org/pdf/0801.1927
>
> sensor networks." /Proc. of IEEE Conference on Sensor and Ad Hoc
> Communications and Networks/. 2004.
> started working on DTNs in 2004. Strictly speaking Netflix (where you
> get dvds) is DTN without using the reference architecture.
> Tanuja Setia. 2012. Facilitated video instruction in low resource
> schools. In Proceedings of the Fifth International Conference on
> Information and Communication Technologies and Development* (ICTD '12).
> ACM, New York, NY, USA, 2-12.
> Doria, Avri, Maria Uden, and D. Pandey. "Providing connectivity to the
> Saami nomadic community." *generations* 1.2 (2009): 3.
>
> media sharing in urban india." /Proceedings of the SIGCHI Conference on
> Human Factors in Computing Systems/. ACM, 2010.
>
> Chetty, Marshini, et al. "Why is my internet slow?: making network
> speeds visible." /Proceedings of the SIGCHI Conference on Human Factors
> in Computing Systems/. ACM, 2011.
> technology use in Nairobi, Kenya." /Proceedings of the SIGCHI Conference
> on Human Factors in Computing Systems/. ACM, 2010.
>
>
>
> On Wed, Jun 10, 2015 at 5:57 PM, Joerg Ott <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>             (831) 659-8360 <tel:%28831%29%20659-8360>
>             www.insidethestack.com <http://www.insidethestack.com>
>
>             *From:* "Burleigh, Scott C (312B)"
>             <[email-masked]
>             <mailto:[email-masked]>>
>             *To:* David Johnson <[email-masked]
>             <mailto:[email-masked]>>; gaia <[email-masked]
>             <mailto:[email-masked]>>
>             <mailto:[email-masked]>
>             <mailto:[email-masked]
>             <mailto:[email-masked]>>] On Behalf Of David Johnson
>             interesting
>             [email-masked] <mailto:[email-masked]> <mailto:[email-masked]
>             <mailto:[email-masked]>>
>             [email-masked] <mailto:[email-masked]> <mailto:[email-masked]
>             <mailto:[email-masked]>>

---

From: Dirk Kutscher <[email-masked]>
Date: Thu, 11 Jun 2015 09:38:07 +0000

Another perspective on this is that there is a good opportunity to rethink mobile network design at this point so that use cases such as “not always on”, “not really seamlessly connected”, “infrastructure-less exchange” can be better integrated with the network infrastructure.

Leaving the 5G buzz aside, there are efforts for

-          Decomposing the previously tightly integrated system into

elements such as “access”, “authorization”, “mobility management”, “(in-network) services” etc.

-          Leveraging this decomposition for realizing customized network slices (i.e., from baseline connectivity to mobility-managed, QoS-guaranteed & in-network service enhanced)

-          Leveraging network programmability for edge computing that could support ICN/DTN “slices” better in the future

I like the notion of “not having fixed assumptions on where the network ends” – so if we do things right, ICN/DTN types of access and local communication do not have to treated as special cases or add-on solutions in the future.

I have some additional thoughts on this – and there are also risks like creating dependencies on in-network functions that need to be considered – happy to discuss this further, maybe in Prague?

Cheers,
Dirk

From: gaia [mailto:[email-masked]] On Behalf Of Jon Crowcroft
Sent: Donnerstag, 11. Juni 2015 09:49
To: Melissa Densmore
Cc: gaia; Adriano Galati; Panayotis Antoniadis; Joerg Ott
Subject: Re: [gaia] Is DTN dead for under-serviced area communication

I'd just note that if you looked at the IP Internet 10 or 15 years in, you'd say it was "failing to thrive" - just stuff takes a long time to deploy, at first...

i'd agree the classic DTN arch is probably not quite the right one (we didn't use it in Haggle for various similar reasons, way back http://www.haggleproject.org/
but something might happen surprisingly (like firechat did, for example) - various infrastructureless projects are starting to take off, and one could imagine a new emergent system appearing if we manage to tease out the right way to present things to people (the main barrier is encountereed like arjuna and others have said, when you try and present a DTN service as a way to do the internet for 2nd class citizens - it isn't the internet and caling your customers 2nd class is a surefire way to not have any:)

On Thu, Jun 11, 2015 at 9:42 AM, Melissa Densmore <[email-masked]<mailto:[email-masked]>> wrote:
I'll paste in my response to David from a separate thread, some additional details and edits:

I would hesitate to say DTN is "dead" but you are right, aside from the disney project there hasn't been that much work done recently in the space - pretty much since Keshav (KioskNet) switched over to environmental sensing.  Even my Ghana Telemedicine Network stuff was done back in 2008.  The main difficulty I think we struggled with was that it takes a ton of work to get a stable DTN going - and often by the time we got something working, mobile phones or DSL would arrive and immediately displace our efforts.

At the same time, it's been 10 years and some parts of Africa are still largely unconnected.  I don't think the applicability of DTN has reduced - but the number of researchers and practitioners looking to leverage it in isolated places has greatly reduced.  It's possible that the DTN reference architecture is simply too much overhead for rural deployments, with no clear benefits (e.g. interoperability, etc) for using it. Tons of people use informal DTNs/sneakernet (flash drives, Netflix, media kiosks) without using a formal network architecture worthy of a paper.  But documentation on this widespread practice is still sparse - one paper is listed below. The existence of intermediaries often co-exists with mobile coverage - which actually reveals the possibility of DTN concurrently existing with fully-connected networks due to quality and cost of available infrastructure.  See bandwidth limit literature below.

My position on satellite - yes it's useful for coverage, but there's limits to how cheap the satellites can get per megabyte, and the on-the-ground capex is still expensive, both in terms of equipment, technical expertise required for maintenance, and physical footprint. Satellite plans also often suffer from the same bandwidth limit issues - either you are constrained to a cap, or your connection is slow due to congestion.

My older papers on DTN deployments:
Luk, Rowena, Melissa Ho, and Paul M. Aoki. "Asynchronous remote medical consultation for Ghana." Proceedings of the SIGCHI conference on human factors in computing systems. ACM, 2008. http://arxiv.org/pdf/0801.1927

Ho, Melissa, and Kevin Fall. "Poster: Delay tolerant networking for sensor networks." Proc. of IEEE Conference on Sensor and Ad Hoc Communications and Networks. 2004.
http://citeseerx.ist.psu.edu/viewdoc/download?doi=10.1.1.59.3330&rep=rep1&type=pdf

The eGranary and PirateBox/LibraryBox are current projects that also provide DTN-like functionality.  eGranary has been around since before I started working on DTNs in 2004. Strictly speaking Netflix (where you get dvds) is DTN without using the reference architecture.
https://www.widernet.org/egranary/
http://piratebox.cc/
http://librarybox.us/

Digital Study Hall was also originally a DTN-based system, most recently presented in 2012, but focus has shifted to questions of interaction rather than content delivery
Richard Anderson, Chad Robertson, Esha Nabi, Urvashi Sahni, and Tanuja Setia. 2012. Facilitated video instruction in low resource schools. In Proceedings of the Fifth International Conference on Information and Communication Technologies and Development* (ICTD '12). ACM, New York, NY, USA, 2-12.
DOI=10.1145/2160673.2160675 http://doi.acm.org/10.1145/2160673.2160675

There's also dtn stuff on SaamiNet (2009), which was contemporary with KioskNet and DakNet
Doria, Avri, Maria Uden, and D. Pandey. "Providing connectivity to the Saami nomadic community." *generations* 1.2 (2009): 3.

On intermediated interactions:
Smyth, Thomas N., et al. "Where there's a will there's a way: mobile media sharing in urban india." Proceedings of the SIGCHI Conference on Human Factors in Computing Systems. ACM, 2010.

On bandwidth limitations from a user perspective:
Chetty, Marshini, et al. "Why is my internet slow?: making network speeds visible." Proceedings of the SIGCHI Conference on Human Factors in Computing Systems. ACM, 2011.
Wyche, Susan P., et al. "Deliberate interactions: characterizing technology use in Nairobi, Kenya." Proceedings of the SIGCHI Conference on Human Factors in Computing Systems. ACM, 2010.

On Wed, Jun 10, 2015 at 5:57 PM, Joerg Ott <[email-masked]<mailto:[email-masked]>> wrote:

Cheers,
Jörg

Hi,

Panayotis Antoniadis

Nalini Elkins
Inside Products, Inc.
(831) 659-8360<tel:%28831%29%20659-8360>
www.insidethestack.com<http://www.insidethestack.com>
------------------------------------------------------------------------
*From:* "Burleigh, Scott C (312B)" <[email-masked]<mailto:[email-masked]>>
*To:* David Johnson <[email-masked]<mailto:[email-masked]>>; gaia <[email-masked]<mailto:[email-masked]>>
*Sent:* Wednesday, June 10, 2015 8:01 AM
*Subject:* Re: [gaia] Is DTN dead for under-serviced area communication

Scott

-----Original Message-----
From: gaia [mailto:[email-masked]<mailto:[email-masked]>
<mailto:[email-masked]<mailto:[email-masked]>>] On Behalf Of David Johnson
Sent: Wednesday, June 10, 2015 4:02 AM
To: gaia
Subject: [gaia] Is DTN dead for under-serviced area communication

Thanks
David

David Johnson
Principal Researcher
Networks and Media group
Meraka, CSIR
Adjunct Senior Lecturer

_______________________________________________
gaia mailing list
[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
https://irtf.org/mailman/listinfo/gaia

_______________________________________________
gaia mailing list
[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
https://irtf.org/mailman/listinfo/gaia

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Thu, 11 Jun 2015 10:41:34 +0100

thanks Dirk - yes would be great to discuss this at the GAIA meeting Prague.

Dirk Trossen will be presenting our RIFE project which discusses the points
you have raised (http://rife-project.eu/about/)

Regards

On 11 June 2015 at 10:38, Dirk Kutscher <[email-masked]> wrote:

>  Another perspective on this is that there is a good opportunity to
> rethink mobile network design at this point so that use cases such as “not
> always on”, “not really seamlessly connected”, “infrastructure-less
> exchange” can be better integrated with the network infrastructure.
>
>
>
> -          Leveraging this decomposition for realizing customized network
> slices (i.e., from baseline connectivity to mobility-managed,
> QoS-guaranteed & in-network service enhanced)
>
> -          Leveraging network programmability for edge computing that
> could support ICN/DTN “slices” better in the future
>
>
>
> I like the notion of “not having fixed assumptions on where the network
> ends” – so if we do things right, ICN/DTN types of access and local
> communication do not have to treated as special cases or add-on solutions
> in the future.
>
>
>
> I have some additional thoughts on this – and there are also risks like
> creating dependencies on in-network functions that need to be considered –
> happy to discuss this further, maybe in Prague?
>
>
>
> Cheers,
>
> Dirk
>
>
>
>
>
>
>
> *From:* gaia [mailto:[email-masked]] *On Behalf Of *Jon Crowcroft
> *Sent:* Donnerstag, 11. Juni 2015 09:49
> *To:* Melissa Densmore
> *Cc:* gaia; Adriano Galati; Panayotis Antoniadis; Joerg Ott

---

From: Jon Rimmer <[email-masked]>
Date: Thu, 11 Jun 2015 10:55:20 +0100

Hi guys

(long time listener, first time caller :)

I'm involved in a University spin out company that uses DTN technology
to boost connectivity in crowded areas - e.g. sporting events. Ideal
for when the available connectivity falls over because it's
overwhelmed and people are often after similar digital content. So
we've had some large scale roll outs at football clubs.

If anyone wants to know anything further I'd be happy to share - just
drop me a line direct, or look here   www.tribehive.co.uk

Regards,

Dr Jon Rimmer
Managing Director
TribeHive

On 11 June 2015 at 10:41, Arjuna Sathiaseelan
<[email-masked]> wrote:
>> Another perspective on this is that there is a good opportunity to rethink
>> mobile network design at this point so that use cases such as “not always
>> on”, “not really seamlessly connected”, “infrastructure-less exchange” can
>> be better integrated with the network infrastructure.
>>
>>
>>
>> slices (i.e., from baseline connectivity to mobility-managed, QoS-guaranteed
>> & in-network service enhanced)
>>
>> communication do not have to treated as special cases or add-on solutions in
>> the future.
>>
>>
>>
>> arjuna and others have said, when you try and present a DTN service as a way
>> to do the internet for 2nd class citizens - it isn't the internet and caling
>> your customers 2nd class is a surefire way to not have any:)
>>
>>
>>
>> On Thu, Jun 11, 2015 at 9:42 AM, Melissa Densmore
>> <[email-masked]> wrote:
>>
>> disney project there hasn't been that much work done recently in the space -
>> pretty much since Keshav (KioskNet) switched over to environmental sensing.
>> Even my Ghana Telemedicine Network stuff was done back in 2008.  The main
>> difficulty I think we struggled with was that it takes a ton of work to get
>> a stable DTN going - and often by the time we got something working, mobile
>> phones or DSL would arrive and immediately displace our efforts.
>>
>>
>>
>> clear benefits (e.g. interoperability, etc) for using it. Tons of people use
>> informal DTNs/sneakernet (flash drives, Netflix, media kiosks) without using
>> a formal network architecture worthy of a paper.  But documentation on this
>> widespread practice is still sparse - one paper is listed below. The
>> existence of intermediaries often co-exists with mobile coverage - which
>> actually reveals the possibility of DTN concurrently existing with
>> consultation for Ghana." Proceedings of the SIGCHI conference on human
>> factors in computing systems. ACM, 2008. http://arxiv.org/pdf/0801.1927
>>
>>
>>
>> networks." Proc. of IEEE Conference on Sensor and Ad Hoc Communications and
>> Networks. 2004.
>>
>>
>> Digital Study Hall was also originally a DTN-based system, most recently
>> presented in 2012, but focus has shifted to questions of interaction rather
>> than content delivery
>> Richard Anderson, Chad Robertson, Esha Nabi, Urvashi Sahni, and Tanuja
>> Setia. 2012. Facilitated video instruction in low resource schools. In
>> Proceedings of the Fifth International Conference on Information and
>> sharing in urban india." Proceedings of the SIGCHI Conference on Human
>> Factors in Computing Systems. ACM, 2010.
>>
>>
>>
>> visible." Proceedings of the SIGCHI Conference on Human Factors in Computing
>> Systems. ACM, 2011.
>>
>> technology use in Nairobi, Kenya." Proceedings of the SIGCHI Conference on
>> Human Factors in Computing Systems. ACM, 2010.
>>
>>
>>
>>
>>
>>
>>

---

From: Nalini Elkins <[email-masked]>
Date: Thu, 11 Jun 2015 13:01:01 +0000 (UTC)

The use cases that we have are mobile trucks / motorcycles going from village to village to provide health care and / or emergency broadband infrastructure.
Two types of connectivity may be needed:
1.  To the Internet
2.  To do real time video (latency OK) to hospital or provider in more major town.
Locations are Sierra Leone and Uganda.   Cost is a major factor.    Would love to talk about this, if appropriate & get updates / suggestions from all.
Am looking forward to finding out how far RIFE has gotten.  I believe that will be a game changer for us. Thanks,
Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

      From: Arjuna Sathiaseelan <[email-masked]>
 To: Dirk Kutscher <[email-masked]> 
Cc: Adriano Galati <[email-masked]>; gaia <[email-masked]>; Panayotis Antoniadis <[email-masked]>; Joerg Ott <[email-masked]>; Melissa Densmore <[email-masked]>; Jon Crowcroft <[email-masked]> 
 Sent: Thursday, June 11, 2015 2:41 AM
 Subject: Re: [gaia] Is DTN dead for under-serviced area communication
   
thanks Dirk - yes would be great to discuss this at the GAIA meeting Prague.
Dirk Trossen will be presenting our RIFE project which discusses the points you have raised (http://rife-project.eu/about/)
Regards
On 11 June 2015 at 10:38, Dirk Kutscher <[email-masked]> wrote:

Another perspective on this is that there is a good opportunity to rethink mobile network design at this point so that use cases such as “not always on”, “not really seamlessly connected”, “infrastructure-less exchange” can be better integrated with the network infrastructure. Leaving the 5G buzz aside, there are efforts for-         Decomposing the previously tightly integrated system intoelements such as “access”, “authorization”, “mobility management”, “(in-network) services” etc.-         Leveraging this decomposition for realizing customized network slices (i.e., from baseline connectivity to mobility-managed, QoS-guaranteed & in-network service enhanced)-         Leveraging network programmability for edge computing that could support ICN/DTN “slices” better in the future I like the notion of “not having fixed assumptions on where the network ends” – so if we do things right, ICN/DTN types of access and local communication do not have to treated as special cases or add-on solutions in the future. I have some additional thoughts on this – and there are also risks like creating dependencies on in-network functions that need to be considered – happy to discuss this further, maybe in Prague? Cheers,Dirk   From: gaia [mailto:[email-masked]]On Behalf Of Jon Crowcroft
Sent: Donnerstag, 11. Juni 2015 09:49
To: Melissa Densmore
Cc: gaia; Adriano Galati; Panayotis Antoniadis; Joerg Ott
Subject: Re: [gaia] Is DTN dead for under-serviced area communication really useful mesage/references - thanks! I'd just note that if you looked at the IP Internet 10 or 15 years in, you'd say it was "failing to thrive" - just stuff takes a long time to deploy, at first... i'd agree the classic DTN arch is probably not quite the right one (we didn't use it in Haggle for various similar reasons, way back http://www.haggleproject.org/ but something might happen surprisingly (like firechat did, for example) - various infrastructureless projects are starting to take off, and one could imagine a new emergent system appearing if we manage to tease out the right way to present things to people (the main barrier is encountereed like arjuna and others have said, when you try and present a DTN service as a way to do the internet for 2nd class citizens - it isn't the internet and caling your customers 2nd class is a surefire way to not have any:) On Thu, Jun 11, 2015 at 9:42 AM, Melissa Densmore <[email-masked]> wrote:I'll paste in my response to David from a separate thread, some additional details and edits: I would hesitate to say DTN is "dead" but you are right, aside from the disney project there hasn't been that much work done recently in the space - pretty much since Keshav (KioskNet) switched over to environmental sensing.  Even my Ghana Telemedicine Network stuff was done back in 2008.  The main difficulty I think we struggled with was that it takes a ton of work to get a stable DTN going - and often by the time we got something working, mobile phones or DSL would arrive and immediately displace our efforts.   At the same time, it's been 10 years and some parts of Africa are still largely unconnected.  I don't think the applicability of DTN has reduced - but the number of researchers and practitioners looking to leverage it in isolated places has greatly reduced.  It's possible that the DTN reference architecture is simply too much overhead for rural deployments, with no clear benefits (e.g. interoperability, etc) for using it. Tons of people use informal DTNs/sneakernet (flash drives, Netflix, media kiosks) without using a formal network architecture worthy of a paper.  But documentation on this widespread practice is still sparse - one paper is listed below. The existence of intermediaries often co-exists with mobile coverage - which actually reveals the possibility of DTN concurrently existing with fully-connected networks due to quality and cost of available infrastructure.  See bandwidth limit literature below. My position on satellite - yes it's useful for coverage, but there's limits to how cheap the satellites can get per megabyte, and the on-the-ground capex is still expensive, both in terms of equipment, technical expertise required for maintenance, and physical footprint. Satellite plans also often suffer from the same bandwidth limit issues - either you are constrained to a cap, or your connection is slow due to congestion.   My older papers on DTN deployments:Luk, Rowena, Melissa Ho, and Paul M. Aoki. "Asynchronous remote medical consultation for Ghana." Proceedings of the SIGCHI conference on human factors in computing systems. ACM, 2008. http://arxiv.org/pdf/0801.1927 Ho, Melissa, and Kevin Fall. "Poster: Delay tolerant networking for sensor networks." Proc. of IEEE Conference on Sensor and Ad Hoc Communications and Networks. 2004.http://citeseerx.ist.psu.edu/viewdoc/download?doi=10.1.1.59.3330&rep=rep1&type=pdf The eGranary and PirateBox/LibraryBox are current projects that also provide DTN-like functionality.  eGranary has been around since before I started working on DTNs in 2004. Strictly speaking Netflix (where you get dvds) is DTN without using the reference architecture.https://www.widernet.org/egranary/http://piratebox.cc/http://librarybox.us/ Digital Study Hall was also originally a DTN-based system, most recently presented in 2012, but focus has shifted to questions of interaction rather than content delivery
Richard Anderson, Chad Robertson, Esha Nabi, Urvashi Sahni, and Tanuja Setia. 2012. Facilitated video instruction in low resource schools. In Proceedings of the Fifth International Conference on Information and Communication Technologies and Development* (ICTD '12). ACM, New York, NY, USA, 2-12.
DOI=10.1145/2160673.2160675 http://doi.acm.org/10.1145/2160673.2160675

Doria, Avri, Maria Uden, and D. Pandey. "Providing connectivity to the Saami nomadic community." *generations* 1.2 (2009): 3. On intermediated interactions:Smyth, Thomas N., et al. "Where there's a will there's a way: mobile media sharing in urban india." Proceedings of the SIGCHI Conference on Human Factors in Computing Systems. ACM, 2010.  On bandwidth limitations from a user perspective:Chetty, Marshini, et al. "Why is my internet slow?: making network speeds visible." Proceedings of the SIGCHI Conference on Human Factors in Computing Systems. ACM, 2011.Wyche, Susan P., et al. "Deliberate interactions: characterizing technology use in Nairobi, Kenya." Proceedings of the SIGCHI Conference on Human Factors in Computing Systems. ACM, 2010.   On Wed, Jun 10, 2015 at 5:57 PM, Joerg Ott <[email-masked]> wrote:Indeed, a key point to making DTN-style operation (not necessarily a

Cheers,
Jörg

Hi,

Panayotis Antoniadis

Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com------------------------------------------------------------------------

Scott

-----Original Message-----

Thanks
David

David Johnson
Principal Researcher
Networks and Media group
Meraka, CSIR
Adjunct Senior Lecturer

_______________________________________________
gaia mailing [email-masked] <mailto:[email-masked]>
https://irtf.org/mailman/listinfo/gaia

---

From: Melissa Densmore <[email-masked]>
Date: Sat, 13 Jun 2015 12:47:59 +0200

Strictly speaking, neither of those two cases are considered DTN, since all
data communications occurs over normal fully-connected IP, unless you are
also using the motorbikes to carry non-real-time video and other data back
to the hospital.

The purpose of the DTN architecture is to assist in bridging communications
where normal IP (whether TCP or UDP) breaks down due to long delays (e.g.
motorcycle travel time, or interplanetary occlusions).

This broadly includes sneakernet applications - more so in cases which the
communication is seamless and doesn't require major interventions to bridge
to the cloud - i.e. the data automatically starts transiting to its desired
location via IP when the usb stick is inserted into an Internet-connected
computer.  The normal modality for sneakernet however initiates a new IP
connection when the cloud is reached (i.e. someone taking the file from the
drive and uploading to a website or sending it by email) - and considered a
less-than-ideal DTN.

Emergency broadband is just considered last-mile connectivity - also a very
important but slightly different area of research.

Melissa

On Thu, Jun 11, 2015 at 3:01 PM, Nalini Elkins <
[email-masked]> wrote:

> The use cases that we have are mobile trucks / motorcycles going from
> village to village to provide health care and / or emergency broadband
> infrastructure.
>
> Locations are Sierra Leone and Uganda.   Cost is a major factor.    Would
> love to talk about this, if appropriate & get updates / suggestions from
> all.
>
> Am looking forward to finding out how far RIFE has gotten.  I believe that
> will be a game changer for us.
>
> Thanks,
>
> Nalini Elkins
> Inside Products, Inc.
> (831) 659-8360
> www.insidethestack.com
>
>  *From:* Arjuna Sathiaseelan <[email-masked]>
> *To:* Dirk Kutscher <[email-masked]>
> *Cc:* Adriano Galati <[email-masked]>; gaia <
> [email-masked]>; Panayotis Antoniadis <[email-masked]>; Joerg
> Ott <[email-masked]>; Melissa Densmore <[email-masked]>;
> Jon Crowcroft <[email-masked]>
> *Sent:* Thursday, June 11, 2015 2:41 AM
>
> Dirk Trossen will be presenting our RIFE project which discusses the
> points you have raised (http://rife-project.eu/about/)
>
> Regards
>
>  but something might happen surprisingly (like firechat did, for example)
> - various infrastructureless projects are starting to take off, and one
> could imagine a new emergent system appearing if we manage to tease out the
> right way to present things to people (the main barrier is encountereed
> like arjuna and others have said, when you try and present a DTN service as
> a way to do the internet for 2nd class citizens - it isn't the internet and
> speeds visible." *Proceedings of the SIGCHI Conference on Human Factors
> in Computing Systems*. ACM, 2011.

---

From: Jon Crowcroft <[email-masked]>
Date: Sat, 13 Jun 2015 14:00:02 +0100

yes, true, althoguh there was a brief period when DTN also stood for
Disruption (or Disconnection) Tolerant Networking , but that's
strictly (I'd say) a subset of the cases/situations that DTN classic
operates - there's also (I think mentioned here before) the case of
using DTN as a tool for carrying out deliberately scheduled/staged bulk 
transfers off the busy hour in different timezones on the terrestrial
internet (which is quite a compelling application as far as I can see)

speaking of disruption, has anyone in the mobile phone/app world
considered scheduled  DTN style HTTP for sending stuff to users on
trains going thru occasional tunnels? you should know when someone
will exit the tunnel (most the time, depending on the reliabilit of
the train company:_)?
> > elements such as “access”, “authorization”, “mobility 
> management”,
> > “(in-network) services” etc.
> space
> get
> schools.
> NY,

---

From: Henning Schulzrinne <[email-masked]>
Date: Sat, 13 Jun 2015 09:13:26 -0400

Not quite scheduled DTN, but we have analyzed a system where the bus or
train has an on-board web cache that allows users to request content, which
is then fetched at the next opportunity. See

Se Gi hong, SungHoon Seo, Henning Schulzrinne, and Prabhakar Chitrapu, "ICOW:
Internet Access in Public Transit Systems,"

http://dx.doi.org/10.1109/MCOM.2015.7120029

See also
https://community.myhughesnet.com/hughesnet/topics/how_do_i_get_netflix_downloads_out_of_download_manager_on_to_my_laptop#reply_13901795
for a related discussion on time shifting.

---

From: Nalini Elkins <[email-masked]>
Date: Sat, 13 Jun 2015 13:36:18 +0000 (UTC)

The reason I was thinking of DTN is that the scenario is the following:
1.  The motorcycle or truck will be doing circles through communities  where we have no IP connectivity to communities where there IS IP connectivity.
2.  In communities where there is NO connectivity,  we can gather data, the data may be image data on health issues or email.
3.  When we loop back around to where there IS connectivity, then we can send our data along.
Would this not be a good application for DTN?   Am I misunderstanding?
Of course, if we can afford satellite connectivity or can get IP connectivity another way, that would be our preference.

Thanks,
Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

      From: Melissa Densmore <[email-masked]>
 To: Nalini Elkins <[email-masked]> 
Cc: Arjuna Sathiaseelan <[email-masked]>; Dirk Kutscher <[email-masked]>; Adriano Galati <[email-masked]>; gaia <[email-masked]>; Panayotis Antoniadis <[email-masked]>; Joerg Ott <[email-masked]>; Jon Crowcroft <[email-masked]> 
 Sent: Saturday, June 13, 2015 3:47 AM
 Subject: Re: [gaia] Is DTN dead for under-serviced area communication
   
Strictly speaking, neither of those two cases are considered DTN, since all data communications occurs over normal fully-connected IP, unless you are also using the motorbikes to carry non-real-time video and other data back to the hospital.
The purpose of the DTN architecture is to assist in bridging communications where normal IP (whether TCP or UDP) breaks down due to long delays (e.g. motorcycle travel time, or interplanetary occlusions).
This broadly includes sneakernet applications - more so in cases which the communication is seamless and doesn't require major interventions to bridge to the cloud - i.e. the data automatically starts transiting to its desired location via IP when the usb stick is inserted into an Internet-connected computer.  The normal modality for sneakernet however initiates a new IP connection when the cloud is reached (i.e. someone taking the file from the drive and uploading to a website or sending it by email) - and considered a less-than-ideal DTN.
Emergency broadband is just considered last-mile connectivity - also a very important but slightly different area of research. 
Melissa

On Thu, Jun 11, 2015 at 3:01 PM, Nalini Elkins <[email-masked]> wrote:

   

Cheers,
Jörg

Hi,

Panayotis Antoniadis

Nalini Elkins
Inside Products, Inc.
(831) 659-8360

Scott

-----Original Message-----

Thanks
David

David Johnson
Principal Researcher
Networks and Media group
Meraka, CSIR
Adjunct Senior Lecturer

---

From: Nalini Elkins <[email-masked]>
Date: Sat, 13 Jun 2015 13:59:16 +0000 (UTC)

I would be very interested in finding out more about what you are doing.  The villages we may be in are also quite remote so your scenario is similar to ours.  Bicycle or trishaw are also vehicles that we might use.
If you are interested in discussing off-line, we can test out your implementation here also.   I live near the Big Sur area and cell phone connectivity drops off very quickly.  So, I believe that we can test this easily.  
I know yours is "development" or "alpha" software and will be treating it accordingly.   Or if you guys want to share your experiences with us and are cautious about software, I completely understand.  
I want to do as much homework as I can. Thanks,

Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

      From: H S Jamadagni <[email-masked]>
 To: Nalini Elkins <[email-masked]> 
Cc: Adriano Galati <[email-masked]>; gaia <[email-masked]>; Panayotis Antoniadis <[email-masked]>; Joerg Ott <[email-masked]>; Dirk Kutscher <[email-masked]>; Jon Crowcroft <[email-masked]>; Arjuna Sathiaseelan <[email-masked]>; Melissa Densmore <[email-masked]>; Prabhakar T. V <[email-masked]> 
 Sent: Saturday, June 13, 2015 6:12 AM
 Subject: Re: [gaia] Is DTN dead for under-serviced area communication
   
We have done some experiments with DTN in our lab in IISc Bangalore. We have designed and produced a few DTN modules that go on a bicycle (or any other vehicle) and even has a GSM connectivity which may be available intermittently. We have file exchange (containing some data) and email exchange implemented on the system with nodes in a few locations. The experiments are going on sporadically in a somewhat remote village 180 km from Bangalore.We are currently trying to make the system as robust as possible. Therefore, I am unable at this stage say whether this system will become "popular". We will be continuing our experimentation and hopefully will have some results by the end of the year (2015).

Cheers, Jamadagni (Indian Institute of Science, Bangalore, India)

----- Original Message -----
From: "Nalini Elkins" <[email-masked]>
To: "Melissa Densmore" <[email-masked]>
Cc: "Adriano Galati" <[email-masked]>, "gaia" <[email-masked]>, "Panayotis Antoniadis" <[email-masked]>, "Joerg Ott" <[email-masked]>, "Dirk Kutscher" <[email-masked]>, "Jon Crowcroft" <[email-masked]>, "Arjuna Sathiaseelan" <[email-masked]>
Sent: Saturday, 13 June, 2015 7:06:18 PM
Subject: Re: [gaia] Is DTN dead for under-serviced area communication

1. T he motorcycle or truck will be doing circles through communities where we have no IP connectivity to communities where there IS IP connectivity. 

Thanks, 

Nalini Elkins 
Inside Products, Inc. 
(831) 659-8360 
www.insidethestack.com 

Melissa 

On Thu, Jun 11, 2015 at 3:01 PM, Nalini Elkins < [email-masked] > wrote: 

1. To the Internet 

Am looking forward to finding out how far RIFE has gotten. I believe that will be a game changer for us. 

Thanks, 

Nalini Elkins 
Inside Products, Inc. 
(831) 659-8360 
www.insidethestack.com 

From: Arjuna Sathiaseelan < [email-masked] > 
To: Dirk Kutscher < [email-masked] > 
Cc: Adriano Galati < [email-masked] >; gaia < [email-masked] >; Panayotis Antoniadis < [email-masked] >; Joerg Ott < [email-masked] >; Melissa Densmore < [email-masked] >; Jon Crowcroft < [email-masked] > 
Sent: Thursday, June 11, 2015 2:41 AM 

Dirk Trossen will be presenting our RIFE project which discusses the points you have raised ( http://rife-project.eu/about/ ) 

Regards 

On 11 June 2015 at 10:38, Dirk Kutscher < [email-masked] > wrote: 

Cheers, 
Dirk 

From: gaia [mailto: [email-masked] ] On Behalf Of Jon Crowcroft 
Sent: Donnerstag, 11. Juni 2015 09:49 
To: Melissa Densmore 
Cc: gaia; Adriano Galati; Panayotis Antoniadis; Joerg Ott 
Subject: Re: [gaia] Is DTN dead for under-serviced area communication 

On Thu, Jun 11, 2015 at 9:42 AM, Melissa Densmore < [email-masked] > wrote: 

Luk, Rowena, Melissa Ho, and Paul M. Aoki. "Asynchronous remote medical consultation for Ghana." Proceedings of the SIGCHI conference on human factors in computing systems . ACM, 2008. http://arxiv.org/pdf/0801.1927 

Ho, Melissa, and Kevin Fall. "Poster: Delay tolerant networking for sensor networks." Proc. of IEEE Conference on Sensor and Ad Hoc Communications and Networks . 2004. 

http://piratebox.cc/ 

http://librarybox.us/ 

Smyth, Thomas N., et al. "Where there's a will there's a way: mobile media sharing in urban india." Proceedings of the SIGCHI Conference on Human Factors in Computing Systems . ACM, 2010. 

Chetty, Marshini, et al. "Why is my internet slow?: making network speeds visible." Proceedings of the SIGCHI Conference on Human Factors in Computing Systems . ACM, 2011. 

Wyche, Susan P., et al. "Deliberate interactions: characterizing technology use in Nairobi, Kenya." Proceedings of the SIGCHI Conference on Human Factors in Computing Systems . ACM, 2010. 

On Wed, Jun 10, 2015 at 5:57 PM, Joerg Ott < [email-masked] > wrote: 

Cheers, 
Jörg 

Hi, 

Panayotis Antoniadis 

Nalini Elkins 
Inside Products, Inc. 
(831) 659-8360 
www.insidethestack.com 
------------------------------------------------------------------------ 
*From:* "Burleigh, Scott C (312B)" < [email-masked] > 
*To:* David Johnson < [email-masked] >; gaia < [email-masked] > 
*Sent:* Wednesday, June 10, 2015 8:01 AM 
*Subject:* Re: [gaia] Is DTN dead for under-serviced area communication 

( http://qz.com/422775/facebook-and-google-are-out-of-the-space-race/ ), 

Scott 

-----Original Message----- 
From: gaia [mailto: [email-masked] 
<mailto: [email-masked] >] On Behalf Of David Johnson 
Sent: Wednesday, June 10, 2015 4:02 AM 
To: gaia 
Subject: [gaia] Is DTN dead for under-serviced area communication 

Thanks 
David 

David Johnson 
Principal Researcher 
Networks and Media group 
Meraka, CSIR 
Adjunct Senior Lecturer 

_______________________________________________ 
gaia mailing list 
[email-masked] <mailto: [email-masked] > 
https://irtf.org/mailman/listinfo/gaia 

_______________________________________________ 
gaia mailing list 
[email-masked] <mailto: [email-masked] > 
https://irtf.org/mailman/listinfo/gaia 

-- 

Arjuna Sathiaseelan 

-- 
This message has been scanned for viruses and 
dangerous content by MailScanner , and is 
believed to be clean. 
_______________________________________________
gaia mailing list
[email-masked]
https://irtf.org/mailman/listinfo/gaia

-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

---

From: Vassilios Tsaoussidis <[email-masked]>
Date: Sat, 13 Jun 2015 17:28:38 +0300

Precisely, 

>internet (which is quite a compelling application as far as I can see)

this is the issue we investigate here 

http://utopia.duth.gr/~slenas/documents/HPSS-mc2r-slenas.pdf 

and intend to deploy here 

http://www.umobile-project.eu/ 

Vassilis 

Στις 2015-06-13 16:00, Jon Crowcroft έγραψε: 

> Strictly speaking, neither of those two cases are considered DTN, since all data communications occurs over normal fully-connected IP, unless you are also using the motorbikes to carry non-real-time video and other data back to the hospital. The purpose of the DTN architecture is to assist in bridging communications where normal IP (whether TCP or UDP) breaks down due to long delays (e.g. motorcycle travel time, or interplanetary occlusions). This broadly includes sneakernet applications - more so in cases which the communication is seamless and doesn't require major interventions to bridge to the cloud - i.e. the data automatically starts transiting to its desired location via IP when the usb stick is inserted into an Internet-connected computer. The normal modality for sneakernet however initiates a new IP connection when the cloud is reached (i.e. someone taking the file from the drive and uploading to a website or sending it by email) - and considered a less-than-ideal DTN.
Emergency broadband is just considered last-mile connectivity - also a very important but slightly different area of research. Melissa On Thu, Jun 11, 2015 at 3:01 PM, Nalini Elkins < [email-masked]> wrote: The use cases that we have are mobile trucks / motorcycles going from village to village to provide health care and / or emergency broadband infrastructure. Two types of connectivity may be needed: 1. To the Internet 2. To do real time video (latency OK) to hospital or provider in more major town. Locations are Sierra Leone and Uganda. Cost is a major factor. Would love to talk about this, if appropriate & get updates / suggestions from all. Am looking forward to finding out how far RIFE has gotten. I believe that will be a game changer for us. Thanks, Nalini Elkins Inside Products, Inc. (831) 659-8360 www.insidethestack.com [1] ------------------------------ *From:* Arjuna Sathiaseelan <[email-masked]> *To:* Dirk Kutscher
<[email-masked]> *Cc:* Adriano Galati <[email-masked]>; gaia < [email-masked]>; Panayotis Antoniadis <[email-masked]>; Joerg Ott <[email-masked]>; Melissa Densmore <[email-masked]>; Jon Crowcroft <[email-masked]> *Sent:* Thursday, June 11, 2015 2:41 AM *Subject:* Re: [gaia] Is DTN dead for under-serviced area communication thanks Dirk - yes would be great to discuss this at the GAIA meeting Prague. Dirk Trossen will be presenting our RIFE project which discusses the points you have raised (http://rife-project.eu/about/ [2]) Regards On 11 June 2015 at 10:38, Dirk Kutscher <[email-masked]> wrote: Another perspective on this is that there is a good opportunity to rethink mobile network design at this point so that use cases such as âEURœnot always onâEUR, âEURœnot really seamlessly connectedâEUR, âEURœinfrastructure-less exchangeâEUR can be better integrated with the network infrastructure. Leaving the
5G buzz aside, there are efforts for - Decomposing the previously tightly integrated system into elements such as âEURœaccessâEUR, âEURœauthorizationâEUR, âEURœmobility managementâEUR, âEURœ(in-network) servicesâEUR etc. - Leveraging this decomposition for realizing customized network slices (i.e., from baseline connectivity to mobility-managed, QoS-guaranteed & in-network service enhanced) - Leveraging network programmability for edge computing that could support ICN/DTN âEURœslicesâEUR better in the future I like the notion of âEURœnot having fixed assumptions on where the network endsâEUR âEUR" so if we do things right, ICN/DTN types of access and local communication do not have to treated as special cases or add-on solutions in the future. I have some additional thoughts on this âEUR" and there are also risks like creating dependencies on in-network functions that need to be considered âEUR" happy to discuss this further, maybe in Prague? Cheers, Dirk *From:*
gaia [mailto:[email-masked]] *On Behalf Of *Jon Crowcroft *Sent:* Donnerstag, 11. Juni 2015 09:49 *To:* Melissa Densmore *Cc:* gaia; Adriano Galati; Panayotis Antoniadis; Joerg Ott *Subject:* Re: [gaia] Is DTN dead for under-serviced area communication really useful mesage/references - thanks! I'd just note that if you looked at the IP Internet 10 or 15 years in, you'd say it was "failing to thrive" - just stuff takes a long time to deploy, at first... i'd agree the classic DTN arch is probably not quite the right one (we didn't use it in Haggle for various similar reasons, way back http://www.haggleproject.org/ [3] but something might happen surprisingly (like firechat did, for example) - various infrastructureless projects are starting to take off, and one could imagine a new emergent system appearing if we manage to tease out the right way to present things to people (the main barrier is encountereed like arjuna and others have said, when you try and present a DTN service
as a way to do the internet for 2nd class citizens - it isn't the internet and caling your customers 2nd class is a surefire way to not have any:) On Thu, Jun 11, 2015 at 9:42 AM, Melissa Densmore < [email-masked]> wrote: I'll paste in my response to David from a separate thread, some additional details and edits: I would hesitate to say DTN is "dead" but you are right, aside from the disney project there hasn't been that much work done recently in the space - pretty much since Keshav (KioskNet) switched over to environmental sensing. Even my Ghana Telemedicine Network stuff was done back in 2008. The main difficulty I think we struggled with was that it takes a ton of work to get a stable DTN going - and often by the time we got something working, mobile phones or DSL would arrive and immediately displace our efforts. At the same time, it's been 10 years and some parts of Africa are still largely unconnected. I don't think the applicability of DTN has reduced - but the
number of researchers and practitioners looking to leverage it in isolated places has greatly reduced. It's possible that the DTN reference architecture is simply too much overhead for rural deployments, with no clear benefits (e.g. interoperability, etc) for using it. Tons of people use informal DTNs/sneakernet (flash drives, Netflix, media kiosks) without using a formal network architecture worthy of a paper. But documentation on this widespread practice is still sparse - one paper is listed below. The existence of intermediaries often co-exists with mobile coverage - which actually reveals the possibility of DTN concurrently existing with fully-connected networks due to quality and cost of available infrastructure. See bandwidth limit literature below. My position on satellite - yes it's useful for coverage, but there's limits to how cheap the satellites can get per megabyte, and the on-the-ground capex is still expensive, both in terms of equipment, technical expertise required
for maintenance, and physical footprint. Satellite plans also often suffer from the same bandwidth limit issues - either you are constrained to a cap, or your connection is slow due to congestion. My older papers on DTN deployments: Luk, Rowena, Melissa Ho, and Paul M. Aoki. "Asynchronous remote medical consultation for Ghana." *Proceedings of the SIGCHI conference on human factors in computing systems*. ACM, 2008. http://arxiv.org/pdf/0801.1927 [4] Ho, Melissa, and Kevin Fall. "Poster: Delay tolerant networking for sensor networks." *Proc. of IEEE Conference on Sensor and Ad Hoc Communications and Networks*. 2004. http://citeseerx.ist.psu.edu/viewdoc/download?doi=10.1.1.59.3330&rep=rep1&type=pdf [5] The eGranary and PirateBox/LibraryBox are current projects that also provide DTN-like functionality. eGranary has been around since before I started working on DTNs in 2004. Strictly speaking Netflix (where you get dvds) is DTN without using the reference architecture.
https://www.widernet.org/egranary/ [6] http://piratebox.cc/ [7] http://librarybox.us/ [8] Digital Study Hall was also originally a DTN-based system, most recently presented in 2012, but focus has shifted to questions of interaction rather than content delivery Richard Anderson, Chad Robertson, Esha Nabi, Urvashi Sahni, and Tanuja Setia. 2012. Facilitated video instruction in low resource schools. In Proceedings of the Fifth International Conference on Information and Communication Technologies and Development* (ICTD '12). ACM, New York, NY, USA, 2-12. DOI=10.1145/2160673.2160675 http://doi.acm.org/10.1145/2160673.2160675 [9] There's also dtn stuff on SaamiNet (2009), which was contemporary with KioskNet and DakNet Doria, Avri, Maria Uden, and D. Pandey. "Providing connectivity to the Saami nomadic community." *generations* 1.2 (2009): 3. On intermediated interactions: Smyth, Thomas N., et al. "Where there's a will there's a way: mobile media sharing in urban india." *Proceedings of
the SIGCHI Conference on Human Factors in Computing Systems*. ACM, 2010. On bandwidth limitations from a user perspective: Chetty, Marshini, et al. "Why is my internet slow?: making network speeds visible." *Proceedings of the SIGCHI Conference on Human Factors in Computing Systems*. ACM, 2011. Wyche, Susan P., et al. "Deliberate interactions: characterizing technology use in Nairobi, Kenya." *Proceedings of the SIGCHI Conference on Human Factors in Computing Systems*. ACM, 2010. On Wed, Jun 10, 2015 at 5:57 PM, Joerg Ott <[email-masked]> wrote: Indeed, a key point to making DTN-style operation (not necessarily a certain set of DTN protocols) suitable is finding the right application and using them in a way that hides the delays from the users so that their experience is good. And as Nalini said, not all applications will fit that bill. This wasn't always in the focus of DTN projects, especially early ones. Cheers, JÃ¶rg On 10.06.2015 18:31, Panayotis Antoniadis wrote: Hi, This
ongoing project in Africa by Disney Research might be of interest: A. Galati et al. "System Architecture for Delay Tolerant Media Distribution for Rural South Africa", WiNTECH 2014. http://www.disneyresearch.com/wp-content/uploads/win08f.pdf [10] Adriano Galati (cc'ed) could perhaps provide more details about the on-going deployment and experimentation and the current status of the project. Panayotis Antoniadis http://www.tik.ee.ethz.ch/~pantonia/ [11] On 10.06.2015 17:12, Nalini Elkins wrote: We have just put in a proposal to provide broadband to underserved areas in Africa (specifically, the Ebola-affected countries). Do not know if it will be accepted. But, what I can say is that satellite is available but it is VERY expensive. I think DTN is a reasonable solution for some applications. In fact, Scott, I was going to start the conversation with you about this. Also looking at TV White Space but it is not regulated in quite a few countries. Thanks, Nalini Elkins Inside Products,
Inc. (831) 659-8360 www.insidethestack.com [1] ------------------------------------------------------------------------ *From:* "Burleigh, Scott C (312B)" <[email-masked]> *To:* David Johnson <[email-masked]>; gaia <[email-masked]> *Sent:* Wednesday, June 10, 2015 8:01 AM *Subject:* Re: [gaia] Is DTN dead for under-serviced area communication My hypothesis is that deploying DTN for communication in under-serviced areas has seemed less compelling as big corporations have undertaken to build satellite constellations that would provide Internet service to those areas. Lately, though, some of those initiatives seem to be ending (http://qz.com/422775/facebook-and-google-are-out-of-the-space-race/ [12]), so DTN-based solutions may regain some appeal. Ideas for providing delayed network service via a very-low-cost constellation of orbiting data mule satellites have been around for several years, and I think advances in Cubesat technology are making that concept
more attractive every month. I think a case can even be made that many of the network applications people use every day would work at least as well over delayed service as over end-to-end Internet service. Scott -----Original Message----- From: gaia [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of David Johnson Sent: Wednesday, June 10, 2015 4:02 AM To: gaia Subject: [gaia] Is DTN dead for under-serviced area communication What are your thoughts on this - surveying the literature it seems like most of work and active deployments like DakNet and KioskNet are mostly historical and that its no longer considered as a serious contender for poorly connected regions ... there are some interesting new developments that mix social networks and delay tolerant networks - but they seem mostly like playful ideas than something to take seriously. Rhizome store-and-forward on a Serval Overlay Mesh seemed to be the most interesting recent work ... but I'm no expert in this
area. Thanks David ___________________________ David Johnson Principal Researcher Networks and Media group Meraka, CSIR Adjunct Senior Lecturer ICT4D, Computer Science Department University of Cape Town _______________________________________________ gaia mailing list [email-masked] <mailto:[email-masked]> https://irtf.org/mailman/listinfo/gaia [13] _______________________________________________ gaia mailing list [email-masked] <mailto:[email-masked]> https://irtf.org/mailman/listinfo/gaia [13] _______________________________________________ gaia mailing list [email-masked] https://irtf.org/mailman/listinfo/gaia [13] _______________________________________________ gaia mailing list [email-masked] https://irtf.org/mailman/listinfo/gaia [13] _______________________________________________ gaia mailing list [email-masked] https://irtf.org/mailman/listinfo/gaia [13] _______________________________________________ gaia mailing list [email-masked] https://irtf.org/mailman/listinfo/gaia [13]
_______________________________________________ gaia mailing list [email-masked] https://irtf.org/mailman/listinfo/gaia [13] -- Arjuna Sathiaseelan Personal: http://www.cl.cam.ac.uk/~as2330/ [14] N4D Lab: http://www.cl.cam.ac.uk/~as2330/n4d [15] _______________________________________________ gaia mailing list [email-masked] https://irtf.org/mailman/listinfo/gaia [13]

_______________________________________________
gaia mailing list
[email-masked]
https://irtf.org/mailman/listinfo/gaia [13]

Links:
------
[1] http://www.insidethestack.com
[2] http://rife-project.eu/about/
[3] http://www.haggleproject.org/
[4] http://arxiv.org/pdf/0801.1927
[5]
http://citeseerx.ist.psu.edu/viewdoc/download?doi=10.1.1.59.3330&amp;rep=rep1&amp;type=pdf
[6] https://www.widernet.org/egranary/
[7] http://piratebox.cc/
[8] http://librarybox.us/
[9] http://doi.acm.org/10.1145/2160673.2160675
[10] http://www.disneyresearch.com/wp-content/uploads/win08f.pdf
[11] http://www.tik.ee.ethz.ch/~pantonia/
[12] http://qz.com/422775/facebook-and-google-are-out-of-the-space-race/
[13] https://irtf.org/mailman/listinfo/gaia
[14] http://www.cl.cam.ac.uk/~as2330/
[15] http://www.cl.cam.ac.uk/~as2330/n4d

---

From: Henning Schulzrinne <[email-masked]>
Date: Sat, 13 Jun 2015 11:11:42 -0400

In many of these cases, using USB memory sticks (or other flash drives)
seems cheap, easy to learn, requires minimal investment, works across
platforms and needs no special skills. If a drive gets lost or damaged, the
impact is minimal (if the data is encrypted). That old-fashioned approach
still seems to be the fastest way to transfer data locally, as anybody who
has ever had to hand a presentation on a memory stick to the tech guy with
the Windows laptop at a conference knows well. Maybe the next ACM DEV
conference can ask attendees to drop off their old USB drives from various
conferences. I suspect there are a few TB of logo-ware sitting in desk
drawers :-)

Apparently, (US) movie theaters do something similar, using hard drives
sent by FedEx to feed their digital projectors with new releases.

Carry medical data to the big city, and a new movie in reverse (assuming
the legalities can be worked out).

On Sat, Jun 13, 2015 at 9:36 AM, Nalini Elkins <
[email-masked]> wrote:

> 1.  The motorcycle or truck will be doing circles through communities
>  where we have no IP connectivity to communities where there IS IP
> connectivity.
>
> 2.  In communities where there is NO connectivity,  we can gather data,
> the data may be image data on health issues or email.
>
> Of course, if we can afford satellite connectivity or can get IP
> connectivity another way, that would be our preference.
>
>
> Thanks,
>
> Nalini Elkins
> Inside Products, Inc.
> (831) 659-8360
> www.insidethestack.com
>

---

From: Nalini Elkins <[email-masked]>
Date: Sat, 13 Jun 2015 15:36:46 +0000 (UTC)

I LOVE the lowest-tech solution!
I have to say, one of the best things about the Internet is lists like this where very smart people will get on and collaborate for the common good.   Would be wonderful if we can get more of the world on. Thanks,
Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

      From: Henning Schulzrinne <[email-masked]>
 To: Nalini Elkins <[email-masked]> 
Cc: Adriano Galati <[email-masked]>; gaia <[email-masked]>; Panayotis Antoniadis <[email-masked]>; Joerg Ott <[email-masked]>; Dirk Kutscher <[email-masked]>; Melissa Densmore <[email-masked]>; Arjuna Sathiaseelan <[email-masked]>; Jon Crowcroft <[email-masked]> 
 Sent: Saturday, June 13, 2015 8:11 AM
 Subject: Re: [gaia] Is DTN dead for under-serviced area communication
   
In many of these cases, using USB memory sticks (or other flash drives) seems cheap, easy to learn, requires minimal investment, works across platforms and needs no special skills. If a drive gets lost or damaged, the impact is minimal (if the data is encrypted). That old-fashioned approach still seems to be the fastest way to transfer data locally, as anybody who has ever had to hand a presentation on a memory stick to the tech guy with the Windows laptop at a conference knows well. Maybe the next ACM DEV conference can ask attendees to drop off their old USB drives from various conferences. I suspect there are a few TB of logo-ware sitting in desk drawers :-)
Apparently, (US) movie theaters do something similar, using hard drives sent by FedEx to feed their digital projectors with new releases.
Carry medical data to the big city, and a new movie in reverse (assuming the legalities can be worked out).

On Sat, Jun 13, 2015 at 9:36 AM, Nalini Elkins <[email-masked]> wrote:

Thanks,
Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

---

From: H S Jamadagni <[email-masked]>
Date: Sat, 13 Jun 2015 18:42:42 +0530 (IST)

----- Original Message -----
From: "Nalini Elkins" <[email-masked]>
To: "Melissa Densmore" <[email-masked]>
Cc: "Adriano Galati" <[email-masked]>, "gaia" <[email-masked]>, "Panayotis Antoniadis" <[email-masked]>, "Joerg Ott" <[email-masked]>, "Dirk Kutscher" <[email-masked]>, "Jon Crowcroft" <[email-masked]>, "Arjuna Sathiaseelan" <[email-masked]>
Sent: Saturday, 13 June, 2015 7:06:18 PM
Subject: Re: [gaia] Is DTN dead for under-serviced area communication

Thanks, 

Nalini Elkins 
Inside Products, Inc. 
(831) 659-8360 
www.insidethestack.com 

Melissa 

1. To the Internet 

Thanks, 

Nalini Elkins 
Inside Products, Inc. 
(831) 659-8360 
www.insidethestack.com 

Regards 

Cheers, 
Dirk 

http://piratebox.cc/ 

http://librarybox.us/ 

Cheers, 
Jörg 

Hi, 

Panayotis Antoniadis 

Nalini Elkins 
Inside Products, Inc. 
(831) 659-8360 
www.insidethestack.com 

Scott 

-----Original Message----- 

Thanks 
David 

David Johnson 
Principal Researcher 
Networks and Media group 
Meraka, CSIR 
Adjunct Senior Lecturer 

-- 

Arjuna Sathiaseelan

---

From: H S Jamadagni <[email-masked]>
Date: Sat, 13 Jun 2015 19:21:35 +0530 (IST)

Thanks for your interest in our project. I will send you some details the coming week. Regards. Jamadagni
----- Original Message -----
From: Nalini Elkins <[email-masked]>
To: H S Jamadagni <[email-masked]>
Cc: Adriano Galati <[email-masked]>, gaia <[email-masked]>, Panayotis Antoniadis <[email-masked]>, Joerg Ott <[email-masked]>, Dirk Kutscher <[email-masked]>, Jon Crowcroft <[email-masked]>, Arjuna Sathiaseelan <[email-masked]>, Melissa Densmore <[email-masked]>
Sent: Sat, 13 Jun 2015 19:29:16 +0530 (IST)
Subject: Re: [gaia] Is DTN dead for under-serviced area communication

Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

----- Original Message -----
From: "Nalini Elkins" <[email-masked]>
To: "Melissa Densmore" <[email-masked]>
Cc: "Adriano Galati" <[email-masked]>, "gaia" <[email-masked]>, "Panayotis Antoniadis" <[email-masked]>, "Joerg Ott" <[email-masked]>, "Dirk Kutscher" <[email-masked]>, "Jon Crowcroft" <[email-masked]>, "Arjuna Sathiaseelan" <[email-masked]>
Sent: Saturday, 13 June, 2015 7:06:18 PM
Subject: Re: [gaia] Is DTN dead for under-serviced area communication

Thanks, 

Nalini Elkins 
Inside Products, Inc. 
(831) 659-8360 
www.insidethestack.com 

Melissa 

1. To the Internet 

Thanks, 

Nalini Elkins 
Inside Products, Inc. 
(831) 659-8360 
www.insidethestack.com 

Regards 

Cheers, 
Dirk 

http://piratebox.cc/ 

http://librarybox.us/ 

Cheers, 
Jörg 

Hi, 

Panayotis Antoniadis 

Nalini Elkins 
Inside Products, Inc. 
(831) 659-8360 
www.insidethestack.com 

Scott 

-----Original Message----- 

Thanks 
David 

David Johnson 
Principal Researcher 
Networks and Media group 
Meraka, CSIR 
Adjunct Senior Lecturer 

-- 

Arjuna Sathiaseelan

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Sat, 13 Jun 2015 17:45:47 +0100

Hello Nalini, all

this is interesting:
http://designtoimprovelife.dk/brck-portable-and-rugged-internet-for-rural-areas/

you could possibly talk to them too..

On 13 June 2015 at 16:36, Nalini Elkins <[email-masked]>
wrote:

> I have to say, one of the best things about the Internet is lists like
> this where very smart people will get on and collaborate for the common
> good.   Would be wonderful if we can get more of the world on.
>
> Thanks,
>
> Nalini Elkins
> Inside Products, Inc.
> (831) 659-8360
> www.insidethestack.com
>
>  *From:* Henning Schulzrinne <[email-masked]>
> *To:* Nalini Elkins <[email-masked]>
> Ott <[email-masked]>; Dirk Kutscher <[email-masked]>; Melissa
> Densmore <[email-masked]>; Arjuna Sathiaseelan <
> [email-masked]>; Jon Crowcroft <
> [email-masked]>
> *Sent:* Saturday, June 13, 2015 8:11 AM

---

From: Nalini Elkins <[email-masked]>
Date: Sat, 13 Jun 2015 17:49:20 +0000 (UTC)

Thanks, Arjuna.   I believe this is the Ushahidi product,if I am not mistaken.
Will take a look at this also. Thanks for the suggestion.

Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

      From: Arjuna Sathiaseelan <[email-masked]>
 To: Nalini Elkins <[email-masked]> 
Cc: Adriano Galati <[email-masked]>; gaia <[email-masked]>; Panayotis Antoniadis <[email-masked]>; Joerg Ott <[email-masked]>; Dirk Kutscher <[email-masked]>; Melissa Densmore <[email-masked]>; Jon Crowcroft <[email-masked]>; Henning Schulzrinne <[email-masked]> 
 Sent: Saturday, June 13, 2015 9:45 AM
 Subject: Re: [gaia] Is DTN dead for under-serviced area communication
   
Hello Nalini, all 
this is interesting: http://designtoimprovelife.dk/brck-portable-and-rugged-internet-for-rural-areas/
you could possibly talk to them too..

On 13 June 2015 at 16:36, Nalini Elkins <[email-masked]> wrote:

   

Thanks,
Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

---

From: Jon Crowcroft <[email-masked]>
Date: Sat, 13 Jun 2015 18:48:50 +0100

it might be interesting to channel an idea an old teacher of mine had
- he ran a charity that trained people in developing regions to make
  sports equipment (particulallry footballs) - the materials had a lot
of educational material printed on, so a side effect of enabling a
village to make money was to deliver some health advice

maybe we could do same (get someone to put health info instead of ust
corporate logos on usb sticks)

actually, we could put the USB/flash inside things that were also
useful....um, no, i dont think putting the USB stick inside the
football would make a whole lot of sense:)

alternative is to give people 3D printers and planes for drones (there
was a nasa project that did a 3D Printable drone design...) and use
those as data mules....

why am i more suspicious of a 3rdparty usb stick in security terms,
than I am of connecting my computer to the interweb? actualy, with
quite good reason (the USB port sometimes goes under a lot of my
computers security checks...for daft reasons - that could be fixed
tho)...

i guess the real thing is seamlessness - the point about having a
powred wireless device with storage, do the mule thing is that it
approximates the internet in some sense - of course, as discussed
before, the poor approximation may in fact be very counter productive
in user-experience terms...

---

From: Jon Crowcroft <[email-masked]>
Date: Sat, 13 Jun 2015 21:57:35 +0200

imagine every postman's sack contained a device which had a lot of store
and wifi and a decent battery life - e.g. a BRCK+a terabyte of usb disk,
for example, which gets recharged every time the sack is in the town
sorting office. which has internet access. then every postal delivery can
also offer DTN net delivery. in our measurement[1] of latency in
opportunistic DTNs, we had a relatively small, sparely connected social
group, which meant that a) delivery probability was low and b) latency
diverged ....but if the postal service itself is also the carrier, we get
carrier-grade DTN- in many countries, this might be as good as 24 hour
round trip time....

reading the story of Darwin's trips on the Beagle, it seems that even when
people were going to obscure parts of the world, they would encounter ships
delivering mail and picking up more mail - it was just built in to
transportation-- this suggests we might kit out wide ranging vehicles with
carrier-dtn kit too [3]

cheers
jon
[1] http://www.cs.columbia.edu/~augustin/pub/hui05pocket.pdf
[2] https://en.wikipedia.org/wiki/Charles_Darwin
[3] https://www.cl.cam.ac.uk/~jac22/out/taxi.pdf

On Sat, Jun 13, 2015 at 8:49 PM, Adriano Galati <
[email-masked]> wrote:

> I also believe that the point is "seamlessness".
> After all, in very simplistic terms, a DTN node might be seen as a mobile
> memory stick,... with some more "functionalities".
> Besides, we should not assume that entrusting memory sticks to carriers
> just for the purpose of carrying them from A to B is cheaper. Actually such
> a solution might be even more expensive (I would say very often) than
> "asking a lift" to, for example, periodic carriers.
>
> I think that the delivery mechanism is something that needs to be designed
> considering the carriers' mobility, the scenario, and the
> application/service to be provided. Such points are strongly tied with each
> other.
>
>
> On Sat, Jun 13, 2015 at 7:48 PM, Jon Crowcroft <[email-masked]
> > wrote:
>
>> > > 3.  When we loop back around to where there IS connectivity, then we
>> can
>> > > send our data along.
>> > >

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Sun, 14 Jun 2015 00:54:15 +0100

the  usecase/businesscase for the postman could be:

there could be people in rural/remote areas (even in places like the UK)
who would want to transfer huge files on a day to day basis as part of
their work and rely on DHL for transfers as they are either on a low
capacity access or no access..for e.g. people working for BBC radio

In the DART project (http://www.erg.abdn.ac.uk/projects/11-DART.html), we
explored how we could use micropayments and adaptive QoS to increase the
QoS to transfer such files with a fraction of the DHL costs over satellite..

the rural postman could do that too and that could make a business case for
royal mail :)

On 13 June 2015 at 20:57, Jon Crowcroft <[email-masked]> wrote:

>> I think that the delivery mechanism is something that needs to be
>> designed considering the carriers' mobility, the scenario, and the
>> On Sat, Jun 13, 2015 at 7:48 PM, Jon Crowcroft <
>> [email-masked]> wrote:
>>

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Sun, 14 Jun 2015 01:15:29 +0000

A possible example: we used to get printed catalogues through the mail and place orders for merchandise we saw in the catalogues.  Now we browse Amazon, etc. online, provided we’ve got connectivity.  An alternative would be for businesses to send catalogues, together with self-contained order placement apps, in USB sticks.  The user loads the catalogue and app as servlets into a local Web server running on the user’s laptop.  The user then has the same fully graphical, HTML-based shopping experience as the online user – actually much better, because there’s no round-trip time to (or congestion at) the vendor’s server farm – and places orders in the same way, but the orders are returned by DTN as well (USB stick, data mule satellite, whatever).  The vendor spends less on hardware and line charges, and the round-trip time for shopping, ordering, and receiving the merchandise is perhaps a day longer.  Maybe less.

Scott

From: gaia [mailto:[email-masked]] On Behalf Of Arjuna Sathiaseelan
Sent: Saturday, June 13, 2015 4:54 PM
To: Jon Crowcroft
Cc: Adriano Galati; Nalini Elkins; gaia; Panayotis Antoniadis; Joerg Ott; Dirk Kutscher; Melissa Densmore; Henning Schulzrinne
Subject: Re: [gaia] Is DTN dead for under-serviced area communication

there could be people in rural/remote areas (even in places like the UK) who would want to transfer huge files on a day to day basis as part of their work and rely on DHL for transfers as they are either on a low capacity access or no access..for e.g. people working for BBC radio

In the DART project (http://www.erg.abdn.ac.uk/projects/11-DART.html), we explored how we could use micropayments and adaptive QoS to increase the QoS to transfer such files with a fraction of the DHL costs over satellite..

the rural postman could do that too and that could make a business case for royal mail :)

On 13 June 2015 at 20:57, Jon Crowcroft <[email-masked]<mailto:[email-masked]>> wrote:
imagine every postman's sack contained a device which had a lot of store and wifi and a decent battery life - e.g. a BRCK+a terabyte of usb disk, for example, which gets recharged every time the sack is in the town sorting office. which has internet access. then every postal delivery can also offer DTN net delivery. in our measurement[1] of latency in opportunistic DTNs, we had a relatively small, sparely connected social group, which meant that a) delivery probability was low and b) latency diverged ....but if the postal service itself is also the carrier, we get carrier-grade DTN- in many countries, this might be as good as 24 hour round trip time....

reading the story of Darwin's trips on the Beagle, it seems that even when people were going to obscure parts of the world, they would encounter ships delivering mail and picking up more mail - it was just built in to transportation-- this suggests we might kit out wide ranging vehicles with carrier-dtn kit too [3]

cheers
jon

On Sat, Jun 13, 2015 at 8:49 PM, Adriano Galati <[email-masked]<mailto:[email-masked]>> wrote:
I also believe that the point is "seamlessness".
After all, in very simplistic terms, a DTN node might be seen as a mobile memory stick,... with some more "functionalities".
Besides, we should not assume that entrusting memory sticks to carriers just for the purpose of carrying them from A to B is cheaper. Actually such a solution might be even more expensive (I would say very often) than "asking a lift" to, for example, periodic carriers.

I think that the delivery mechanism is something that needs to be designed considering the carriers' mobility, the scenario, and the application/service to be provided. Such points are strongly tied with each other.

On Sat, Jun 13, 2015 at 7:48 PM, Jon Crowcroft <[email-masked]<mailto:[email-masked]>> wrote:

> [email-masked]<mailto:[email-masked]>> wrote:
>

---

From: Henning Schulzrinne <[email-masked]>
Date: Sat, 13 Jun 2015 21:33:51 -0400

There's actually a fairly successful "DTN" service in the US: RedBox, a
vending machine for 7GB data carriers known as DVDs. Still found at many
grocery stores, particularly in more rural areas. And then there was that
other 7GB delivery service, involving red envelopes...

On Sat, Jun 13, 2015 at 9:15 PM, Burleigh, Scott C (312B) <
[email-masked]> wrote:

>  A possible example: we used to get printed catalogues through the mail
> and place orders for merchandise we saw in the catalogues.  Now we browse
> Amazon, etc. online, provided we’ve got connectivity.  An alternative would
> be for businesses to send catalogues, together with self-contained order
> placement apps, in USB sticks.  The user loads the catalogue and app as
> servlets into a local Web server running on the user’s laptop.  The user
> then has the same fully graphical, HTML-based shopping experience as the
> online user – actually much better, because there’s no round-trip time to
> (or congestion at) the vendor’s server farm – and places orders in the same
> way, but the orders are returned by DTN as well (USB stick, data mule
> satellite, whatever).  The vendor spends less on hardware and line charges,
> and the round-trip time for shopping, ordering, and receiving the
> merchandise is perhaps a day longer.  Maybe less.
>
>
>
> Scott
>
>
>
> *From:* gaia [mailto:[email-masked]] *On Behalf Of *Arjuna
> Sathiaseelan
> *Sent:* Saturday, June 13, 2015 4:54 PM
> *To:* Jon Crowcroft
> *Cc:* Adriano Galati; Nalini Elkins; gaia; Panayotis Antoniadis; Joerg
> Ott; Dirk Kutscher; Melissa Densmore; Henning Schulzrinne
> On Sat, Jun 13, 2015 at 7:48 PM, Jon Crowcroft <[email-masked]>
> wrote:
>

---

From: Jon Crowcroft <[email-masked]>
Date: Sun, 14 Jun 2015 11:27:23 +0100

yes, of course - however, one of the points of building something a
bit more active is that it represents a channel (and a bi-directional
channel, at that) - once you have something that can carry a
bi-directional protocol, people can build all kinds of services we
won't imagine here...i'd claim that the evidence is not there yet that
a DTN channel doesn't excite such innovation - after all it tool at
least 15 years of pretty widespread IP connectivity before someone
thought of WWW :)

> designed
> > > platforms and needs no special skills. If a drive gets lost or 
> damaged,
> > > the

---

From: Joerg Ott <[email-masked]>
Date: Sun, 14 Jun 2015 18:22:04 +0300

I like the ship for mail analogy.  Works, of course, even better
for schedules traffic, even if they don't always quite follow their
schedule.  We looked at aerial carriers [1] and a recently concluded
MSc thesis [2] took a first stab at studying the minimal requirements
for Helsinki, Arlanda, and Heathrow airports. Similar concepts would
hold for other means of transportation, even if they move slower and
may not stay as long at a stop.  But, then, taxi are nice, too, and
flocks of them do get predictable.

Cheers,
Jörg

[1] http://www.netlab.tkk.fi/~jo/papers/2009-09-aerial-dtn.pdf
[2] Kimmo Hietalahti: A Case Study for Bulk Data Transfer Using
     Aircraft. MSc thesis, Aalto University, 2015.

On 13.06.2015 22:57, Jon Crowcroft wrote:
> sorting office. which has internet access. then every postal delivery
> can also offer DTN net delivery. in our measurement[1] of latency in
> diverged ....but if the postal service itself is also the carrier, we
> get carrier-grade DTN- in many countries, this might be as good as 24
> hour round trip time....
>
> reading the story of Darwin's trips on the Beagle, it seems that even
> when people were going to obscure parts of the world, they would
> encounter ships delivering mail and picking up more mail - it was just
> built in to transportation-- this suggests we might kit out wide ranging
> vehicles with carrier-dtn kit too [3]
>
> cheers
> jon
> On Sat, Jun 13, 2015 at 8:49 PM, Adriano Galati
> <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     After all, in very simplistic terms, a DTN node might be seen as a
>     mobile memory stick,... with some more "functionalities".
>     Besides, we should not assume that entrusting memory sticks to
>     carriers just for the purpose of carrying them from A to B is
>     cheaper. Actually such a solution might be even more expensive (I
>     would say very often) than "asking a lift" to, for example, periodic
>     carriers.
>
>     application/service to be provided. Such points are strongly tied
>     with each other.
>
>
>     On Sat, Jun 13, 2015 at 7:48 PM, Jon Crowcroft
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>          > platforms and needs no special skills. If a drive gets lost
>         or damaged,
>          > the
>          > [email-masked]
>         <mailto:[email-masked]>> wrote:
>          >
>          > > 3.  When we loop back around to where there IS
>         connectivity, then we can
>          > > send our data along.
>          > >

---

From: "Burleigh, Scott C (312B)" <[email-masked]>
Date: Sun, 14 Jun 2015 16:58:17 +0000

Except the Nextflix system seems to me to be more of a delivery system than a communication network, since customers don’t convey a lot of information to the vendor by US mail pickup, aside from “This DVD doesn’t load.”  I don’t know about RedBox.

Scott

From: Henning Schulzrinne [mailto:[email-masked]]
Sent: Saturday, June 13, 2015 6:34 PM
To: Burleigh, Scott C (312B)
Cc: Arjuna Sathiaseelan; Jon Crowcroft; Adriano Galati; Nalini Elkins; gaia; Panayotis Antoniadis; Joerg Ott; Dirk Kutscher; Melissa Densmore
Subject: Re: [gaia] Is DTN dead for under-serviced area communication

There's actually a fairly successful "DTN" service in the US: RedBox, a vending machine for 7GB data carriers known as DVDs. Still found at many grocery stores, particularly in more rural areas. And then there was that other 7GB delivery service, involving red envelopes...

On Sat, Jun 13, 2015 at 9:15 PM, Burleigh, Scott C (312B) <[email-masked]<mailto:[email-masked]>> wrote:
A possible example: we used to get printed catalogues through the mail and place orders for merchandise we saw in the catalogues.  Now we browse Amazon, etc. online, provided we’ve got connectivity.  An alternative would be for businesses to send catalogues, together with self-contained order placement apps, in USB sticks.  The user loads the catalogue and app as servlets into a local Web server running on the user’s laptop.  The user then has the same fully graphical, HTML-based shopping experience as the online user – actually much better, because there’s no round-trip time to (or congestion at) the vendor’s server farm – and places orders in the same way, but the orders are returned by DTN as well (USB stick, data mule satellite, whatever).  The vendor spends less on hardware and line charges, and the round-trip time for shopping, ordering, and receiving the merchandise is perhaps a day longer.  Maybe less.

Scott

From: gaia [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Arjuna Sathiaseelan
Sent: Saturday, June 13, 2015 4:54 PM
To: Jon Crowcroft
Cc: Adriano Galati; Nalini Elkins; gaia; Panayotis Antoniadis; Joerg Ott; Dirk Kutscher; Melissa Densmore; Henning Schulzrinne
Subject: Re: [gaia] Is DTN dead for under-serviced area communication

cheers
jon

---

From: Steve Song <[email-masked]>
Date: Mon, 15 Jun 2015 16:12:40 -0300

Hi Nalini,

On a slightly different tack, I think the challenge you face is not a
technological one; it is a challenge of sustainability.  Back in 2003, the
Wizzy Digital Courier Project in South Africa followed exactly the model of
driving around to schools with memory sticks (obviously much smaller memory
sticks then) to transfer mail and web resources.  It was a big success and
widely feted at the time.  Today I struggle to find references[1] to it.
If memory serves it was the brainchild of an American named John Johnson.
It was set up as a non-profit but unfortunately when John moved on, the
project did not survive.  It was his impetus that drove it forward.  So
many successful projects that we attribute to brilliant technology are
actually just brilliant people making stuff happen.  Assuming you are
successful, how will you ensure this project survives beyond the length of
your intervention?

The challenge therefore is more of finding a business model that will
appeal either to small entrepreneurs or to local/provincial/national
governments prepared to adopt technologies to solve a problem they have.  I
particularly like startups like Endaga and EveryLayer who have taken
technologies we are already familiar with (GSM and WiFi respectively) and
brought business-model innovation as their key offering for affordable
access.

My 2 cents... Steve Song

[1]
http://www.researchgate.net/profile/Farid_Farahmand2/publication/220098639_Performance_of_vehicular_delay-tolerant_networks_with_relay_nodes/links/09e4150ac1f7ae7677000000.pdf

On 13 June 2015 at 10:59, Nalini Elkins <[email-masked]>
wrote:

> I would be very interested in finding out more about what you are doing.
> The villages we may be in are also quite remote so your scenario is similar
> to ours.  Bicycle or trishaw are also vehicles that we might use.
>
> If you are interested in discussing off-line, we can test out your
> implementation here also.   I live near the Big Sur area and cell phone
> connectivity drops off very quickly.  So, I believe that we can test this
> easily.
>
> I know yours is "development" or "alpha" software and will be treating it
> accordingly.   Or if you guys want to share your experiences with us and
> are cautious about software, I completely understand.
>
> I want to do as much homework as I can.
>
> Thanks,
>
>
> Nalini Elkins
> Inside Products, Inc.
> (831) 659-8360
> www.insidethestack.com
>
>  *From:* H S Jamadagni <[email-masked]>
> Ott <[email-masked]>; Dirk Kutscher <[email-masked]>; Jon
> Crowcroft <[email-masked]>; Arjuna Sathiaseelan <
> [email-masked]>; Melissa Densmore <
> [email-masked]>; Prabhakar T. V <[email-masked]>
>
> *Sent:* Saturday, June 13, 2015 6:12 AM
>
> We have done some experiments with DTN in our lab in IISc Bangalore. We
> have designed and produced a few DTN modules that go on a bicycle (or any
> other vehicle) and even has a GSM connectivity which may be available
> intermittently. We have file exchange (containing some data) and email
> exchange implemented on the system with nodes in a few locations. The
> experiments are going on sporadically in a somewhat remote village 180 km
> from Bangalore.We are currently trying to make the system as robust as
> possible. Therefore, I am unable at this stage say whether this system will
> become "popular". We will be continuing our experimentation and hopefully
> will have some results by the end of the year (2015).
>
> Cc: "Adriano Galati" <[email-masked]>, "gaia" <
> [email-masked]>, "Panayotis Antoniadis" <[email-masked]>,
> "Joerg Ott" <[email-masked]>, "Dirk Kutscher" <[email-masked]>,
> "Jon Crowcroft" <[email-masked]>, "Arjuna Sathiaseelan" <
> [email-masked]>
> 1. T he motorcycle or truck will be doing circles through communities
> 2. In communities where there is NO connectivity, we can gather data, the
> data may be image data on health issues or email.
>
>
> Cc: Arjuna Sathiaseelan <[email-masked]>; Dirk Kutscher
> <[email-masked]>; Adriano Galati <
> [email-masked]>; gaia <[email-masked]>; Panayotis
> Antoniadis <[email-masked]>; Joerg Ott <[email-masked]>; Jon
> Crowcroft <[email-masked]>
> Strictly speaking, neither of those two cases are considered DTN, since
> all data communications occurs over normal fully-connected IP, unless you
> are also using the motorbikes to carry non-real-time video and other data
> back to the hospital.
>
>
> The purpose of the DTN architecture is to assist in bridging
> communications where normal IP (whether TCP or UDP) breaks down due to long
> delays (e.g. motorcycle travel time, or interplanetary occlusions).
>
>
> Emergency broadband is just considered last-mile connectivity - also a
> very important but slightly different area of research.
>
>
> Melissa
>
>
>
>
>
>
> [email-masked] > wrote:
>
>
>
>
>
> Locations are Sierra Leone and Uganda. Cost is a major factor. Would love
> to talk about this, if appropriate & get updates / suggestions from all.
>
>
> Cc: Adriano Galati < [email-masked] >; gaia <
> [email-masked] >; Panayotis Antoniadis < [email-masked] >;
> Joerg Ott < [email-masked] >; Melissa Densmore <
> [email-masked] >; Jon Crowcroft < [email-masked]
> >
> points you have raised ( http://rife-project.eu/about/ )
>
>
> Regards
>
>
> - Leveraging this decomposition for realizing customized network slices
> (i.e., from baseline connectivity to mobility-managed, QoS-guaranteed &
> in-network service enhanced)
> didn't use it in Haggle for various similar reasons, way back http://www.haggleproject.org/
>
>
> [email-masked] > wrote:
>
> using a formal network architecture worthy of a paper. But documentation on
> this widespread practice is still sparse - one paper is listed below. The
> factors in computing systems . ACM, 2008. http://arxiv.org/pdf/0801.1927
>
>
>
> Networks . 2004.
> Factors in Computing Systems . ACM, 2010.
>
>
>
> visible." Proceedings of the SIGCHI Conference on Human Factors in
> Computing Systems . ACM, 2011.
>
> Human Factors in Computing Systems . ACM, 2010.
>
>
>
>
>
>
>
>
>

---

From: Jim Forster <[email-masked]>
Date: Mon, 15 Jun 2015 12:55:24 -0700

> The challenge therefore is more of finding a business model that will appeal either to small entrepreneurs 

..and usually a strong part of the appeal the entrepreneurs has to be “Oh wow! I can make some money on this!”.  So the value delivered to customers has to be greater than the cost of the service (including payroll!).  Volunteer efforts are commendable, but discounting one’s own labor must not mask the true cost of sustainable labor. 

Jim

> On Jun 15, 2015, at 12:12 PM, Steve Song <[email-masked]> wrote:
> 
> On a slightly different tack, I think the challenge you face is not a technological one; it is a challenge of sustainability.  Back in 2003, the Wizzy Digital Courier Project in South Africa followed exactly the model of driving around to schools with memory sticks (obviously much smaller memory sticks then) to transfer mail and web resources.  It was a big success and widely feted at the time.  Today I struggle to find references[1] to it.  If memory serves it was the brainchild of an American named John Johnson.  It was set up as a non-profit but unfortunately when John moved on, the project did not survive.  It was his impetus that drove it forward.  So many successful projects that we attribute to brilliant technology are actually just brilliant people making stuff happen.  Assuming you are successful, how will you ensure this project survives beyond the length of your intervention?
> 
> The challenge therefore is more of finding a business model that will appeal either to small entrepreneurs or to local/provincial/national governments prepared to adopt technologies to solve a problem they have.  I particularly like startups like Endaga and EveryLayer who have taken technologies we are already familiar with (GSM and WiFi respectively) and brought business-model innovation as their key offering for affordable access.
>

---

From: Nalini Elkins <[email-masked]>
Date: Mon, 15 Jun 2015 20:24:39 +0000 (UTC)

Guys,
You are very right!!! Definitely one of the things we are thinking of.  But, one step at a time.   We want to have this all work for a long time & so it definitely has to be sustainable (that is pay for itself).
Thanks,
Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

      From: Jim Forster <[email-masked]>
 To: Steve Song <[email-masked]> 
Cc: gaia <[email-masked]> 
 Sent: Monday, June 15, 2015 12:55 PM
 Subject: Re: [gaia] Is DTN dead for under-serviced area communication

---

From: Jon Crowcroft <[email-masked]>
Date: Mon, 15 Jun 2015 22:12:43 +0100

Optimistic ..
http://www.theatlantic.com/technology/archive/2015/06/hibernating-comet-lander-robot-philae-wakes-up-rosetta-mission/395819/

Note Philae actually had worked for days before hibernating but did not
have power to tx til coming out of shadow noe..
.great design!!
On 15 Jun 2015 21:24, "Nalini Elkins" <[email-masked]>
wrote:

> Guys,
>
> You are very right!!!
>
> Definitely one of the things we are thinking of.  But, one step at a time.
>   We want to have this all work for a long time & so it definitely has to
> be sustainable (that is pay for itself).
>
> Thanks,
>
> Nalini Elkins
> Inside Products, Inc.
> (831) 659-8360
> www.insidethestack.com
>
>  *From:* Jim Forster <[email-masked]>
> *To:* Steve Song <[email-masked]>
> *Cc:* gaia <[email-masked]>
> *Sent:* Monday, June 15, 2015 12:55 PM
> appeal either to small entrepreneurs
>
>
> ..and usually a strong part of the appeal the entrepreneurs has to be “Oh
> wow! I can make some money on this!”.  So the value delivered to customers
> has to be greater than the cost of the service (including payroll!).
> Volunteer efforts are commendable, but discounting one’s own labor must not
> mask the true cost of sustainable labor.
>
> Jim
>
>

---

From: "Psaras, Ioannis" <[email-masked]>
Date: Tue, 16 Jun 2015 06:08:24 +0000

From a modelling perspective, we tried to see if users can have undisrupted playback in the London Underground. We didn’t consider extra caches in trains or stations, or scheduled transmissions, but these would be easy to integrate I assume. An extension to this is also available which utilises 3G connectivity as well.

"Mind the gap: modelling video delivery under expected periods of disconnection", ACM CHANTS 2014, http://dl.acm.org/citation.cfm?id=2645680

Regards,
Yiannis.

all

communications

This broadly includes sneakernet applications - more so in cases which the
communication is seamless and doesn't require major interventions to
bridge
to the cloud - i.e. the data automatically starts transiting to its
desired
location via IP when the usb stick is inserted into an Internet-connected
computer.  The normal modality for sneakernet however initiates a new IP
connection when the cloud is reached (i.e. someone taking the file from
the
drive and uploading to a website or sending it by email) - and considered
a
less-than-ideal DTN.

very

Melissa

1.  To the Internet

2.  To do real time video (latency OK) to hospital or provider in more
major town.

Locations are Sierra Leone and Uganda.   Cost is a major factor.
Would
love to talk about this, if appropriate & get updates / suggestions from
all.

Am looking forward to finding out how far RIFE has gotten.  I believe
that
will be a game changer for us.

Thanks,

Nalini Elkins
Inside Products, Inc.
(831) 659-8360

thanks Dirk - yes would be great to discuss this at the GAIA meeting
Prague.

Regards

Another perspective on this is that there is a good opportunity to
rethink mobile network design at this point so that use cases such as
â?onot
always onâ?, â?onot really seamlessly connectedâ?,
â?oinfrastructure-less
exchangeâ? can be better integrated with the network infrastructure.

Leaving the 5G buzz aside, there are efforts for
-          Decomposing the previously tightly integrated system into
elements such as â?oaccessâ?, â?oauthorizationâ?, â?omobility
managementâ?,
â?o(in-network) servicesâ? etc.
-          Leveraging this decomposition for realizing customized
network
slices (i.e., from baseline connectivity to mobility-managed,
QoS-guaranteed & in-network service enhanced)
-          Leveraging network programmability for edge computing that
could support ICN/DTN â?oslicesâ? better in the future

I like the notion of â?onot having fixed assumptions on where the
network
endsâ? â?" so if we do things right, ICN/DTN types of access and local
communication do not have to treated as special cases or add-on
solutions
in the future.

I have some additional thoughts on this â?" and there are also risks
like
creating dependencies on in-network functions that need to be
considered â?"
happy to discuss this further, maybe in Prague?

Cheers,
Dirk

 *From:* gaia [mailto:[email-masked]] *On Behalf Of *Jon
Crowcroft
*Sent:* Donnerstag, 11. Juni 2015 09:49
*To:* Melissa Densmore
*Cc:* gaia; Adriano Galati; Panayotis Antoniadis; Joerg Ott
*Subject:* Re: [gaia] Is DTN dead for under-serviced area communication

i'd agree the classic DTN arch is probably not quite the right one (we
didn't use it in Haggle for various similar reasons, way back
http://www.haggleproject.org/
but something might happen surprisingly (like firechat did, for
example)
- various infrastructureless projects are starting to take off, and one
could imagine a new emergent system appearing if we manage to tease out
the
right way to present things to people (the main barrier is encountereed
like arjuna and others have said, when you try and present a DTN
service as
a way to do the internet for 2nd class citizens - it isn't the internet
and
caling your customers 2nd class is a surefire way to not have any:)

On Thu, Jun 11, 2015 at 9:42 AM, Melissa Densmore <
[email-masked]<mailto:[email-masked]>> wrote:
I'll paste in my response to David from a separate thread, some
additional details and edits:

sensing.  Even my Ghana Telemedicine Network stuff was done back in
2008.

At the same time, it's been 10 years and some parts of Africa are still
largely unconnected.  I don't think the applicability of DTN has
reduced -
but the number of researchers and practitioners looking to leverage it
in
isolated places has greatly reduced.  It's possible that the DTN
reference
architecture is simply too much overhead for rural deployments, with no
clear benefits (e.g. interoperability, etc) for using it. Tons of people
use informal DTNs/sneakernet (flash drives, Netflix, media kiosks)
without
using a formal network architecture worthy of a paper.  But
documentation
on this widespread practice is still sparse - one paper is listed below.
The existence of intermediaries often co-exists with mobile coverage -
which actually reveals the possibility of DTN concurrently existing with
fully-connected networks due to quality and cost of available
infrastructure.  See bandwidth limit literature below.

My older papers on DTN deployments:
 Luk, Rowena, Melissa Ho, and Paul M. Aoki. "Asynchronous remote
medical
consultation for Ghana." *Proceedings of the SIGCHI conference on human
factors in computing systems*. ACM, 2008. http://arxiv.org/pdf/0801.1927

Cheers,
JÃ¶rg

Hi,

Panayotis Antoniadis

Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

*To:* David Johnson <[email-masked]>; gaia
<[email-masked]>

Scott

-----Original Message-----

to be the most interesting recent work ... but I'm no expert in this
area.

Thanks
David

David Johnson
Principal Researcher
Networks and Media group
Meraka, CSIR
Adjunct Senior Lecturer

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Tue, 16 Jun 2015 07:14:12 +0100

Why dont we cache the whole Internet on to the end devices and do a diff
synch ;)

Cloud to fog to the end device i say :)
On 16 Jun 2015 07:09, "Psaras, Ioannis" <[email-masked]> wrote:

>  From a modelling perspective, we tried to see if users can have
> undisrupted playback in the London Underground. We didn’t consider extra
> caches in trains or stations, or scheduled transmissions, but these would
> be easy to integrate I assume. An extension to this is also available which
> utilises 3G connectivity as well.
>
>  "Mind the gap: modelling video delivery under expected periods of
> disconnection", ACM CHANTS 2014, http://dl.acm.org/citation.cfm?id=2645680
>
>  Regards,
> Yiannis.
>
>  *From:* gaia [mailto:[email-masked] <[email-masked]>] *On
> Behalf Of *Jon
>
> Crowcroft
>

---

From: Joerg Ott <[email-masked]>
Date: Tue, 16 Jun 2015 09:39:40 +0300

We built a system for delay-tolerant Internet access on trains at some
point: http://www.netlab.tkk.fi/~jo/papers/2009-06-chianti-arch.pdf

This was an extension to our early work on Drive-thru Internet:
http://www.drive-thru-internet.org/

As for service interruptions and video, we also did some work on
predictive buffering for streaming video along the lines Yiannis
pointed out: http://www.netlab.tkk.fi/~jo/papers/2012-wowmom-glass.pdf
We used crowd sourcing to gather experience on time,location-dependent
network performance and then use this to proactive either preload
content or step down video quality.

Cheers.
Jörg

On 16.06.2015 09:08, Psaras, Ioannis wrote:
> caches in trains or stations, or scheduled transmissions, but these
> would be easy to integrate I assume. An extension to this is also
> available which utilises 3G connectivity as well.
>
>>>> [email-masked] <mailto:[email-masked]>>
>>>> wrote:

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Wed, 17 Jun 2015 21:05:52 +0100

Was  going through the iSavi today -- great device by Inmarsat - but
ridiculous costs for such low data rates :)

http://www.groundcontrol.com/IsatHub.htm

Regards

---

From: Nalini Elkins <[email-masked]>
Date: Wed, 17 Jun 2015 20:14:10 +0000 (UTC)

Cost is a HUGE factor.
Especially, given that we are talking about people who may be earning $2 per day.
Thanks,
Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

      From: Arjuna Sathiaseelan <[email-masked]>
 To: Nalini Elkins <[email-masked]> 
Cc: "Burleigh, Scott C (312B)" <[email-masked]>; David Johnson <[email-masked]>; gaia <[email-masked]> 
 Sent: Wednesday, June 17, 2015 1:05 PM
 Subject: Re: [gaia] Is DTN dead for under-serviced area communication
   
Was  going through the iSavi today -- great device by Inmarsat - but ridiculous costs for such low data rates :)
http://www.groundcontrol.com/IsatHub.htm

Regards
On 10 June 2015 at 16:12, Nalini Elkins <[email-masked]> wrote:

   

Scott

-----Original Message-----
From: gaia [mailto:[email-masked]] On Behalf Of David Johnson
Sent: Wednesday, June 10, 2015 4:02 AM
To: gaia
Subject: [gaia] Is DTN dead for under-serviced area communication

Thanks
David

David Johnson
Principal Researcher
Networks and Media group
Meraka, CSIR
Adjunct Senior Lecturer

---

From: "Paul M. Aoki" <[email-masked]>
Date: Wed, 17 Jun 2015 14:49:04 -0700

cost does matter, though i'm not sure what the relevance of inmarsat is. 
  BGAN is a mobile terminal solution and correspondingly expensive. 
perhaps more to the point are Ka band HTS services like yahclick, which 
in ZA is ~$8/GB (http://www.yahclick.co.za/consumer) as opposed to 
~$8/MB for inmarsat.  high performance modems for such services are more 
like $200-300 than the >$1000 that the inmarsat terminal costs, and 
that's also at low production volume.

let's think about the economics for a second. higher system throughput 
results in correspondingly lower $/GB - if you can sell it.  yahsat can 
deliver ~$8/GB in ZA with a ~15 Gbps satellite.  FB could have 
contracted a satellite with 100s of Gbps of throughput.  what do you 
think the missing information was that caused them not to invest?  what 
data could research provide that would enable satellite operators to 
close these deals?

-- 
Paul M. Aoki <[email-masked]>
Google Inc.
1600 Amphitheatre Parkway
Mountain View, CA 94043-1351 USA

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Thu, 18 Jun 2015 10:05:13 +0100

Hello Paul -

yes the BGAN solution is not the right approach for low cost connectivity
-- interestingly BRCK have partnered with them for their satellite backhaul
-- so looks like BRCK is not targetting the low cost Internet access
market..

Agree with Ka band -- Avanti has been using their Ka band Hylas 2 satellite
to connect number of rural schools in Africa and have been providing
educational content
http://www.avantiplc.com/sites/default/files/satellite-evolution-emea-education.pdf

Also Facebook has been talks with Avanti for providing free Internet access:
http://www.telegraph.co.uk/finance/newsbysector/mediatechnologyandtelecoms/telecoms/11232599/Facebook-in-talks-with-Avanti-over-Africa-deal.html

Had a discussion with one of the Avanti directors last week about this too.
I have not managed to gather much info on whats happening currently with
Avanti and Facebook.

On 17 June 2015 at 22:49, Paul M. Aoki <[email-masked]> wrote:

> BGAN is a mobile terminal solution and correspondingly expensive. perhaps
> more to the point are Ka band HTS services like yahclick, which in ZA is
> ~$8/GB (http://www.yahclick.co.za/consumer) as opposed to ~$8/MB for
> inmarsat.  high performance modems for such services are more like $200-300
> than the >$1000 that the inmarsat terminal costs, and that's also at low
> production volume.
>
> deliver ~$8/GB in ZA with a ~15 Gbps satellite.  FB could have contracted a
> satellite with 100s of Gbps of throughput.  what do you think the missing
> information was that caused them not to invest?  what data could research
> provide that would enable satellite operators to close these deals?
>

---

From: Jane Coffin <[email-masked]>
Date: Thu, 18 Jun 2015 10:17:38 +0000

Start up/investment costs, including attending WRC¹s + to lobby and get
licensing, orbital slots+, base-station rights of way/lease/whathave you
(not insignificant)
Build, production
Launch
Maintenance
More?

---

From: Steve Song <[email-masked]>
Date: Thu, 18 Jun 2015 10:31:28 -0300

Hi Paul, Arjuna, Jane,

I have been wondering myself about the potential of Ka-band HTS satellites
since YahClick announced services in South Africa a few years ago.
Obviously rain fade is an issue in Ka-band frequencies.  Ka-band dissipates
3-10x more energy at Ka-band than at Ku-band for downloads and 63-400x for
uplinks[1].  The higher energy of the Ka-band spot beam compensates for
this to some degree.  In many parts of Africa, I suspect that higher power
terminal equipment may also be required to compensate.  A colleague in
Mpumulanga was quoted R7000 (approx $700) about 2 years ago for the
Yahclick terminal equipment.  For many consumer services, it is possible
that rainfade interference may be tolerable but it only takes one user with
a mission critical application to change that.  Also, the ADSL-like nature
of Ka-band HTS limits bi-directional applications like video conferencing.
For many people, these issues may be small change when it comes to offering
services where none currently exist.

The other issue that comes to mind is coverage.  Because Ka-band HTS
satellites use steerable spot-beams, their coverage areas are going to be
much smaller than traditional Ku or C band satellite services.  Yahclick et
al are a little bit tricksy in their coverage maps.  Their maps indicate
where they could cover but not necessarily where they will cover.  In order
to be profitable, they are likely to focus on more populated regions.

I see Intelsat and others are launching Ku-band HTS (steerable spot-beam)
satellites.  With OneWeb and SpaceX getting into the game, one can't help
but wonder if there is a chance that the satellite market might actually
become competitive.  Every time I think of the comparatively high profits
made by some African MNOs with EBITDA margins in range of 40-45% (MTN,
Safaricom, and others come to mind) I have to keep in mind Intelsat's
EBITDA margin which has been hovering just under the 80% mark for the last
few years.

Cheers... Steve

[1]
http://www.harriscaprock.com/downloads/HarrisCapRock_WhitePaper-Ka-Ku_Analysis.pdf

On 18 June 2015 at 06:05, Arjuna Sathiaseelan <
[email-masked]> wrote:

> Agree with Ka band -- Avanti has been using their Ka band Hylas 2
> satellite to connect number of rural schools in Africa and have been
> providing educational content
> Had a discussion with one of the Avanti directors last week about this
> too. I have not managed to gather much info on whats happening currently
> with Avanti and Facebook.
>
>
>

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Fri, 19 Jun 2015 06:53:12 +0100

Thanks Steve.

Excellent points - thanks.

Regarding rain fading and its effect on Ka band - I think the DVB-RCS2/S2
standard takes this into account using adaptive coding and modulation and
dynamic rate adaptation..

Regards

On 18 June 2015 at 14:31, Steve Song <[email-masked]> wrote:

>>> cost does matter, though i'm not sure what the relevance of inmarsat
>>> is.  BGAN is a mobile terminal solution and correspondingly expensive.
>>> perhaps more to the point are Ka band HTS services like yahclick, which in
>>> ZA is ~$8/GB (http://www.yahclick.co.za/consumer) as opposed to ~$8/MB
>>> for inmarsat.  high performance modems for such services are more like
>>> $200-300 than the >$1000 that the inmarsat terminal costs, and that's also
>>> at low production volume.
>>>

---

From: Steve Song <[email-masked]>
Date: Mon, 22 Jun 2015 10:27:06 -0300

Interesting interview with Emeka Afigbo, a program manager for Google in
Nigeria.

http://timbuktuchronicles.blogspot.ca/2015/06/coffee-with-googler.html

talks about developing offline content to assist developers.

Cheers... Steve

On 19 June 2015 at 02:53, Arjuna Sathiaseelan <
[email-masked]> wrote:

>> I have been wondering myself about the potential of Ka-band HTS
>> satellites since YahClick announced services in South Africa a few years
>> ago.   Obviously rain fade is an issue in Ka-band frequencies.
>> Ka-band dissipates 3-10x more energy at Ka-band than at Ku-band for
>> downloads and 63-400x for uplinks[1].  The higher energy of the Ka-band
>> spot beam compensates for this to some degree.  In many parts of Africa, I
>> suspect that higher power terminal equipment may also be required to
>> compensate.  A colleague in Mpumulanga was quoted R7000 (approx $700) about
>> 2 years ago for the Yahclick terminal equipment.  For many consumer
>> services, it is possible that rainfade interference may be tolerable but it
>> only takes one user with a mission critical application to change that.
>> Also, the ADSL-like nature of Ka-band HTS limits bi-directional
>> applications like video conferencing.  For many people, these issues may be
>> small change when it comes to offering services where none currently exist.
>>
>>> yes the BGAN solution is not the right approach for low cost
>>> connectivity -- interestingly BRCK have partnered with them for their
>>> satellite backhaul -- so looks like BRCK is not targetting the low cost
>>> Internet access market..
>>>

---

From: Steve Song <[email-masked]>
Date: Mon, 29 Jun 2015 09:19:13 -0300

WhatsApp voice messaging takes off in Argentina.  Another interesting
phenomenon.  Not quite DTN but a deliberate choice to use use asynchronous
communication over synchronous.

http://motherboard.vice.com/read/everyone-in-buenos-aires-is-communicating-by-voice-memo-now

Cheers... Steve

On 22 June 2015 at 10:27, Steve Song <[email-masked]> wrote:

>>> I see Intelsat and others are launching Ku-band HTS (steerable
>>> spot-beam) satellites.  With OneWeb and SpaceX getting into the game, one
>>> can't help but wonder if there is a chance that the satellite market might
>>> actually become competitive.  Every time I think of the comparatively high
>>> profits made by some African MNOs with EBITDA margins in range of 40-45%
>>> (MTN, Safaricom, and others come to mind) I have to keep in mind Intelsat's
>>>>> ZA is ~$8/GB (http://www.yahclick.co.za/consumer) as opposed to
>>>>> like $200-300 than the >$1000 that the inmarsat terminal costs, and that's
>>>>> also at low production volume.
>>>>>

---

From: Hervey Allen <[email-masked]>
Date: Mon, 29 Jun 2015 10:56:53 -0700

On 6/29/15 5:19 AM, Steve Song wrote:
> phenomenon.  Not quite DTN but a deliberate choice to use use
> asynchronous communication over synchronous.
> 

This is absolutely true in Chile as well. Whatsapp is the overwhelming
app used for text, images and now voice memos. Having moved to the
States from Chile 18 months ago almost all communication from countless
friends and family comes to our entire family via Whatsapp - and,
interestingly, multiple voice snippets resulting in asynchronous
"conversations".

- Hervey

> On 22 June 2015 at 10:27, Steve Song <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     Interesting interview with Emeka Afigbo, a program manager for
>     Google in Nigeria.
> 
>     On 19 June 2015 at 02:53, Arjuna Sathiaseelan
>     <[email-masked]
>     <mailto:[email-masked]>> wrote:
> 
>         Thanks Steve.
> 
>         Regarding rain fading and its effect on Ka band - I think the
>         DVB-RCS2/S2 standard takes this into account using adaptive
>         coding and modulation and dynamic rate adaptation..
> 
>         Regards
> 
>         On 18 June 2015 at 14:31, Steve Song <[email-masked]
>         <mailto:[email-masked]>> wrote:
> 
>             Hi Paul, Arjuna, Jane,
> 
>             I have been wondering myself about the potential of Ka-band
>             HTS satellites since YahClick announced services in South
>             Africa a few years ago.   Obviously rain fade is an issue in
>             Ka-band frequencies.  Ka-band dissipates 3-10x more energy
>             at Ka-band than at Ku-band for downloads and 63-400x for
>             uplinks[1].  The higher energy of the Ka-band spot beam
>             compensates for this to some degree.  In many parts of
>             Africa, I suspect that higher power terminal equipment may
>             also be required to compensate.  A colleague in Mpumulanga
>             was quoted R7000 (approx $700) about 2 years ago for the
>             Yahclick terminal equipment.  For many consumer services, it
>             is possible that rainfade interference may be tolerable but
>             it only takes one user with a mission critical application
>             to change that.  Also, the ADSL-like nature of Ka-band HTS
>             limits bi-directional applications like video conferencing. 
>             For many people, these issues may be small change when it
>             comes to offering services where none currently exist.
> 
>             The other issue that comes to mind is coverage.  Because
>             Ka-band HTS satellites use steerable spot-beams, their
>             coverage areas are going to be much smaller than traditional
>             Ku or C band satellite services.  Yahclick et al are a
>             little bit tricksy in their coverage maps.  Their maps
>             indicate where they could cover but not necessarily where
>             they will cover.  In order to be profitable, they are likely
>             to focus on more populated regions.
> 
>             I see Intelsat and others are launching Ku-band HTS
>             (steerable spot-beam) satellites.  With OneWeb and SpaceX
>             getting into the game, one can't help but wonder if there is
>             a chance that the satellite market might actually become
>             competitive.  Every time I think of the comparatively high
>             profits made by some African MNOs with EBITDA margins in
>             range of 40-45% (MTN, Safaricom, and others come to mind) I
>             have to keep in mind Intelsat's EBITDA margin which has been
>             hovering just under the 80% mark for the last few years.
> 
>             Cheers... Steve
> 
>             [1]
>             On 18 June 2015 at 06:05, Arjuna Sathiaseelan
>             <[email-masked]
>             <mailto:[email-masked]>> wrote:
> 
>                 Hello Paul - 
> 
>                 yes the BGAN solution is not the right approach for low
>                 cost connectivity -- interestingly BRCK have partnered
>                 with them for their satellite backhaul -- so looks like
>                 BRCK is not targetting the low cost Internet access market..
> 
>                 Agree with Ka band -- Avanti has been using their Ka
>                 band Hylas 2 satellite to connect number of rural
>                 schools in Africa and have been providing educational
>                 content
>                 Also Facebook has been talks with Avanti for providing
>                 free Internet
>                 access:http://www.telegraph.co.uk/finance/newsbysector/mediatechnologyandtelecoms/telecoms/11232599/Facebook-in-talks-with-Avanti-over-Africa-deal.html
> 
>                 Had a discussion with one of the Avanti directors last
>                 week about this too. I have not managed to gather much
>                 info on whats happening currently with Avanti and Facebook.
> 
> 
> 
>                 On 17 June 2015 at 22:49, Paul M. Aoki <[email-masked]
>                 <mailto:[email-masked]>> wrote:
> 
>                     cost does matter, though i'm not sure what the
>                     relevance of inmarsat is.  BGAN is a mobile terminal
>                     solution and correspondingly expensive. perhaps more
>                     to the point are Ka band HTS services like yahclick,
>                     which in ZA is ~$8/GB
>                     (http://www.yahclick.co.za/consumer) as opposed to
>                     ~$8/MB for inmarsat.  high performance modems for
>                     such services are more like $200-300 than the >$1000
>                     that the inmarsat terminal costs, and that's also at
>                     low production volume.
> 
>                     let's think about the economics for a second. higher
>                     system throughput results in correspondingly lower
>                     $/GB - if you can sell it.  yahsat can deliver
>                     ~$8/GB in ZA with a ~15 Gbps satellite.  FB could
>                     have contracted a satellite with 100s of Gbps of
>                     throughput.  what do you think the missing
>                     information was that caused them not to invest? 
>                     what data could research provide that would enable
>                     satellite operators to close these deals?
> 
>                     Paul M. Aoki <[email-masked] <mailto:[email-masked]>>
>                     Google Inc.

-- 
Hervey Allen      Assistant Director, Network Startup Resource Center
[email-masked]   http://nsrc.org/ : http://facebook.com/nsrc.org
GPG Fingerprint:  AC08 31CB E453 6C65 2AB3 4EDB CEEB 5A74 C6E5 624F

---

From: Jane Coffin <[email-masked]>
Date: Mon, 29 Jun 2015 18:01:35 +0000

Hi Steve -
Sorry for the late reply.
Hear you on Ka band.
Intelsat are telling me that they are working on new emerging market projects.
Let me ask them for a summary as it might be interesting to see how they are moving given competition and other infrastructure being rolled out that did not exist years ago.  Am assuming their model is adaptive, but we shall see.

Jane

From: gaia <[email-masked]<mailto:[email-masked]>> on behalf of Steve Song <[email-masked]<mailto:[email-masked]>>
Date: Thursday, June 18, 2015 at 9:31 AM
To: gaia <[email-masked]<mailto:[email-masked]>>
Subject: Re: [gaia] Is DTN dead for under-serviced area communication

Hi Paul, Arjuna, Jane,

I have been wondering myself about the potential of Ka-band HTS satellites since YahClick announced services in South Africa a few years ago.   Obviously rain fade is an issue in Ka-band frequencies.  Ka-band dissipates 3-10x more energy at Ka-band than at Ku-band for downloads and 63-400x for uplinks[1].  The higher energy of the Ka-band spot beam compensates for this to some degree.  In many parts of Africa, I suspect that higher power terminal equipment may also be required to compensate.  A colleague in Mpumulanga was quoted R7000 (approx $700) about 2 years ago for the Yahclick terminal equipment.  For many consumer services, it is possible that rainfade interference may be tolerable but it only takes one user with a mission critical application to change that.  Also, the ADSL-like nature of Ka-band HTS limits bi-directional applications like video conferencing.  For many people, these issues may be small change when it comes to offering services where none currently exist.

The other issue that comes to mind is coverage.  Because Ka-band HTS satellites use steerable spot-beams, their coverage areas are going to be much smaller than traditional Ku or C band satellite services.  Yahclick et al are a little bit tricksy in their coverage maps.  Their maps indicate where they could cover but not necessarily where they will cover.  In order to be profitable, they are likely to focus on more populated regions.

I see Intelsat and others are launching Ku-band HTS (steerable spot-beam) satellites.  With OneWeb and SpaceX getting into the game, one can't help but wonder if there is a chance that the satellite market might actually become competitive.  Every time I think of the comparatively high profits made by some African MNOs with EBITDA margins in range of 40-45% (MTN, Safaricom, and others come to mind) I have to keep in mind Intelsat's EBITDA margin which has been hovering just under the 80% mark for the last few years.

Cheers... Steve

[1] http://www.harriscaprock.com/downloads/HarrisCapRock_WhitePaper-Ka-Ku_Analysis.pdf

On 18 June 2015 at 06:05, Arjuna Sathiaseelan <[email-masked]<mailto:[email-masked]>> wrote:
Hello Paul -

yes the BGAN solution is not the right approach for low cost connectivity -- interestingly BRCK have partnered with them for their satellite backhaul -- so looks like BRCK is not targetting the low cost Internet access market..

Agree with Ka band -- Avanti has been using their Ka band Hylas 2 satellite to connect number of rural schools in Africa and have been providing educational content http://www.avantiplc.com/sites/default/files/satellite-evolution-emea-education.pdf

Also Facebook has been talks with Avanti for providing free Internet access:http://www.telegraph.co.uk/finance/newsbysector/mediatechnologyandtelecoms/telecoms/11232599/Facebook-in-talks-with-Avanti-over-Africa-deal.html

Had a discussion with one of the Avanti directors last week about this too. I have not managed to gather much info on whats happening currently with Avanti and Facebook.

On 17 June 2015 at 22:49, Paul M. Aoki <[email-masked]<mailto:[email-masked]>> wrote:
cost does matter, though i'm not sure what the relevance of inmarsat is.  BGAN is a mobile terminal solution and correspondingly expensive. perhaps more to the point are Ka band HTS services like yahclick, which in ZA is ~$8/GB (http://www.yahclick.co.za/consumer) as opposed to ~$8/MB for inmarsat.  high performance modems for such services are more like $200-300 than the >$1000 that the inmarsat terminal costs, and that's also at low production volume.

let's think about the economics for a second. higher system throughput results in correspondingly lower $/GB - if you can sell it.  yahsat can deliver ~$8/GB in ZA with a ~15 Gbps satellite.  FB could have contracted a satellite with 100s of Gbps of throughput.  what do you think the missing information was that caused them not to invest?  what data could research provide that would enable satellite operators to close these deals?

--
Paul M. Aoki <[email-masked]<mailto:[email-masked]>>
Google Inc.
1600 Amphitheatre Parkway
Mountain View, CA 94043-1351 USA

---

From: David Johnson <[email-masked]>
Date: Mon, 29 Jun 2015 22:08:11 +0200

Many thanks to all for an amazing flood of interesting responses to the
"Is DTN dead" question.  If I can summarize from what most of said.
There is not any current true DTN network (true in the sense of using
a protocol like Prophet or RAPID or MaxProp)  being used on a wide
scale specifically for areas with poor connectivity.

But we are seeing a fair amount of informal DTN-like networks with
data being disseminated by exchanging files on personal storage
devices like flash / hard drives / DVDs with plugin offloads or
personal networks like Blueooth or even some store and forward like
messaging on public networks  e.g. WhatsApp voice messaging.  Sorry I
don't consider the Disney Research on DTN in South Africa to be worth
taking seriously - there were no African researchers on the paper and
the trial was run in Pretoria - South Africa an area with excellent
universities and research institutions (I'm a stickler for avoiding
parachute research - and lack of local researchers raises red flags
for me - I read the paper and it made little business sense)

And yes Steve I remember the Wizzy Digital Courier Project - great
project - it inspired a lot of our early thinking about rural
connectivity at CSIR around 2004 - I remember us thinking about a sort
of digital mailman with a computer in their backpack that would run a
business by going house to house delivering and retrieiving mail
messages, software or music they requested etc.

This is probably a new thread but what's clear to me is we need lots
more intelligent caching at the edges e.g. low cost /free public
networks (WiFi for now) or offline public data caches like
Internet-in-a-Box that update with DTN like update mechanisms - the
intelligence can start by harnessing the fact there is usually
locality of interest in content,apps etc. I imagine an app where you
describe you need a Linux iso, an large app download .. and it gives
you coordinates of the nearest smart cache with a free download - this
may even be a moving phone if people volunteered to become mobile data
caches. Smart phones are robbing many low-income users of their data
on GSM networks with non-deliberate data access e.g.  cloud syncing,
app updates ...

David

On Mon, Jun 29, 2015 at 8:01 PM, Jane Coffin <[email-masked]> wrote:
> Let me ask them for a summary as it might be interesting to see how they are
> moving given competition and other infrastructure being rolled out that did
> not exist years ago.  Am assuming their model is adaptive, but we shall see.
>
> Jane
>
> From: gaia <[email-masked]> on behalf of Steve Song
> <[email-masked]>
> To: gaia <[email-masked]>
> uplinks[1].  The higher energy of the Ka-band spot beam compensates for this
> to some degree.  In many parts of Africa, I suspect that higher power
> Mpumulanga was quoted R7000 (approx $700) about 2 years ago for the Yahclick
> terminal equipment.  For many consumer services, it is possible that
> rainfade interference may be tolerable but it only takes one user with a
> mission critical application to change that.  Also, the ADSL-like nature of
> Ka-band HTS limits bi-directional applications like video conferencing.  For
> many people, these issues may be small change when it comes to offering
> Safaricom, and others come to mind) I have to keep in mind Intelsat's EBITDA
> margin which has been hovering just under the 80% mark for the last few
> years.
>
> Cheers... Steve
>
> [1]
>> Also Facebook has been talks with Avanti for providing free Internet

---

From: Rohan Mahy <[email-masked]>
Date: Mon, 29 Jun 2015 13:28:48 -0700

I’ve been following this thread for a while but haven’t chimed in yet.
Below are my 2 cents.

A lot of people have been talking about data mule and interactive services
as an either/or solution. I think that real-time interactivity is extremely
important to the user experience of the Internet, but I think that slower
real-time services like SMS, 2G, and low-speed satellite work better in
tandem with a data mule system than either do by themselves. At the very
least, being able to offload OS updates and antivirus definitions frees up
a lot of bandwidth. If you distribute standard curricula or references to
schools or health clinics that is another place you can free up a lot of
bandwidth. These can be a hook to let people request their own delayed
downloads or RSS or version-control style subscriptions.

Another issue that very few have mentioned here is Agency. If you are doing
top-down planning, then rolling out a nationwide fiber backbone with 5Ghz
spurs into smaller communities yields a fantastic bang for the buck and
DTN-style services are probably not a great investment. Unfortunately, the
places with the most stubborn deficit of connectivity also tend to be
neglected by governments, incumbent telcos and mobile network operators;
and generally lack large amounts of their own capital. Having a data mule
solution that is easy to deploy by individuals without requiring a
government or large company to do something new makes the solution
enormously more accessible.

For example, many tablets and smartphones have a microSD or similar
removable storage card. Imagine that individual private taxi or bus drivers
could sign up to be data mules for a local ISP in a provincial capital.
They each buy a 64GB storage card for a smartphone or tablet. They leave
their device to charge and sync for an hour or two before leaving for some
small villages. When they arrive they can do a device to device sync with a
small number of devices there (ex: general store that sells credit, health
post, school). Users who want to send or receive bulk data use a prepaid
account with the local ISP to pay for the data mule service (just like an
Internet café or mobile operator charges for regular Internet access). The
local ISP could actually be a mobile network operator.

What are the incentives for everyone? The village users get large bulk
transfers for a relatively small cost and without requiring electricity to
power their devices overnight. The mules get free charging in the capital
and some amount of free bandwidth as their incentive. The local ISP gets
more users using more bandwidth. The government can be blissfully ignorant
or can become a customer. What I like about this is that it also proves the
market. If there is strong demand the ISP or mobile operator can justify an
investment to expand or improve service there.

This is just one example of an application, but as Joerg said, you need to
start with an application and then build the solution from there.

Thanks,
-rohan

---

From: "Paul M. Aoki" <[email-masked]>
Date: Mon, 29 Jun 2015 15:13:20 -0700

wechat and viber have been doing voice messaging for 4-5 years. a pop 
culture commentary on wechat (from 2013) is excerpted below.

there's a very rich UX design space in the tradeoff between asynchrony 
and immediacy.  asynchrony enables the ability for the user to drop in 
and out of interaction, and the ability of the UI to avoid blatting out 
audio in public (walkie-talkie style); immediacy is what makes 
interaction fun/spontaneous.  i would expect that a communication 
service that is asynchronous but involves long delays in the *usual* 
case can be useful in some cases but is not going to be particularly 
compelling for mass-market users.  some of my own thoughts in this area: 
<http://www.paulaoki.com/papers/jcscw05.pdf>.

from <http://frankjwu.com/posts/wechat-isnt-a-messaging-app/>:

But it isn’t just text messaging that is helping to drive WeChat’s user 
retention. I was pretty surprised by how popular the walkie talkie 
(push-to-talk) feature is for communication, which I believe stems from 
how difficult it is to enter Chinese characters on a phone. It’s not 
uncommon to see people walking down the street or on the subway, 
speaking in quick 2 to 3 second bursts on their WeChat accounts. Instead 
of calling one another, a lot of Chinese people choose to use these 
walkie talkie conversations, giving them the benefits of asynchronous 
communication coupled with the power of voice. I’m also suspecting that 
more and more people are starting to substitute their phone service with 
WeChat’s walkie talkie feature as well, making an average Chinese user’s 
phone plan pretty heavily focused on 3G data.

---

From: "Paul M. Aoki" <[email-masked]>
Date: Mon, 29 Jun 2015 15:21:53 -0700

i think steve's point re: rain was that the outdoor unit may cost more 
in areas where you need more uplink transmit power (i.e., where ACM 
alone is not enough).  i'm not going to claim to be an expert here, but:
- i believe the vast majority of the cost of a consumer ground station 
is the indoor unit (modem) and not the outdoor unit (LNB etc.)
- i'd be willing to bet that national differences in ground station 
price have more to do with stuff like import taxes and other local, er, 
"cost-of-business" variations
- i would think that national differences in service price may have to 
do with needing more downlink transmit power on the satellite (=> you're 
serving fewer customers so you have to charge more)

re: steve's point about footprint.  the announced generation of HTS are 
advertising considerably increased beam "flexibility," which is a 
working approximation to the ability to steer beams when you're talking 
about the smaller Ka spot beams.

re: jane's points about the difficulty of getting a GEO launched.  it's 
certainly true that time to market is surely an issue for anybody going 
as fast as FB.  otoh one might ask what the analogous issues are for 
UAVs vs. GEOs, and yet they are apparently pursuing UAVs.

On 6/18/2015 10:53 PM, Arjuna Sathiaseelan wrote:
> DVB-RCS2/S2 standard takes this into account using adaptive coding and
> modulation and dynamic rate adaptation..
>
> Regards
>
>     satellites since YahClick announced services in South Africa a few
>     years ago.   Obviously rain fade is an issue in Ka-band
>     frequencies.  Ka-band dissipates 3-10x more energy at Ka-band than
>     at Ku-band for downloads and 63-400x for uplinks[1].  The higher
>     energy of the Ka-band spot beam compensates for this to some
>     degree.  In many parts of Africa, I suspect that higher power
>     terminal equipment may also be required to compensate.  A colleague
>     in Mpumulanga was quoted R7000 (approx $700) about 2 years ago for
>     the Yahclick terminal equipment.  For many consumer services, it is
>     possible that rainfade interference may be tolerable but it only
>     takes one user with a mission critical application to change that.
>     applications like video conferencing.  For many people, these issues
>     may be small change when it comes to offering services where none
>     currently exist.
>
>     satellites use steerable spot-beams, their coverage areas are going
>     to be much smaller than traditional Ku or C band satellite
>     services.  Yahclick et al are a little bit tricksy in their coverage
>     maps.  Their maps indicate where they could cover but not
>     necessarily where they will cover.  In order to be profitable, they
>     are likely to focus on more populated regions.
>
>     spot-beam) satellites.  With OneWeb and SpaceX getting into the
>     game, one can't help but wonder if there is a chance that the
>     satellite market might actually become competitive.  Every time I
>     think of the comparatively high profits made by some African MNOs
>     with EBITDA margins in range of 40-45% (MTN, Safaricom, and others
>     come to mind) I have to keep in mind Intelsat's EBITDA margin which
>     has been hovering just under the 80% mark for the last few years.
>
>     Cheers... Steve
>
>     [1]
>         connectivity -- interestingly BRCK have partnered with them for
>         their satellite backhaul -- so looks like BRCK is not targetting
>         the low cost Internet access market..
>
>         Agree with Ka band -- Avanti has been using their Ka band Hylas
>         2 satellite to connect number of rural schools in Africa and
>         have been providing educational content
>         Had a discussion with one of the Avanti directors last week
>         about this too. I have not managed to gather much info on whats
>         happening currently with Avanti and Facebook.
>
>
>
>             cost does matter, though i'm not sure what the relevance of
>             inmarsat is.  BGAN is a mobile terminal solution and
>             correspondingly expensive. perhaps more to the point are Ka
>             band HTS services like yahclick, which in ZA is ~$8/GB
>             (http://www.yahclick.co.za/consumer) as opposed to ~$8/MB
>             for inmarsat.  high performance modems for such services are
>             more like $200-300 than the >$1000 that the inmarsat
>             terminal costs, and that's also at low production volume.
>
>             let's think about the economics for a second. higher system
>             throughput results in correspondingly lower $/GB - if you
>             can sell it.  yahsat can deliver ~$8/GB in ZA with a ~15
>             Gbps satellite.  FB could have contracted a satellite with
>             100s of Gbps of throughput.  what do you think the missing
>             information was that caused them not to invest?  what data
>             could research provide that would enable satellite operators
>             to close these deals?

---

From: Nalini Elkins <[email-masked]>
Date: Tue, 30 Jun 2015 18:50:12 +0000 (UTC)

Very interesting idea for broadband to the village.   I was thinking of something similar calling it "Bush Taxi Network".   
Having said that, when I lived in a small town in West Africa, taxi service was regular-ish but depending on how many people were waiting, if the taxi got full, then the guy took off.   If the taxi was not full, you wait until it does get full.  Could be 10 minutes, could be 2 hours.   
If we can make the "wait" time productive for the driver, then definitely, it is an incentive for them to provide services.
I am having some conversations in the next couple of weeks with physicians working in Africa.   I want to see if DTN, data saved on a thumb drive, etc. is something that they would find valuable.   The application that we are looking at first is for health.
I would love to continue these conversations in Prague. Thanks,
Nalini Elkins
Inside Products, Inc.
(831) 659-8360
www.insidethestack.com

      From: Rohan Mahy <[email-masked]>
 To: David Johnson <[email-masked]> 
Cc: gaia <[email-masked]> 
 Sent: Monday, June 29, 2015 1:28 PM
 Subject: Re: [gaia] Is DTN dead for under-serviced area communication
   
I’ve been following this thread for a while but haven’t chimed in yet. Below are my 2 cents.

A lot of people have been talking about data mule and interactive services as an either/or solution. I think that real-time interactivity is extremely important to the user experience of the Internet, but I think that slower real-time services like SMS, 2G, and low-speed satellite work better in tandem with a data mule system than either do by themselves. At the very least, being able to offload OS updates and antivirus definitions frees up a lot of bandwidth. If you distribute standard curricula or references to schools or health clinics that is another place you can free up a lot of bandwidth. These can be a hook to let people request their own delayed downloads or RSS or version-control style subscriptions.

Another issue that very few have mentioned here is Agency. If you are doing top-down planning, then rolling out a nationwide fiber backbone with 5Ghz spurs into smaller communities yields a fantastic bang for the buck and DTN-style services are probably not a great investment. Unfortunately, the places with the most stubborn deficit of connectivity also tend to be neglected by governments, incumbent telcos and mobile network operators; and generally lack large amounts of their own capital. Having a data mule solution that is easy to deploy by individuals without requiring a government or large company to do something new makes the solution enormously more accessible.

For example, many tablets and smartphones have a microSD or similar removable storage card. Imagine that individual private taxi or bus drivers could sign up to be data mules for a local ISP in a provincial capital. They each buy a 64GB storage card for a smartphone or tablet. They leave their device to charge and sync for an hour or two before leaving for some small villages. When they arrive they can do a device to device sync with a small number of devices there (ex: general store that sells credit, health post, school). Users who want to send or receive bulk data use a prepaid account with the local ISP to pay for the data mule service (just like an Internet café or mobile operator charges for regular Internet access). The local ISP could actually be a mobile network operator.

What are the incentives for everyone? The village users get large bulk transfers for a relatively small cost and without requiring electricity to power their devices overnight. The mules get free charging in the capital and some amount of free bandwidth as their incentive. The local ISP gets more users using more bandwidth. The government can be blissfully ignorant or can become a customer. What I like about this is that it also proves the market. If there is strong demand the ISP or mobile operator can justify an investment to expand or improve service there. 

This is just one example of an application, but as Joerg said, you need to start with an application and then build the solution from there.

Thanks,
-rohan

On Wed, Jun 10, 2015 at 4:02 AM, David Johnson <[email-masked]> wrote:

Thanks
David

David Johnson
Principal Researcher
Networks and Media group
Meraka, CSIR
Adjunct Senior Lecturer