Subject: Re: [gaia] august meeting minute

From: Arjuna Sathiaseelan <[email-masked]>
Date: Fri, 7 Aug 2015 04:51:54 +0100

I think we need to contribute to the icnrg strongly.

One suggestion would be to write a draft probably as an informational on
the need for an integrated icn and dtn architecture? Joerg, Dirk and I
could start this..

Regards
On 5 Aug 2015 21:17, "Andrés Arcia-Moret" <[email-masked]> wrote:

> 1.  WP1 (MGT):
>
> 1.1: May-July QPR inputs are now due
>
> 1.2: Consortium Agreement
>
> everybody has agreed on the version 27th of january.
> contract amendment: description of actions changed. TUMunich has signed
> already.
> The original (27 January) version is signed by all partners
>
>
> We are making a scan of the signature pages to send by e-mail. Originals will be brought to the next meeting.
>
> 1.3: Contract Amendment to include TUM
>
> The Amendment has been submitted and the (electronic) signatures process is in progress.
> (done)
> Have to wait from TUM to see if other partners have to sign something.
>
> 1.4: Deliverables due at the end of July:
>
> - D2.1: Usage Scenarios and Requirements (IDC) - awaiting any last comments
>
> - D5.2: Dissemination and Communication Plan (TAS) - 1-week delay (Renaud is on holiday)
> recommendations for improving. Wait for Renaud next week (10-14 aug)
>
> - D5.7: architectuRe of an Internet For Everybody (RIFE) document (TAS) - awaiting any last comments
> to be sent today (5th aug)
>
> - D5.8: architectuRe of an Internet For Everybody (RIFE) leaflet and poster (TAS) - submitted
>
>
> 1.5: Deliverables due at the end of October:
>      - D1.3: 1st technical progress report
> month 1-9 should be in
>
>      - D2.2: Initial Component and Interface Specifications
>      - D5.4: RIFE Standardization Survey (TAS)
> Standardisation activities (thales)
>
> 1.6: Next project meeting:
>         - 9-11 November, Barcelona
> (ok confirmed by roger)
>
> 1.7: 9-Month Project Review:
>
> - 20 November, Brussels (note the short timeframe after the end the 3rd Quarter (end October)
> to write the reports, prepare slides, ...)
>
> 2.  WP2 (System Design) / WP3 Development
> Status?
>
> 3.  WP4: Evaluation and Field Trial
> Status?
>
> IP/ICN demo ready
> HTTP stuff working
> MSBF workings with Cambridge.
> Edge cache. Demonstrate at the review.
>
> Basic blacker development. We’re gonna continue with that in September.
> code maintenance. approach the right partners for testing.
>
> VPN servers from Cambridge.
> testbed all nodes available.
>
> how many nodes from partners?
>
> Avanti, dirk is gonna ask other partners.
>
> Not much progress SCAMPI/ICN.
>
> We have enough to show at the technical review. Data mule take care for
> the surrogate aspects. Dirk is very excited about. How we could showcase
> this.
>
>
> Event last July: many people suggested what? Roger is a bit concerned
> because he’s confused about what to deliver. Install devices with the
> community firmware? have the network setup? install the new software.
>
> Dirk: it would be good to phone call to prepare the Barcelona meeting. How
> do we transition into an installation into GUIFI.net then a number of
> preparation of phone calls: software, devices, we’d be in a good shape to
> discuss devices, platforms, perform an INSTALLATION not TRIAL. Get couple
> of things done. Code camp very hands on exercise so that mini system can be
> replicating in GUIFI.net. This is the biggest task in the couple of weeks
> to come. Standard wireless access routers.
>
> RIFE/POINT: both have trials and can be joint. Bristol open environments
> to discuss what can be transferred to that environment. Even in Bristol is
> well connected area there are common points with GUIFI community
> perspectives. Reuse: IP/ICN, edge caching, surrogate servers
> (appearing/disappearing). Flash one or two slides at the Technical Review.
> This is an excellent use-case for extending RIFE ideas.
>
> Joerg: see what the synergies are going on here. keep him updated about
> Bristol.
>
> Dirk: IP/ICN story, and edge caching with AVANTI we’ve put the satellite
> component. another overlap is the smart-city, which gets a lot of press,
> this gives a new set of use cases.
>
> AALTO: solid ground under feet. data collection, take data with net radar
> and try to compare different features. determine the bottleneck, technical
> solutions for bottlenecks and pricing. You’ll get some information about
> this approach soon.
>
> Me: More or less the same as july’s, I’ve been working on things related
> to WP5.
>
> on couple of papers. One for hotnets for virtual cells, and CCNC assisted
> network discovery.
>
> Dirk: how to take forward standardisation initiatives to standardise
> efforts on ICN. Joerg could participate in this.
> IP to ICN work: how to make the transition work. How is this technology
> gonna look like?
> Working group about: if we are in an IP world, then we can make IP run
> better. (ICNRG). Dirk is gonna start a wiki page. who’s supporting? (to be
> decided in the next couple of weeks). It is not in a hurry, but Dirk’s want
> to get into this.
>
> 4.  WP5: Dissemination and Exploitation
>
> Martin: very happy.
>
> Dissemination news since the previous telco (or not previously mentioned):
>
>  - ACM ICN 2015, in San Francisco, USA: Accepted paper: âPro-Diluvian: Understanding Scoped-Flooding
>
> for Content Discovery in Information-Centric Networkingâ, by Liang Wang, Suzan Bayhan, JÃ¶rg Ott,
>
> Jussi Kangasharju, Arjuna Sathiaseelan, Jon Crowcroft (RIFE and UMobile projects)
>
>  - CFP has been issued for a special session on Content Centric Internet of Things (CCIoT) at IEEE
>
> Consumer Communications & Networking Conference (CCNC), held in conjunction with the International
> Consumer Electronics Show, Las Vegas, 9-12 January, 2016
>
>  - Arjuna is planning to submit a proposal for a breakout event along the intersection for big data
>
> for social good and networking for development at "Tech4Dev 2016: From Innovation to Social Impact" to be
> held at EPFL, 2-4 May 2016
>
>  - Arjuna submitted a Hotnets paper on wireless related stuff for both the RIFE and the Metrics projects
>        -
> UCAM and IDC are organising a special workshop at the IEEE CCNC on topics related to the RIFE and UMobile
> projects. The call is at:
>  http://ccnc2016.ieee-ccnc.org/call-for-submissions/call-for-workshop-papers
> <http://ccnc2016.ieee-ccnc.org/call-for-submissions/call-for-workshop-papers>
>        - Paper from
> J. Qadir, A. Ali, K. Yau, A. Sathiaseelan and J. Crowcroft,
>  on multipathing in ICN (LIPSIN, MS-BF,
>
> etc.) has been accepted for the IEEE Communications Surveys and Tutorials, acknowledging both the Trilogy2
> and RIFE projects:
> http://ieeexplore.ieee.org/xpl/articleDetails.jsp?arnumber=7152820
>         - Arjuna gave an interview with SciDev.Net <http://scidev.net/>
>  on universal Internet access, mentioning the project (and AVANTI), at:
>
> http://www.scidev.net/global/technology/multimedia/podcast-internet-access-china-july-carbon-insurance.html
>        - Jon gave an interview with SciDev.Net <http://scidev.net/>
>  about the goals of the RIFE and n4d lab:
>
> http://www.scidev.net/global/vulnerability/multimedia/June-podcast-missing-millions-vulnerable.html
>        - The programme for the SIGCOMM workshop on NS is at:
> http://ensr.oii.ox.ac.uk/sigcomm-workshop/.
> The RIFE paper from UCAM is at:
> http://ensr.oii.ox.ac.uk/wp-content/uploads/2015/05/Does-the-Internet-deserve-everybody.pdf
>
>        - Andres presented on the TVWS
> measurement and deployment challenges and experiences at the IRTF GAIA
> meeting in Prague on 22 July
>        - Did anyone present the RIFE architecture
> at the IRTF GAIA meeting in Prague on 22 July?
>
>  - Arjuna was interviewed by Jonathan Donner (who was previously at MSR Technology for Emerging
> Markets) who recently foundedÂ Caribou Digital (http://cariboudigital.net/
> ) and Charlotte Smart from Oxford
> Internet Institute - whichÂ has received support from the MasterCardÂ
> Foundation to assess the changing landscape for
> access to (and use of) theÂ
> internet among rural and resource-constrained communities in sub-SaharanÂ
> Africa, with a
> special emphasis on the prospects for new technologiesÂ
> (unlicensed spectrum, drones, near-earth satellites, etc.) to
> augmentÂ
> conventional cellular/mobile infrastructure by 2020. Arjuna spoke specifically about the RIFE project and satellites
>
>  - The Content Caching and Delivery in Wireless Networks (CCDWN2015) looks relevant for RIFE:
> http://conferences2.sigcomm.org/co-next/2015/#!/ccdwn (deadline 21 August)
>
> 5.  AoB
>
>
>
>

---

From: "Trossen, Dirk" <[email-masked]>
Date: Fri, 7 Aug 2015 07:09:38 +0000

Arjuna

I offered to add to the disaster draft, which will include something on ICN / DTN integration. To be honest, I don't expect much of informational drafts in the icnrg and will largely focus on initiating efforts that go beyond the RG. It just doesn't have much momentum beyond CCN.

Dirk

Dirk Trossen
Principal Engineer
InterDigital UK, Inc.
Shoreditch Business Center
64 Great Eastern Street
London,  EC2A 3QR
T: +44 207.749.9178
[email-masked]
www.InterDigital.com<http://www.interdigital.com>

This e-mail is intended only for the use of the individual or entity to which it is addressed, and may contain information that is privileged, confidential and/or otherwise protected from disclosure to anyone other than its intended recipient. Unintended transmission shall not constitute waiver of any privilege or confidentiality obligation. If you received this communication in error, please do not review, copy or distribute it, notify me immediately by email, and delete the original message and any attachments. Unless expressly stated in this e-mail, nothing in this message or any attachment should be construed as a digital or electronic signature.

________________________________
From: gaia on behalf of Arjuna Sathiaseelan
Sent: Friday, August 07, 2015 4:51:54 AM
To: Andrés Arcia-Moret; gaia
Subject: Re: [gaia] august meeting minute

One suggestion would be to write a draft probably as an informational on the need for an integrated icn and dtn architecture? Joerg, Dirk and I could start this..

Regards

On 5 Aug 2015 21:17, "Andrés Arcia-Moret" <[email-masked]<mailto:[email-masked]>> wrote:
1.  WP1 (MGT):

everybody has agreed on the version 27th of january.
contract amendment: description of actions changed. TUMunich has signed already.
The original (27 January) version is signed by all partners

The Amendment has been submitted and the (electronic) signatures process is in progress. (done)
Have to wait from TUM to see if other partners have to sign something.

IP/ICN demo ready
HTTP stuff working

We have enough to show at the technical review. Data mule take care for the surrogate aspects. Dirk is very excited about. How we could showcase this.

Event last July: many people suggested what? Roger is a bit concerned because he’s confused about what to deliver. Install devices with the community firmware? have the network setup? install the new software.

Dirk: it would be good to phone call to prepare the Barcelona meeting. How do we transition into an installation into GUIFI.net<http://GUIFI.net> then a number of preparation of phone calls: software, devices, we’d be in a good shape to discuss devices, platforms, perform an INSTALLATION not TRIAL. Get couple of things done. Code camp very hands on exercise so that mini system can be replicating in GUIFI.net<http://GUIFI.net>. This is the biggest task in the couple of weeks to come. Standard wireless access routers.

RIFE/POINT: both have trials and can be joint. Bristol open environments to discuss what can be transferred to that environment. Even in Bristol is well connected area there are common points with GUIFI community perspectives. Reuse: IP/ICN, edge caching, surrogate servers (appearing/disappearing). Flash one or two slides at the Technical Review. This is an excellent use-case for extending RIFE ideas.

Joerg: see what the synergies are going on here. keep him updated about Bristol.

Dirk: IP/ICN story, and edge caching with AVANTI we’ve put the satellite component. another overlap is the smart-city, which gets a lot of press, this gives a new set of use cases.

AALTO: solid ground under feet. data collection, take data with net radar and try to compare different features. determine the bottleneck, technical solutions for bottlenecks and pricing. You’ll get some information about this approach soon.

Me: More or less the same as july’s, I’ve been working on things related to WP5.

on couple of papers. One for hotnets for virtual cells, and CCNC assisted network discovery.

Dirk: how to take forward standardisation initiatives to standardise efforts on ICN. Joerg could participate in this.
IP to ICN work: how to make the transition work. How is this technology gonna look like?
Working group about: if we are in an IP world, then we can make IP run better. (ICNRG). Dirk is gonna start a wiki page. who’s supporting? (to be decided in the next couple of weeks). It is not in a hurry, but Dirk’s want to get into this.

Martin: very happy.

Dissemination news since the previous telco (or not previously mentioned):
       - ACM ICN 2015, in San Francisco, USA: Accepted paper: âPro-Diluvian: Understanding Scoped-Flooding
for Content Discovery in Information-Centric Networkingâ, by Liang Wang, Suzan Bayhan, JÃ¶rg Ott,
Jussi Kangasharju, Arjuna Sathiaseelan, Jon Crowcroft (RIFE and UMobile projects)
       - CFP has been issued for a special session on Content Centric Internet of Things (CCIoT) at IEEE
Consumer Communications & Networking Conference (CCNC), held in conjunction with the International
Consumer Electronics Show, Las Vegas, 9-12 January, 2016
       - Arjuna is planning to submit a proposal for a breakout event along the intersection for big data
for social good and networking for development at "Tech4Dev 2016: From Innovation to Social Impact" to be
held at EPFL, 2-4 May 2016
       - Arjuna submitted a Hotnets paper on wireless related stuff for both the RIFE and the Metrics projects
       - UCAM and IDC are organising a special workshop at the IEEE CCNC on topics related to the RIFE and UMobile
projects. The call is at: http://ccnc2016.ieee-ccnc.org/call-for-submissions/call-for-workshop-papers<http://ccnc2016.ieee-ccnc.org/call-for-submissions/call-for-workshop-papers>
       - Paper from J. Qadir, A. Ali, K. Yau, A. Sathiaseelan and J. Crowcroft, on multipathing in ICN (LIPSIN, MS-BF,
etc.) has been accepted for the IEEE Communications Surveys and Tutorials, acknowledging both the Trilogy2
and RIFE projects: http://ieeexplore.ieee.org/xpl/articleDetails.jsp?arnumber=7152820
        - Arjuna gave an interview with SciDev.Net<http://scidev.net/> on universal Internet access, mentioning the project (and AVANTI), at:
http://www.scidev.net/global/technology/multimedia/podcast-internet-access-china-july-carbon-insurance.html
       - Jon gave an interview with SciDev.Net<http://scidev.net/> about the goals of the RIFE and n4d lab:
http://www.scidev.net/global/vulnerability/multimedia/June-podcast-missing-millions-vulnerable.html
       - The programme for the SIGCOMM workshop on NS is at: http://ensr.oii.ox.ac.uk/sigcomm-workshop/.
The RIFE paper from UCAM is at: http://ensr.oii.ox.ac.uk/wp-content/uploads/2015/05/Does-the-Internet-deserve-everybody.pdf
       - Andres presented on the TVWS measurement and deployment challenges and experiences at the IRTF GAIA
meeting in Prague on 22 July
       - Did anyone present the RIFE architecture at the IRTF GAIA meeting in Prague on 22 July?
       - Arjuna was interviewed by Jonathan Donner (who was previously at MSR Technology for Emerging
Markets) who recently foundedÂ Caribou Digital (http://cariboudigital.net/) and Charlotte Smart from Oxford
Internet Institute - whichÂ has received support from the MasterCardÂ Foundation to assess the changing landscape for
access to (and use of) theÂ internet among rural and resource-constrained communities in sub-SaharanÂ Africa, with a
special emphasis on the prospects for new technologiesÂ (unlicensed spectrum, drones, near-earth satellites, etc.) to
augmentÂ conventional cellular/mobile infrastructure by 2020. Arjuna spoke specifically about the RIFE project and satellites
       - The Content Caching and Delivery in Wireless Networks (CCDWN2015) looks relevant for RIFE:
http://conferences2.sigcomm.org/co-next/2015/#!/ccdwn<http://conferences2.sigcomm.org/co-next/2015/#%21/ccdwn> (deadline 21 August)

5.  AoB

---

From: Paulo Mendes <[email-masked]>
Date: Mon, 10 Aug 2015 18:19:51 +0100

I agree that the differentiator factor may be not to devise yet another requirements/scenario informational draft, but to contribute to a draft targeting the design of a ICN node suitable for communicating over disruptive networks. In UMOBILE will have our proposal (first version) for such high level design ready in October, and it would be good to see if we can use it to come up with a strong proposal...

Paulo

> On 07 Aug 2015, at 08:09, Trossen, Dirk <[email-masked]> wrote:
> 
> Arjuna
> 
> _______________________________________________
> gaia mailing list
> [email-masked]
> https://irtf.org/mailman/listinfo/gaia

Melhores Cumprimentos/Best Regards/Mit Freundlichen Gruessen
Paulo Mendes
------------------------------------------------------------
Paulo Mendes, Ph.D
Vice-director of the Research Unit in Cognition and People Centric Computing (COPELABS)
Director of the Ph.D program on Informatics - New Media and Pervasive Systems (NEMPS)
Associated Professor at University Lusofona, Portugal

http://www.paulomilheiromendes.com
Tel.: +351 217 50 50 22