Subject: [gaia] What if all phones were always on the Internet?

From: Steve Song <[email-masked]>
Date: Thu, 26 Nov 2015 10:36:18 -0400

Hi all,

Following on some of the previous discussion about the non-linear
relationship between Internet speed and value to the consumer; and
reflecting on some of the discussions on zero-rating at the IGF; and
thinking further about the PAYG model that enabled the dramatic growth of
mobile telephony in emerging markets, I came to the conclusion that a
low-bitrate, always-on Internet for all mobile phones would benefit
everyone.

https://manypossibilities.net/2015/11/zero-rating-a-modest-proposal/

Would love to have the idea critiqued (gently).

Thanks... Steve Song

---

From: Jon Crowcroft <[email-masked]>
Date: Thu, 26 Nov 2015 14:38:33 +0000

sort of the equiv of all phones in japan ship with FM radio so they can
receive quake warnings, only more general - nice!

On Thu, Nov 26, 2015 at 2:36 PM, Steve Song <[email-masked]> wrote:

> _______________________________________________
> gaia mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/gaia
>
>

---

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 26 Nov 2015 14:45:26 +0000

On 2015-11-26, at 15:36, Steve Song <[email-masked]> wrote:
> Following on some of the previous discussion about the non-linear relationship between Internet speed and value to the consumer; and reflecting on some of the discussions on zero-rating at the IGF; and thinking further about the PAYG model that enabled the dramatic growth of mobile telephony in emerging markets, I came to the conclusion that a low-bitrate, always-on Internet for all mobile phones would benefit everyone.

When I was at Nokia, we did an offsite ca. 2009 in Oulu and visited Radio Arcala (someone else's blog about them is http://g7vjr.org/2013/02/radio-arcala-visit-oh8x-finland/ <http://g7vjr.org/2013/02/radio-arcala-visit-oh8x-finland/>). One topic discussed in the sauna was exactly whether a few large antennas like this could cover the globe  low-bitrate, and what such connectivity could be used for. I thought the idea was very cool (and still think it is), but Nokia was preoccupied with other issues and nothing ever came out of it.

Lars

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Thu, 26 Nov 2015 14:46:21 +0000

it will be really great to understand the lowest common denominator of
usable info that can be currently sent through such low rate capacity link
-- if there are any studies it will be great I think..

arjuna

-- 
Arjuna Sathiaseelan
Personal: http://www.cl.cam.ac.uk/~as2330/
N4D Lab: http://www.cl.cam.ac.uk/~as2330/n4d

---

From: "Eggert, Lars" <[email-masked]>
Date: Thu, 26 Nov 2015 14:49:03 +0000

And of course I forgot to link to their actual page at http://www.radioarcala.com <http://www.radioarcala.com/>

On 2015-11-26, at 15:45, Eggert, Lars <[email-masked]> wrote:
> 
> On 2015-11-26, at 15:36, Steve Song <[email-masked] <mailto:[email-masked]>> wrote:

---

From: Phil Regnauld <[email-masked]>
Date: Thu, 26 Nov 2015 16:00:54 +0100

Steve Song (stevesong) writes:
> I came to the conclusion that a

	Sort of what you get when you reach your "cap-which-isn't-a-cap"
	on your postpaid plan in overdeveloped nations. Here it's typically
	128 Kbps ad libitum until end of the month.

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 26 Nov 2015 10:42:11 -0500

Or the Microsoft SPOT watch (also FM).

https://gigaom.com/2013/09/03/what-microsoft-got-right-with-its-smartwatch-nearly-a-decade-ago-more-than-you-think/

I wouldn't be surprised if we'll see devices with prepaid connectivity
(i.e., paid by the hardware device vendor) - after all, the Amazon Kindle
has been doing this for years to deliver books.

---

From: Jon Crowcroft <[email-masked]>
Date: Thu, 26 Nov 2015 15:47:19 +0000

agree - e.g. #2:

for some uk iot deployments (e.g. smart meter) that use your home broadband
to get data up to a cloud service, some vendors ship a cellular dongle to
add to your home router to provide resilience in the event that your
dsl/cable modem line break, so you still get service (typically, a low rate
edge/gprs device) - mcuh like the whispernet kindle use, it seems like its
usage is low enough to just get bundled in with the contract for the iot
ecosystem

On Thu, Nov 26, 2015 at 3:42 PM, Henning Schulzrinne <[email-masked]>
wrote:

> On Thu, Nov 26, 2015 at 9:38 AM, Jon Crowcroft <[email-masked]
> > wrote:
>

---

From: Steve Song <[email-masked]>
Date: Thu, 26 Nov 2015 12:57:10 -0400

Hi all,

I think there are some very interesting options for what can be done with
amateur radio.  I am a fan of David Rowe's work on codec2 which is a very
low-bitrate codec designed for digital voice over HF frequencies.  None of
the alternative solutions though have the ubiquitous reach of the mobile
phone itself, unless, as Jon suggests, you start including these radios in
mobile handset design.  A more ambitious prospect.

@Phil Exactly! People would go bananas if you completely cut off their
Internet once they reached their cap.

Cheers... Steve

On 26 November 2015 at 11:47, Jon Crowcroft <[email-masked]>
wrote:

> agree - e.g. #2:
>
> for some uk iot deployments (e.g. smart meter) that use your home
> broadband to get data up to a cloud service, some vendors ship a cellular
> dongle to add to your home router to provide resilience in the event that
> your dsl/cable modem line break, so you still get service (typically, a low
> rate edge/gprs device) - mcuh like the whispernet kindle use, it seems like
> its usage is low enough to just get bundled in with the contract for the
> iot ecosystem
>
>> On Thu, Nov 26, 2015 at 9:38 AM, Jon Crowcroft <
>> [email-masked]> wrote:
>>

-- 
+1 902 529 0046
[email-masked]
http://nsrc.org

---

From: Jim Forster <[email-masked]>
Date: Thu, 26 Nov 2015 11:51:34 -0800

Steve,

I think it’s a great idea!  

AirJaldi has been recently offering two different pre-paid hot spot systems.  One, called XWF (Express WiFi) is offered in Rishikesh and Garwhal district of Uttrakhand.  Facebook/Internet.org <http://internet.org/> did the software for XWF; AirJaldi deployed the access points on our backbone in that district and manages the sales agents.  See this NY Time article <http://bits.blogs.nytimes.com/2015/10/25/facebook-strives-to-bring-cheap-wi-fi-to-rural-india-2/> for more info.  It is intended that this system will use their Free Basics system to give free access to certain sites.

The second pre-paid service AirJaldi has is called JaldiFi. A couple AirJaldi engineers did the software, using various Mikrotik & Ubiquity features.  JaldiFi is deploying in various places throughout AirJaldi’s network, including Kangra Valley, Kumaon, and Jharkand.  JaldiFi does not use Free Basics; instead we simply give registered users 10-20MB/day free service.  Registration is free and automated (users must supply a mobile phone number & then we send them a username/pw).  It’s obvious but worth noting that 10MB is 1/100th of 1GB, so a lot of ‘free’ users don’t impact the network much. It’s our belief that if the service is priced affordably, enough people will pay to make it worth our while.  Pricing is about Rs80/GB (~$1.25/GB), with some plans for as little Rs25.  Kumaon area prices are here <http://www.jaldifi.net/kumaon.html>.  

Mawingu in Kenya does it a little differently.  For about 300Ksh, users get high speed service for a month, or if they don’t have that much money, they can buy a week’s service for 100Ksh.  Mawingu doesn’t give them completely unlimited service, but we find that the great majority of customers don’t use too much for us; email & web browsing is easily accommodated, but heavy YouTube/video watching eats up the MBs quickly.  The heaviest users will find then that their speed slowed way down, to about 128kbps.  That’s fine for email & tolerable for web browsing so they’re not cut off, but if they want more high speed for video, they’ll need to pay some more.

US-centric salutation: Happy Thanksgiving everyone! 

  — Jim

> On Nov 26, 2015, at 6:36 AM, Steve Song <[email-masked]> wrote:
> 
> Hi all,
> 
> https://manypossibilities.net/2015/11/zero-rating-a-modest-proposal/ <https://manypossibilities.net/2015/11/zero-rating-a-modest-proposal/>
>

---

From: Phil Regnauld <[email-masked]>
Date: Thu, 26 Nov 2015 21:27:23 +0100

> Internet once they reached their cap.

	... if only to access the portal where you can buy more data :D

---

From: Dirk Kutscher <[email-masked]>
Date: Thu, 26 Nov 2015 20:34:37 +0000

There are two different service categories that I find interesting:

1) Ubiquituous, low-cost (or free) Baseline mobile communication (like T-Mobile USA's international 64kbit/s service).

2) Broadcast data service, e.g., over long-range radio or more dense digital broadcast services.

Japan had digital broadcast in phones since 2006 ("oneseg", based on the Japanese ISDB-T standard for digital terrestial broadcast). This could also be used for earthquake warnings, and, of course EPG distribution etc.

Here is a link to a report by DOCOMO from that time: https://www.nttdocomo.co.jp/english/binary/pdf/corporate/technology/rd/technical_journal/bn/vol8_1/vol8_1_047en.pdf

My view is that it's about time to extend the general understanding of mobile communication to services like delay-tolerant background transmission or proactive information distribution.

Unfortunately little of this is being considered in the still relatively bellhead-dominated 5G efforts...

--
Dirk

Am 26.11.2015 um 20:51 schrieb Jim Forster <[email-masked]<mailto:[email-masked]>>:

Steve,

AirJaldi has been recently offering two different pre-paid hot spot systems.  One, called XWF (Express WiFi) is offered in Rishikesh and Garwhal district of Uttrakhand.  Facebook/Internet.org<http://internet.org> did the software for XWF; AirJaldi deployed the access points on our backbone in that district and manages the sales agents.  See this NY Time article<http://bits.blogs.nytimes.com/2015/10/25/facebook-strives-to-bring-cheap-wi-fi-to-rural-india-2/> for more info.  It is intended that this system will use their Free Basics system to give free access to certain sites.

The second pre-paid service AirJaldi has is called JaldiFi. A couple AirJaldi engineers did the software, using various Mikrotik & Ubiquity features.  JaldiFi is deploying in various places throughout AirJaldi’s network, including Kangra Valley, Kumaon, and Jharkand.  JaldiFi does not use Free Basics; instead we simply give registered users 10-20MB/day free service.  Registration is free and automated (users must supply a mobile phone number & then we send them a username/pw).  It’s obvious but worth noting that 10MB is 1/100th of 1GB, so a lot of ‘free’ users don’t impact the network much. It’s our belief that if the service is priced affordably, enough people will pay to make it worth our while.  Pricing is about Rs80/GB (~$1.25/GB), with some plans for as little Rs25.  Kumaon area prices are here<http://www.jaldifi.net/kumaon.html>.

  — Jim

On Nov 26, 2015, at 6:36 AM, Steve Song <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

Thanks... Steve Song

_______________________________________________
gaia mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/gaia

---

From: Henning Schulzrinne <[email-masked]>
Date: Thu, 26 Nov 2015 16:42:26 -0500

Broadcast data delivery is being discussed for ATSC 3.0, the possible
successor to the current over-the-air TV standard in the US and Canada (and
other places). But many of the places that don't have LTE 4G service also
have dicey OTA TV reception, e.g., due to being shaded by mountains (think
West Virginia or Rocky Mountains).

Henning

On Thu, Nov 26, 2015 at 3:34 PM, Dirk Kutscher <[email-masked]>
wrote:

> 1) Ubiquituous, low-cost (or free) Baseline mobile communication (like
> T-Mobile USA's international 64kbit/s service).
>
> Japan had digital broadcast in phones since 2006 ("oneseg", based on the
> Japanese ISDB-T standard for digital terrestial broadcast). This could also
> be used for earthquake warnings, and, of course EPG distribution etc.
>
> Here is a link to a report by DOCOMO from that time:
> https://www.nttdocomo.co.jp/english/binary/pdf/corporate/technology/rd/technical_journal/bn/vol8_1/vol8_1_047en.pdf
>
> My view is that it's about time to extend the general understanding of
> mobile communication to services like delay-tolerant background
> transmission or proactive information distribution.
>

---

From: Simeon Miteff <[email-masked]>
Date: Fri, 27 Nov 2015 00:26:20 +0200

On 26 Nov 2015, at 6:57 PM, Steve Song <[email-masked]> wrote:
> I think there are some very interesting options for what can be done with amateur radio.  I am a fan of David Rowe's work on codec2 which is a very low-bitrate codec designed for digital voice over HF frequencies.  None of the alternative solutions though have the ubiquitous reach of the mobile phone itself, unless, as Jon suggests, you start including these radios in mobile handset design.  A more ambitious prospect.

Looks like David is building a narrowband modem for Outernet now: http://www.rowetel.com/blog/?p=4538

Speaking of HF, the idea of globally propagating signals is very appealing to me (in a romantic, Nikola Tesla/earth-resonance kind of way). 

I'm aware of the constraints of spectrum, high power and large antennas, but I wonder if there is a practical way for an ultra-narrowband HF uplink to be combined with direct broadcast satellite for an asymmetrical duplex system (like ISPs use to do with dial-up for the uplink back in the 1990s)?

---

From: Stephen Farrell <[email-masked]>
Date: Fri, 27 Nov 2015 01:10:56 +0000

On 26/11/15 20:34, Dirk Kutscher wrote:
> Unfortunately little of this is being considered in the still
> relatively bellhead-dominated 5G efforts...

How would that best be progressed? I think there are good ideas
here (adding delay-tolerant features to mainstream protocols) but
I'm not sure how to get those ingrained in e.g. 5g stuff.

S.

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Fri, 27 Nov 2015 01:22:02 +0000

Very nice Jim.

One problem of giving specific low usage caps in access could be there is
quite a lot of mobile apps background traffic which randomly consume the
usage caps?

As i pointed out earlier it will be really interesting to know what can we
browse/do with today's apps/services over 9.6 kbps..as steve mentioned
earlier this requires redesigning apps/content - FB is doing that but
9.6kbps is really pushing the limit? how would today's transport protocols
work?

Regards
On 26 Nov 2015 19:51, "Jim Forster" <[email-masked]> wrote:

> AirJaldi has been recently offering two different pre-paid hot spot
> systems.  One, called XWF (Express WiFi) is offered in Rishikesh and
> Garwhal district of Uttrakhand.  Facebook/Internet.org
> <http://internet.org> did the software for XWF; AirJaldi deployed the
> access points on our backbone in that district and manages the sales
> agents.  See this NY Time article
> <http://bits.blogs.nytimes.com/2015/10/25/facebook-strives-to-bring-cheap-wi-fi-to-rural-india-2/> for
> more info.  It is intended that this system will use their Free Basics
> system to give free access to certain sites.
>
> The second pre-paid service AirJaldi has is called JaldiFi. A couple
> AirJaldi engineers did the software, using various Mikrotik & Ubiquity
> features.  JaldiFi is deploying in various places throughout AirJaldi’s
> network, including Kangra Valley, Kumaon, and Jharkand.  JaldiFi does not
> use Free Basics; instead we simply give registered users 10-20MB/day free
> service.  Registration is free and automated (users must supply a mobile
> phone number & then we send them a username/pw).  It’s obvious but worth
> noting that 10MB is 1/100th of 1GB, so a lot of ‘free’ users don’t impact
> the network much. It’s our belief that if the service is priced affordably,
> enough people will pay to make it worth our while.  Pricing is about
> Rs80/GB (~$1.25/GB), with some plans for as little Rs25.  Kumaon area
> prices are here <http://www.jaldifi.net/kumaon.html>.
>
> Mawingu in Kenya does it a little differently.  For about 300Ksh, users
> get high speed service for a month, or if they don’t have that much money,
> they can buy a week’s service for 100Ksh.  Mawingu doesn’t give them
> completely unlimited service, but we find that the great majority of
> customers don’t use too much for us; email & web browsing is easily
> accommodated, but heavy YouTube/video watching eats up the MBs quickly.
> The heaviest users will find then that their speed slowed way down, to
> about 128kbps.  That’s fine for email & tolerable for web browsing so
> they’re not cut off, but if they want more high speed for video, they’ll
> need to pay some more.
>

---

From: Dirk Kutscher <[email-masked]>
Date: Fri, 27 Nov 2015 08:51:25 +0000

> How would that best be progressed? I think there are good ideas here (adding
> delay-tolerant features to mainstream protocols) but I'm not sure how to get
> those ingrained in e.g. 5g stuff.

In Europe, review and have your say on what's happening here: https://5g-ppp.eu/

There is a second phase of projects in preparation -- that should ideally cater for topics like this, but people need to speak up.

Technically, I think that ICN as a concept has good potential as a network infrastructure technology that can span both well-connected traditional type of networks as well as less conventional ones, including uni-directional and disruption-prone networks.

One of the keywords is access network heterogeneity, e.g., "hybrid access" in the current IP access world. It's obvious that TCP/IP (even MPTCP) with DNS/CDN has issues in even the simple hybrid access home gateway scenario.

Another keyword is transport performance (related to the transport encryption discussion): with heterogeneous access, and especially with low-bitrate, unreliable secondary access, you want to have a more powerful forwarding plane that can react to changing link layer characteristics locally and that can employ in-network storage for reacting to disruption/delay. Today, mobile network operators are trying to address some of these issues with TCP proxies and application-layer proxies (the latter will probably become more expensive in the future because of encryption, see below).

Finally, security: I see two things happening:

1) HTTP/2 and TLS => ubiquitous encryption
2) CDN extending into core and access networks => many vulnerable platforms that manage keys and certificates on behalf of original data owners and service providers to maintain connection-based encryption

This does not look very promising to me. We ought to figure object-based security and fine-granular access control based on that.

With virtualization extending to all parts of the network, it now becomes feasible to prototype and evaluate such systems, e.g., as a slice in a virtualized mobile network.

There is some interesting work going on, just a few pointers:

http://conferences2.sigcomm.org/acm-icn/2015/proceedings/p189-auge.pdf

http://conferences2.sigcomm.org/acm-icn/2015/proceedings/p137-schneider.pdf

http://conferences2.sigcomm.org/acm-icn/2015/proceedings/p177-yu.pdf

Cheers,
Dirk

---

From: Steve Song <[email-masked]>
Date: Fri, 27 Nov 2015 08:05:17 -0400

Hi Arjuna,

It is already possible, on Android, to turn off background data updates and
to do per-app tuning of background updates and data consumption in
general.  What I would imagine is that when a phone runs out of data and
finds itself in basic rate mode, then it would only update apps/services
that have been actively selected by the user e.g. whatsapp, twitter,
signal, telegram, FB messenger, email, browser, etc. The selectivity about
apps and services would then be in the hands of the consumer not the
provider.

Cheers... Steve

-- 
+1 902 529 0046
[email-masked]
http://nsrc.org

---

From: "Psaras, Ioannis" <[email-masked]>
Date: Fri, 27 Nov 2015 13:56:29 +0000

Very interesting thoughts Dirk.

A pointer on this is our recent work on In-Network Resource Pooling (in ACM HotNets 2014): http://www.ee.ucl.ac.uk/~uceeips/files/inrpp-hotnets14-ipsaras.pdf

According to this framework, in-network storage is utilised to temporarily store/cache data *mid-path* when some link along the path is broken or very slow/congested. Then transmission resumes when conditions get back to normal. It sounds like a good fit for low-bitrate, unreliable links.

Thanks,
Yiannis.

On 27 Nov 2015, at 08:51, Dirk Kutscher <[email-masked]<mailto:[email-masked]>> wrote:

Cheers,
Dirk

---

From: Dirk Kutscher <[email-masked]>
Date: Fri, 27 Nov 2015 14:10:42 +0000

Thanks, Yiannis,
This is actually interesting in a sense because it enables moving from the traditional downstream (from cloud to consumer) paradigm to information sharing at the edge with a relatively simple enhancement.

Dirk

From: Psaras, Ioannis [mailto:[email-masked]]
Sent: Freitag, 27. November 2015 14:56
To: Dirk Kutscher
Cc: Stephen Farrell; Jim Forster; gaia; Steve Song
Subject: Re: [gaia] What if all phones were always on the Internet?

Thanks,
Yiannis.

Cheers,
Dirk

---

From: David Johnson <[email-masked]>
Date: Fri, 27 Nov 2015 17:22:20 +0200

This has also got me thinking about the parallel in the world of
dynamic spectrum access. One of the concerns about TV white spaces
that use spectrum databases is that they effectively give evil
governments or anti-competitive operators a kill switch for TV white
space devices they want to block.

I think we should fight for regulation that reserves a UHF amateur
radio survival channel that allows all dynamic spectrum access devices
to continue operating at lower bit-rates using spread spectrum
techniques that allow them to share the survival band. This can be for
cases where no white space channels exist, the device can't access the
spectrum database or an evil government has flicked the kill switch.
This can also be used for negotiating full-access secondary user
channels - this control data also requires very low data rates.

On Fri, Nov 27, 2015 at 4:10 PM, Dirk Kutscher <[email-masked]> wrote:
> Thanks, Yiannis,
>
> This is actually interesting in a sense because it enables moving from the
> traditional downstream (from cloud to consumer) paradigm to information
> sharing at the edge with a relatively simple enhancement.
>
>
>
> Dirk
>
>
>
>
>
> Another keyword is transport performance (related to the transport
> encryption discussion): with heterogeneous access, and especially with
> low-bitrate, unreliable secondary access, you want to have a more powerful
> forwarding plane that can react to changing link layer characteristics
> locally and that can employ in-network storage for reacting to
> disruption/delay. Today, mobile network operators are trying to address some
> of these issues with TCP proxies and application-layer proxies (the latter
> will probably become more expensive in the future because of encryption, see
> below).
>
>
>
> A pointer on this is our recent work on In-Network Resource Pooling (in ACM
> HotNets 2014):
> http://www.ee.ucl.ac.uk/~uceeips/files/inrpp-hotnets14-ipsaras.pdf
>
>
>
> According to this framework, in-network storage is utilised to temporarily
> store/cache data *mid-path* when some link along the path is broken or very
> slow/congested. Then transmission resumes when conditions get back to
> normal. It sounds like a good fit for low-bitrate, unreliable links.
>
>
>
> Thanks,
>
> Yiannis.
>
>
>
> On 27 Nov 2015, at 08:51, Dirk Kutscher <[email-masked]> wrote:
>
>
>
> There is a second phase of projects in preparation -- that should ideally
> cater for topics like this, but people need to speak up.
>
> Technically, I think that ICN as a concept has good potential as a network
> infrastructure technology that can span both well-connected traditional type
> of networks as well as less conventional ones, including uni-directional and
> disruption-prone networks.
>
> One of the keywords is access network heterogeneity, e.g., "hybrid access"
> in the current IP access world. It's obvious that TCP/IP (even MPTCP) with
> DNS/CDN has issues in even the simple hybrid access home gateway scenario.
>
> Another keyword is transport performance (related to the transport
> encryption discussion): with heterogeneous access, and especially with
> low-bitrate, unreliable secondary access, you want to have a more powerful
> forwarding plane that can react to changing link layer characteristics
> locally and that can employ in-network storage for reacting to
> disruption/delay. Today, mobile network operators are trying to address some
> of these issues with TCP proxies and application-layer proxies (the latter
> will probably become more expensive in the future because of encryption, see
> below).
>
> 2) CDN extending into core and access networks => many vulnerable platforms
> that manage keys and certificates on behalf of original data owners and
> service providers to maintain connection-based encryption
>
> This does not look very promising to me. We ought to figure object-based
> security and fine-granular access control based on that.
>
> With virtualization extending to all parts of the network, it now becomes
> feasible to prototype and evaluate such systems, e.g., as a slice in a
> virtualized mobile network.
>

---

From: Rohan Mahy <[email-masked]>
Date: Fri, 27 Nov 2015 17:37:29 -0800

Thanks Steve,

You did a nice job of explaining this model that I’ve also been quietly
promoting.  I have two comments:

1) I think backhaul is a serious limiting factor here in some remote areas.
If the nearest tower is serviced by satellite or any of the slowish
configurations of terrestrial microwave, paying customers might already be
getting less than full 2G. That was certainly the case in some of the
places I lived. I think it is reasonable to offer 2G for free when 3G is in
place (or 2G with a high-speed terrestrial wireless or fiber backhaul).
This would also make it obvious to users and regulators which locations
need backhaul upgrades.

2) The approach of bandwidth limiting instead of volume limiting is both
more valuable for the end user (a little bit of data every day is worth
more than one big burst at the beginning of the month) and easier to
implement for the mobile network operator (when a free Internet user roams
the infrastructure does not need to keep track of total usage).

Thanks,

-rohan

---

From: "El Khatib, Yehia (elkhatib)" <[email-masked]>
Date: Sat, 28 Nov 2015 10:48:28 +0000

Nice idea, Steve.

The selectivity is slowly becoming in the hand of the consumer, as with newer Android versions like you mentioned.

However, most services (read: majority of cloud-hosted services) are developed with an assumption of over provisioned networks. This results in "chatty application syndrome”, and becomes very apparent when you take said application and try to run it over a poor network. So my point is, developers could and perhaps should equip their services for deployment in poor network conditions. I wrote a short piece about this earlier in the year: http://www.comp.lancs.ac.uk/~elkhatib/Docs/2015.11_ccis.pdf

/Yehia

--
Dr. Yehia Elkhatib
School of Computing & Communications
Lancaster University, LA1 4WA, UK
y.elkhatib <then add> lancaster.ac.uk
http://www.comp.lancs.ac.uk/~elkhatib

From: gaia <[email-masked]<mailto:[email-masked]>> on behalf of Steve Song <[email-masked]<mailto:[email-masked]>>
Date: Friday, 27 November 2015 12:05
To: gaia <[email-masked]<mailto:[email-masked]>>
Subject: Re: [gaia] What if all phones were always on the Internet?

Hi Arjuna,

It is already possible, on Android, to turn off background data updates and to do per-app tuning of background updates and data consumption in general.  What I would imagine is that when a phone runs out of data and finds itself in basic rate mode, then it would only update apps/services that have been actively selected by the user e.g. whatsapp, twitter, signal, telegram, FB messenger, email, browser, etc. The selectivity about apps and services would then be in the hands of the consumer not the provider.

Cheers... Steve

On 26 November 2015 at 21:22, Arjuna Sathiaseelan <[email-masked]<mailto:[email-masked]>> wrote:

Very nice Jim.

One problem of giving specific low usage caps in access could be there is quite a lot of mobile apps background traffic which randomly consume the usage caps?

As i pointed out earlier it will be really interesting to know what can we browse/do with today's apps/services over 9.6 kbps..as steve mentioned earlier this requires redesigning apps/content - FB is doing that but 9.6kbps is really pushing the limit? how would today's transport protocols work?

Regards

On 26 Nov 2015 19:51, "Jim Forster" <[email-masked]<mailto:[email-masked]>> wrote:
Steve,

  — Jim

Hi all,

Thanks... Steve Song

--
+1 902 529 0046
[email-masked]<mailto:[email-masked]>
http://nsrc.org

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Sat, 28 Nov 2015 18:38:11 +0000

Exactly -- if getting to the Internet is tough - just get the Internet to
you :)

https://www.cl.cam.ac.uk/~as2330/docs/p15-sathiaseelan.pdf
https://www.cl.cam.ac.uk/~as2330/docs/EGC15.pdf

Regards

On 28 November 2015 at 10:48, El Khatib, Yehia (elkhatib) <
[email-masked]> wrote:

> Nice idea, Steve.
>
> The selectivity is slowly becoming in the hand of the consumer, as with
> newer Android versions like you mentioned.
>
> However, most services (read: majority of cloud-hosted services) are
> developed with an assumption of over provisioned networks. This results in
> "chatty application syndrome”, and becomes very apparent when you take said
> application and try to run it over a poor network. So my point is,
> developers could and perhaps should equip their services for deployment in
> poor network conditions. I wrote a short piece about this earlier in the
> year: http://www.comp.lancs.ac.uk/~elkhatib/Docs/2015.11_ccis.pdf
>
> /Yehia
>
> --
> Dr. Yehia Elkhatib
> From: gaia <[email-masked]> on behalf of Steve Song <
> [email-masked]>
> To: gaia <[email-masked]>
> It is already possible, on Android, to turn off background data updates
> and to do per-app tuning of background updates and data consumption in
>> As i pointed out earlier it will be really interesting to know what can
>> we browse/do with today's apps/services over 9.6 kbps..as steve mentioned