Subject: [gaia] controversial paper for CNs

From: Arjuna Sathiaseelan <[email-masked]>
Date: Thu, 17 Dec 2015 02:00:11 +0000

thought I will ignite some discussions on this paper which I think makes
some controversial claims on the role mesh networks for enabling
connectivity especially with the success of CNs around the globe:
http://www.jwcn.eurasipjournals.com/content/2008/1/274790

they state: "Our conclusions are intentionally controversial to stimulate a
discussion among researchers and industry. We argue that wireless mesh
networks will not be deployed for user access—at least from an economic
point of view. Instead, they will be financed to increase the automation of
remotely controlled devices, such as meters for gas or heating, parking
meters, and traffic lights, whereas the financial contributions of users
will be dismal."

if the authors revisited this paper now - what would change?

Looking forward to hear from the community network folks :)

regards

-- 
Arjuna Sathiaseelan
Personal: http://www.cl.cam.ac.uk/~as2330/
N4D Lab: http://www.cl.cam.ac.uk/~as2330/n4d

---

From: Roger Baig Viñas <[email-masked]>
Date: Fri, 18 Dec 2015 14:00:12 +0100

Hi Arjuna,

On 12/17/2015 03:00 AM, Arjuna Sathiaseelan wrote:
> thought I will ignite some discussions on this paper which I think
> makes some controversial claims on the role mesh networks for
> enabling connectivity especially with the success of CNs around the
> globe: http://www.jwcn.eurasipjournals.com/content/2008/1/274790
> 
> they state: "Our conclusions are intentionally controversial to 
> stimulate a discussion among researchers and industry. We argue
> that wireless mesh networks will not be deployed for user access—at
> least from an economic point of view. Instead, they will be
> financed to increase the automation of remotely controlled devices,
> such as meters for gas or heating, parking meters, and traffic
> lights, whereas the financial contributions of users will be
> dismal."
> 

At least I would suggest to:

1) Include the consideration of the effect of the
introduction of wired-links, at least in the backbone. Our vision
is to have three of four wireless hops at most everywhere.

2) Avoid the idea of a totally unplanned network made out of ultra-cheap
devices. Obviously the performance of a WiFi 10€ router should not be
comparable to a >1000€ wired router.

3) Include the social economics in the economics section (otherwise
you will observe inexplicable behaviours).

Best regards.

> 
> regards
> 
> -- Arjuna Sathiaseelan Personal: http://www.cl.cam.ac.uk/~as2330/ 
> _______________________________________________ gaia mailing list 
> [email-masked] https://www.irtf.org/mailman/listinfo/gaia
> 

- -- 
Roger Baig Viñas
Fundació Privada per a la Xarxa Oberta, Lliure i Neutral guifi.net

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Tue, 22 Dec 2015 07:07:21 +0000

Thanks Roger -

In a recent call with Steve Song and Jane Coffin we were discussing why
Guifi was successful and Steve nicely mentioned the social
structures/community cohesion are very important and Jane Coffin pointed
out about Guifi's business models.

Was wondering if technological innovation in Guifi had a role to play with
too?

regards

On 18 December 2015 at 13:00, Roger Baig Viñas <[email-masked]> wrote:

> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Hi Arjuna,
>
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1
>
> iQIcBAEBAgAGBQJWdANaAAoJEKzTrZPPgKKDGRUP/RQunzDMc/XzvghuIDe09kH8
> L8PRa1KyRR0LdkZLhzDtLMMUe0y1gwbmMWN+PmFkke/3+vC/dAdbgfpDZzmfTvoK
> IW8vapxjK+t8Rus0Q/ftGxOiVMtCjP+9uL/+X5XOQXj4/g9P7iNdSP2pPE8kOK5Y
> 6yIZ6Ro/RbxijyHAfwhLxSHnEi/9w+KhGgWR0liH7mNapj7pAK0zn6qnr5ZWLx7E
> FRoCG32PW5/LpPpeIqtOlkICir958MOR7vZfjhPOL3f6L6mpzqMHlOFTroEVgH3X
> ayLJnsUi6rh1Zy+iu5FBcA08+fACQQpi5ma+V6LLwzWZDGjRR/+v3vmnqMKx4DtA
> drkKrdgI6LUVlFvOHf/PnkR5VF1joXCWFD2h/wfuAME9b298EJWIxfpqCWdeB7QV
> OOdTuU03k+DTKV9ycj7i6a5GLbbR+XwUrnQsebG1T53XdK2tOzF5LJ9RrbDChMi3
> huqM3TIoxrbIMUI/KDVIq0/wj3Tv+6tNik5c4PrndgDuUy+TWhxJDH2WkEqX6m62
> T/U4zFcfDtr2FRVYerF+4Ecb/vQZwl8JXGjdizll6xjhi33EhcAtGAhz040GoVpx
> T0WLB13RoA7/5y3xXIALMpY1S9llYRhlQ+YrdMG8yp0VVgbz+AsTuRjl8hvNNHIj
> gYaLBXSAzR1gQlokbmZL
> =pbKM
> -----END PGP SIGNATURE-----
>
> [email-masked]
> https://www.irtf.org/mailman/listinfo/gaia
>

---

From: Leandro Navarro <[email-masked]>
Date: Tue, 22 Dec 2015 10:21:16 +0100

> On 22 Dec 2015, at 08:07, Arjuna Sathiaseelan <[email-masked]> wrote:
> 
> Thanks Roger -
> 
Hi, 
I agree that social structures that enable, support, coordinates, regulates socio-economic interaction: the “ecosystem”, is key for develop a sustainable infrastructure.

I’d say guifi.net <http://guifi.net/> is not driven by taking advantage of bleeding edge tech per se, but more in the socialisation of tech: guifi has been able to develop knowledge/ways/tools/best-practices to apply commoditised tech (e.g. low cost WiFi or Fibre, existing and new routing protocols, net services) in the hands of normal citizens. 

For instance a decade ago they created a local web site to share knowledge about how-to-do things required to combine inexpensive devices to setup a network in the ISM band. Sharing knowledge to reduce barriers is a key point.
The guifi.net <http://guifi.net/> site and tools were key to simplify the deployment of network as it was able to automatically create config files for a wide range of hardware devices so expanding the network was simple and almost error free. Similarly they found a way to let people to contribute funding to expand critical links in the network, before crowdsourcing was defined.

Not only socialisation to private citizens but also creating business opportunities for locals to earn a living from installation, maintenance, expansion, provision of services over the underlying network, …

Regards, Leandro.

> 
> regards
> 
> On 18 December 2015 at 13:00, Roger Baig Viñas <[email-masked] <mailto:[email-masked]>> wrote:
> 
>>> globe: http://www.jwcn.eurasipjournals.com/content/2008/1/274790 <http://www.jwcn.eurasipjournals.com/content/2008/1/274790>
>>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.irtf.org/mailman/listinfo/gaia <https://www.irtf.org/mailman/listinfo/gaia>
>> 
> 
> 
> 
> -- 
> Arjuna Sathiaseelan
> Personal: http://www.cl.cam.ac.uk/~as2330/ <http://www.cl.cam.ac.uk/~as2330/>
> N4D Lab: http://www.cl.cam.ac.uk/~as2330/n4d <http://www.cl.cam.ac.uk/~as2330/n4d>
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/gaia <https://www.irtf.org/mailman/listinfo/gaia>
--
Leandro Navarro
http://people.ac.upc.edu/leandro	 http://dsg.ac.upc.edu

---

From: Leonardo Maccari <[email-masked]>
Date: Tue, 22 Dec 2015 10:52:14 +0100

On Tue, 2015-12-22 at 07:07 +0000, Arjuna Sathiaseelan wrote:
> Thanks Roger -
> 
> In a recent call with Steve Song and Jane Coffin we were discussing
> why Guifi was successful and Steve nicely mentioned the social
> structures/community cohesion are very important and Jane Coffin
> pointed out about Guifi's business models.
> 
> Was wondering if technological innovation in Guifi had a role to play 
> with too?

Hi Arjuna, 

Apart from what has been already said about the social aspects, I think
technology innovation was a key too and the paper analyses technology
from 2008, primarily 802.11a/g radios. In the case of Ninux.org, a
boost to the development of the network was the presence on the market
of cheap outdoor 5GHz MIMO devices, like the Ubiquiti M5. These allowed
to use directional antennas in a frequency range that is much less
crowded, to realize links that could reach up to 10/20km with high
throughput. The use of PoE makes it easy to install devices on the roof
and allows to separate "dummy" devices (on the roof) from "smart" ones
(in house, doing the routing). So the configuration with one broadcast
directional antenna per node, that is referred to in the paper was
significantly improved. Also, vendors use their own MAC enhancement
scheme that allows to better exploit the available frequencies.

On the security point of view instead, I'm not aware of much progress
compared to what is said in the paper, but this is also due to the open
nature of the networks.

leonardo.

-- 
Leonardo Maccari, Post-doc researcher@University of Trento
Tel: +39 0461 285323, www.disi.unitn.it/~maccari, gpg ID: AABE2BD7

---

From: Roger Baig Viñas <[email-masked]>
Date: Tue, 22 Dec 2015 13:24:09 +0100

Hi,

Regarding guifi.net, I totally agree with Leandro's points. Obviously
the project is constantly benefiting from technological advances but I
wouldn't say that guifi.net is actively contributing to push this
innovation forward (specially in comparison with other CNs like
Freifunk, Ninux, etc.). As I have already said many times, in my
opinion, the key contributions of guifi.net are, on the one hand, the
vision and conceptualisation achievements, and, on the other hand, the
usage of the technologies available (e.g. the web) to lower the entry
barriers for participation.

Regards.

On 12/22/2015 10:21 AM, Leandro Navarro wrote:
> 
>> On 22 Dec 2015, at 08:07, Arjuna Sathiaseelan 
>> <[email-masked] 
>> <mailto:[email-masked]>> wrote:
>> 
>> Thanks Roger -
>> 
>> In a recent call with Steve Song and Jane Coffin we were
>> discussing why Guifi was successful and Steve nicely mentioned
>> the social structures/community cohesion are very important and
>> Jane Coffin pointed out about Guifi's business models.
>> 
>> Was wondering if technological innovation in Guifi had a role to
>> play with too?
> Hi, I agree that social structures that enable, support,
> coordinates, regulates socio-economic interaction: the “ecosystem”,
> is key for develop a sustainable infrastructure.
> 
> I’d say guifi.net <http://guifi.net> is not driven by taking
> advantage of bleeding edge tech per se, but more in the
> socialisation of tech: guifi has been able to develop
> knowledge/ways/tools/best-practices to apply commoditised tech
> (e.g. low cost WiFi or Fibre, existing and new routing protocols,
> net services) in the hands of normal citizens.
> 
> For instance a decade ago they created a local web site to share 
> knowledge about how-to-do things required to combine inexpensive
> devices to setup a network in the ISM band. Sharing knowledge to
> reduce barriers is a key point. The guifi.net <http://guifi.net>
> site and tools were key to simplify the deployment of network as it
> was able to automatically create config files for a wide range of
> hardware devices so expanding the network was simple and almost
> error free. Similarly they found a way to let people to contribute
> funding to expand critical links in the network, before 
> crowdsourcing was defined.
> 
> Not only socialisation to private citizens but also creating
> business opportunities for locals to earn a living from
> installation, maintenance, expansion, provision of services over
> the underlying network, …
> 
> 
> Regards, Leandro.
> 
>> 
>> regards
>> 
>> On 18 December 2015 at 13:00, Roger Baig Viñas
>> <[email-masked] <mailto:[email-masked]>> wrote:
>> 
> Hi Arjuna,
> 
>>>>> thought I will ignite some discussions on this paper which
>>>>> I think makes some controversial claims on the role mesh
>>>>> networks for enabling connectivity especially with the
>>>>> success of CNs around the globe:
>>>>> they state: "Our conclusions are intentionally
>>>>> controversial to stimulate a discussion among researchers
>>>>> and industry. We argue that wireless mesh networks will not
>>>>> be deployed for user access—at least from an economic point
>>>>> of view. Instead, they will be financed to increase the
>>>>> automation of remotely controlled devices, such as meters
>>>>> for gas or heating, parking meters, and traffic lights,
>>>>> whereas the financial contributions of users will be 
>>>>> dismal."
>>>>> 
> 1) Include the consideration of the effect of the introduction of
> wired-links, at least in the backbone. Our vision is to have three
> of four wireless hops at most everywhere.
> 
> 2) Avoid the idea of a totally unplanned network made out of
> ultra-cheap devices. Obviously the performance of a WiFi 10€ router
> should not be comparable to a >1000€ wired router.
> 
> 3) Include the social economics in the economics section
> (otherwise you will observe inexplicable behaviours).
> 
> Best regards.
> 
>>>>> 
>>>>> regards
>>>>> 
>>>>> -- Arjuna Sathiaseelan Personal:
>>>>> http://www.cl.cam.ac.uk/~as2330/ N4D Lab:
>>>>> http://www.cl.cam.ac.uk/~as2330/n4d
>>>>> 
>>>>> 
>>>>> _______________________________________________ gaia
>>>>> mailing list [email-masked] <mailto:[email-masked]> 
>>> _______________________________________________ gaia mailing
>>> list [email-masked] <mailto:[email-masked]> 
>> -- Arjuna Sathiaseelan Personal:
>> http://www.cl.cam.ac.uk/~as2330/ N4D Lab:
>> http://www.cl.cam.ac.uk/~as2330/n4d 
>> _______________________________________________ gaia mailing
>> list [email-masked] <mailto:[email-masked]> 
> -- Leandro Navarro http://people.ac.upc.edu/leandro
> http://dsg.ac.upc.edu
> 

- -- 
Roger Baig Viñas