Subject: Re: [gaia] What if all phones were always on the Internet?

From: Dirk Kutscher <[email-masked]>
Date: Tue, 1 Dec 2015 10:49:05 +0000

Hi,

A different perspective  is that the ISP would not have to limit the user to a fixed low bitrate in general (like 64 kbit/s), but make the allowed/acceptable bitrate depending on the actual cost at a time, i.e., the congestion contribution. This was one of the use cases for the Congestion Exposure (ConEx) work: incentivizing users and applications to make background traffic yield to other traffic through an congestion accountability framework. By doing so, users could still enjoy higher send/receive rates in off-peak times for example – when this would not create additional cost to the ISP.

In a potential next-generation network, an easier (to understand) way could be to offer a less-than-best-effort virtual network that is subject to different charging (no charging, ideally) policies.

Cheers,
Dirk

From: gaia [mailto:[email-masked]] On Behalf Of Steve Song
Sent: Freitag, 27. November 2015 13:05
To: gaia
Subject: Re: [gaia] What if all phones were always on the Internet?

Hi Arjuna,

It is already possible, on Android, to turn off background data updates and to do per-app tuning of background updates and data consumption in general.  What I would imagine is that when a phone runs out of data and finds itself in basic rate mode, then it would only update apps/services that have been actively selected by the user e.g. whatsapp, twitter, signal, telegram, FB messenger, email, browser, etc. The selectivity about apps and services would then be in the hands of the consumer not the provider.

Cheers... Steve

On 26 November 2015 at 21:22, Arjuna Sathiaseelan <[email-masked]<mailto:[email-masked]>> wrote:

Very nice Jim.

One problem of giving specific low usage caps in access could be there is quite a lot of mobile apps background traffic which randomly consume the usage caps?

As i pointed out earlier it will be really interesting to know what can we browse/do with today's apps/services over 9.6 kbps..as steve mentioned earlier this requires redesigning apps/content - FB is doing that but 9.6kbps is really pushing the limit? how would today's transport protocols work?

Regards
On 26 Nov 2015 19:51, "Jim Forster" <[email-masked]<mailto:[email-masked]>> wrote:
Steve,

I think it’s a great idea!

AirJaldi has been recently offering two different pre-paid hot spot systems.  One, called XWF (Express WiFi) is offered in Rishikesh and Garwhal district of Uttrakhand.  Facebook/Internet.org<http://internet.org> did the software for XWF; AirJaldi deployed the access points on our backbone in that district and manages the sales agents.  See this NY Time article<http://bits.blogs.nytimes.com/2015/10/25/facebook-strives-to-bring-cheap-wi-fi-to-rural-india-2/> for more info.  It is intended that this system will use their Free Basics system to give free access to certain sites.

The second pre-paid service AirJaldi has is called JaldiFi. A couple AirJaldi engineers did the software, using various Mikrotik & Ubiquity features.  JaldiFi is deploying in various places throughout AirJaldi’s network, including Kangra Valley, Kumaon, and Jharkand.  JaldiFi does not use Free Basics; instead we simply give registered users 10-20MB/day free service.  Registration is free and automated (users must supply a mobile phone number & then we send them a username/pw).  It’s obvious but worth noting that 10MB is 1/100th of 1GB, so a lot of ‘free’ users don’t impact the network much. It’s our belief that if the service is priced affordably, enough people will pay to make it worth our while.  Pricing is about Rs80/GB (~$1.25/GB), with some plans for as little Rs25.  Kumaon area prices are here<http://www.jaldifi.net/kumaon.html>.

Mawingu in Kenya does it a little differently.  For about 300Ksh, users get high speed service for a month, or if they don’t have that much money, they can buy a week’s service for 100Ksh.  Mawingu doesn’t give them completely unlimited service, but we find that the great majority of customers don’t use too much for us; email & web browsing is easily accommodated, but heavy YouTube/video watching eats up the MBs quickly.  The heaviest users will find then that their speed slowed way down, to about 128kbps.  That’s fine for email & tolerable for web browsing so they’re not cut off, but if they want more high speed for video, they’ll need to pay some more.

US-centric salutation: Happy Thanksgiving everyone!

  — Jim

On Nov 26, 2015, at 6:36 AM, Steve Song <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

Following on some of the previous discussion about the non-linear relationship between Internet speed and value to the consumer; and reflecting on some of the discussions on zero-rating at the IGF; and thinking further about the PAYG model that enabled the dramatic growth of mobile telephony in emerging markets, I came to the conclusion that a low-bitrate, always-on Internet for all mobile phones would benefit everyone.

https://manypossibilities.net/2015/11/zero-rating-a-modest-proposal/

Would love to have the idea critiqued (gently).

Thanks... Steve Song

_______________________________________________
gaia mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/gaia

--
+1 902 529 0046
[email-masked]<mailto:[email-masked]>
http://nsrc.org

---

From: Mat Ford <[email-masked]>
Date: Tue, 1 Dec 2015 14:33:21 +0000

> On 28 Nov 2015, at 10:48, El Khatib, Yehia (elkhatib) <[email-masked]> wrote:
> 
> However, most services (read: majority of cloud-hosted services) are developed with an assumption of over provisioned networks. This results in "chatty application syndrome”, and becomes very apparent when you take said application and try to run it over a poor network. So my point is, developers could and perhaps should equip their services for deployment in poor network conditions.

Related to this point, please see the briefing panel we hosted during the IETF93 meeting in Prague earlier this year:

http://www.internetsociety.org/internet-society-briefing-panel-ietf-93

Tackling Connectivity Diversity: Protocol Challenges for Constrained Radio Networks and Devices

Abstract
In many areas, Internet connectivity is primarily via low-end mobile devices capable of only 2G or 3G connections to cellular networks. But many application developers live and work with much faster computing platforms and networking environments. Does the infrastructure need to change to accommodate the continuing use of these devices? Is this a transient condition of uneven development, or do we need to re-architect and re-design systems to better cope with connectivity diversity?

Mat

---

From: Dirk Kutscher <[email-masked]>
Date: Wed, 2 Dec 2015 13:56:34 +0000

There is a public consultation on the EU 5GPPP phase 2 planning: http://networld2020.eu/

If you are interested in seeing more opportunities for GAIA topics, try to review this and provide your comments.

Cheers,
Dirk

> -----Original Message-----
> From: gaia [mailto:[email-masked]] On Behalf Of Dirk Kutscher
> Sent: Freitag, 27. November 2015 09:51
> To: Stephen Farrell; Jim Forster
> Cc: gaia; Steve Song
> > How would that best be progressed? I think there are good ideas here
> > (adding delay-tolerant features to mainstream protocols) but I'm not
> > sure how to get those ingrained in e.g. 5g stuff.
> 
> In Europe, review and have your say on what's happening here: https://5g-
> ppp.eu/
> 
> There is a second phase of projects in preparation -- that should ideally cater for
> topics like this, but people need to speak up.
> 
> Technically, I think that ICN as a concept has good potential as a network
> infrastructure technology that can span both well-connected traditional type of
> networks as well as less conventional ones, including uni-directional and
> disruption-prone networks.
> 
> One of the keywords is access network heterogeneity, e.g., "hybrid access" in
> the current IP access world. It's obvious that TCP/IP (even MPTCP) with
> DNS/CDN has issues in even the simple hybrid access home gateway scenario.
> 
> Another keyword is transport performance (related to the transport encryption
> discussion): with heterogeneous access, and especially with low-bitrate,
> unreliable secondary access, you want to have a more powerful forwarding
> plane that can react to changing link layer characteristics locally and that can
> employ in-network storage for reacting to disruption/delay. Today, mobile
> network operators are trying to address some of these issues with TCP proxies
> and application-layer proxies (the latter will probably become more expensive in
> the future because of encryption, see below).
> 
> Finally, security: I see two things happening:
> 
> 1) HTTP/2 and TLS => ubiquitous encryption
> 2) CDN extending into core and access networks => many vulnerable platforms
> that manage keys and certificates on behalf of original data owners and service
> providers to maintain connection-based encryption
> 
> This does not look very promising to me. We ought to figure object-based
> security and fine-granular access control based on that.
> 
> With virtualization extending to all parts of the network, it now becomes
> feasible to prototype and evaluate such systems, e.g., as a slice in a virtualized
> mobile network.
> 
> There is some interesting work going on, just a few pointers:
> 
> http://conferences2.sigcomm.org/acm-icn/2015/proceedings/p189-auge.pdf
> 
> http://conferences2.sigcomm.org/acm-icn/2015/proceedings/p137-
> schneider.pdf
> 
> http://conferences2.sigcomm.org/acm-icn/2015/proceedings/p177-yu.pdf
> 
> 
> Cheers,
> Dirk
> [email-masked]

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Wed, 2 Dec 2015 22:02:29 +0000

there was a very nice paper at DEV this year which is very relevant:

Optimizing Mobile Application Communication for Challenged Network
Environments
Waylon Brunette (University of Washington), Morgan Vigil (University of
California Santa Barbara), Fahad Pervaiz(University of Washington), Shahar
Levari (University of Washington), Richard Anderson (University of
Washington)

I cant find the paper online -- will post it once available..
regards

On 1 December 2015 at 14:33, Mat Ford <[email-masked]> wrote:

> > However, most services (read: majority of cloud-hosted services) are
> developed with an assumption of over provisioned networks. This results in
> "chatty application syndrome”, and becomes very apparent when you take said
> application and try to run it over a poor network. So my point is,
> developers could and perhaps should equip their services for deployment in
> poor network conditions.
>
> Related to this point, please see the briefing panel we hosted during the
> IETF93 meeting in Prague earlier this year:
>
> In many areas, Internet connectivity is primarily via low-end mobile
> devices capable of only 2G or 3G connections to cellular networks. But many
> application developers live and work with much faster computing platforms
> and networking environments. Does the infrastructure need to change to
> accommodate the continuing use of these devices? Is this a transient
> condition of uneven development, or do we need to re-architect and
> re-design systems to better cope with connectivity diversity?
>
>
> Mat

-- 
Arjuna Sathiaseelan
Personal: http://www.cl.cam.ac.uk/~as2330/
N4D Lab: http://www.cl.cam.ac.uk/~as2330/n4d

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Fri, 4 Dec 2015 12:25:37 +0000

This is the paper I mentioned below (attached) - thanks goes to Adisorn for
finding it in the USB stick :)

Regards