Subject: Re: [gaia] [5gangip] [Stackevo-discuss] 5G: It's the Network, Stupid

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Sat, 2 Jan 2016 22:29:02 +0000

In a world of clouds the concept of E2E security becomes somehow cloudy, if you allow me the easy pun. At least at the provider clouds I see many of those trusted middleboxes now…

Be goode,

On 17 Dec 2015, at 11:10 , Dirk Kutscher <[email-masked]<mailto:[email-masked]>> wrote:

Regarding security, unless we want to introduce “trusted middleboxes”,

Why not?

No e2e security.

That may be OK for some use cases, like IoT or home GWs, but could be less convincing for accessing public network services -- for example, if you extend the network with multiple hops of device-to-device communication, data mules etc.

Dirk

object encryption and authentication seems to be the way. Of course there are
other challenges for that, too – key management for example.

--
Dirk

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Jon
Crowcroft
Sent: Donnerstag, 17. Dezember 2015 08:57
To: Dirk Kutscher
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; gaia;
[email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [gaia] 5G: It's the Network, Stupid

Great article...one thing about the 4g..5g evolution is increasing cooperation
in forwarding and relaying signal, bits, packets (shared cell tower/base
station/antennae across provider). So direct,mesh,adhoc stop just being edge
notions, but are all first class part of the architecture ("don't fear the edge").
There is huge tension between this trend, and e2e security....I have not seen
anyone address how to resolve that tension...

On 16 Dec 2015 6:42 pm, "Dirk Kutscher" <[email-masked]<mailto:[email-masked]>> wrote:
[apologies for cross-posting]

Hi,

I have written up a few thoughts on current discussions around 5G and
network evolution. I might publish this as paper later, but wanted to get it out
early and ask for comments – so would be grateful for any feedback. It’s not
very polished and slightly long, but hopefully understandable enough. Take it as
a “position paper” for now.

Abstract:
Current 5G network discussion are often focusing on providing more
comprehensive and integrated orchestration and management functions in
order to improve “end-to-end” managebility and programmability, derived from
NGMN and similar requirements. While these are important challenges, this
memo takes the perspective that in order to arrive at a more powerful network,
it is important to understand the pain points and the reasons for certain design
choices of today’s networks. Understanding the drivers for traffic management
systems, middleboxes, CDNs and other application-layer overlays should be
taken as a basis for analyzing 5G uses cases and their requirements. In this
memo, I am making the point that many of today’s business needs and the
ambitious 5G use cases do call for a more powerful data forwarding plane,
taking ICN as an example. Features of such a forwarding plane would include
better support for heterogeneous networks (access networks and whole
network deployments), multi-path communication, in-network storage and
implementation of operator policies. This would help to avoid overlay silos and
finally simplify network management.

http://dirk-kutscher.info/posts/5g-its-the-network-stupid/

Thanks,
Dirk

_______________________________________________
gaia mailing list
[email-masked]
https://www.irtf.org/mailman/listinfo/gaia

_______________________________________________
Stackevo-discuss mailing list
[email-masked]
https://www.iab.org/mailman/listinfo/stackevo-discuss

_______________________________________________
gaia mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/gaia
_______________________________________________
5gangip mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/5gangip

--
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Dirk Kutscher <[email-masked]>
Date: Thu, 14 Jan 2016 08:22:54 +0000

Hi Diego,

yes, that’s true: Even with TLS you can essentially only rely on communication privacy for the connection from your application to the next CDN  node (that represents the application/content provider). You have no control over what happens to your requests, meta data, resources in the CDN and application service domain (in the current model).

The trusted middleboxes in the ISP domain (unless you are talking about CDN nodes) will go away or at least look very different soon – when mainstream CDN rolls out HTTP/2 support.

Cheers,
Dirk

From: DIEGO LOPEZ GARCIA [mailto:[email-masked]]
Sent: Samstag, 2. Januar 2016 23:29
To: Dirk Kutscher
Cc: Michael Welzl; [email-masked]; gaia; [email-masked]; Jon Crowcroft; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [5gangip] [gaia] [Stackevo-discuss] 5G: It's the Network, Stupid

Be goode,

Why not?

No e2e security.

Dirk

--
Dirk

Hi,

Abstract:

Thanks,
Dirk

_______________________________________________
Stackevo-discuss mailing list
[email-masked]<mailto:[email-masked]>
https://www.iab.org/mailman/listinfo/stackevo-discuss

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------