Subject: Re: [gaia] Heterogeneity in network capacity: growing?

From: Manner Jukka <[email-masked]>
Date: Mon, 29 Feb 2016 07:33:33 +0000

Hi,

I would say yes, they are globally, but it also depends on what area/market you are talking about. How would you calculate it if there was data? I have data, but not sure how to calculate this.

cheers,
Jukka

> On 29 Feb 2016, at 01:04, Michael Welzl <[email-masked]> wrote:
> 
> Hi,
> 
> I guess this is probably the right group to ask: is the heterogeneity of link bandwidths growing?
> Another way of asking this is: across the whole Internet, do old links roughly get removed as quickly as capacities grow?
> 
> I guess the answer is no - but are there any good citable references for this? Data?
> 
> Cheers,
> Michael
> 
> _______________________________________________
> gaia mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/gaia

---

From: Michael Welzl <[email-masked]>
Date: Mon, 29 Feb 2016 09:16:20 +0100

First,

Apologies for asking first formulating a question in two ways with contradictory outcomes (yes/no) and then saying "I guess the answer is no" - that was confusing!  :)   I was tired when I wrote it...
so I meant the second question, i.e. my guess was also that heterogeneity *is* growing.

How would you calculate if there was data: I guess what I'm interested in is bandwidth statistics: how often do we see a bottleneck of X bit/s? The Internet-wide distribution of X is what I'm looking for...

Depending on area/market: I'd also be happy to have X for India, X for Europe, X for ... whatever. It's a start!
Ideally citable - some publicly available study I could refer to.

Cheers,
Michael

> On 29 Feb 2016, at 08:33, Manner Jukka <[email-masked]> wrote:
> 
> Hi,
>

---

From: Manner Jukka <[email-masked]>
Date: Mon, 29 Feb 2016 09:11:45 +0000

Hi,

I don’t have a published analysis to cite, have done similar comparisons many times in various presentations. I could run that distribution from the Netradar database for 2014 and 2015, just need to give me the X buckets where to allocate the samples. 

Market analysis is a bit trickier, since measurements need to be mapped to a region somehow. IP address is one option if it can be trusted enough.

Jukka

> On 29 Feb 2016, at 10:16, Michael Welzl <[email-masked]> wrote:
> 
> First,
>

---

From: "Eric A. BREWER" <[email-masked]>
Date: Mon, 29 Feb 2016 07:00:22 -0800

Seems to me the two likely bottlenecks are last-mile mobile links
(especially old devices), and international gateways.  Since international
bandwidth can be quite expensive (even with undersea fiber in some areas,
but especially without it), there is often throttling and/or congestion at
those points, even when your device has high bandwidth.

On Mon, Feb 29, 2016 at 1:11 AM, Manner Jukka <[email-masked]> wrote:

> Hi,
>
> I don’t have a published analysis to cite, have done similar comparisons
> many times in various presentations. I could run that distribution from the
> Netradar database for 2014 and 2015, just need to give me the X buckets
> where to allocate the samples.
>
> Market analysis is a bit trickier, since measurements need to be mapped to
> a region somehow. IP address is one option if it can be trusted enough.
>
> Jukka
>
> > Apologies for asking first formulating a question in two ways with
> contradictory outcomes (yes/no) and then saying "I guess the answer is no"
> - that was confusing!  :)   I was tired when I wrote it...
> > How would you calculate if there was data: I guess what I'm interested
> in is bandwidth statistics: how often do we see a bottleneck of X bit/s?
> The Internet-wide distribution of X is what I'm looking for...
> >
> > Depending on area/market: I'd also be happy to have X for India, X for
> Europe, X for ... whatever. It's a start!
> >> I would say yes, they are globally, but it also depends on what
> area/market you are talking about. How would you calculate it if there was
> data? I have data, but not sure how to calculate this.
> >>
> >> cheers,
> >> Jukka
> >>
> >>> Another way of asking this is: across the whole Internet, do old links
> roughly get removed as quickly as capacities grow?
> >>>

---

From: Steve Song <[email-masked]>
Date: Mon, 29 Feb 2016 11:39:40 -0400

Looking at sub-Saharan Africa, I think the key enabler of heterogeneity is
the availability of open access national and metro fibre.  This is enabling
everything from data-only LTE service providers like Smile and Bitflux, to
FTTH, to metro WiFi, to TVWS.
https://manypossibilities.net/2016/01/africa-telecoms-infrastructure-in-2015/
reveals a positive trend in access diversity, although rural areas remain a
challenge.

Cheers... Steve

On 29 February 2016 at 11:00, Eric A. BREWER <[email-masked]> wrote:

>> Market analysis is a bit trickier, since measurements need to be mapped
>> to a region somehow. IP address is one option if it can be trusted enough.
>>
>> Jukka
>>
>> >>> Another way of asking this is: across the whole Internet, do old
>> links roughly get removed as quickly as capacities grow?
>> >>>

-- 
+1 902 529 0046
[email-masked]
http://nsrc.org

---

From: Michael Welzl <[email-masked]>
Date: Mon, 29 Feb 2016 17:26:15 +0100

> On 29. feb. 2016, at 10.11, Manner Jukka <[email-masked]> wrote:
> 
> Hi,
> 

NetRadar data would definitely be nice as a data point!  About buckets, not sure I get it: I mean e.g. a CDF of bandwidth values that were seen overall in 2014 and 2015; that would show if there is a shift not only towards higher bandwidths but if the diversity als increases, I guess.

If you need to have buckets to query, I guess it can be any reasonable low / high bandwidth values… the question is, do the low bandwidths disappear as quickly as the higher ones pop up?

> Market analysis is a bit trickier, since measurements need to be mapped to a region somehow. IP address is one option if it can be trusted enough.

*I* don’t actually care about markets much. I just wonder what range of bandwidths network protocols need to be able to operate over… is it always the same range or is the range growing (as I suspect)?

Cheers,
Michael

---

From: <[email-masked]>
Date: Mon, 29 Feb 2016 18:22:54 +0000

Hi Michael

A good starting point is Ofcom's infrastructure annual report; here is the 2015 one:
http://stakeholders.ofcom.org.uk/binaries/research/infrastructure/2015/downloads/connected_nations2015.pdf

You will find several distribution graphs like the one in Figure 4 that compares the monthly usage to the access speed range for 2014 and 2015.

You could also find the reports from previous years to see how things have changed over time:
http://stakeholders.ofcom.org.uk/market-data-research/market-data/infrastructure/?a=0

For a more global point of view, you could check Akamai's State of the Internet Report:
https://www.stateoftheinternet.com/resources-connectivity-2015-q3-state-of-the-internet-report.html

or play with their visualisations:
https://www.stateoftheinternet.com/trends-visualizations-connectivity-global-heat-map-internet-speeds-broadband-adoption.html

Hope this helps
Achilles

-----Original Message-----
From: gaia [mailto:[email-masked]] On Behalf Of Michael Welzl
Sent: 29 February 2016 08:16
To: Manner Jukka <[email-masked]>
Cc: [email-masked]
Subject: Re: [gaia] Heterogeneity in network capacity: growing?

First,

Cheers,
Michael

---

From: Henning Schulzrinne <[email-masked]>
Date: Mon, 29 Feb 2016 13:31:40 -0500

I'm not sure this is a well-defined question. For example, if you are
running a video service, the prevalence of modem connections (still about
1% in the US - https://www.census.gov/history/pdf/2013comp-internet.pdf) is
of somewhat limited interest except to the extent that they'd cut into your
addressable market. Thus, the question might be better phrased as "how many
people are you willing NOT to reach for a given application" in a
particular market. Also, in many cases, high-speed wireless data (e.g.,
LTE) may be available, but data charges are sufficiently high that many
people will be reluctant to use them for more than a few MB/month.

In many rural areas in the US (and elsewhere), a big problem is diurnal
variation of Internet speed - you might get 3 Mb/s at 2 am, but get 20%
packet loss at 5 pm.

Thus, theoretically, the dynamic range keeps increasing since the lowest
speeds never go away, but the top available speeds keep increasing, but
that may be no more interesting than noting that the range of memory
capacities now ranges from a few kB in a light switch to PB in a data
warehouse.

Henning

On Mon, Feb 29, 2016 at 11:26 AM, Michael Welzl <[email-masked]> wrote:

> NetRadar data would definitely be nice as a data point!  About buckets,
> not sure I get it: I mean e.g. a CDF of bandwidth values that were seen
> overall in 2014 and 2015; that would show if there is a shift not only
> towards higher bandwidths but if the diversity als increases, I guess.
>
> If you need to have buckets to query, I guess it can be any reasonable low
> / high bandwidth values… the question is, do the low bandwidths disappear
> as quickly as the higher ones pop up?
>
>
> *I* don’t actually care about markets much. I just wonder what range of
> bandwidths network protocols need to be able to operate over… is it always
> the same range or is the range growing (as I suspect)?
>
> Cheers,
> Michael
>

---

From: Michael Welzl <[email-masked]>
Date: Mon, 29 Feb 2016 20:58:13 +0100

Well … I do think this is interesting as it is when considering the evolution of TCP, which should *always* work - which is why I’m less interested in the congested case, as this is also (at least to some degree) a function of TCP’s behavior. I think “how many % of hosts still face bandwidths of X” is more important than “how much of a market share is this”, at least from my idealist academic ivory tower...

Cheers,
Michael

> On 29. feb. 2016, at 19.31, Henning Schulzrinne <[email-masked]> wrote:
> 
> I'm not sure this is a well-defined question. For example, if you are running a video service, the prevalence of modem connections (still about 1% in the US - https://www.census.gov/history/pdf/2013comp-internet.pdf <https://www.census.gov/history/pdf/2013comp-internet.pdf>) is of somewhat limited interest except to the extent that they'd cut into your addressable market. Thus, the question might be better phrased as "how many people are you willing NOT to reach for a given application" in a particular market. Also, in many cases, high-speed wireless data (e.g., LTE) may be available, but data charges are sufficiently high that many people will be reluctant to use them for more than a few MB/month. 
> 
> In many rural areas in the US (and elsewhere), a big problem is diurnal variation of Internet speed - you might get 3 Mb/s at 2 am, but get 20% packet loss at 5 pm.
> 
> Thus, theoretically, the dynamic range keeps increasing since the lowest speeds never go away, but the top available speeds keep increasing, but that may be no more interesting than noting that the range of memory capacities now ranges from a few kB in a light switch to PB in a data warehouse.
> 
> Henning
> 
> On Mon, Feb 29, 2016 at 11:26 AM, Michael Welzl <[email-masked] <mailto:[email-masked]>> wrote:
> 
> > On 29. feb. 2016, at 10.11, Manner Jukka <[email-masked] <mailto:[email-masked]>> wrote:
> >
> > Hi,
> >
> [email-masked] <mailto:[email-masked]>
> https://www.irtf.org/mailman/listinfo/gaia <https://www.irtf.org/mailman/listinfo/gaia>
>

---

From: Michael Welzl <[email-masked]>
Date: Mon, 29 Feb 2016 20:59:11 +0100

Great, thanks!

Good thinking about Akamai’s report - of course! I should have looked at that first

> On 29. feb. 2016, at 19.22, [email-masked] wrote:
> 
> Hi Michael
>