Subject: Re: [gaia] Review required: draft-irtf-gaia-alternative-network-deployments

From: [email-masked]
Date: Wed, 06 Apr 2016 13:33:54 +0200

Dear authors of "Alternative Network Deployments: Taxonomy, 
characterization,
                      technologies and architectures
            draft-irtf-gaia-alternative-network-deployments-04"

I'd find it useful if your draft provided a perspective towards future 
Alternative Networks.
I am thinking of software projects that have a strong emphasis on 
privacy and security in their network design.
After Snowden it is only a logical next step in order to meet the 
requirement of providing "freedom to communicate without interference, 
or interception" to explore and develop this kind of networks for public 
use.
So these projects are for example

* GNUnet [1]
* Maidsafe [2]
* Net2o [3]
* Briar [4]
* Sneakernet aDTN with its client Timberdoodle [5]

Some of these have developed privacy aware routing algorithms and 
decentral naming systems for about a decade now.
So in contrast to the existing Alternative Networks they provide 
meta-data-protection (implications of having none: [13])
by design as well as the encryption of contents.
What makes them special is that some of them (the first three) are 
alternative internet protocol stacks which don't depend on servers or 
central authorites. They are fully distributed and decentralized. So 
they not only have the potential to provide a free and open 
communication means to its users but also one that backs up their civil 
rights by being censorship resistant and by keeping its users' 
communication confidental and secure - more than the current internet 
does. [6],[7]

It is only a matter of time that they include the capability to do mesh 
networking.
GNUnet has its own module for this: CADET [8][9].
GNUnet has been packed for OpenWRT half a year ago [10]
It fits on a 8 MB Router and possibly on a 4 MB one, but still needs 
improvements to "dance the wifi" [11].
Maidsafe is rewritten in Rust- a security aware language. This rewrite 
should fit well on embedded devices.
When Rust is ported to OpenWRT also Maidsafe can run its first 
experiments with open-wireless-networks.
Net2o is built to be lightweight as well. It's developer claims that 
there is no reason why it should be not able to do wifi-mesh-networking.

You really should mention in your draft, that community networks are 
severely threatend by FCC and EU regulations.[12]
Proposal 1: All radio equipped hardware being sold must be open and 
enable alternative firmware to be deployed.

The current open frequencies have a very low throughput or need an 
enormous effort and knowledge to use them.
Wifi delivers very bad results when walls, vegetation or water is 
involved.
Proposal 2: The most suitable (best throughput under various conditions) 
frequencies must be opened for public use worldwide.
Under these conditions more people would be able to participate in 
digital communication.

Streets have physical limitations. Who owns them has got a monopoly.
With telecommunication infrastructure it is quite similar and the reason 
why for example in Germany at last the variety of telecommunication 
providers has declined with the result of one telecommunication provider 
having a monopoly and therefore can
dictate the prices.(Telekom)
Streets as well as communication means are vital for the well being of a 
society.
To leave these life veins to bodies with commercial interest without 
ethical commitments results in a discrimination (against)
the poor.
In wireless communities the poor depend on the generosity of others to 
pay their access where it is actually the responsibilty of a country to 
provide free access to communication means indiscriminately to its 
inhabitants as it is ususal for streets and has been proven to be a good 
idea.
Therefore
Proposal 3: The digital communication infrastructure such as conductions 
and antennas should be mostly tax funded, free to use and in public 
hand.

[1] https://gnunet.org/
[2] http://maidsafe.net/
[3] http://net2o.de/
[4] https://briarproject.org/
[5] https://github.com/timberdoodle/TimberdoodleApp

[6] https://www.w3.org/2014/strint/papers/65.pdf
[7] wiki.c3d2.de/EDN
[8] https://gnunet.org/cadet
[9] 
http://mirror.eu.oneandone.net/projects/media.ccc.de/congress/2013/workshops/30c3-WS-en-YBTI_Mesh-Bart_Polot-GNUnet_Wireless_Mesh_DHT.webm
[10] https://github.com/dangowrt/gnunet-15.05

[11] https://www.youtube.com/watch?v=OEBu7u6hZSo
[12] https://fsfe.org/activities/radiodirective/
[13] https://www.youtube.com/watch?v=g00l5qBYXu8, starting from minute 
4:00

Hope this helped.
Kind regards
Fmod

Project EDN
wiki.c3d2.de/EDN

---

From: [email-masked]
Date: Thu, 07 Apr 2016 09:30:49 +0200

Hi

i'd like to add some corrections:

> 
> It is only a matter of time that they include the capability to do
> mesh networking.

Correction, i've been told today: CADET is the routing engine. GNUnet's 
wifi module is called dv-module.

> GNUnet has been packed for OpenWRT half a year ago [10]
-> the package in trunk, it's more up to date:
https://github.com/openwrt/packages/blob/master/net/gnunet/Makefile

> should fit well on embedded devices

of mid-range sizes with 128MB Flash

Kind regards
Fmod
> 
> Project EDN
> wiki.c3d2.de/EDN
> 
> _______________________________________________
> gaia mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/gaia

---

From: Jose Saldana <[email-masked]>
Date: Mon, 11 Apr 2016 10:30:57 +0200

Hi,

I have had a look to the web sites you suggest in your e-mail. The 
question is that I think they are not about Alternative Networks, but 
about alternative protocols or applications. I mean, none of them is 
about deploying new physical infrastructure, but about software. The 
draft is about deploying new networks, with physical devices, links, 
antennae, etc.

Do you think this is true for all the links you have sent?

Thanks in advance,

Jose

El 2016-04-06 13:33, [email-masked] escribió:
> or interception" to explore and develop this kind of networks for
> public use.
> communication means to its users but also one that backs up their
> civil rights by being censorship resistant and by keeping its users'
> Proposal 2: The most suitable (best throughput under various
> conditions) frequencies must be opened for public use worldwide.
> With telecommunication infrastructure it is quite similar and the
> reason why for example in Germany at last the variety of
> telecommunication providers has declined with the result of one
> telecommunication provider having a monopoly and therefore can
> Streets as well as communication means are vital for the well being of
> a society.
> pay their access where it is actually the responsibilty of a country
> to provide free access to communication means indiscriminately to its
> inhabitants as it is ususal for streets and has been proven to be a
> good idea.
> Therefore
> Proposal 3: The digital communication infrastructure such as
> conductions and antennas should be mostly tax funded, free to use and
> in public hand.
> 
> 
> [1] https://gnunet.org/
> [2] http://maidsafe.net/
> [3] http://net2o.de/

---

From: [email-masked]
Date: Wed, 13 Apr 2016 21:45:45 +0000

Hi all,
What do you think of including potential Future Alternative Networks?
As i mentioned before-see below- these focus on privacy and security and 
to even replace the current insecure Internet with a new one.

Kind regards
Fmod

######################
Hi,

I think we should discuss this in the GAIA list. I would like to hear 
others' opinions. If you could post this message there, it would be 
great.

Thanks!

Jose

###########################
> 
> Hi Jose,
> 
> yes. Currently there are no wireless communities using this software.
> But i suggested to put them under a new section:
> Possible ->Future<- Alternative Networks.
> Since they are aiming at replacing the existing solutions with more 
> secure and
> privacy preserving ones- even replacing the existing Internet-protocol 
> stack:
> https://www.youtube.com/watch?v=eM4J7ljCExM
> 
> Kind regards
> Dmos
> 
> Am 2016-04-11 08:30, schrieb Jose Saldana:
> > Hi,
> >
> >> I'd find it useful if your draft provided a perspective towards
> >> future Alternative Networks.
> >> requirement of providing "freedom to communicate without
> >> interference, or interception" to explore and develop this kind of
> >> networks for public use.
> >> meta-data-protection (implications of having none: [13]) by design as
> >> well as the encryption of contents.
> >> GNUnet has been packed for OpenWRT half a year ago [10] It fits on a
> >> 8 MB Router and possibly on a 4 MB one, but still needs improvements
> >> to "dance the wifi" [11].
> >> Maidsafe is rewritten in Rust- a security aware language. This
> >> rewrite should fit well on embedded devices.
> >> severely threatend by FCC and EU regulations.[12] Proposal 1: All
> >> radio equipped hardware being sold must be open and enable
> >> alternative firmware to be deployed.
> >>
> >> dictate the prices.(Telekom) Streets as well as communication means
> >> are vital for the well being of a society.
> >> ethical commitments results in a discrimination (against) the poor.
> >> In wireless communities the poor depend on the generosity of others
> >> to pay their access where it is actually the responsibilty of a
> >> country to provide free access to communication means
> >> indiscriminately to its inhabitants as it is ususal for streets and
> >> has been proven to be a good idea.
> >> Therefore
> >> http://mirror.eu.oneandone.net/projects/media.ccc.de/congress/2013/wo
> >> rkshops/30c3-WS-en-YBTI_Mesh-Bart_Polot-
> GNUnet_Wireless_Mesh_DHT.webm

---

From: Mitar <[email-masked]>
Date: Thu, 14 Apr 2016 02:21:52 -0700

Hi!

Those are mostly overlay networks, no? They do not really work on
providing the infrastructure itself? I think this document is
targeting networks which provide infrastructure in some alternative
ways.

Some other similar projects (to my knowledge):

https://en.wikipedia.org/wiki/Cjdns
https://ipfs.io/

Mitar

On Wed, Apr 13, 2016 at 2:45 PM,  <[email-masked]> wrote:
> As i mentioned before-see below- these focus on privacy and security and to
> even replace the current insecure Internet with a new one.
>
> Kind regards
> Fmod
>
> ######################
> Hi,
>
> others' opinions. If you could post this message there, it would be great.
>
> Thanks!
>
> Jose
>
>> Since they are aiming at replacing the existing solutions with more secure
>> and

-- 
http://mitar.tnode.com/
https://twitter.com/mitar_m

---

From: [email-masked]
Date: Fri, 15 Apr 2016 13:20:26 +0000

Hi,

> Those are mostly overlay networks

If this answers your question:
GNUnet, Maidsafe, Net2o can all set on UDP:

http://www.grothoff.org/christian/mapping2014.pdf, page 34
https://github.com/maidsafe/MaidSafe-Transport
http://fossil.net2o.de/net2o/doc/trunk/wiki/topology.md

In addition GNUnet can set on WLAN and Bluetooth.
So what is missing for the others is just the right module beneath.
It is a question of time that they get it and that at least one of these 
newcomers constitute community wireless networks, whereas GNUnet is 
closest, and will again, afaik participate at the Battlemesh this year.

  They do not really work on
> providing the infrastructure itself?
Actually they all do, as long as you don't mean layer 0 - hardware.
But that might come along when the time has come.

> https://en.wikipedia.org/wiki/Cjdns
Cjdns provides end-2-end-encryption and there are communities using it.
As long as not configured (using Tor) it provides no protection of 
metadata.

> https://ipfs.io/
Provides no end-to-end-encryption nor metadata-protection.
Maybe useful on top of an Internet that delivers the above requirements.

--Fmod
#######################################

>>> secure

---

From: Mitar <[email-masked]>
Date: Sat, 16 Apr 2016 23:20:27 -0700

Hi!

On Fri, Apr 15, 2016 at 6:20 AM,  <[email-masked]> wrote:
> newcomers constitute community wireless networks, whereas GNUnet is closest,
> and will again, afaik participate at the Battlemesh this year.

OK, let me rephrase my question: there is no currently existing direct
non-testped deployment on dedicated infrastructure for these protocols
(so that there would be for example routers running those protocols)?
Any real network one can use are currently still overlay networks?

So the question is: while this is still in process, there is still no
party which would decide to use it "in production", directly, no?

What is this document's editorial policy on including promising to-be
technologies and approaches? Should we maybe have a section to
speculate and provide some links (we could also mention DTN there)?

> But that might come along when the time has come.

I meant hardware, yes.

> As long as not configured (using Tor) it provides no protection of metadata.
>
>> https://ipfs.io/
>

Yes, it is interesting how different projects are picking different
trade-offs. It will be really interesting to see which ones will take
off.

Mitar

---

From: "Jose Saldana" <[email-masked]>
Date: Mon, 25 Apr 2016 17:14:47 +0200

Hi, Mitar,

> -----Mensaje original-----
> De: gaia [mailto:[email-masked]] En nombre de Mitar
> Enviado el: domingo, 17 de abril de 2016 8:20
> Para: [email-masked]
> CC: gaia <[email-masked]>
> Asunto: Re: [gaia] Fwd: RE: Review required:
draft-irtf-gaia-alternative-network-
> deployments
> > It is a question of time that they get it and that at least one of
> > these newcomers constitute community wireless networks, whereas GNUnet
> > is closest, and will again, afaik participate at the Battlemesh this
year.
> OK, let me rephrase my question: there is no currently existing direct
non-testped
> deployment on dedicated infrastructure for these protocols (so that there
would be
> for example routers running those protocols)?
party which would
> decide to use it "in production", directly, no?
> 
technologies
> and approaches? Should we maybe have a section to speculate and provide
some
> links (we could also mention DTN there)?

Currently the draft only covers tested and deployed technologies.

I don't think we should speculate about the future, just build a
classification of what already exists (it is my opinion).

metadata.
> Yes, it is interesting how different projects are picking different
trade-offs. It will be
> really interesting to see which ones will take off.
> 
> 
> Mitar
> 
> --
> http://mitar.tnode.com/

Best regards,

Jose