Subject: Re: [gaia] draft-irtf-gaia-alternative-network-deployments. Mitar review, question #7: MAC protocols

From: "Jose Saldana" <[email-masked]>
Date: Tue, 12 Apr 2016 16:47:09 +0200

Hi,
 
> Section 6.2.1,  Media Access Control (MAC) protocols for wireless links
> 
> "Wireless standards ensure interoperability and usability to those who
design, deploy
> and manage wireless networks."
> 
> Wireless standard ensure low-cost of equipment due to economies of scale
and
> mass production. This is the main reason I think why WiFi is so popular in
alternative
> networks. You can get a device for $10. And you can get this because
everyone is
> producing this hardware, and the hardware is not just made for the
alternative
> networks. In contrast, traditional ISPs use hardware which is developed
only for
> them. Even if they are big ISP, number of units is still much smaller than
number of
> WiFi routers produced for the global market.

This would be the new version of this subsection:

6.2.1.  Media Access Control (MAC) Protocols for Wireless Links

   Different protocols for Media Access Control, which also include
   physical layer (PHY) recommendations, are widely used in Alternative
   Network Deployments.  Wireless standards ensure interoperability and
   usability to those who design, deploy and manage wireless networks.
   In addition, then ensure low-cost of equipment due to economies of
   scale and mass production.

   The standards used in the vast majority of Alternative Networks come
   from the IEEE Standard Association's IEEE 802 Working Group.
   Standards developed by other international entities can also be used,
   as e.g. the European Telecommunications Standards Institute (ETSI).

> 
> Question about list of WiFi standards in this draft. Why is that needed?
Why
> properties and descriptions of those standards should be in this draft?
They belong
> to Wikipedia, or their own standard. In this draft we can just reference
those
> standards. Like what of all this text is relevant to alternative networks?
It is general
> text which is true for any use:
> 
> "802.22 [IEEE.802-22.2011] is a standard developed specifically for long
range rural
> communications in TV white space frequencies and first approved in July
2011. The
> standard is similar to the 802.16
> (WiMax) [IEEE.802-16.2008] standard with an added cognitive radio ability.
The
> maximum throughput of 802.22 is 22.6 Mbps for a single 8 MHz channel using
64-
> QAM modulation. The achievable range using the default MAC scheme is 30
km,
> however 100 km is possible with special scheduling techniques. The MAC of
802.22
> is specifically customized for long distances - for example, slots in a
frame destined
> for more distant Consumer Premises Equipment (CPEs) are sent before slots
> destined for nearby CPEs.
> 
> Base stations are required to have a Global Positioning System (GPS) and a
> connection to the Internet in order to query a geolocation spectrum
database. Once
> the base station receives the allowed TV channels, it communicates a
preferred
> operating white space TV channel with the CPE devices. The standard also
includes
> a coexistence mechanism that uses beacons to make other 802.22 base
stations
> aware of the presence of a base station that is not part of the same
network."
You are right. We have only briefly summarized each of the most popular
standards, trying to focus on the characteristics that make them suitable
for Alternative networks: kilometers, requirements, standards especially
suited for ANs (e.g. WILD). We also talk about the maximum rates.

So it is a matter of style if we remove some content from this section, I
think. I would not touch it.

Jose

---

From: Mitar <[email-masked]>
Date: Wed, 13 Apr 2016 02:37:25 -0700

Hi!

> This would be the new version of this subsection:

It sounds good.

> suited for ANs (e.g. WILD). We also talk about the maximum rates.

In this case it might be interesting to also look into non-standard
behavior done with such WiFi devices. For example, running them in
ad-hoc mode even in N protocol (which by standard does not have that
mode). Or using L2 routing protocol like Batman advanced to get
roaming support in community networks. (For this latter thing I am not
sure if it should be under this section or routing.)

> think. I would not touch it.

OK.

Mitar

-- 
http://mitar.tnode.com/
https://twitter.com/mitar_m

---

From: "Jose Saldana" <[email-masked]>
Date: Wed, 13 Apr 2016 18:21:18 +0200

Hi,

> -----Mensaje original-----
> De: Mitar [mailto:[email-masked]]
> Enviado el: miércoles, 13 de abril de 2016 11:37
> Para: Jose Saldana <[email-masked]>
> CC: gaia <[email-masked]>
> Asunto: Re: [gaia] draft-irtf-gaia-alternative-network-deployments. Mitar review,
> question #7: MAC protocols
> 
> Hi!
> 
> > You are right. We have only briefly summarized each of the most
> > popular standards, trying to focus on the characteristics that make
> > them suitable for Alternative networks: kilometers, requirements,
> > standards especially suited for ANs (e.g. WILD). We also talk about the maximum
> rates.
> 
> In this case it might be interesting to also look into non-standard behavior done with
> such WiFi devices. For example, running them in ad-hoc mode even in N protocol
> (which by standard does not have that mode). Or using L2 routing protocol like
> Batman advanced to get roaming support in community networks. (For this latter
> thing I am not sure if it should be under this section or routing.)

Does anyone have any example or reference of an Alternative Network using these things?

> 
> > So it is a matter of style if we remove some content from this
> > section, I think. I would not touch it.
> 
> OK.
> 
> 
> Mitar
> 
> --
> http://mitar.tnode.com/

Thanks,

Jose

---

From: Max B <[email-masked]>
Date: Wed, 13 Apr 2016 10:38:29 -0700

Here's a diagram showing a mix of layer 2 and 3 for theoretically better roaming support:

https://libre-mesh.org/projects/libre-mesh/wiki/Network_Architecture?version=10

As for something like 802.11n adhoc mode, sudomesh - the group that I'm part of - is leveraging ath9k support to use 802.11n adhoc mode.

We probably have some reference documentation of that somewhere on our wiki. If it's not there I can add it....

On April 13, 2016 9:21:18 AM PDT, Jose Saldana <[email-masked]> wrote:
>behavior done with
>_______________________________________________
>gaia mailing list
>[email-masked]
>https://www.irtf.org/mailman/listinfo/gaia

---

From: "Jose Saldana" <[email-masked]>
Date: Thu, 14 Apr 2016 10:38:21 +0200

Hi, Max.
 
Sorry, I am not an expert on this. Could you provide a summary of these two things? I mean, they are to be added as non-standard use of 802.11, so we should focus on that.
 
1) What is the non-standard use of 802.11 in libre-mesh.org?
 
2) Is the non-standard part of sudomesh the use of 802.11n in adhoc mode? Could you provide a couple of sentences explaining it?
 
Thanks in advance!
 
Jose
 
De: Max B [mailto:[email-masked]] 
Enviado el: miércoles, 13 de abril de 2016 19:38
Para: Jose Saldana <[email-masked]>; 'Mitar' <[email-masked]>
CC: 'gaia' <[email-masked]>
Asunto: Re: [gaia] draft-irtf-gaia-alternative-network-deployments. Mitar review, question #7: MAC protocols

We probably have some reference documentation of that somewhere on our wiki. If it's not there I can add it....
On April 13, 2016 9:21:18 AM PDT, Jose Saldana <[email-masked] <mailto:[email-masked]> > wrote:
Hi,
 -----Mensaje original-----
 De: Mitar [mailto:[email-masked]]
 Enviado el: miércoles, 13 de abril de 2016 11:37
 Para: Jose Saldana <[email-masked] <mailto:[email-masked]> >
 CC: gaia <[email-masked] <mailto:[email-masked]> >
 Asunto: Re: [gaia] draft-irtf-gaia-alternative-network-deployments. Mitar review,
 question #7: MAC protocols
 
 Hi!

 It sounds good.
 
 You are right. We have only briefly summarized each of the most
 popular standards, trying to focus on the characteristics t!
 hat
make
 them suitable for Alternative networks: kilometers, requirements,
 standards especially suited for ANs (e.g. WILD). We also talk about the maximum
 rates.

 
 So i!
 t is a
matter of style if we remove some content from this
 section, I think. I would not touch it.
 
 OK.

 Mitar

Thanks,

Jose

  _____  

gaia mailing list
[email-masked] <mailto:[email-masked]> 
https://www.irtf.org/mailman/listinfo/gaia