Subject: [gaia] draft-irtf-gaia-alternative-network-deployments. Stephen Farrel's comment #1. DTN

From: "Jose Saldana" <[email-masked]>
Date: Fri, 15 Apr 2016 10:17:53 +0200

Hi,

Any thoughts about the use of DTN in Alternative Networks? Any experiences, references or some news about DTN being used in some of them?

> > - 5.5: you don't mention DTN, there have been a number DTN based
> > testbeds, but probably none that reached any scale (so you might be
> > right to leave those out)

Best regards,

Jose 

> -----Mensaje original-----
> De: gaia [mailto:[email-masked]] En nombre de Matthew Ford
> Enviado el: lunes, 04 de abril de 2016 15:22
> Para: gaia <[email-masked]>
> Asunto: [gaia] Fwd: [irsg] IRSG Poll: draft-irtf-gaia-alternative-network-deployments
> 
> With Stephen’s permission, I’m sharing his comments on the alternative-network-
> deployments draft.
> 
> Mat
> 
> > Begin forwarded message:
> >
> > From: Stephen Farrell <[email-masked]>
> > Subject: Re: [irsg] IRSG Poll:
> > draft-irtf-gaia-alternative-network-deployments
> > Date: 18 March 2016 at 13:21:38 GMT-3
> > To: Matthew Ford <[email-masked]>, Internet Research Steering Group
> > <[email-masked]>
> >
> >
> > - 5.5: you don't mention DTN, there have been a number DTN based
> > testbeds, but probably none that reached any scale (so you might be
> > right to leave those out)
> >
> > - 7.2 doesn't mention PEPs, might be worth including as satellite was
> > mentioned earlier (as they break stuff when
> > present;-)
> >
> > - 7.3 omits email, which is odd and you only mention the web in the
> > context of proxies which is maybe even more odd; and NTP is not really
> > an "intranet" service, nor is IRC. Maybe this section could do with
> > some more work?
> >
> > Missing characteristics - I didn't see much or any consideration of
> > the stuff below and would have thought that these issues were
> > important in characterising alternative networks:
> >
> > - Reliability: I only see one instance of the string "reliab"
> > which is odd - wouldn't the reliability of these networks be a major
> > consideration? I mean the overall uptime mostly, and not the packet
> > loss rate.
> >
> > - Latency: I also see only one mention of latency which is also
> > surprising - for some of these networks I assume that e.g. not being
> > fast enough to use FB, gmail or similar is a barrier. I'd have thought
> > that'd be an interesting characteristic too.
> >
> > - Power: whether the nodes have reliable power or not would also seem
> > to be an interesting way to characterise 'em.
> >
> 
> _______________________________________________
> gaia mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/gaia

---

From: Javier Simó <[email-masked]>
Date: Fri, 15 Apr 2016 13:07:16 +0200

I feel very much interested by DTN and I have always been supportive in 
including DTN as a strategic technology in this field, but I cannot 
contribute with personal experiences. In my humble opinion, there are 
many scenarios where communities are artificially choosing between 
having full connectivity or no connectivity at all, while there is a 
very interesting alternative in the middle that has not been explored 
enough.

I can imagine many interesting applications in emergency communications, 
in remote areas, ... just there are other people in the list better 
placed to talk about it.

Best
Javier

-- 

---------------------------------------------------
Fco. Javier Simó Reigadas <[email-masked]>
Subdirector de Ord. Docente
ETS de Ingeniería de Telecomunicación
D-204, Departamental III
Camino Del Molino, s/n - 28943 Fuenlabrada (Madrid)
Tel: 914888428, Fax: 914887500
Web personal: http://www.tsc.urjc.es/~javier.simo

---

From: Joerg Ott <[email-masked]>
Date: Fri, 15 Apr 2016 15:10:36 +0200

Two data points:

Within the RIFE project: https://rife-project.eu
Here, we use DTN as on local dissemination strategy to reach less well
connected users.

We build small things like the liberouter: www.liberouter.mobi
We think that this is a suitable model for localized networking
(understanding that global information access is important, but it's
not everything).  We spent some time with a student project course
looking at self sustainability of such systems from an energy 
perspective.  More left to do.

Jörg

On 15.04.16 13:07, Javier Simó wrote:
>> Any thoughts about the use of DTN in Alternative Networks? Any
>> experiences, references or some news about DTN being used in some of
>> them?
>>
>>> Asunto: [gaia] Fwd: [irsg] IRSG Poll:

---

From: "Jose Saldana" <[email-masked]>
Date: Fri, 15 Apr 2016 16:35:23 +0200

Hi,

Thanks a lot for the information.

The questions are:

- Where could DTNs fit in the draft? "Technologies employed" section? https://tools.ietf.org/html/draft-irtf-gaia-alternative-network-deployments-04#section-6

- Are these efforts only experimental or are being used in operational environments?

Thanks,

Jose

> De: gaia [mailto:[email-masked]] En nombre de Joerg Ott
> Enviado el: viernes, 15 de abril de 2016 15:11
> Para: Javier Simó <[email-masked]>; [email-masked]
> Asunto: Re: [gaia] draft-irtf-gaia-alternative-network-deployments. Stephen Farrel's
> comment #1. DTN
> 
> Two data points:
> 
> Within the RIFE project: https://rife-project.eu Here, we use DTN as on local
> dissemination strategy to reach less well connected users.
> 
> We build small things like the liberouter: www.liberouter.mobi We think that this is a
> suitable model for localized networking (understanding that global information
> access is important, but it's not everything).  We spent some time with a student
> project course looking at self sustainability of such systems from an energy
> > I feel very much interested by DTN and I have always been supportive
> > in including DTN as a strategic technology in this field, but I cannot
> > I can imagine many interesting applications in emergency
> > communications, in remote areas, ... just there are other people in
> > the list better placed to talk about it.
> >
> > Best
> > Javier
> >
> >>>> - 7.2 doesn't mention PEPs, might be worth including as satellite
> >>>> was mentioned earlier (as they break stuff when
> >>>> present;-)
> >>>>
> >>>> context of proxies which is maybe even more odd; and NTP is not
> >>>> really an "intranet" service, nor is IRC. Maybe this section could
> >>>> do with some more work?
> >>>>
> >>>> which is odd - wouldn't the reliability of these networks be a
> >>>> major consideration? I mean the overall uptime mostly, and not the
> >>>> packet loss rate.
> >>>>
> >>>> surprising - for some of these networks I assume that e.g. not
> >>>> being fast enough to use FB, gmail or similar is a barrier. I'd
> >>>> have thought that'd be an interesting characteristic too.
> >>>>
> >>>> - Power: whether the nodes have reliable power or not would also
> >>>> seem to be an interesting way to characterise 'em.
> >>>>