Subject: [gaia] IRTF GAIA at IETF, Berlin?

From: Arjuna Sathiaseelan <[email-masked]>
Date: Mon, 16 May 2016 11:50:08 +0100

All,
  Mat and I were wondering if we should have a GAIA meeting at the IETF in
Berlin (July 17-22, 2016). If anyone is interested in presenting, please
let us know. If there is interest, we can schedule a meeting.

Thanks.

-- 
Arjuna Sathiaseelan
Personal: http://www.cl.cam.ac.uk/~as2330/
N4D Lab: http://www.cl.cam.ac.uk/~as2330/n4d

---

From: Corinne Cath <[email-masked]>
Date: Mon, 16 May 2016 14:49:44 +0100

Would be great to have a meeting!

Best,

On Mon, May 16, 2016 at 11:50 AM, Arjuna Sathiaseelan <
[email-masked]> wrote:

> _______________________________________________
> gaia mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/gaia
>
>

-- 
Corinne J.N. Cath

---

From: Niels ten Oever <[email-masked]>
Date: Tue, 17 May 2016 09:56:18 +0200

Hi Arjuna,

Shane Kerr and I have been working on providing Internet access to
refugees and migrants, among other things with a Refugee Hotspot [0],
which we would be more than happy to present.

Best,

Niels

PS As long at the session is not on Monday or coincides with hrpc,
dnsops or dprive

[0] https://github.com/RefugeeHotspot/RefugeeHotspot

On 05/16/2016 12:50 PM, Arjuna Sathiaseelan wrote:
> All,
>   Mat and I were wondering if we should have a GAIA meeting at the IETF
> in Berlin (July 17-22, 2016). If anyone is interested in presenting,
> please let us know. If there is interest, we can schedule a meeting.
> 
> Thanks.
> 
> -- 
> Arjuna Sathiaseelan

-- 
Niels ten Oever
Head of Digital

Article 19
www.article19.org

PGP fingerprint    8D9F C567 BEE4 A431 56C4
                   678B 08B5 A0F2 636D 68E9

---

From: Stephen Farrell <[email-masked]>
Date: Tue, 17 May 2016 11:15:25 +0100

> which we would be more than happy to present.

I'd be interested in that. (If I can make the session which is by
no means certain due to conflicts).

Two questions though:

Can you elaborate on how you're thinking of making this bit work:
"It will be possible to distribute files, images, statements and
flyers wireless using the landingpage." The naming and search issues
involved in the above seem tricky, if one is to avoid a single
point of failure. (If it's too early to say, that's fine.)

The second one goes back to stuff we found when we did hotspots
at the end of DTNs some years ago. We found that early iPhones were
a problem as they wouldn't associate with an open hotspot without
first calling home to Cupertino. Since we couldn't do that (being
in a DTN) we just faked the DNS as the phones accepted the "right"
error and continued on nicely. I'd expect that this situation might
now be worse, so have you any thoughts about trying to make it
possible for people to use this hotspot without all their devices
calling home to the many vendors and service providers involved
today? I'm guessing doing stuff there might just be too hard though
but it'd I assume be considered a nice feature if this box made it
a little harder to track everyone who associated with the AP. What's
your thinking there? (And once again, "dunno yet" is a fine answer
if that's the case.)

Cheers,
S.

---

From: Arjuna Sathiaseelan <[email-masked]>
Date: Tue, 17 May 2016 15:58:18 +0100

Dear Niels -

Yes I know about your awesome work.

At Cambridge, we are carrying out some experimental work on building adhoc
micro datacenters in the air using a mesh of Rasp PI drones running Dockers
:)..

We have some done preliminary design and are currently running full scale
experiments to understand the feasibility and scenarios where this could be
useful.

If you/anyone is interested, we will be presenting this concept in the ACM
Mobisys Dronet Workshop this summer:
https://arxiv.org/pdf/1604.08243v1.pdf

ofcourse we are limited by the battery - but these are all interesting
research/deployment challenges we are currently investigating..

Regards

---

From: Niels ten Oever <[email-masked]>
Date: Sat, 21 May 2016 13:35:01 +0200

Hi Stephen,

> point of failure. (If it's too early to say, that's fine.)

Hmmmmm, good point. Thinking thusfar has been to navigate of the landing
page, but as you say (or imply) it is impossible to return to the
landingpage once one has clicked 'connect'.

Something we did not give a great deal of thought to yet. One idea would
be to create a WiFi network called 'info' and one called 'internet
access' as to differentiate purpose by network.

Need to give this more thought.

Currently we're mostly focusing on testing though, to ensure we do not
come up with funky features that are not actually used in practice.

> your thinking there? (And once again, "dunno yet" is a fine answer

This is a great point. Currently, even though we will use a VPN by
default in all installations, the Refugee Hotspot is not meant as a
privacy enhacing device. This is because it would be hard to combine an
open access point with good security.

Of course we could have increased security in several ways, but managing
expectations of the users would subsequently be hard, Therefore we make
it clear on the landing page that users should use endpoint security and
not rely on this device for their privacy.

But all thoughts and suggestions on improving security and privacy of
the users of this device is of course more than welcome, since it's such
a precarious group of users.

Best,

Niels

-- 
Niels ten Oever
Head of Digital

Article 19
www.article19.org