Subject: [gaia] Mobile apps for validating mobile operator coverage

From: Steve Song <[email-masked]>
Date: Fri, 5 Aug 2016 17:25:40 -0300

Hi all,

Has anyone used mobile apps for monitoring/testing/validating mobile
operator coverage in their research?  I am planning on running some tests
in rural Uganda later this month.

My first inclination is to use Mozilla Stumbler as it is completely open
and the data is accessible to anyone but I am concerned that it may only be
collecting very basic information on towers.  OpenSignalMaps is also
popular but the data is less accessible.  And there are others like Network
Cell Info and Gmon or commercial solutions like GWS.

Any researchers out there have recommendations or have a custom tool they
would like to test?

Many thanks... Steve Song

---

From: Danny Iland <[email-masked]>
Date: Fri, 5 Aug 2016 15:06:21 -0700

I have used two apps in the past for this task: MobiLog and Wigle WiFi. I
suggest running MobiLog and NetRadar at the same time, so you don't lose
data if one fails. Be sure to have a battery pack as logging this once per
second eats your phone's battery.

http://www.valerio.im/others.html#mobilog

MobiLog logs GPS coordinates, Cellular Network details (e.g. cell-IDs,
RSSIs, Neighboring Cells, Connection States, etc.), and Wifi Access Points
information (e.g. SSID, BSSID, RSSI, Frequency, Encryption).

MobiLog was written by a University of Vienna grad student. it works well
for logging cellular data to your phone in an easy to parse CSV file and/or
KML.

Be careful to stop it and wait for it to finish writing to file before you
turn off the phone. It's not very good about flushing to disk I think.

Danny

On Aug 5, 2016 1:25 PM, "Steve Song" <[email-masked]> wrote:

> _______________________________________________
> gaia mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/gaia
>
>

---

From: Steve Song <[email-masked]>
Date: Sun, 7 Aug 2016 10:11:40 -0300

Hi Jukka, Danny,

Appreciate the guidance.  Will try out both Netradar and Mobilog.  I don't
suppose either of you could point to papers that have been published that
are based on the use of these tools?

Thanks again... Steve

-- 
+1 902 529 0046
[email-masked]
http://nsrc.org

---

From: "Amreesh D. Phokeer" <[email-masked]>
Date: Sun, 7 Aug 2016 16:16:13 +0200

Hi Steve,

I don't know if mobiperf can be of any help.

https://sites.google.com/site/mobiperfdev/home

Paper:

http://bit.ly/2aYlWt6

Regards,

Amreesh

On 8/5/16 10:25 PM, Steve Song wrote:
> operator coverage in their research?  I am planning on running some
> tests in rural Uganda later this month.  
>
> My first inclination is to use Mozilla Stumbler as it is completely
> open and the data is accessible to anyone but I am concerned that it
> may only be collecting very basic information on towers. 
> OpenSignalMaps is also popular but the data is less accessible.  And
> there are others like Network Cell Info and Gmon or commercial
> solutions like GWS.
>
> Any researchers out there have recommendations or have a custom tool
> they would like to test?
>

-- 
Amreesh D. Phokeer
PhD Student
Centre for ICT for Development
Computer Science Department
University of Cape Town

---

From: Manner Jukka <[email-masked]>
Date: Sun, 7 Aug 2016 16:28:32 +0000

Hi, you can from Aalto (aaltodoc.aalto.fi<http://aaltodoc.aalto.fi>?) the phd dissertation by Sebastian Sonntag that has papers based on Netradar.

Jukka

--

Sent from a tablet. Sorry for being brieef, for typoss and other spellning erros.

Steve Song <[email-masked]<mailto:[email-masked]>> kirjoitti 7.8.2016 kello 16.11:

Hi Jukka, Danny,

Appreciate the guidance.  Will try out both Netradar and Mobilog.  I don't suppose either of you could point to papers that have been published that are based on the use of these tools?

Thanks again... Steve

On 5 August 2016 at 19:06, Danny Iland <[email-masked]<mailto:[email-masked]>> wrote:

I have used two apps in the past for this task: MobiLog and Wigle WiFi. I suggest running MobiLog and NetRadar at the same time, so you don't lose data if one fails. Be sure to have a battery pack as logging this once per second eats your phone's battery.

MobiLog logs GPS coordinates, Cellular Network details (e.g. cell-IDs, RSSIs, Neighboring Cells, Connection States, etc.), and Wifi Access Points information (e.g. SSID, BSSID, RSSI, Frequency, Encryption).

MobiLog was written by a University of Vienna grad student. it works well for logging cellular data to your phone in an easy to parse CSV file and/or KML.

Be careful to stop it and wait for it to finish writing to file before you turn off the phone. It's not very good about flushing to disk I think.

Danny

On Aug 5, 2016 1:25 PM, "Steve Song" <[email-masked]<mailto:[email-masked]>> wrote:
Hi all,

Has anyone used mobile apps for monitoring/testing/validating mobile operator coverage in their research?  I am planning on running some tests in rural Uganda later this month.

My first inclination is to use Mozilla Stumbler as it is completely open and the data is accessible to anyone but I am concerned that it may only be collecting very basic information on towers.  OpenSignalMaps is also popular but the data is less accessible.  And there are others like Network Cell Info and Gmon or commercial solutions like GWS.

Any researchers out there have recommendations or have a custom tool they would like to test?

_______________________________________________
gaia mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/gaia

--
+1 902 529 0046
[email-masked]<mailto:[email-masked]>
http://nsrc.org

_______________________________________________
gaia mailing list
[email-masked]<mailto:[email-masked]>
https://www.irtf.org/mailman/listinfo/gaia

---

From: Danny Iland <[email-masked]>
Date: Sun, 7 Aug 2016 13:32:27 -0700

Paul Schmitt and I used MobiLog in the Zaatari refugee camp to collect data
for this paper. We used the RSSI info and data service type to make some
interesting figures and reveal disparities in mobile data quality between
the districts of the camp.

P. Schmitt, D. Iland, E. Belding, B. Tomaszewski, Y. Xu and C.
Maitland, "Community-Level
Access Divides: A Refugee Camp Case Study
<http://people.cs.ucsb.edu/ebelding/sites/people/ebelding/files/publications/main_1.pdf>",
ICTD, Ann Arbor, MI, June 2016.

Danny

On Aug 7, 2016 6:11 AM, "Steve Song" <[email-masked]> wrote:

>> Be careful to stop it and wait for it to finish writing to file before
>> you turn off the phone. It's not very good about flushing to disk I think.
>>
>> Danny
>>

---

From: Steve Song <[email-masked]>
Date: Mon, 8 Aug 2016 15:47:10 -0300

Thanks again Jukka/Danny!

@amreesh checking out mobiperf as well.

Cheers... Steve

On 7 August 2016 at 17:32, Danny Iland <[email-masked]> wrote:

> Paul Schmitt and I used MobiLog in the Zaatari refugee camp to collect
> data for this paper. We used the RSSI info and data service type to make
> some interesting figures and reveal disparities in mobile data quality
> between the districts of the camp.
>
> P. Schmitt, D. Iland, E. Belding, B. Tomaszewski, Y. Xu and C. Maitland, "Community-Level
>> Appreciate the guidance.  Will try out both Netradar and Mobilog.  I
>> don't suppose either of you could point to papers that have been published
>> that are based on the use of these tools?
>>
>> Thanks again... Steve
>>
>>> I have used two apps in the past for this task: MobiLog and Wigle WiFi.
>>> I suggest running MobiLog and NetRadar at the same time, so you don't lose
>>> MobiLog was written by a University of Vienna grad student. it works
>>> well for logging cellular data to your phone in an easy to parse CSV file
>>> and/or KML.
>>>
>>>> open and the data is accessible to anyone but I am concerned that it may
>>>> only be collecting very basic information on towers.  OpenSignalMaps is
>>>> also popular but the data is less accessible.  And there are others like
>>>> Network Cell Info and Gmon or commercial solutions like GWS.
>>>>

-- 
+1 902 529 0046
[email-masked]
http://nsrc.org

---

From: Nick Feamster <[email-masked]>
Date: Mon, 08 Aug 2016 20:59:36 +0200

Steve, 

We maintain and use our own Android app for this, MySpeedTest: http://goo.gl/VHuh4

Periodic performance measurements, usage data, GPS, carrier  etc. Information is all logged. 

We'd be happy to work with you to tailor the app to your needs if there are specific things you're looking for. 

On August 8, 2016 8:47:10 PM GMT+02:00, Steve Song <[email-masked]> wrote:
>------------------------------------------------------------------------
>

-Nick

---

From: Steve Song <[email-masked]>
Date: Tue, 9 Aug 2016 13:47:16 -0300

Hi Nick,

Thanks for the generous offer!  I am now faced with an embarrassment of
riches when it comes to mobile phone-based network monitoring tools.  I am
going to do a little investigation into their relative features and report
back.

Cheers... Steve

On 8 August 2016 at 15:59, Nick Feamster <[email-masked]> wrote:

>>> P. Schmitt, D. Iland, E. Belding, B. Tomaszewski, Y. Xu and C. Maitland,
>>> "Community-Level Access Divides: A Refugee Camp Case Study
>>>>> I have used two apps in the past for this task: MobiLog and Wigle
>>>>> WiFi. I suggest running MobiLog and NetRadar at the same time, so you don't
>>>>> lose data if one fails. Be sure to have a battery pack as logging this once
>>>>> per second eats your phone's battery.
>>>>>
> ------------------------------
>
> gaia mailing list
> [email-masked]

-- 
+1 902 529 0046
[email-masked]
http://nsrc.org