Subject: Re: [gaia] Mobile apps for validating mobile operator coverage

From: Esteban Municio <[email-masked]>
Date: Thu, 11 Aug 2016 19:20:29 +0200

Hi,

I have used this open source app: NetworkMonitor
(https://f-droid.org/repository/browse/?fdfilter=monitor&fdid=ca.rmen.android.networkmonitor)

As the other suggested options, you can periodically collect data from
mobile networks as well as perform up/down FTP speed tests for each
location.

Danny, Nick, have you considered publish your app in a FOSS repository
such as F-Droid? I think it would be a nice contribution since they seem
very good tools

Kind regards,
Esteban

> 
> Hi Nick, 
> 
> 
> Thanks for the generous offer!  I am now faced with an embarrassment
> of riches when it comes to mobile phone-based network monitoring
> tools.  I am going to do a little investigation into their relative
> features and report back.
> 
> 
> Cheers... Steve
> 
> On 8 August 2016 at 15:59, Nick Feamster <[email-masked]>
> wrote:
>         Steve, 
>         
>         We maintain and use our own Android app for this, MySpeedTest:
>         http://goo.gl/VHuh4
>         
>         Periodic performance measurements, usage data, GPS, carrier
>         etc. Information is all logged. 
>         
>         We'd be happy to work with you to tailor the app to your needs
>         if there are specific things you're looking for. 
>         
>         On August 8, 2016 8:47:10 PM GMT+02:00, Steve Song
>         <[email-masked]> wrote: 
>                 Thanks again Jukka/Danny! 
>                 
>                 
>                 @amreesh checking out mobiperf as well.
>                 
>                 
>                 Cheers... Steve
>                 
>                 On 7 August 2016 at 17:32, Danny Iland
>                 <[email-masked]> wrote:
>                         Paul Schmitt and I used MobiLog in the Zaatari
>                         refugee camp to collect data for this paper.
>                         We used the RSSI info and data service type to
>                         make some interesting figures and reveal
>                         disparities in mobile data quality between the
>                         districts of the camp.
>                         
>                         P. Schmitt, D. Iland, E. Belding, B.
>                         Tomaszewski, Y. Xu and C. Maitland,
>                         "Community-Level Access Divides: A Refugee
>                         Camp Case Study", ICTD, Ann Arbor, MI, June
>                         2016.
>                         
>                         Danny
>                         
>                         
>                         On Aug 7, 2016 6:11 AM, "Steve Song"
>                         <[email-masked]> wrote:
>                                 Hi Jukka, Danny, 
>                                 
>                                 
>                                 Appreciate the guidance.  Will try out
>                                 both Netradar and Mobilog.  I don't
>                                 suppose either of you could point to
>                                 papers that have been published that
>                                 are based on the use of these tools?
>                                 
>                                 
>                                 Thanks again... Steve
>                                 
>                                 On 5 August 2016 at 19:06, Danny Iland
>                                 <[email-masked]> wrote:
>                                         I have used two apps in the
>                                         past for this task: MobiLog
>                                         and Wigle WiFi. I suggest
>                                         running MobiLog and NetRadar
>                                         at the same time, so you don't
>                                         lose data if one fails. Be
>                                         sure to have a battery pack as
>                                         logging this once per second
>                                         eats your phone's battery.
>                                         
>                                         http://www.valerio.im/others.html#mobilog
>                                         
>                                         MobiLog logs GPS
>                                         coordinates, Cellular Network
>                                         details (e.g. cell-IDs, RSSIs,
>                                         Neighboring Cells, Connection
>                                         States, etc.), and Wifi Access
>                                         Points information (e.g. SSID,
>                                         BSSID, RSSI, Frequency,
>                                         Encryption).
>                                         
>                                         MobiLog was written by a
>                                         University of Vienna grad
>                                         student. it works well for
>                                         logging cellular data to your
>                                         phone in an easy to parse CSV
>                                         file and/or KML.
>                                         
>                                         Be careful to stop it and wait
>                                         for it to finish writing to
>                                         file before you turn off the
>                                         phone. It's not very good
>                                         about flushing to disk I
>                                         think.
>                                         
>                                         Danny
>                                         
>                                         
>                                         On Aug 5, 2016 1:25 PM, "Steve
>                                         Song" <[email-masked]>
>                                         wrote:
>                                         
>                                                 Hi all, 
>                                                 
>                                                 
>                                                 Has anyone used mobile
>                                                 apps for
>                                                 monitoring/testing/validating mobile operator coverage in their research?  I am planning on running some tests in rural Uganda later this month.  
>                                                 
>                                                 
>                                                 My first inclination
>                                                 is to use Mozilla
>                                                 Stumbler as it is
>                                                 completely open and
>                                                 the data is accessible
>                                                 to anyone but I am
>                                                 concerned that it may
>                                                 only be collecting
>                                                 very basic information
>                                                 on towers.
>                                                 OpenSignalMaps is also
>                                                 popular but the data
>                                                 is less accessible.
>                                                 And there are others
>                                                 like Network Cell Info
>                                                 and Gmon or commercial
>                                                 solutions like GWS.
>                                                 
>                                                 
>                                                 Any researchers out
>                                                 there have
>                                                 recommendations or
>                                                 have a custom tool
>                                                 they would like to
>                                                 test?
>                                                 
>                                                 
>                                                 Many thanks... Steve
>                                                 Song
>                                                 
>                                                 
>                                                 
>                                                 
>                                                 
>                                                 
>                                                 
>                                         _______________________________________________
>                                         gaia mailing list
>                                         [email-masked]
>                                         https://www.irtf.org/mailman/listinfo/gaia
>                                         
>                                         
>                         
>                         
>                         
>                         
>                         -- 
>                         +1 902 529 0046
>                         [email-masked]
>                         http://nsrc.org
>                         
>                         
>                         
>                         
>                         _______________________________________________
>                         gaia mailing list
>                         [email-masked]
>                         https://www.irtf.org/mailman/listinfo/gaia
>                         
>                         
>         
>         
>         
>         
>         -- 
>         +1 902 529 0046
>         [email-masked]
>         http://nsrc.org
>         
>         
>         
>         
>         
>         ______________________________________________________________
>         
>         gaia mailing list
>         [email-masked]
>         https://www.irtf.org/mailman/listinfo/gaia
>         
>         
>         
>         -Nick
>         _______________________________________________
>         gaia mailing list
>         [email-masked]
>         https://www.irtf.org/mailman/listinfo/gaia
>         
> 
> 
> 
> 
> -- 
> +1 902 529 0046
> [email-masked]
> http://nsrc.org
> 
> 
> 
> 
> _______________________________________________
> gaia mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/gaia
> 
> 
> 
> 
> 
> 

-- 
Esteban Municio

---

From: Nick Feamster <[email-masked]>
Date: Thu, 11 Aug 2016 20:15:40 +0200

Esteban, 

Yes, MySpeedTest is already open sourced on Github:
https://github.com/noise-lab/MySpeedTest

We are happy to accept pull requests. 

On August 11, 2016 7:20:29 PM GMT+02:00, Esteban Municio <[email-masked]> wrote:
>>                                                 Has anyone used
>mobile
>monitoring/testing/validating mobile operator coverage in their
>research?  I am planning on running some tests in rural Uganda later
>this month.  
>>                                                 
>>                                                 
>>                                                 My first inclination
>>                                                 is to use Mozilla
>>                                                 Stumbler as it is
>>                                                 completely open and
>>                                                 the data is
>accessible
>>                                                 to anyone but I am
>>                                                 concerned that it may
>>                                                 only be collecting
>>                                                 very basic
>information
>>                                                 on towers.
>>                                                 OpenSignalMaps is
>also
>>                                                 popular but the data
>>                                                 is less accessible.
>>                                                 And there are others
>>                                                 like Network Cell
>Info
>>                                                 and Gmon or
>commercial
>>                                                 solutions like GWS.
>>                                                 
>>                                                 
>>                                                 Any researchers out
>>                                                 there have
>>                                                 recommendations or
>>                                                 have a custom tool
>>                                                 they would like to
>>                                                 test?
>>                                                 
>>                                                 
>>                                                 Many thanks... Steve
>>                                                 Song
>>                                                 
>>                                                 
>>                                                 
>>                                                 
>>                                                 
>>                                                 
>>                                                 
>>                                        

-Nick

---

From: Steve Song <[email-masked]>
Date: Thu, 11 Aug 2016 17:12:08 -0300

I've begun a table to compare the applications but will need to try them
all out live and in more detail before I can fill in everything.

@nick @esteban @danny @amreesh   If you have a minute to tick a few boxes
or make the odd comment, I'll make sure this stays a public resource.

https://docs.google.com/spreadsheets/d/1L2qTi55aDZzJuo9EgjYL_M4FxNai1RE4rpK-bMgTJr4/edit?usp=sharing

Regards... Steve Song

On 11 August 2016 at 15:15, Nick Feamster <[email-masked]> wrote:

>>>  of riches when it comes to mobile phone-based network monitor!
>>>  ing
>>>                  @amreesh checking out mobiper!
>>>  f as
>>> well.
>>>
>>>
>>>                  Cheers... Steve
>>>
>>>            !
>>>                           !
>>>           !
>>>                                          phone !
>>>  in an
>>> easy to parse CSV
>>>                                 !
>>>                                                  the data is acces!
>>>  sible
>>>                                        !
>>>                                              !
>>> ------------------------------
>>>
>>>                                          gaia mailing list
>>>                                          [email-masked]
>>> ------------------------------
>>>
>>>                          gaia mailing list
>>>                          [email-masked]
>>>
>>> ------------------------------
>>>
>>>
>>>          gaia mailing list
>>>          [email-masked]
>>> ------------------------------
>>>
>>>          gaia mailing list
>>>          [email-masked]
>>> ------------------------------
>>>
>>>  gaia mailing list
>>>  [email-masked]

-- 
+1 902 529 0046
[email-masked]
http://nsrc.org

---

From: Nick Feamster <[email-masked]>
Date: Thu, 11 Aug 2016 23:32:43 +0200

I don't have permissions to edit, but we collect and store all of the fields you list, and several others, as well (e.g., battery life, Android version, phone model, etc.). All data is logged every 15 minutes, with timestamps. 

All data is stored in a postgres database on the back end. 

On August 11, 2016 10:12:08 PM GMT+02:00, Steve Song <[email-masked]> wrote:
>>>>                                                  My first
>inclination
>>>>                                                  completely open
>and
>>>>                                                  concerned that it
>may
>>>>                                                  popular but the
>data
>>>>                                                  is less
>accessible.
>>>>                                                  And there are
>others
>>>>                                                  solutions like
>GWS.
>>>>                                                  Any researchers
>out
>>>>                                                  Many thanks...
>Steve
>------------------------------------------------------------------------
>

-Nick