Subject: [Gen-art] RE: review of draft-ietf-sieve-variables-07.txt

From: [email-masked]
Date: Thu, 27 Oct 2005 12:18:57 +0300

Hi Alexey,
>>The nit is:
>>
>>In the 1st page header, it says: "Updates: 3028"
>>
>>   In the Meta-info section, it says:
>>
>>   This draft is intended to be an extension to the Sieve mail
filtering
>>   language, available from the RFC repository as
>>   <ftp://ftp.ietf.org/rfc/rfc3028.txt>.
>>
>>--> shouldn't say what it updates (section numbers, etc.)?
>>
>RFC 3028 doesn't allow for variables. But I can't think of an obvious
>section(s) in the base document that the variables draft updates.
>
>> <> Also shouldn't this info be carried in the Abstract?
>
>It is already described in details:
>
>   In advanced mail filtering rule sets, it is useful to keep state or
>   configuration details across rules.  This extension to the filtering
>   language Sieve changes the interpretation of strings, adds an action
>   to store data in variables, and supplies a new test so that the
value
>   of a string can be examined.

So, if the Abstract would say:

 This updates RFC3028 with an extension to support variables ins mail 
 filtering rule sets.

(or something along those lines) then I'd be statisfied.

thanks,
John

_______________________________________________
Gen-art mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gen-art

---

From: [email-masked]
Date: Thu, 27 Oct 2005 12:20:03 +0300

One more note, as this is a General Area Review, is the background:

GenART is the Area Review Team for the General Area of the IETF.

We advise the General Area Director (i.e. the IETF/IESG chair) by
providing more in depth reviews than he could do himself of documents
that come up for final decision in IESG telechat.  I was selected as the
GenART member to review this document.  Below is my review, which was
written specifically with an eye to the GenART process, but since I
believe that it will be useful to have these comments more widely
distributed, others outside the GenART group are included.

Review criteria for WG submissions: "Is this document a reasonable
contribution to the area of Internet engineering which it covers? If
not, what changes would make it so?" 

thanks,
John
>-----Original Message-----
>From: ext Alexey Melnikov [mailto:[email-masked]] 
>Sent: 27 October, 2005 12:14
>To: Loughney John (Nokia-NRC/Helsinki)
>Cc: [email-masked]; [email-masked]
>Subject: Re: review of draft-ietf-sieve-variables-07.txt
>
>[email-masked] wrote:
>
>>A quick gen-art review.
>>
>>One line summary: "Ready, with one nit."
>>
>>The nit is:
>>
>>   This draft is intended to be an extension to the Sieve 
>mail filtering
>   to store data in variables, and supplies a new test so that 
>the value
>Regards,
>Alexey