Subject: [Gen-art] RE: Gen-art review: draft-ietf-ltru-registry-13.txt

From: "Addison Phillips" <[email-masked]>
Date: Mon, 10 Oct 2005 09:15:34 -0700

Dear Elwyn,

Thank you again for reviewing the LTRU documents. The minor nit I will correct in my editor's copy.

The original draft you reviewed did not include text to generate registration forms for the initial registry. Doing so would be, in my opinion, a colossal waste of time. In fact, I question the wisdom of archiving any registration records separate from the registry itself. Part of the point of having a registry is to have a single authoritative source and stability guarantees in draft-registry help ensure that the state of the registry at any point in time is highly compatible with previous versions of the registry.

It is the case that the initial state of the registry cannot be recaptured in its entirety, but the initial set of records can be identified (no records may ever be removed and deprecations include a deprecation date). I'm not sure why the initial registry state would be of particular interest, except as a curiosity. The underlying ISO standards and RFC 1766/3066 have functioned well enough with *no* stable reference to this information. 

Therefore I suggest that this comment be rejected by the WG. I could see maintaining a copy of the registry in draft-initial, if the IESG feels it is important to capture the initial state for posterity. I just don't think generating several hundred artificial registration forms is of any use to anyone.

Best Regards,

Addison

Addison P. Phillips
Globalization Architect, Quest Software
Chair, W3C Internationalization Core Working Group

Internationalization is not a feature.
It is an architecture. 
> -----Original Message-----
> From: Elwyn Davies [mailto:[email-masked]]
> Sent: Monday, October 10, 2005 4:49 AM
> To: [email-masked]
> Cc: Randy Presuhn; Mary Barnes; Scott Hollenbeck; [email-masked];
> Addison Phillips
> Subject: Gen-art review: draft-ietf-ltru-registry-13.txt
> 
> Background for those on the CC list, who may be unaware of GenART:
> GenART is the Area Review Team for the General Area of the IETF.  We
> advise the General Area Director (i.e. the IETF/IESG chair) by providing
> more in depth reviews than he could do himself of documents that come up
> for final decision in IESG telechat.  I was selected as the GenART
> member to review this document.  Below is my review, which was written
> specifically with an eye to the GenART process, but since I believe that
> it will be useful to have these comments more widely distributed, others
> outside the GenART group are being copied.
> 
> Document: draft-ietf-ltru-registry-13.txt
> Intended Status: BCP
> Shepherding AD: Scott Hollenbeck
> PROTO Shepherd: Randy Presuhn
> Review Trigger: IESG Telechat, 13 November 2005
> 
> LC Date:  06 Sept 2005
> 
> Review: This document is generally in good shape and well written but is
> almost
> ready for publication, subject to one issue and an editorial nit:
> 
> 
> S3.1, para 1, last sentence: Unfortunately there has been an interaction
> between
> two sets of last call comments which has lead to a problem.
> 
> When I reviewed this document for last call the corresponding registry
> initialisation document  (draft-ietf-ltru-initial-04.txt) was going
> to contain an archival list of all the subtags that were going to be
> registered
> initially.  I therefore made the point that generating registration forms
> for them was rather redundant.  The authors and wg accepted this and s3.1
> was
> changed accordingly.
> 
> In the meantime, another last call reviewer suggested that maintaining the
> list
> in the initialisation document was dangerous as it might be
> used instead of the registry itself. This comment was also accepted and so
> draft-ietf-ltru-initial-05.txt has instructions to remove the actual list
> before publication.
> 
> This means that we have gone from the position where there would have been
> two
> records of the initial registrations to one where there will now be zero
> records.  This is almost certainly not desirable.
> 
> So I guess we should go back to the original wording from v11 of this
> draft
> which requires the creation of registration forms for the extra  (non-3066)
> items registered when the new registry is created.
> 
> Editorial nit:
> The new title of Figure 2 should be 'Registry Record Format' and not
> 'record-jar format' (which it isn't in any case).
> 
> 
> 
> 

_______________________________________________
Gen-art mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gen-art

---

From: Elwyn Davies <[email-masked]>
Date: Mon, 10 Oct 2005 23:45:09 +0100

If all concerned are happy with this situation, then that's fair enough
- in practice the old versions of the I-D could be resurrected if some
sort of disaster overtook the registry.

Regards,
Elwyn

---

From: "Randy Presuhn" <[email-masked]>
Date: Mon, 10 Oct 2005 16:07:19 -0700

Hi -

I believe the discussion on the ltru WG mailing list of the IETF last call comments
from Elwyn Davies and Scott Bradner made it clear that the WG didn't see
any particular value to preserving those bits of history, particularly when
their preservation increases risk or complexity.  Making the initial regsitry
RFC content-free satisfied Scott's concerns; and I think Addison's assessment
of the non-value of generating registration forms for the initial registry is correct,
though I'd like the rest of the WG to confirm whether they do or don't see value
to creating these.  As I see it, the desire to avoid pointless effort is what motivated
the initial registry document in the first place.

So, I concur that (1) the title for figure 2 be fixed in AUTH48 or in
the next update, should a new i-d be needed for whatever reason; and
(2) that we should *not* accept the other proposed Gen-art change,
since no one involved in the registry work needs or wants these additional
records to be generated.

If you seriously object to this proposed resolution, please speak up.

Randy, ltru co-chair

> From: "Addison Phillips" <[email-masked]>
> To: "Elwyn Davies" <[email-masked]>; <[email-masked]>
> Cc: "Randy Presuhn" <[email-masked]>; "Mary Barnes" <[email-masked]>; "Scott Hollenbeck"
<[email-masked]>; <[email-masked]>
> Sent: Monday, October 10, 2005 9:15 AM
> Subject: RE: Gen-art review: draft-ietf-ltru-registry-13.txt
>

> Dear Elwyn,
>
> Thank you again for reviewing the LTRU documents.
> The minor nit I will correct in my editor's copy.
>
> The original draft you reviewed did not include text to generate
> registration forms for the initial registry. Doing so would be,
> in my opinion, a colossal waste of time. In fact, I question the
> wisdom of archiving any registration records separate from
> the registry itself. Part of the point of having a registry is to have
> a single authoritative source and stability guarantees in draft-registry
> help ensure that the state of the registry at any point in time is highly
> compatible with previous versions of the registry.
>
> It is the case that the initial state of the registry cannot be
> recaptured in its entirety, but the initial set of records can be
> identified (no records may ever be removed and deprecations
> include a deprecation date). I'm not sure why the initial registry
> state would be of particular interest, except as a curiosity. The
> underlying ISO standards and RFC 1766/3066 have functioned
> well enough with *no* stable reference to this information.
>
> Therefore I suggest that this comment be rejected by the WG.
> I could see maintaining a copy of the registry in draft-initial,
> if the IESG feels it is important to capture the initial state for posterity.
> I just don't think generating several hundred artificial registration
> forms is of any use to anyone.
>
> Best Regards,
>
> Addison
>
> Addison P. Phillips