Subject: RE: [Gen-art] Assignment: draft-ietf-netconf-prot-11.txt

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 24 Feb 2006 15:26:12 -0500

This looks very close.
There is one thing that I think needs to be handled, and one question.

Firstly, the text refers to "the <url> element can appear as the 
<config> parameter..."  As such, there appears to be a requirement 
that whatever the data model defines <config> to be, it must be 
allowed to have a URL as its contents.  Can we say this somehow in 7.2?

Secondly, the examples all seem to assume an outer <top> element in 
the config.  I can not actually tell if this is required.  If it is, 
should we say something about that in 7.2?

Thanks for taking the time to address this,
Joel

At 03:15 PM 2/24/2006, Rob Enns wrote:
>Hi Joel,
>
>Netconf is content agnostic.  .....
>
>You are right that we never connect this back to the contents
>of the <config> element, and we should.  How about adding the
>following to section 5.2:
>
>
>     NETCONF carries configuration data inside the <config> element
>     that is specific to device's data model.  The protocol treats the
>     contents of that element as opaque data.  The device uses
>     capabilities to announce the set of data models which the
>     device implements.  The capability definition details the
>     operation and constraints imposed by data model.
>
>     Devices and managers may support multiple data models,
>     including both standard and proprietary data models.
>
>The discussion of the <config> element in section 7.2 should also be
>expanded.  How about the following?
>
>       config:
>
>         A hierarchy of configuration data as defined by one of the
>         device's data models.  The contents MUST be placed in an
>         appropriate namespace, to allow the device to detect the
>         appropriate data model, and the contents MUST follow the
>         constraints of that data model, as defined by its capability
>         definition.  Capabilities are discussed in section XXX.

_______________________________________________
Gen-art mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gen-art

---

From: "Rob Enns" <[email-masked]>
Date: Fri, 24 Feb 2006 12:15:48 -0800

Hi Joel,

Netconf is content agnostic.  On page 8, the draft says:

   4.  The content layer is outside the scope of this document.  Given
       the current proprietary nature of the configuration data being
       manipulated, the specification of this content depends on the
       NETCONF implementation.  It is expected that a separate effort to
       specify a standard data definition language and standard content
       will be undertaken.

and on page 17:

 5.2.  Data Modeling

   Data modeling and content issues are outside the scope of the NETCONF
   protocol.  An assumption is made that the device's data model is
   well-known to the application and that both parties are aware of
   issues such as the layout, containment, keying, lookup, replacement,
   and management of the data, as well as any other constraints imposed
   by the data model.

      config:

> -----Original Message-----
> From: Joel M. Halpern [mailto:[email-masked]] 
> Sent: Friday, February 24, 2006 8:16 AM
> To: Mary Barnes; [email-masked]
> Cc: [email-masked]; Rob Enns; Simon Leinen; Andy Bierman
> Subject: Re: [Gen-art] Assignment: draft-ietf-netconf-prot-11.txt
> 
> This document is almost ready for publication as a Proposed Standard.
> 
> While they have fixed several of my concerns, I still can not find 
> any description of the <config> element.  Given that this document 
> makes use of the fact that it may contain a URL, and that it makes 
> other structural assumptions, it seems that <config> structure can 
> not be considered to be only part of the data model.
> I can not find any comments from the authors in my records.  It is 
> possible that they provided a good reason for not addressing this, 
> and I have lost it.
> It is also possible that there is a change I missed in the document 
> which addresses this.
> 
> Yours,
> Joel M. Halpern
> 
> -------
> OPS  Feb 23
>    Two-Document ballot: 
> <https://datatracker.ietf.org/public/pidtracker.cgi?command=pr
> int_ballot&ballot_id=1768&filename=draft-ietf-netconf-prot>[Open 
> Web Ballot] - 7 of 16
>    NETCONF Configuration Protocol (Proposed Standard) - 7 of 16
>      
> <http://www.ietf.org/internet-drafts/draft-ietf-netconf-prot-1
> 1.txt>draft-ietf-netconf-prot-11.txt 
> 
> 
> Token: <mailto:[email-masked]>Bert Wijnen
> Reviewer: Joel Halpern (reviewed -10 and -05 respectively for LC)
>

---

From: Phil Shafer <[email-masked]>
Date: Fri, 24 Feb 2006 15:41:34 -0500

>allowed to have a URL as its contents.  Can we say this somehow in 7.2?

I think this is a bug.  The contents of the <config> element
are data-model specific, so an <url> element would conflict
with this idea, and disturb the opaqueness of the <config>
element.  The <url> is the <source> and <target> elements
of other RPCs works well, but <url> inside <config> seems
like a conflict.

>should we say something about that in 7.2?

<top> is just an example top-level element for a fictional
data model.  We should explicitly state this.

Thanks,
 Phil

---

From: Andy Bierman <[email-masked]>
Date: Fri, 24 Feb 2006 14:49:42 -0800

> allowed to have a URL as its contents.  Can we say this somehow in 7.2?

No.
<url> appears instead of the <config> element.
It is not part of any data model.

> should we say something about that in 7.2?

The <top> element is just an example.
I guess the document could stress that the examples
are not normative.
Data model content is not in any way constrained by the
examples in this draft.

> Thanks for taking the time to address this,

Andy

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 24 Feb 2006 18:14:41 -0500

I can see, given this clarification, how the text in 7.2 can mean that.
How about, instead of "the <url> element can appear as the <config> 
parameter" we change "as" to "instead of", so taht the sentences 
becomes "the <url> element can appear instead of the <config> parameter".
I certainly did not realize in reading that this was the intent.
With the other tweaks Rob has suggested, this would clarify that 
<config> really is out of scope for this document.

Yours,
Joel