Subject: RE: [Gen-art] Assignment: draft-ietf-netconf-prot-11.txt

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Sat, 25 Feb 2006 00:00:53 +0100

[adding my successor Dan Romascanu]
Phil,

can you for now just give me all the required changes in
the form of

-- page xx
   OLD:
     old text
   NEW:
     new text or additional text.

So that for now I can do them as a "Note to RFC-Editor".
If we end up with too many I may ask for another rev, but
if it is containable, then a note-to-rfc-ed may be fastest.

Thanks,
Bert
> -----Original Message-----
> From: Phil Shafer [mailto:[email-masked]]
> Sent: Friday, February 24, 2006 21:42
> To: Joel M. Halpern
> Cc: Rob Enns; Mary Barnes; [email-masked]; [email-masked]; Simon
> Leinen; Andy Bierman
> Subject: Re: [Gen-art] Assignment: draft-ietf-netconf-prot-11.txt 
> 
> 
> "Joel M. Halpern" writes:
> >Firstly, the text refers to "the <url> element can appear as the 
> ><config> parameter..."  As such, there appears to be a requirement 
> >that whatever the data model defines <config> to be, it must be 
> >allowed to have a URL as its contents.  Can we say this 
> somehow in 7.2?
> 
> I think this is a bug.  The contents of the <config> element
> are data-model specific, so an <url> element would conflict
> with this idea, and disturb the opaqueness of the <config>
> element.  The <url> is the <source> and <target> elements
> of other RPCs works well, but <url> inside <config> seems
> like a conflict.
> 
> >Secondly, the examples all seem to assume an outer <top> element in 
> >the config.  I can not actually tell if this is required.  If it is, 
> >should we say something about that in 7.2?
> 
> <top> is just an example top-level element for a fictional
> data model.  We should explicitly state this.
> 
> Thanks,
>  Phil
> 

_______________________________________________
Gen-art mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gen-art

---

From: "Rob Enns" <[email-masked]>
Date: Fri, 24 Feb 2006 16:05:06 -0800

Yes, s/as/instead of/ in 7.2, it was very misleading as written. 
The XSD is accurate in this respect so the wording change should be
all we need to clarify this point. I'll get an updated list of 
changes into another email.

Rob

> From: Joel M. Halpern [mailto:[email-masked]] 
> Sent: Friday, February 24, 2006 3:15 PM
> To: Andy Bierman
> Cc: Rob Enns; Mary Barnes; [email-masked]; 
> [email-masked]; Simon Leinen; Phil Shafer
> I can see, given this clarification, how the text in 7.2 can 
> mean that.
> How about, instead of "the <url> element can appear as the <config> 
> parameter" we change "as" to "instead of", so taht the sentences 
> becomes "the <url> element can appear instead of the <config> 
> parameter".
> I certainly did not realize in reading that this was the intent.
> With the other tweaks Rob has suggested, this would clarify that 
> <config> really is out of scope for this document.
> 
> Yours,
> Joel
> 
> At 05:49 PM 2/24/2006, Andy Bierman wrote:
> >No.
> ><url> appears instead of the <config> element.
> >It is not part of any data model.
>