Subject: [Gen-art] review of draft-eastlake-sha2-01.txt

From: [email-masked]
Date: Wed, 1 Feb 2006 14:29:22 +0200

Brian filed a discuss on this - I agree with it:

>Discuss:
>11. Security Considerations
>
>    This document is intended to provide convenient open source access
by
>    the Internet community to the United States of America Federal
>    Information Processing Standard Secure Hash Algorithms (SHAs) [FIPS
>    180-2] and HMACs based thereon.
>
>"open source access"? RFCs don't carry an open source license. 
>I believe this should just read "open access".

I note that the Abstract says:

Abstract

   The United States of America has adopted a suite of secure hash
   algorithms (SHAs), including four beyond SHA-1, as part of a Federal
   Information Processing Standard (FIPS), specifically SHA-224 [RFC
   3874], SHA-256, SHA-384, and SHA-512.  The purpose of this document
   is to make open source code performing these hash functions
   conveniently available to the Internet community.  ....

I think this should be updated accordingly as well.

John

_______________________________________________
Gen-art mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gen-art

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 01 Feb 2006 16:50:48 +0100

Yes, and in fact there is already an RFC Editor note
to fix this, and also a -02 version, so I was able to clear
my discuss. (We had an IESG retreat Monday and Tuesday,
so a number of discusses got cleared during coffee breaks.)

Thanks

     Brian