Subject: [Gen-art] review of draft-crockford-jsonorg-json-03.txt

From: Scott W Brim <[email-masked]>
Date: Mon, 27 Feb 2006 10:39:22 -0500

For more info on GEN-ART reviews, see
http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html

I just have two small questions, perhaps silly.

(1) Apparently all JSON texts are preceded with whitespace.  True?

      JSON-text = object / array
      begin-array     = ws %x5B ws  ; [ left square bracket
      begin-object    = ws %x7B ws  ; { left curly bracket

(2) "A number contains an integer component which may be prefixed with
an optional minus sign"

  Is an optional plus sign allowed?

_______________________________________________
Gen-art mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gen-art

---

From: Douglas Crockford <[email-masked]>
Date: Mon, 27 Feb 2006 08:32:23 -0800 (PST)

Not silly.

(1) No, JSON texts are not necessarily preceded by whitespace. The ws rule shows that whitespace is optional. 

(2) No, a plus sign is not allowed.