Subject: [Gen-art] GenART review of draft-ietf-imapext-condstore-08.txt

From: [email-masked]
Date: Thu, 9 Feb 2006 01:59:39 -0500

Background for those who may be unaware of GenART:

GenART is the Area Review Team for the General Area of the IETF.
We advise the General Area Director (i.e. the IETF/IESG chair) by
providing more in depth reviews than he could do himself of documents
that come up for final decision in IESG telechat.  I was selected
as the GenART member to review this document.  Below is my review,
which was written specifically with an eye to the GenART process, but
since I believe that it will be useful to have these comments more
widely distributed, others outside the GenART group are included.

This review was done as part of IETF Last Call.

Review criteria: "Is this document a reasonable contribution to the
area of Internet engineering which it covers?  If not, what changes
would make it so?"

This draft is basically ready for publication as a Proposed
Standard RFC, but has nits that should be fixed before publication.

The formatting of this draft is awful, as it takes ragged
right to a whole new level.  The idnits checker is not happy
about this or the lack of proper page separators, both of which
are already covered in Bert Wijnen's nits Comment in IESG discussion.

The table of contents is missing all of its page numbers.

The first portion of Section 2 is unclear as to whether it
is describing the elsewhere-specified behavior of IMAP vs.
imposing new requirements.  A check of RFC 3501 indicates
that the entire notion of mod-sequence is new to this draft.
The first sentence of the second paragraph is the problem -
is should be rephrased to something like:

   An IMAP server that supports this extension MUST associate
   a positive unsigned 64-bit value called a modification
   sequence (mod-sequence) with every IMAP message.

Beyond this, the draft is well-written with extensive
examples that will be of great use to implementers.

Thanks,
--David
----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

_______________________________________________
Gen-art mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gen-art

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 09 Feb 2006 11:16:45 +0000

>The table of contents is missing all of its page numbers.
Right.
Firstly, this document is a minor updated to an already approved 
document, the original document predates IDnits. I didn't want to do any 
major reformatting, as this would make diffing the changes very difficult.
Secondly, I think an RFC editor is perfectly capable of fixing all these 
issues.

>   sequence (mod-sequence) with every IMAP message.
Sounds good. I will make sure this text is added.

>examples that will be of great use to implementers.
Thank you for the review.
Alexey

---

From: Alexey Melnikov <[email-masked]>
Date: Fri, 10 Feb 2006 13:20:39 +0000

>   sequence (mod-sequence) with every IMAP message.
I've replaced the first sentence of the second paragraph with the one 
you've suggested.
(-09 is coming out soon).