Subject: [Gen-art] Re: Gen-Art review of draft-ietf-bmwg-dsmterm-12.txt (Information al)

From: Scott W Brim <[email-masked]>
Date: Tue, 13 Jun 2006 18:37:09 -0400

I'm quite happy.  Thanks.

See you ... Scott

On 06/13/2006 18:20 PM, [email-masked] allegedly wrote:
> Hi Scott,
> 
> Thank you for your helpful input.  To your first point, for which I agree, I
> would like to change the Abstract and text for the term Classification to be
> in the -13 rev as follows:
> 
> Abstract       
>      This document describes terminology for the benchmarking of 
>      devices that implement traffic control using packet classification 
>      based on defined criteria.  The terminology is to be applied to 
>      measurements made on the data plane to evaluate IP traffic control 
>      mechanisms.  Rules for packet classification can be based on any 
>      field in the IP header, such as DSCP, or field in the packet 
>      payload, such as port number.
> 
> 3.1.1 Classification 
>       
>         Definition: 
>           Selection of packets according to defined rules. 
>       
>         Discussion: 
>           Classification determines the per-hop behaviors and traffic 
>           conditioning functions such as shaping and dropping that 
>           are to be applied to the packet. 
> 
>           Classification of packets can be made based on the DS field 
>           or IP Precedence in the packet header.  Classification can 
>           be based on other IP header fields such as IP Source 
>           Address (SA), Destination Address (DA), and protocol, or 
>           fields in the packet payload such as port number.  
>           Classification can also be based on ingress interface.
>           It is possible to classify based on Multi-Field (MF) 
>           criteria such as IP source and destination addresses, 
>           protocol and port number. 
> 
> Do you agree with the changes to this text?
> 
> For you second point, those questions are important, but I believe to be
> more appropriate for the Methodology document currently being worked for
> this agenda item.
> 
> Please let me know if you have any further input.
> 
> Thank you,
> Scott
> 
> -----Original Message-----
> From: Scott W Brim [mailto:[email-masked]]
> Sent: Thursday, June 01, 2006 7:36 AM
> To: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; Al Morton; General Area Review Team; David
> Kessens
> Subject: Gen-Art review of draft-ietf-bmwg-dsmterm-12.txt
> (Informational)
> 
> 
> Oops, I missed this one.  I hope this late comment is useful in some
> way.
> 
> Gen-Art front boilerplate:
> 
>         I am the assigned Gen-ART reviewer for
>         draft-ietf-bmwg-dsmterm-12.txt.
> 
>         For background on Gen-ART, please see the FAQ at
>         <http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html>.
> 
>         Please wait for direction from your document shepherd or AD
>         before posting a new version of the draft.
> 
> Review summary: This draft is basically ready but has nits.
> 
> Review comments:
> 
> In addition to what others have already said, consider
> 
>     3.1.1 Classification
> 
>     Definition:
>       Selection of packets based on the contents of packet header
>       according to defined rules.
> 
>     Discussion:
>       Packets can be selected based on the DS field or IP
>       Precedence in the packet header.  Classification can also be
>       based on Multi-Field (MF) criteria such as IP Source and
>       destination addresses, protocol and port number.
> 
>       Classification determines the per-hop behaviors and traffic
>       conditioning functions such as shaping and dropping that are
>       to be applied to the packet.
> 
> The abstract says this draft is about "devices that implement traffic
> control based on IP precedence or diff-serv code point criteria." I
> see from the above Section 3.1.1 that such devices could use more than
> the diffserv field. That's better, but then you limit what can be used
> to just the packet header. In fact **classification** can be done on
> anything, including what's in the payload, for example whether a
> packet is HTTP.  It can even be done on input interface (real and/or
> virtual), etc.  What do you think of generalizing the definition to
> something simple such as "selection of packets according to defined
> rules", and then add another phrase to the first paragraph of the
> discussion, for example "or fields in the packet payload".
> 
>      
> 
> One more comment:
> 
>     3.2.1 Forwarding Capacity
> 
> I don't see anywhere where time interval is brought into play -- do
> you distinguish between measurements over short versus "long" amounts
> of time (burst versus sustained)?
> 
> Thanks ... Scott

_______________________________________________
Gen-art mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gen-art

---

From: [email-masked]
Date: Tue, 13 Jun 2006 18:20:44 -0400

Hi Scott,

Abstract       

3.1.1 Classification 
      
        Definition: 
      
        Discussion: 

Thank you,
Scott

-----Original Message-----
From: Scott W Brim [mailto:[email-masked]]
Sent: Thursday, June 01, 2006 7:36 AM
To: [email-masked]; [email-masked]; [email-masked];
[email-masked]; Al Morton; General Area Review Team; David
Kessens
Subject: Gen-Art review of draft-ietf-bmwg-dsmterm-12.txt
(InFrom [email-masked] Tue Jun 13 21:45:26 2006
From: [email-masked]
To: [email-masked], [email-masked], [email-masked], 
	[email-masked], [email-masked], [email-masked], 
	[email-masked], [email-masked]
Date: Tue, 13 Jun 2006 18:20:44 -0400
Cc: 
Subject: [Gen-art] RE: Gen-Art review of draft-ietf-bmwg-dsmterm-12.txt
	(Information al)

Hi Scott,

Abstract       

3.1.1 Classification 
      
        Definition: 
      
        Discussion: 

Thank you,
Scott

-----Original Message-----
From: Scott W Brim [mailto:[email-masked]]
Sent: Thursday, June 01, 2006 7:36 AM
To: [email-masked]; [email-masked]; [email-masked];

Review comments:

    3.1.1 Classification

    Definition:

    Discussion:

One more comment:

Thanks ... Scott