Subject: [Gen-art] Gen-ART review of draft-ietf-crisp-iris-xpc-04.txt

From: [email-masked]
Date: Thu, 24 Aug 2006 16:26:41 -0400

I am the assigned Gen-ART reviewer for draft-ietf-crisp-iris-xpc-04.txt
.

For background on Gen-ART, please see the FAQ at
<http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html>.

Please resolve these comments along with any other
Last Call comments you may receive.

This draft is on the right track but has open issues,
described in the review.

I found one open issue - Section 14's discussion of the use
of SASL is incomplete, as it does not satisfy the requirements
stated in Section 4 of RFC 4422.  See Section 4 of RFC 4422.

I also found a few minor concerns/nits:

Sections 5 and 6 ought to contain ASCII diagrams of the
bit fields in the Block Header and Chunk Descriptor.

The discussion of chunk ordering in Section 6 on p.9
combines restrictions on which chunk types may co-exist
in a single block with requirements on ordering of those
types within a block.  The combined discussion is somewhat
confusing - it would be clearer if these two topics were
separated - specify what is allowed within a single block,
then specify ordering requirements for what is allowed.

Section 9 should state how the client and server determine
whether TLS is to be used.  Since well-known ports are
registered for both XPC and XPCS, this appears to be
determined by client selection of which server port to use.

Thanks,
--David
----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

_______________________________________________
Gen-art mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gen-art

---

From: Andrew Newton <[email-masked]>
Date: Thu, 24 Aug 2006 16:37:36 -0400

David,

Thanks for the feedback.  This is very helpful.

-andy