Subject: [Gen-art] Gen-ART LC review of draft-ietf-dhc-dhcpv6-opt-dnsdomain-03.txt

From: "Gray, Eric" <[email-masked]>
Date: Fri, 29 Sep 2006 11:32:11 -0400

Authors,

	I am the the assigned General Area Review Team (Gen-ART) 
reviewer for this draft (for background on Gen-ART, please see 
http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html). 

	Please resolve these comments along with any other Last 
Call comments you may receive. 

Document: 
--------

            Domain Suffix Option for DHCPv6
      <draft-ietf-dhc-dhcpv6-opt-dnsdomain-03.txt>

Reviewer: Eric Gray

Review Date: 9/30/2006

IETF LC Date: through 10/10/2006

Summary:
-------

	This draft is not quite ready for publication as a 
Proposed Standard. 

Comments:  

	The relatively minor shortcomings of this draft have been
exhaustively digested on the following lists:

	DHC Working Group ([email-masked])
	IETF-Announce ([email-masked])
	IETF-Discussion ([email-masked])

People commenting in the (public) discussion include all of the 
following (no special order - some complaining, some defending):

	John C Klensin
	Frank Ellermann
	Jeffrey Hutzelman
	Ralph Droms
	Matt Larson
	David W Hankins
	Dave Crocker
	Fred Baker
	Harald Alvestrand
	Keith Moore
	Stig Venaas

	The draft is 5 pages long - meaning that it has less than two 
pages of non-template content.

	If any one thing has emerged consistently in the discussion,
it is that there are some areas that need clearing up.  I have been
following the discussion, and have reviewed the document itself.  I
have nothing new to add to this discussion except to congratulate 
the authors on having created so succinct an Internet Draft as a
candidate for Proposed Standard.

	However, I fully support Ralph Droms' suggestion that the ID
be taken back under the DHC working group aegis (cooperating with 
the DNSOP working group) and modified - per his suggestions - i.e.

	1. clarify the use case motivating this option
	2. clarify/reword the phrase "domain suffix"
	3. simplify the reference to RFC 1035 encoding

I would add to this, in addition, that the clarifications referred 
to in number 2 above should include clarifying the entire phrase 
starting with:

"The domain suffix in the 'domain suffix' field MUST include only one
 item, ..."

	From the discussion, I believe that phrases "domain suffix" and 
"one item" both need some clarification.

--
Eric Gray

_______________________________________________
Gen-art mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gen-art

---

From: Jari Arkko <[email-masked]>
Date: Fri, 29 Sep 2006 20:57:35 +0300

Thank you for your review. The draft is indeed going
back to the WG (and sent to the DNS related WGs for
discussion as well).

--Jari