Subject: [Gen-art] Re: Gen-ART review of draft-ietf-enum-validation-arch-03.txt

From: Alexander Mayrhofer <[email-masked]>
Date: Mon, 04 Sep 2006 13:32:16 +0200

[email-masked] wrote:
> The example in Figure 2 uses what appear to be real phone
> numbers (or what could be real phone numbers) in Switzerland.
> That's not a good idea - see Section 3, subsection 6 of:
> 
> 	http://www.ietf.org/ID-Checklist.html
> 
> It's not clear to me whether the fictitious phone numbers described
> in the ID-Checklist are sufficient for the examples required
> in Figure 2.  If fictitious phone numbers in Switzerland are used,
> please describe them as fictitious and please provide the IESG
> with a reference showing that they are fictitious so that they
> can be added to the Checklist's list of available fictitious
> phone numbers.

David,

thanks for performing the review. We have discussed the issue, and would
appreciate feedback on how to proceed. Here's what we've got:

- Drama numbers seem to be available in +1 (North America etc.) and +44
(UK). There are no drama numbers in Switzerland and Austria (although the
Austrian Regulator RTR recommends to use incomplete numbers (eg. truncated
by 2 or 3 digits). The allocation policies in the ranges from which those
drama numbers are taken fulfill the "Variant 1" case (assignment via CSP).

- However, none of those +1/+44 drama numbers have assignment policies which
fulfill the "Variant 2" case (direct assignment to user)

So, our choices now are:

- Leave the number out completely in the example of variant 2.
- Use a drama number for variant 2, nevertheless it would _not_ be assigned
that way, and add a note about this deficiency.
- Use truncated "real" numbers as recommended by the Austrian Regulator.

We'd appreciate feedback on what would be preferred - probably this can even
be addressed in a completely different way?

thanks,

Alex & Bernie.

_______________________________________________
Gen-art mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gen-art

---

From: "Richard Shockey" <[email-masked]>
Date: Mon, 4 Sep 2006 09:57:31 -0400

You have two choices one respin the document and we proceed as normal. 

This is a very very minor editorial comment that does not affect the WG last
call or IESG approval.

The second alternative is a note to the RFC editor when it goes into 48 hour
last call.

I don't understand why drama numbers have to have assignment policies they
are just numbers.

> -----Original Message-----
> From: Alexander Mayrhofer [mailto:[email-masked]]
> Sent: Monday, September 04, 2006 7:32 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: Re: Gen-ART review of draft-ietf-enum-validation-arch-03.txt
>

---

From: [email-masked]
Date: Mon, 4 Sep 2006 17:15:45 -0400

Richard and Alex,

> This is a very very minor editorial comment that does not 
> affect the WG last call or IESG approval.

At least for IESG approval, I believe that's incorrect, as I
believe I've seen an AD Discuss promised on this issue for a
different draft.  The phone number item is in the ID-Checklist
for good reasons.  Ultimately, this is Brian Carpenter's call,
as I'm effectively his reviewer.

IMHO, variant 1 clearly ought to use fictitious or drama numbers.
For variant 2, Alex's alternatives of using a fictitious or drama
number and explaining that it wouldn't be allocated that way makes
sense:

> > - Use a drama number for variant 2, nevertheless it would
> > _not_ be assigned that way, and add a note about this deficiency.

There's precedent for this, as RFC 4632 (the new CIDR RFC) does
something analogous with Internet address allocation - that RFC uses
private address space blocks (e.g., 10.0.0.0/8, see RFC 1918) in its
examples of allocation of global Internet addresses, even though the
private addresses aren't globally routable and hence would never be
allocated by a service provider as global Internet addresses.  The
clarity of the examples does not seem to be affected.

OTOH, if there is a good reason for not using US or UK numbers in
the examples, use of a truncated number may be ok.

Thanks,
--David
----------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

> From: Richard Shockey [mailto:[email-masked]] 
> Sent: Monday, September 04, 2006 9:58 AM
> To: 'Alexander Mayrhofer'; Black, David
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]
> Subject: RE: Gen-ART review of draft-ietf-enum-validation-arch-03.txt
> 
> 
>

---

From: "Richard Shockey" <[email-masked]>
Date: Mon, 4 Sep 2006 17:32:46 -0400

Hense your opinion is to respin the document??? <please comment>

I certainly have no problem with that as far as the WG goes this is a
editorial change and does not change the consensus of the WG. 

Patrik? Concur? 

> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, September 04, 2006 5:16 PM
> To: [email-masked]; [email-masked]
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]

---

From: Alexander Mayrhofer <[email-masked]>
Date: Tue, 05 Sep 2006 09:28:20 +0200

> editorial change and does not change the consensus of the WG. 

As far as i understood we should change the example to contain drama
numbers, and have the publication process continue from where the document
is right now (-> Writeup -> IESG Eval).

comments?

Alex

---

From: Alexander Mayrhofer <[email-masked]>
Date: Mon, 11 Sep 2006 10:40:20 +0200

Patrik Fältström wrote:
> On 4 sep 2006, at 23.32, Richard Shockey wrote:
> 
> The numbers should be changed according to the id nits. I do not hear
> any reason why the numbers can NOT be according to the suggested policy.
> 

We've done exactly that in version -04.

thanks,

Alex

---

From: Patrik Fältström <[email-masked]>
Date: Mon, 11 Sep 2006 09:51:42 +0200

Patrik -- after 1 week of vacation...

>>>> drama numbers are taken fulfill the "Variant 1" case (assignment  
>>>> via
>> CSP).
>>>>

---

From: Patrik Fältström <[email-masked]>
Date: Mon, 11 Sep 2006 11:11:12 +0200

> We've done exactly that in version -04.

Sorry, I have had a number of weeks of vacation, and decided this  
morning to go through the 500 unread email I had...

    Patrik