Subject: [Gen-art] RE: Gen-ART review of draft-ietf-enum-validation-arch-04.txt

From: "Wijnen, Bert (Bert)" <[email-masked]>
Date: Mon, 11 Sep 2006 17:48:44 +0200

W.r.t. the ID-Checklist.
http://www.ietf.org/ID-Checklist.html ietm 6.c

I don't think we want that checklist to enumerate all possible 
phone numbers that can be used as examples. We just give an 
example. 

Having said that, it might be good to point out that the ones 
listed are just 2 example ranges, and that others may exist.

David, are you saying that the example for the UK includes
numbers that are not valid for use as examples? Maybe it is
indeed not valid for all area codes. We could add a note to 
state that they should pick up an area code listed on the 
web page that we point to, namely:
  http://www.ofcom.org.uk/telecoms/ioi/numbers/num_drama

We got the info from Jim Reid by the way, whom I have also copied.

Bert

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Monday, September 11, 2006 15:03
> To: [email-masked]; [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Subject: Gen-ART review of draft-ietf-enum-validation-arch-04.txt
> 
> 
> I am the assigned Gen-ART reviewer for
> draft-ietf-enum-validation-arch-04.txt.
> For background on Gen-ART, please see the FAQ at
> <http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html>.
> 
> Please wait for direction from your document shepherd
> or AD before posting a new version of the draft.
> 
> This draft is ready for publication as an Informational RFC.
> 
> The issue around use of actual phone numbers in -03 has
> been corrected in the -04 version.
> 
> The ID checklist does not contain a complete or completely
> correct list of fictitious phone numbers for the UK, but
> it does contain a link to the official source of that info.
> I've added Bert Wijnen to the cc: list for this review as
> he's listed as author of that checklist.
> 
> The ID checklist says that the UK drama number range is:
>     UK: +44-<geographic-area-code>-496-<0000-0999>
> 
> The numbers used in the -04 version of the draft are:
> 	a) (e.g. +44 20 7946 xxxx) 
> 	b) (e.g. +44 20 79460999, +44 20 794607xx)
> 	c) (eg. +44 909 8790879)
> 
> In a), the "xxxx" might want to be "0xxx", but it's probably ok
> as-is.  b) is fine.  c) turns out to be ok, as it's in a UK "drama"
> number range not shown in the ID-Checklist, suggesting that an
> update to the ID-Checklist may be in order - a sentence pointing
> out that only specific UK geographic area codes have fictitious
> phone  numbers and that there are additional fictitious phone
> number ranges listed on the cited web page would suffice.
> 
> Thanks,
> --David
> ----------------------------------------------------
> David L. Black, Senior Technologist
> EMC Corporation, 176 South St., Hopkinton, MA  01748
> +1 (508) 293-7953             FAX: +1 (508) 293-7786
> [email-masked]        Mobile: +1 (978) 394-7754
> ----------------------------------------------------
> 

_______________________________________________
Gen-art mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gen-art

---

From: Jim Reid <[email-masked]>
Date: Mon, 11 Sep 2006 17:24:12 +0100

On Sep 11, 2006, at 16:48, Wijnen, Bert (Bert) wrote:

> numbers that are not valid for use as examples?

I'm not too sure what David means either. Perhaps he's concerned that  
the draft says  "the UK drama number range is:  UK: +44-<geographic- 
area-code>-496-<0000-0999>" when only some geographic area codes have  
drama ranges and there are non-geographic "area codes" that have  
drama numbers. No matter. IMO the draft is "good enough" if the UK  
examples are somehow linked to the Ofcom web page containing these  
drama numbers.

> Maybe it is
> web page

This makes sense. After all Ofcom may well add more drama numbers for  
additional area codes or new telephony-type services.

---

From: [email-masked]
Date: Mon, 11 Sep 2006 14:52:03 -0400

> > numbers that are not valid for use as examples?

No, the -04 enum-validation draft is fine, although it looks like
I had a mild instance of dyslexia in writing my messages about it
- this is just about the ID-Checklist section on fictitious phone
numbers.

> > state that they should pick up an area code listed on the

That is the issue.  In contrast to the US (+1) where the 555-01xx range
is fictitious for all area codes, the UK (+44) 496-0xxx range is *only*
fictitious (drama) for the specific area codes listed on Ofcom's web
page.  This is important to note, as anyone familiar with US practice
may assume the UK is the same (bad assumption, as, among other things,
UK area codes are variable length); if they don't check Ofcom's web
page, they could wind up using a non-drama number.

> additional area codes or new telephony-type services.

Right, I'm suggesting that two things be noted on the ID checklist:
(1) For the UK (+44) fictitious range, one MUST select an area code
	listed on Ofcom's web page for which 496-0xxx is a drama number
	range.  For example, 0151 and 0161 are ok, but 0191 is not,
	even though there is a drama number range in 0191.
(2) There are additional UK drama number ranges on Ofcom's web page
	that may be useful.  For example, IMHO, the enum validation
draft
	made a good choice in selecting a number for the single-number-
	allocation example from the UK drama number block for Premium
	Rate Services.

Sorry for the confusion,
--David

---

From: Jim Reid <[email-masked]>
Date: Mon, 11 Sep 2006 20:16:05 +0100

On Sep 11, 2006, at 19:52, [email-masked] wrote:

> 	that may be useful.  For example, IMHO, the enum validation draft

Fair enough. [I wonder why the drama ranges are different for some  
area codes. Oh well.] Perhaps the ID checklist should use the drama  
range from the ficticious 01632 area code for specific illustrations?  
It could then have a note explaining there are other (types of)  
numbers and area codes that can be used for examples followed by a  
link to the Ofcom web page.

---

From: Harald Alvestrand <[email-masked]>
Date: Tue, 12 Sep 2006 22:06:57 +0200

> link to the Ofcom web page. 
the checklist should IMHO list a single UK drama number range and say 
where the definition comes from (and that there are more there), so that 
reviewers can go there if needed.

+44 151 496 0xxx.

KISS for the users.

("drama number"... what a term....  what next........?)