Subject: [Gen-art] Re: Gen-ART Review of draft-ietf-l3vpn-ce-based-03.txt

From: Mark Townsley <[email-masked]>
Date: Thu, 14 Sep 2006 10:39:14 +0200

Harald Alvestrand wrote:
>
> But I am hard pressed to figure out why such documents belong even in 
> the vicinity of the IETF standards track.
> I'm happy to let these two documents out as Informational. I think any 
> such document belongs in that class.
They are being targeted for informational. And note the additional 
language I included in the IETF LC for these documents:

These documents were a product of first the PPVPN WG, and later the L3VPN
WG. They passed WG Last Call, but have not been actively discussed in the
WG for some time. There is little interest to work on CE-based VPN
problems within the WG today. The L3VPN WG is being rechartered to reflect
this, and these documents are being advanced as Informational for the
historical record.

- Mark
>
> But I suspect the political waters here are deep and troubled. I wish 
> the WG chairs and the ADs the best of luck in navigating them.
>
> No nits worth mentioning.
>
>                          Harald
>
>

_______________________________________________
Gen-art mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gen-art

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 14 Sep 2006 01:27:57 -0700

I am the Gen-ART assigned Last Call reviewer for 
this draft pair: draft-ietf-l3vpn-ce-based-03 and draft-declercq-dl3vpn-ce-based-as

	For background on Gen-ART, please see the FAQ at:

	http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html

Please resolve these comments along with any other comments you may receive.

Document: draft-ietf-l3vpn-ce-based-03.txt, draft-declercq-l3vpn-ce-based-as-00.txt
Reviewer: Harald Alvestrand
Date: September 14, 2006
Summary: Mostly harmless

My biggest concern with this class of specification is that it doesn't specify anything.
As I read it, it's basically a primer on the things you have to think about when creating a VPN based on Customer Edge equipment - you have to provision them from somewhere (using an unspecified protocol), you have to think about how to give them Internet access, you have to secure traffic between the devices so that nobody else can snoop on them, and you have to throw away traffic that isn't what you expected it to be. Motherhood and apple pie, and I'm sure there's a target audience for this stuff.

But there is no protocol here, there is no requirements language, there is nothing by which one can test that a particular implementation of such a VPN behaves like an "IETF-defined CE-based PPVPN", and there is not even the beginning of requirements for interoperability between vendors of CE-based VPN equipment.
The most you can say is that some approaches (such as VPN over SSH) aren't part of this model.

I think the documents are coherent, well written, readable, and probably useful for some target audience.

But I am hard pressed to figure out why such documents belong even in the vicinity of the IETF standards track.
I'm happy to let these two documents out as Informational. I think any such document belongs in that class.

But I suspect the political waters here are deep and troubled. I wish the WG chairs and the ADs the best of luck in navigating them.

                          Harald

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 14 Sep 2006 02:05:28 -0700

> this, and these documents are being advanced as Informational for the
I noticed. My beef is mainly with the fact that the L3VPN WG is 
apparently going down the path where shipping "standards" that don't 
standardize anything is considered a legitimate activity.

If they do a similarly content-free one on (for instance) IPSec-based 
PPVPNs, my review of that would also say that it ought to be Info, not 
Standards-track; useful, but not a standard.

(for all I know, such a document might already be approved.... I don't 
follow that area closely....)

---

From: Harald Alvestrand <[email-masked]>
Date: Thu, 14 Sep 2006 02:05:28 -0700

---

From: Mark Townsley <[email-masked]>
Date: Thu, 14 Sep 2006 13:12:33 +0200

Harald Alvestrand wrote:
> Mark Townsley wrote:
>> Harald Alvestrand wrote:
>>>
>>> But I am hard pressed to figure out why such documents belong even 
>>> in the vicinity of the IETF standards track.
Going down, no. Has been in the past, perhaps yes (at least for a 
portion of the effort in the WG).
> Standards-track; useful, but not a standard.
I agree with your beef, which is one reason why the upcoming recharter 
of L3VPN will be dispensing of the VR and CE efforts going forward. The 
focus will be (and effectively is now in practice) on BGP IP/MPLS based 
VPNs and their associated protocol extensions.

- Mark
>>> But I suspect the political waters here are deep and troubled. I 
>>> wish the WG chairs and the ADs the best of luck in navigating them.
>>>

---

From: Jeremy De Clercq <[email-masked]>
Date: Thu, 14 Sep 2006 16:29:09 +0200

I agree with all comments. There is no protocol specification nor 
extension in the document, no MUSTs, etc.

and there's no politics involved with this, all authors agree to make 
this an informational document.

(it was started in the past with the aim to become a standards track 
spec, but as no interoperable implementations came, and there was no WG 
interest to go forward with this, it was decided to classify these as 
informational for descriptive and historical reasons)

regards,
Jeremy.