Subject: [Gen-art] Genart review: draft-bellovin-keyroll2385-03.txt

From: Robert Sparks <[email-masked]>
Date: Tue, 14 Nov 2006 22:01:03 -0500

(resending with a non-empty subject - apologies for the duplication)

On Nov 14, 2006, at 9:58 PM, Robert Sparks wrote:

> (forgive the boilerplate - i know everyone copied here understands  
> - keeping to format with the hope that it facilitates future searches)
>
> I am the assigned Gen-ART reviewer for draft-bellovin- 
> keyroll2385-03.txt.
>
> For background on Gen-ART, please see the FAQ at <http:// 
> www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html>.
>
> Please wait for direction from your document shepherd or AD before  
> posting a new version of the draft.
>
> Summary: This draft is ready for publication as an Informational  
> RFC (modulo a missing but trivial IANA considerations section)
>
> Comments:
> This subject matter of this draft is outside my direct area of  
> expertise.
> I found it quite clear and believe I would know what to do if I  
> found myself needing to implement the idea.
>
> From a quick skim of the LC comments, I note one opinion expressed  
> that this will prolong sore operational-behavior rather
> than addressing a root cause, but the responses and draft support  
> the idea that this would make a current situation better
> without introducing harm, even in the form of removing motivation  
> to do other work.
>
> I've sent minor nits directly to Steve.

_______________________________________________
Gen-art mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gen-art

---

From: Robert Sparks <[email-masked]>
Date: Tue, 14 Nov 2006 21:58:14 -0500

(forgive the boilerplate - i know everyone copied here understands -  
keeping to format with the hope that it facilitates future searches)

Summary: This draft is ready for publication as an Informational RFC  
(modulo a missing but trivial IANA considerations section)

Comments:
This subject matter of this draft is outside my direct area of  
expertise.
I found it quite clear and believe I would know what to do if I found  
myself needing to implement the idea.

 From a quick skim of the LC comments, I note one opinion expressed  
that this will prolong sore operational-behavior rather
than addressing a root cause, but the responses and draft support the  
idea that this would make a current situation better
without introducing harm, even in the form of removing motivation to  
do other work.

---

From: "Steven M. Bellovin" <[email-masked]>
Date: Tue, 14 Nov 2006 22:50:03 -0500

> > RFC (modulo a missing but trivial IANA considerations section)

Is there a policy requiring null IANA Considerations sections?  I don't
see evidence of one in recent RFCs.

		--Steven M. Bellovin, http://www.cs.columbia.edu/~smb

---

From: Robert Sparks <[email-masked]>
Date: Tue, 14 Nov 2006 23:08:24 -0500

It's my understanding that IANA prefers explicit notification that  
they have nothing to do
(see http://www.ietf.org/ID-Checklist.html section 7D). Sections like  
this are then removed
by the RFC Editor.

RjS

---

From: "Steven M. Bellovin" <[email-masked]>
Date: Tue, 14 Nov 2006 23:18:56 -0500

> (see http://www.ietf.org/ID-Checklist.html section 7D). Sections like  

New text:

                <section title="Security Considerations">
                <t>     
                        There are no IANA actions required.  The TCP-MD5
                        option number is defined in
                        <xref target='RFC2385'/>, and is currently
                        listed by IANA. 
                </t>
                </section>

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 15 Nov 2006 10:38:24 +0100

Robert is correct - the I-D checklist does require such a section
in every draft. Otherwise IANA has to peruse each draft looking for
work to do.

Since the proposed new section actually has content, the editor may
decide to leave it. You might check the proposed section title ;-)

    Brian

---

From: Russ Housley <[email-masked]>
Date: Wed, 15 Nov 2006 09:31:34 -0500

Steve:

We have been requiring an IANA Considerations section, but when there 
are no IANA actions, the RFC Editor deletes it prior to publication.

I'll handle this with an RFC Editor / IANA note.

Russ

---

From: "Steven M. Bellovin" <[email-masked]>
Date: Wed, 15 Nov 2006 10:09:19 -0500

> decide to leave it. You might check the proposed section title ;-)

Hey -- I *really* want folks to feel secure.

As for the "content" -- I dislike null sections, so I stuck something in
there....

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 16 Nov 2006 13:34:08 +0100

> As for the "content" -- I dislike null sections, so I stuck something in

Just to be very clear: "This document require no IANA actions" is *not*
a null statement. It contains one bit of information that saves
a lot of time for IANA.

(Personally, I disagree with removing this from the published RFCs.
I think that one bit of information has potential value for future
readers. But I appear to have lost that argument.)

    Brian