Subject: Re: FW: [Gen-art] Gen-ART review of draft-saintandre-rfc4622bis-01

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 21 Aug 2007 13:38:16 -0500

Peter Saint-Andre wrote:
>>3) In S2.7.2 and S2.8.2, XMPP addresses continue to the next line.
>> Do you need LWS at the beginning of the second line to denote
>> continuation?
> 
> It's not clear to me how best to represent the line breaks. I will
> inquire of this with the RFC Editor.

I do not know of other areas, but at least within the SIP set of
documents in the RAI area, we have a convention: SIP header field
values can be folded onto multiple lines if the continuation line
begins with a LWS.  This includes URIs as well; i.e., a SIP URI
may continue on the next line if the continuation line starts
with a LWS.

Now, I am not sure what the general behavior of URIs is with
respect to line folding; at least rfc3986 (URI: Generic Syntax)
appears to be silent on this topic (a quick search of "folding",
"LWS", "continuation" does not yeild anything in that RFC.)  Maybe
someone from the Apps area can help.

Thanks,

- vijay
-- 
Vijay K. Gurbani, Bell Laboratories, Alcatel-Lucent
2701 Lucent Lane, Rm. 9F-546, Lisle, Illinois 60532 (USA)
Email: vkg@{alcatel-lucent.com,bell-labs.com,acm.org}
WWW:   http://www.alcatel-lucent.com/bell-labs

_______________________________________________
Gen-art mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gen-art

---

From: "Vijay K. Gurbani" <[email-masked]>
Date: Tue, 21 Aug 2007 14:23:57 -0500

Peter Saint-Andre wrote:
> The line breaks are included in this spec only for the sake of
> readability. No line breaks are allowed in XMPP IRIs or URIs. Thus the
> usage here is different from what you might find in SIP headers or email
> headers as far as I can see.

OK; if that is indeed the case, then please feel free to
disregard that comment in the original review, and consider
this issue resolved.

Thanks,

- vijay

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 21 Aug 2007 12:25:33 -0600

Thank you for the review. I'm moving email addresses right now, so
replying from my new address. Comments inline.

Peter Saint-Andre wrote:
> ----- Forwarded message from "Vijay K. Gurbani" <[email-masked]> -----
> 
> From: "Vijay K. Gurbani" <[email-masked]>
> To: [email-masked]
> CC: [email-masked], General Area Review Team <[email-masked]>
> Subject: [Gen-art] Gen-ART review of draft-saintandre-rfc4622bis-01
> X-Scanned-By: MIMEDefang 2.57 on 135.245.2.37
> 
> I have been selected as the General Area Review Team (Gen-ART)
> reviewer for this draft (for background on Gen-ART, please see
> http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).
> 
> Please wait for direction from your document shepherd
> or AD before posting a new version of the draft.
> 
> Document: draft-saintandre-rfc4622bis-01
> Reviewer: Vijay K. Gurbani
> Review Date: 21 Aug 2007
> IESG Telechat date: 1 Sept 2007
> 
> Summary: This draft is ready for publication as a Proposed Standard.
> 
> This is a short draft that defines the use of IRIs and URIs
> in XMPP communications.  A few nits follow:
> 
> 1) In a few places, [IRI], [IDNA] et al. are used as a reference
>  holder as well as a subject, example in S2.2:
> 
>   "...to convert [IRI] syntax into [IDNA] syntax ..."
> 
>  You may want to reconsider rewriting these as follows:
> 
>   "... to convert IRI syntax [IRI] into IDNA syntax [IDNA]..."
> 
>  for better readability.

Good point. I have cleaned that up in my working copy.

> 2) S2.5: s/examples include but are not/examples include, but are not/

Fixed.

> 4) S3.8, consider s/XXXX/this document

Done.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 21 Aug 2007 13:18:28 -0600

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 21 Aug 2007 12:25:33 -0600

Fixed.

Done.

Peter

-- 
Peter Saint-Andre
https://stpeter.im/

---

From: Peter Saint-Andre <[email-masked]>
Date: Tue, 21 Aug 2007 13:18:28 -0600

Peter

-- 
Peter Saint-Andre
https://stpeter.im/