Subject: [Gen-art] RE: Gen-ART LC Review of draft-ietf-smime-bfibecms-07.txt

From: "Luther Martin" <[email-masked]>
Date: Thu, 1 Nov 2007 13:09:49 -0700

Comments in-line. 

> -----Original Message-----
> From: Eric Gray [mailto:[email-masked]]
> Sent: Thursday, October 25, 2007 11:20 AM
> To: Luther Martin; Mark Schertler
> Cc: Tim Polk; [email-masked]
> Subject: Gen-ART LC Review of draft-ietf-smime-bfibecms-07.txt
> 
> Authors,
> 
> I have been selected as the General Area Review Team (Gen-ART)
> reviewer for this draft (for background on Gen-ART, please see
> http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).
> 
> Please resolve these comments along with any other Last Call comments
> you may receive.
> 
> 
> 
> Document:
> 
> "Using the Boneh-Franklin and Boneh-Boyen identity-based
>  encryption algorithms with the Cryptographic Message Syntax"
> (draft-ietf-smime-bfibecms-07.txt)
> 
> Reviewer:         Eric Gray
> Review Date:      10/25/2007
> IETF LC End Date: 10/25/2007
> 
> Summary:
> =======
> 
> This draft is almost ready for publishing as a Proposed Standard.
> 
> I have some questions and comments below.
> 
> Comments:
> ========
> 
> Question: In the second bullet, of section 1.2 on page 3, what
> does the expression "secure distribution" mean?  Is the PPS an
> authenticate-able source, does it only distribute the "publicly
> sharable cryptographic material" to authenticated recipients or
> does it use secure connections in the distribution process?

Changed to reflect this comment.

> 
> From the discussion in section 7.1 (second paragraph), it looks
> as if a PPS is an authenticate-able source.  Should this be
> stated more clearly?

Changed to reflect this comment.

> ________________________________________________________________
> 
> [DER] is listed as an informative reference, yet text on page
> 5 says -
> 
> "the structure MUST be DER encoded [DER] ..."
> 
> This should warrant a Normative reference, since it seems it
> is necessary to have this information in order to implement
> the step described in this text.
> 
> A similar argument can be made for each of the following:
> 
> 	ASN1 (see reference toward the top of page 3)
> 	IBCS (see references at the top of page 8)
> 	IBE (see - in particular - process step references -
> 		section 4, bullet 1, page 7
> 		section 5, bullets 3 through 5, page 8)
> _________________________________________________________________
> 

Changed to reflect this comment.

> 
> NITs:
> ====
> 
> There are format problems (premature line-wrap) that should be
> fixed prior to publication (this probably can be handled as an
> RFC Editor's note).  See, for example, numbered bullets on page
> 6 (number 2 in the first set, and number 4 in the second).

Changed to reflect this comment.

_______________________________________________
Gen-art mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gen-art

---

From: "Eric Gray" <[email-masked]>
Date: Mon, 12 Nov 2007 12:39:54 -0600

Luther,

	I apologize if I should know this, but I do not.  Have
you posted a revised draft?

--
Eric Gray
Principal Engineer
Ericsson  

> From: Luther Martin [mailto:[email-masked]] 
> Sent: Thursday, November 01, 2007 4:10 PM
> To: Eric Gray; Mark Schertler
> Subject: RE: Gen-ART LC Review of draft-ietf-smime-bfibecms-07.txt
> Importance: High
> 
> Comments in-line. 
>

---

From: "Luther Martin" <[email-masked]>
Date: Mon, 12 Nov 2007 11:39:48 -0800

Absolutely. 

> Sent: Monday, November 12, 2007 10:40 AM

---

From: "Eric Gray" <[email-masked]>
Date: Mon, 12 Nov 2007 13:55:46 -0600

Luther,

	I reviewed the new version at -

http://www.ietf.org/internet-drafts/draft-ietf-smime-bfibecms-08.txt

- and I conclude that all of my issues appear to have been dealt 
with.  IMO, the newest draft is ready for publication as a PS.

Thanks!

--
Eric Gray
Principal Engineer
Ericsson  

> Sent: Monday, November 12, 2007 2:40 PM