Subject: [Gen-art] Corrected: Gen-ART LC review of draft-ietf-sipping-capacity-attribute-05.txt

From: Brian E Carpenter <[email-masked]>
Date: Tue, 04 Dec 2007 07:00:53 +1300

Thanks to Frank Ellermann for pointing out to me that
'invalid' is a valid documentation TLD ;-)

     Brian

_______________________________________________
Gen-art mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gen-art

---

From: Miguel Garcia <[email-masked]>
Date: Mon, 03 Dec 2007 21:05:58 +0200

Brian,

Thanks for the review. Some inline comments.

Brian E Carpenter wrote:
> ------------------------------------------------------------------------
> 
> I have been selected as the General Area Review Team (Gen-ART) reviewer
> for this draft (for background on Gen-ART, please see
> http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).
> Please resolve these comments along with any other Last Call comments
> you may receive.
> Document: draft-ietf-sipping-capacity-attribute-05.txt
> Reviewer: Brian Carpenter
> Review Date: 2007-12-04 
> IETF LC End Date: 2007-12-20
> IESG Telechat date: (if known)
> 
> Summary: Almost ready, one formal problem
> 
> Comments: 
> 
> Section 4 (but this also affects other sections):
>  
>    ... URI-list servers can use URIs
>    tagged with the 'anonymize' attribute for routing SIP requests, but
>    MUST convert them to an anonymized URI (such as
>    sip:[email-masked]) in recipient-history lists.  
> 
> I think that to be watertight, the anonymous URI should be well-defined, 
> i.e. not 'such as' but simply 'MUST be sip:[email-masked]'.

Essentially, RFC 3261 allows to have any .invalid TLD as an anonymous 
URI, so, I don't think we need to have further restrictions on that.

> 
> Also, but less important: There's a booby-trap in blind-copied email,
> namely sending a reply-all without noticing that you've been blind-copied.
> Would it be useful to add a 'blind-copy' attribute for Bcc recipients,
> so that they can easily know about it?
> 

I appreciate the comment. However, we never had such a requirement, 
perhaps because the idea is to mimic e-mail.

There is one issue with your suggestion. If I understand correctly, the 
'blind-copy' attribute would only be present in the URI of the recipient 
that receives the blind copy. This basically requires that the URI-list 
server creates a different URI-list body (recipient-history list) per 
recipient. With the current draft, all the recipients receive the same 
recipient-history list.

/Miguel

-- 
Miguel A. Garcia           tel:+358-50-4804586
Nokia Siemens Networks     Espoo, Finland

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 04 Dec 2007 08:16:44 +1300

On 2007-12-04 08:05, Miguel Garcia wrote:
...
>> I think that to be watertight, the anonymous URI should be 
>> well-defined, i.e. not 'such as' but simply 'MUST be 
>> sip:[email-masked]'.
> 

However, by leaving it open you make the job of a person writing code
to interpret this URI very much harder. If you specify the exact string,
it becomes trivial to check for it. I think it should be specified.

> perhaps because the idea is to mimic e-mail.

...including its problems ;-)
> recipient. With the current draft, all the recipients receive the same 

Understood. I wouldn't insist on this.

    Brian

---

From: Miguel Garcia <[email-masked]>
Date: Mon, 03 Dec 2007 22:07:38 +0200

Hi Brian:

Brian E Carpenter wrote:
>>>    sip:[email-masked]) in recipient-history lists. I 
>>> think that to be watertight, the anonymous URI should be 

Point taken. I'll add it to the next version of the draft.

/Miguel