Subject: [Gen-art] Gen-ART Review of draft-ietf-16ng-ps-goals-03

From: Ben Campbell <[email-masked]>
Date: Mon, 10 Dec 2007 11:31:46 -0600

I have been selected as the General Area Review Team (Gen-ART)
reviewer for this draft (for background on Gen-ART, please see
http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).

Please resolve these comments along with any other Last Call comments
you may receive.

Document: draft-ietf-16ng-ps-goals-03
Reviewer: Ben Campbell
Review Date:  10 December 2007
IETF LC End Date:  10 December 2007
IESG Telechat date: (if known)

Summary:

This document is almost ready for publication as an informational RFC.  
There are some editorial nits that should be addressed prior to  
publication.

Comments:

General: There are many occurrences of missing articles ("a", "an", or  
"the") or the occasional use of an article where it does not belong.  
While I assume that the RFC editors will fix these, it would same them  
some work if you did an additional proofreading pass for this sort of  
thing.

Terminology Section, Definition of "Ethernet CS":

It would be helpful to have a reference for 802.16 STD.

Section 4.1, paragraph 7: "In the first point-to-point link model..."

I think you mean to refer to the first model in the preceding list,  
which is the point-to-point link model. The wording sounds like you  
mean the first of a set of point-to-point link models, which is  
incorrect. I suggest just dropping the word "first".

A similar issue occurs in paragraph 9 ("In the second Ethernet like  
link model...") and 11 ("The last shared IPv6 prefix link model")

Section 4.1, paragraph 9: "There needs mechanisms ..."

It looks like some words are missing from this sentence.

Section 4.1, paragraph 10, starting with "Moreover, the frequent IP  
multicast..."

I had trouble parsing this paragraph in general. Also, Is "IP subnet  
like ethernet" the same as "Ethernet like link model"?

Section 4.1, last paragraph:

"According to the point-to-point feature of 802.16's MAC, the Point-
    to-Point link model is the feasible IP Subnet model for IP CS under
    considering the multilink subnet problems. "

I cannot parse this sentence--please rephrase.

Thanks!

Ben Campbell.

_______________________________________________
Gen-art mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gen-art

---

From: "Junghoon Jee" <[email-masked]>
Date: Tue, 11 Dec 2007 11:24:35 +0900

Dear Ben Campbell,
Thank you for carefully reviewing the draft.
Please find inline replies.

----- Original Message ----- 
From: "Ben Campbell" <[email-masked]>
To: "General Area Review Team" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Tuesday, December 11, 2007 2:31 AM
Subject: Gen-ART Review of draft-ietf-16ng-ps-goals-03

> some work if you did an additional proofreading pass for this sort of  

Yes, additional proofreading will be done ASAP and the next revision will apply the correction.

> It would be helpful to have a reference for 802.16 STD.

That part will be amended that part like below:
Ethernet CS: It means 802.3/Ethernet CS specific part of the Packet CS defined in [IEEE802.16].

IP CS terminology will also reference [IEEE802.16].

> incorrect. I suggest just dropping the word "first".

Right! 
Let me drop that word.

> link model...") and 11 ("The last shared IPv6 prefix link model")

Let me drop the 'second' and 'last' in them.
 
> It looks like some words are missing from this sentence.

Let me try to apply the following change:
- From: There needs mechanisms like IEEE 802.1D to realize multicast and broadcast for Ethernet CS.  
- To: Therefore, we need a mechanism like 802.1D to realize multicast and broadcast.

> like ethernet" the same as "Ethernet like link model"?

Let me try to apply the following change:
- From: Moreover, the frequent IP multicast and broadcast signaling within the IP subnet like Ethernet needs to be avoided not to wake up sleep/idle [IEEE802.16e] SSs.
- To: Moreover, the frequent IP multicast and broadcast signaling should be avoided not to wake up sleep/idle [IEEE802.16e] SSs.

> I cannot parse this sentence--please rephrase.

Let me try to apply the following change:
- From: According to the point-to-point feature of 802.16's MAC, the Point-to-Point link model is the feasible IP Subnet model for IP CS under considering the multilink subnet problems. 
- To: According to the point-to-point feature of 802.16's MAC, the Point-to-Point link model is the feasible IP Subnet model in case of the IP CS.  

> Ben Campbell.

Best Regards,
Junghoon

---

From: Ben Campbell <[email-masked]>
Date: Mon, 10 Dec 2007 21:22:49 -0600

Thanks for the quick response!

I think that the changes you propose will address my comments.

Thanks!

Ben.

On Dec 10, 2007, at 8:24 PM, Junghoon Jee wrote:

> Cc: <[email-masked]>; <[email-masked]>; <[email-masked] 
> >; <[email-masked]>; <jeff@streetwaves- 
> networks.com>; <[email-masked]>; <[email-masked]>; <[email-masked] 
> >
> - From: Moreover, the frequent IP multicast and broadcast signaling  
> within the IP subnet like Ethernet needs to be avoided not to wake  
> up sleep/idle [IEEE802.16e] SSs.
> - To: Moreover, the frequent IP multicast and broadcast signaling  
> should be avoided not to wake up sleep/idle [IEEE802.16e] SSs.
>
>
>>
> - From: According to the point-to-point feature of 802.16's MAC, the  
> Point-to-Point link model is the feasible IP Subnet model for IP CS  
> under considering the multilink subnet problems.
> - To: According to the point-to-point feature of 802.16's MAC, the  
> Point-to-Point link model is the feasible IP Subnet model in case of  
> the IP CS.
>
>> Thanks!
>>
>> Ben Campbell.
>>
>
> Best Regards,
> Junghoon

---

From: "Junghoon Jee" <[email-masked]>
Date: Tue, 11 Dec 2007 13:20:25 +0900

Thank Ben very much!
The revised version will be ready ASAP by incorporating the changes.

Best Regards,
Junghoon