Subject: [Gen-art] RE: Gen-ART review of draft-ietf-v6ops-802-16-deployment-scenarios-06.txt

From: 김상언[무선인터넷개발담당]<[email-masked]>
Date: Mon, 7 Jan 2008 16:00:50 +0900

Hi everyone,

> 2.5.  IPv6 Security
>
>    When initiating the connection, an MS is authenticated by the AAA
This is the first time that a connection mechanism is mentioned
in the draft. It seems to need more description or a reference.

An example of connection mechanism can be refer to 
http://tools.ietf.org/wg/16ng/draft-sekim-16ng-ip-00.txt

If you (other author and reviewers) agree, I accept to merge above draft to draft-ietf-v6ops-802-16-deployment-scenarios-06.txt.

>    server located at its service provider network.  All the parameters
>    related to authentication (username, password and etc.) are forwarded
>    by the BS to the AAA server.  The AAA server authenticates the MSs
>    and when an MS is once authenticated and associated successfully with
>    BS, IPv6 an address will be acquired by the MS through stateless
>    autoconfiguration or DHCPv6.  Note the initiation and authentication
>    process is the same as used in IPv4.
Does the AAA exchange run over IP? If so, what IP address is used? If not,
what packetization is used for the AAA exchange?

The AAA run over IP.
ASN gateway (or ACR that stands for Access Control Router) and AAA servers are network infrastructure.
ASN gateway is an WiMAX Forum's term.
Before an MS initiates to access, ACR and AAA maintain AAA connection by IP network.
ACR serves for AAA client function and AAA servers provide AAA server function.   
It depends on AAA protocols such as RADIUS, TACACS and Diameter.
The WiMAX Forum prefer RADIUS protocol.
However the commercial service is used Diameter protocol in Korea due to its advanced capabilities.

Sang-Eon Kim / KT

Subject: Gen-ART review of draft-ietf-v6ops-802-16-deployment-scenarios-06.txt
From: "Brian E Carpenter" <[email-masked]>
To: "General Area Review Team" <[email-masked]>
Cc: "Ron Bonica" <[email-masked]>, <[email-masked]>, "Fred Baker" <[email-masked]>
Date: Mon, 07 Jan 2008 15:31:25 +1300

_______________________________________________
Gen-art mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gen-art

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 08 Jan 2008 10:01:11 +1300

>> what packetization is used for the AAA exchange?

I understand that between the BS and the AAA server. But what about
the initial AAA exchange between the MS and the BS? At that time,
according to the draft, the MS has no IP address.

Regards
    Brian Carpenter
    University of Auckland

On 2008-01-07 20:00, 김상언[무선인터넷개발담당] wrote:
> ------------------------------------------------------------------------
> 
> Subject:
> Gen-ART review of draft-ietf-v6ops-802-16-deployment-scenarios-06.txt
> From:
> "Brian E Carpenter" <[email-masked]>
> Date:
> To:
> "General Area Review Team" <[email-masked]>
> 
> To:
> "General Area Review Team" <[email-masked]>
> CC:
> "Ron Bonica" <[email-masked]>, 
> <[email-masked]>, "Fred 
> Baker" <[email-masked]>
> 
> 
> 
> 
>

---

From: 김상언[무선인터넷개발담당]<[email-masked]>
Date: Tue, 8 Jan 2008 09:33:25 +0900

-----원본 메시지-----
보낸 사람: "Brian E Carpenter" <[email-masked]>
보낸 날짜: 2008-01-08 오전 6:01:11
받는 사람: "김상언[무선인터넷개발담당]" <[email-masked]>
참조: "General Area Review Team" <[email-masked]>, "Ron Bonica" <[email-masked]>, "[email-masked]" <[email-masked]>, "Fred Baker" <[email-masked]>
제목: Re: Gen-ART review of draft-ietf-v6ops-802-16-deployment-scenarios-06.txt

A PKM (Privacy Key Management) message is for initial AAA exchange at Figure 6 in the http://tools.ietf.org/wg/16ng/draft-sekim-16ng-ip-00.txt. 
More detailed procedures are on the section 6.3.2.3.9 in IEEE 802.16e-2005

I will appreciate to reply to [email-masked]
This address ([email-masked]) has some constraints to discuss.

Regards,
    Sang-Eon Kim at KT in Seoul

Regards
    Brian Carpenter
    University of Auckland

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 08 Jan 2008 13:51:44 +1300

On 2008-01-08 13:33, 김상언[무선인터넷개발담당] wrote:
> 참조: "General Area Review Team" <[email-masked]>, "Ron Bonica" 
> <[email-masked]>, 
> "[email-masked]" 
> 제목: Re: Gen-ART review of 
> draft-ietf-v6ops-802-16-deployment-scenarios-06.txt
> 
> 
> A PKM (Privacy Key Management) message is for initial AAA exchange at 
> Figure 6 in the 
> http://tools.ietf.org/wg/16ng/draft-sekim-16ng-ip-00.txt. More detailed 
> procedures are on the section 6.3.2.3.9 in IEEE 802.16e-2005

OK - I think the draft should state that the MS-BS AAA exchange occurs
in 802.16 messages and not over IP.

> This address ([email-masked]) has some constraints to discuss.

No problem, but your KT address is used in the draft.

Thanks
    Brian

>> If you (other author and reviewers) agree, I accept to merge above 
>> draft to draft-ietf-v6ops-802-16-deployment-scenarios-06.txt.
>>
>> ACR serves for AAA client function and AAA servers provide AAA server 
>> function.  It depends on AAA protocols such as RADIUS, TACACS and 
>> Diameter.

---

From: "김상언" <[email-masked]>
Date: Tue, 8 Jan 2008 15:48:00 +0900

> in 802.16 messages and not over IP.

What would you recommend either a wholle procedures of Fig. 6 on
16ng-ip-00.txt or a partial procedures related to PKM?
MS and BS exchange 802.16 messages.
BS and AAA exchange AAA protocols

> No problem, but your KT address is used in the draft.

Yes, KT address is used in the draft.
Gmail is for discussion.

Thanks
>    Brian

Thank you
sekim

> >> to its advanced capabilities.
------------------------------------------------
Sang-Eon Kim
Senior Researcher
Infra. Lab., KT
139-791, Woomyeon-dong, Seocho-gu, Seoul, Korea

Voice: +82-2-526-6117
Mobile: +82-10-3073-4084
E-mail: [email-masked]
------------------------------------------------
_______________________________________________
Gen-art mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/gen-art

---

From: Brian E Carpenter <[email-masked]>
Date: Wed, 09 Jan 2008 09:41:04 +1300

> BS and AAA exchange AAA protocols

I think it is enough to add one sentence such as:

Note that 802.16 messages are used for initial Privacy Key Management
between the MS and BS.

    Brian