Subject: Re: [Gen-art] Gen-ART IETF LC review of draft-ietf-imapext-i18n-14

From: Alexey Melnikov <[email-masked]>
Date: Thu, 31 Jan 2008 22:07:42 +0000

Ben Campbell wrote:

> I have been selected as the General Area Review Team (Gen-ART)
> reviewer for this draft (for background on Gen-ART, please see
> http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).
>
> Please resolve these comments along with any other Last Call comments
> you may receive.

Hi Ben,
Thank you for your review!

> Document: draft-ietf-imapext-i18n-14
> Reviewer: Ben Campbell
> Review Date:  2008-01-27
> IETF LC End Date: 2008-01-29
>
> Summary:
>
> This draft is almost ready for publication as a proposed standard.  
> There are editorial issues that should be considered prior to  
> publication.
>
> Comments:
>
> In general this draft is very easy to read and understand. I believe  
> my comments are all editorial, although the first one might be  
> considered substantive by some.
>
> Sections 5 and 9 entirely consist of problem identification, guidance  
> to implementors of IMAP in general, and even some possible best  
> practices, much of which are not directly related to the extensions  
> being defined in this draft. While I agree it is valuable 
> information,  I wonder if it is more appropriate to include them in a 
> standards  track RFC, or to remove them to one or more separate 
> informational  RFCs. I do not mean to dispute the will of the working 
> group; I merely  bring it up to make sure people have thought about 
> it. That is, it's  okay with me if the answer is "we've thought about 
> it, and prefer to  keep it the way it is".

I think there was sufficient support for keeping this information in the 
same document.
The whole document is about IMAP internationalization (or at least about 
bits that the IMAPEXT WG decided to tackle this round).
Sections 5 and 9 provide important information for people who are 
interested in the topic, or are willing to add internationalization 
support to their clients/servers, so I think it is important to keep 
them with the rest of the document.

> Section 4.3, paragraph 1:
>
> Plural subject "servers" does not agree with "advertises" and 
> "doesn't  support" later in the sentence.
>
> Section 4.4. paragraph 1:
>
> Plural subject "servers" does not agree with "advertises" and 
> "doesn't  support" later in the sentence.

Both fixed, thanks.

> Section 4.5, last paragraph:
>
> I assume this paragraph was not intended to be normative, given the  
> lower-case "should"s. I call attention to it only to make sure that 
> is  the authors' intent.

Yes, it was. The last paragraph is a recommendation to implementors and 
has no normative meaning.

> Section 4.6, 3 paragraphs from end: " <<Add an example>>"
>
> Do you still intend to add the example, or is the text obsolete? I  
> think an example would help.

Ok, I will do that.

> Finally, IDNITS returns the following comments, that I include 
> without  prejudice:

 [...]

>>   == Outdated reference: A later version (-12) exists of
>>      draft-daboo-imap-annotatemore-11
>
Fixed.

> Thanks!
> Ben.

_______________________________________________
Gen-art mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/gen-art

---

From: Ben Campbell <[email-masked]>
Date: Fri, 1 Feb 2008 07:51:41 -0600

> Thank you for your review!

You're welcome--thanks for the quick response.

I think that your responses address all of my concerns.

Thanks!

Ben.

[...]