Subject: Re: [Gen-art] [Fwd: Gen-ART LC review of draft-moriarty-post-inch-rid-02.txt]

From: [email-masked]
Date: Wed, 20 Feb 2008 09:19:41 -0500

Hello Brian,

I went through your comments and made the necessary changes to the RID
document yesterday.  I submitted the new version last night.

I am attaching the edited txt document you sent with comments.  Please let
me know if there are other adjustments that should be made or if I did not
address your comments adequately.

Thank you,
Kathleen

-----Original Message-----
From: Brian E Carpenter [mailto:[email-masked]] 
Sent: Saturday, February 16, 2008 4:02 PM
To: Moriarty, Kathleen
Cc: Tim Polk
Subject: [Fwd: Gen-ART LC review of draft-moriarty-post-inch-rid-02.txt]

Kathleen, comments will tend to go to the address in
the draft ;-)

Please cc any reply to [email-masked]

Thanks

   Brian

-------- Original Message --------
Subject: Gen-ART LC review of draft-moriarty-post-inch-rid-02.txt
Date: Thu, 07 Feb 2008 16:29:08 +1300
From: Brian E Carpenter <[email-masked]>
Organization: University of Auckland
To: General Area Review Team <[email-masked]>
CC: Tim Polk <[email-masked]>,
[email-masked]

-- 
Regards
   Brian Carpenter
   University of Auckland

_______________________________________________
Gen-art mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/gen-art

---

From: Brian E Carpenter <[email-masked]>
Date: Thu, 21 Feb 2008 14:47:28 +1300

Kathleen,

Just a few remaining comments:

> Each of the three listed classes may be the only class included in	
> the RID class, hence the option for zero or one.

Ah, it means zero or one *occurrences*, that wasn't obvious to me.
BTW is 'RID class' what you mean rather than 'RID extension'?

> 6.3 Authentication of RID Protocol

I'm still a little puzzled by the mention of WS-Security.
That is such an enormous beast that I don't see how you
can refer to it in passing without any details.

> Email: [email-masked]

Didn't you need to update that?

Thanks

    Brian

---

From: [email-masked]
Date: Thu, 21 Feb 2008 08:43:48 -0500

Good morning Brian,

Thank you.  I will make the updates later today.  I had changed my contact
information in the version 3 that was really just a contact update, but I
went back to my original document for version 4 and must have overlooked
that change.

As for the WS-security, should I leave that reference out then?  The draft
is long enough as it is, so I am not sure I want to expand it further.  Or
should I state the discussion is out of scope for the document?

Yes, it is more accurate to say RID class.  We went through many revisions
and it was an extension at one point in time.  I'll comb through the
document again for that as well and correct where needed.

Thank you,
Kathleen 

-----Original Message-----
From: Brian E Carpenter [mailto:[email-masked]] 
Sent: Wednesday, February 20, 2008 8:47 PM
To: Moriarty, Kathleen
Cc: [email-masked]; [email-masked]
Subject: Re: [Fwd: Gen-ART LC review of draft-moriarty-post-inch-rid-02.txt]

Kathleen,

Thanks

    Brian

---

From: Brian E Carpenter <[email-masked]>
Date: Fri, 22 Feb 2008 09:40:57 +1300

Hi,

Thanks.

>> should I state the discussion is out of scope for the document?

I'd hazard a guess that the current text won't survive the Security Area
review, because it doesn't make it clear what is the mandatory security
requirement for this specific draft. I think the sentence needs to be
restructured so that it's clear what an implementor MUST do.

The problem may be a bit deeper. I see several uses of XML Digital
Signature and XML Encryption in the text that don't cite [3] and [5].
I would think they need references. If that's all you're taking from
WS-Security, it would be better to drop the reference to WS-Security
altogether. If there's more, life can get very painful as WS-Security
is such a complex model.

Incidentally, I thought the reference for XMLDSIG would be RFC3275.

   Brian