Subject: Re: [Gen-art] (full) review of draft-ietf-imss-fc-fcsp-mib-02.txt

From: Keith McCloghrie <[email-masked]>
Date: Mon, 23 Jun 2008 05:09:53 -0700 (PDT)

Thanks for your comments.  I'm impressed that you were still awake
enough to find typos on page 183 :-), and if they can all be handled by
the RFC Editor, that's better for me.  (I expect others to "abuse" the
Queen's English, but it's a personal pain if I have to do so myself :-).

Keith.
 
> I have been selected as the General Area Review Team (Gen-ART)
> reviewer for this draft (for background on Gen-ART, please see
> http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).
> 
> Please resolve these comments along with any other Last Call comments
> you may receive.
> 
> Document: draft-ietf-imss-fc-fcsp-mib-02.txt
> Reviewer: Francis Dupont
> Review Date: 2008-06-19
> IETF LC End Date: 2008-06-19
> IESG Telechat date: unknown
> 
> Summary: Ready
> 
> Comments: I've found only a low number of editorial (i.e., to be handled
> by the RFC Editor) problems (spelling errors, typos, raw abbrevs, ...):
> (I've put a '?' after suggestions/questionable items, MIB names are for
>  their descriptions)
> 
>  - ToC page 2: Acknowledgements -> Acknowledgments
>   (i.e., US spelling, same in 7 page 232)
> 
>  - 1 page 3: IETF's -> IETF? (same in t11FcTcMIB page 27,
>   t11FcSpAuthenticationMIB page 43, t11FcSpZoningMIB page 64,
>   t11FcSpPolicyMIB page 77, t11FcSpSaMIB page 176, 7 page 232)
> 
>  - 3.2 page 11: HBAs -> Host Bus Adapters
>   (usually abbrevs, including this one, should be introduced by it is
>    the only use)
> 
>  - 3.4.7 page 17: introduce abbrevs: SSB (Server Session Begin), SSE
>   (Server Session End), SW_ILS (Switch Fabric Internal Link Services);
>   or extend them when they are used once in the introduction part:
>   EACA -> Enhanced Acquire Change Authorization Request, ERCA ->
>   Enhanced Release Change Authorization, SFC -> Stage Fabric Configuration
> 
>  - 4.9 page 25: the the -> the (and in t11FcSpAuRejDirection page 58,
>   don't believe you can get >240 pages without a typo :-)
> 
>  - 5 page 26: focussed -> focused?
> 
>  - t11FcSpAuIfStatOutAcceptedMsgs page 55: neighbouring -> neighboring?
>  
>  - t11FcSpPoSwMembAuthBehaviour page 89: neighbour -> neighbor?
>   (same in t11FcSpPoNaSwMembAuthBehaviour page 129
> 
>  - t11FcSpPoSwConnAllowedNameType page 99: portname -> portName
> 
>  - t11FcSpSaIfTerminateAllSas page 183: outsanding -> outstanding
> 
> Regards
> 
> [email-masked]
> 

_______________________________________________
Gen-art mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/gen-art

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 23 Jun 2008 14:27:06 +0200

Keith,

If you can suggest the necessary edits using the OLD/NEW style, we can
already include them in the tracker write-up. Please also include
whatever edits resulted from my review.  The document will be placed for
approval on the agenda of the upcoming telechat which is scheduled for
7/3. 

Thanks and Regards,

Dan

> -----Original Message-----
> From: Keith McCloghrie [mailto:[email-masked]] 
> Sent: Monday, June 23, 2008 3:10 PM
> To: Francis Dupont
> Cc: [email-masked]; [email-masked]; [email-masked]; 
> [email-masked]; Romascanu, Dan (Dan)
> Subject: Re: (full) review of draft-ietf-imss-fc-fcsp-mib-02.txt
> 
> Thanks for your comments.  I'm impressed that you were still 
> awake enough to find typos on page 183 :-), and if they can 
> all be handled by the RFC Editor, that's better for me.  (I 
> expect others to "abuse" the Queen's English, but it's a 
> personal pain if I have to do so myself :-).
> 
> Keith.
>  
> > Comments: I've found only a low number of editorial (i.e., to be 
> > handled by the RFC Editor) problems (spelling errors, 
> typos, raw abbrevs, ...):
> > (I've put a '?' after suggestions/questionable items, MIB names are 
> > for  their descriptions)
> >

---

From: Keith McCloghrie <[email-masked]>
Date: Mon, 23 Jun 2008 08:25:45 -0700 (PDT)

Dan,

> approval on the agenda of the upcoming telechat which is scheduled for
 
How about the below.

Thanks,
Keith.
===================

Insertion after the picture in section 3.4.4, on page 15:

  OLD:

  NEW:

    Note that the arrows in the picture above are used to indicate the
    movement of "data", rather than the direction of "messages", e.g.,
    for a "Get" (with no data) in one direction which invokes a
    "Response" (typically with data) in the reverse direction, the
    diagram has arrows only for the "with data" direction.

Line 4 on page 30:

  OLD:
           'stale' to this object is an error ('wrongValue')."

  NEW:
           'stale' to this object is an error (e.g., 'wrongValue')."

Near the bottom of page 67:

  OLD:
           is an error ('wrongValue')."

  NEW:
           is an error (e.g., 'wrongValue')."

At bottom of page 115:

  OLD:
           Writing any other value into this object is a
           ('wrongValue') error.
 
  NEW:
           Writing any other value into this object is an error
           (e.g., 'wrongValue').

Middle of page 121:
 
  OLD:
           or 'stale' to this object is a ('wrongValue') error."

  NEW:
           or 'stale' to this object is an error (e.g.,
           'wrongValue')."

In Reference section, for IPSP-IKE-ACTION on page 236:

  OLD:
         nn.txt, work-in-progress, October 2006.

  NEW:
         02.txt, work-in-progress, October 2006.

In references section, for IPSP-IPSEC-ACTION on page 236:

  OLD:
         nn.txt, work-in-progress, October 2006.

  NEW:
         02.txt, work-in-progress, October 2006.

Section 3.2, middle of page 11:

  OLD:

    Hard zoning and soft zoning are two different means of realizing
    this.  Hard zoning is enforced in the Fabric (i.e., Switches) whereas
    soft zoning is enforced at the endpoints (e.g., HBAs) by ...

  NEW:

    Hard zoning and soft zoning are two different means of realizing
    this.  Hard zoning is enforced in the Fabric (i.e., Switches) whereas
    soft zoning is enforced at the endpoints (e.g., Host Based Adapters)
    by ...

Title of section 7:

  OLD: 

     Acknowledgements

  NEW:

     Acknowledgements

In section 3.4.7, at bottom of page 17 through top of page 18:

  OLD:

    The Enhanced Commit Service [FC-SW-4] is used to perform Fabric
    operations as and when necessary (see table 144 of [FC-SP]).  Each
    server session begins and ends, with a SSB request and a SSE request
    respectively, sent ...

  NEW:

    The Enhanced Commit Service [FC-SW-4] is used to perform Fabric
    operations as and when necessary (see table 144 of [FC-SP]).
    Many of these operations are named as if they were acronyms,
    e.g.,  SSB for Server Session Begin; SSE for Server Session End;
    SW_ILS for Switch Fabric Internal Link Services; EACA for Enhanced
    Acquire Change Authorization; ERCA for Enhanced Release Change
    Authorization; SFC for Stage Fabric Configuration.

    Each server session begins and ends, with a SSB request and a SSE
    request respectively, sent ...

In Section 4.9, at bottom of page 25:

  OLD:
                                      ...  Note that while these
   suppressions prevent the the network being flooded with ...

  NEW:
                                      ...  Note that while these
   suppressions prevent the network being flooded with ...

Lines 3 & 4 on page 30:

  OLD:
                                                            ... of the
           the identified MIB objects. 

  NEW:
                                                            ... of the
           identified MIB objects. 

In t11FcSpAuRejDirection's DESCRIPTION, on page 58:

  OLD:
           "An indication of whether the the rejection was sent or
           received by the identified entity.

  NEW:
           "An indication of whether the rejection was sent or
           received by the identified entity.

On page 217:

  OLD:
           If the corresponding instance of t11FcSpSaTSelSpiDirection
           has the value 'egress', then this object contains the
           the value ...

  NEW:
           If the corresponding instance of t11FcSpSaTSelSpiDirection
           has the value 'egress', then this object contains the
           value ...

In t11FcSpPoSwConnAllowedNameType's DESCRIPTION, on page 99:

  OLD:
            - allowed by 'nodeName' and 'portname',

  NEW:
            - allowed by 'nodeName' and 'portName',

In t11FcSpSaIfTerminateAllSas's DESCRIPTION, on page 183:

  OLD:
           terminate all outsanding Security Associations on this

  NEW:
           terminate all outstanding Security Associations on this

Near bottom of page 89:

  OLD:
           between this Switch and neighbour Switches must be
  NEW:
           between this Switch and neighbo?r Switches must be

Middle of page 129:

  OLD:
           between this Switch and neighbour Switches must be
  NEW:
           between this Switch and neighbo?r Switches must be

Middle of page 54:

  OLD:
           neighbouring entity, i.e., not rejected by an AUTH_Reject
  NEW:
           neighbo?ring entity, i.e., not rejected by an AUTH_Reject

---

From: "Romascanu, Dan (Dan)" <[email-masked]>
Date: Mon, 23 Jun 2008 17:45:20 +0200

These look good to me. 

I assume you meant neighbor, etc. 

Also, there are a number of edits suggested by David in his
proto-shepherd write-up concerning references, I guess these should be
added as well (see  below). 

Dan

---------------

[1] In Normative References
OLD
[FC-SP]
    "Fibre Channel - Security Protocols (FC-SP)", ANSI INCITS xxx-200x,
    http://www.t11.org/t11/stat.nsf/upnum/1570-d, T11/Project
    1570-D/Rev 1.8, 13 June 2003.

NEW
[FC-SP]
    "Fibre Channel - Security Protocols (FC-SP)", ANSI INCITS 426-2007,
    http://www.t11.org/t11/stat.nsf/upnum/1570-d, T11/Project
    1570-D, February 2007.

[2] In numerous REFERENCE clauses throughout the MIB modules
OLD
    REFERENCE
          "INCITS xxx/200x, T11/Project 1570-D/Rev 1.8,
          Fibre Channel - Security Protocols (FC-SP),
          13 June 2006, Appendix A.3.1, tables A.23, A.25."
NEW
    REFERENCE
          "ANSI INCITS 426-2007, T11/Project 1570-D,
          Fibre Channel - Security Protocols (FC-SP),
          February 2007, Appendix A.3.1, tables A.23, A.25."
NOTE
The section references (Appendix A.3.1, ...) are different
for each REFERENCE clause, and need to be preserved.

[3] In a couple of REFERENCE clauses in the MIB modules
OLD
          " - Fibre Channel - Framing and Signaling-2 (FC-FS-2),
          INCITS xxx/200x, Project T11/1619-D Rev 1.01,
          8 August 2006, section 9.3.
NEW
          " - Fibre Channel - Framing and Signaling-2 (FC-FS-2),
          ANSI INCITS 424-2007, Project T11/1619-D,
          February 2007, section 9.3.
NOTE
The section references (section 9.3) are different
for each REFERENCE clause, and need to be preserved.
--------------- 

> Sent: Monday, June 23, 2008 6:26 PM
> To: Romascanu, Dan (Dan)
> Cc: Keith McCloghrie; Francis Dupont; [email-masked]; 
> [email-masked]; [email-masked]; [email-masked]
> > whatever edits resulted from my review.  The document will 
> be placed 
> > for approval on the agenda of the upcoming telechat which 
> is scheduled 
> > for 7/3.
>  
> How about the below.
> 
> Thanks,
> Keith.
> ===================
>