Subject: [Gen-art] Gen-ART Review of draft-ietf-isis-te-bis-00

From: Christian Vogt <[email-masked]>
Date: Fri, 25 Jul 2008 20:04:25 +0300

I have been selected as the General Area Review Team (Gen-ART)
reviewer for this draft (for background on Gen-ART, please see
http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).

Please resolve these comments along with any other Last Call comments
you may receive.

Document..........:  draft-ietf-isis-te-bis-00
Reviewer..........:  Christian Vogt
Review date.......:  2008/07/25

Summary:  This draft is ready for publication as a Proposed Standard
RFC.

The document is clearly ready for publication.  Just two nits:

In section 3, you write:

    Further, there is no defined mechanism for extending the sub-TLV
    space for a particular neighbor.  Thus, wasting sub-TLV space is
    discouraged.

This seems to be a general issue that may be good to move to a more
dominant position.  It refers to the sub-TLV concept in general, but
here it is mentioned only in the specific context of the Extended IS
Reachability TLV.  Consider moving this to a place that talks
generally about the sub-TLV concept, e.g., to section 2.

In section 4, you write:

    This data structure can be replicated within the TLV,
    without exceeding the maximum length of the TLV.

Suggest rewording to "...as long as the maximum length of the TLV is
not exceeded".

Best regards,
- Christian

_______________________________________________
Gen-art mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/gen-art

---

From: Christian Vogt <[email-masked]>
Date: Fri, 25 Jul 2008 23:23:01 +0300

Never mind.  The document is great also without the modifications.

- Christian

On Jul 25, 2008, at 20:45, Tony Li wrote:

> Hi Christian,
>
> Thank you very much for your review.
>
> Unfortunately, the document has already been approved by the IESG:
> https://datatracker.ietf.org/idtracker/draft-ietf-isis-te-bis/
>
> FWIW, I agree with your nits.  ;-)
>
> Regards,
> Tony

---

From: Tony Li <[email-masked]>
Date: Fri, 25 Jul 2008 10:45:06 -0700

Hi Christian,

Regards,
Tony

|-----Original Message-----
|From: Christian Vogt [mailto:[email-masked]]
|Sent: Friday, July 25, 2008 10:04 AM
|To: Gen-ART Mailing List
|Cc: Tony Li; [email-masked]; Ross Callon
|Subject: Gen-ART Review of draft-ietf-isis-te-bis-00
|
|I have been selected as the General Area Review Team (Gen-ART)
|reviewer for this draft (for background on Gen-ART, please see
|http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).
|
|Please resolve these comments along with any other Last Call comments
|you may receive.
|
|
|Document..........:  draft-ietf-isis-te-bis-00
|Reviewer..........:  Christian Vogt
|Review date.......:  2008/07/25
|
|
|Summary:  This draft is ready for publication as a Proposed Standard
|RFC.
|
|
|The document is clearly ready for publication.  Just two nits:
|
|In section 3, you write:
|
|    Further, there is no defined mechanism for extending the sub-TLV
|    space for a particular neighbor.  Thus, wasting sub-TLV space is
|    discouraged.
|
|This seems to be a general issue that may be good to move to a more
|dominant position.  It refers to the sub-TLV concept in general, but
|here it is mentioned only in the specific context of the Extended IS
|Reachability TLV.  Consider moving this to a place that talks
|generally about the sub-TLV concept, e.g., to section 2.
|
|In section 4, you write:
|
|    This data structure can be replicated within the TLV,
|    without exceeding the maximum length of the TLV.
|
|Suggest rewording to "...as long as the maximum length of the TLV is
|not exceeded".
|
|Best regards,
|- Christian
|
|
|
_______________________________________________
Gen-art mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/gen-art