Subject: [Gen-art] Gen-ART review of draft-ietf-geopriv-pdif-lo-profile-13.txt

From: "Miguel A. Garcia" <[email-masked]>
Date: Mon, 24 Nov 2008 15:29:41 +0100

I have been selected as the General Area Review Team (Gen-ART)
reviewer for this draft (for background on Gen-ART, please see
http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).

Please resolve these comments along with any other Last Call comments
you may receive.

Document: draft-ietf-geopriv-pdif-lo-profile-13.txt
Reviewer: Miguel Garcia <[email-masked]>
Review Date: 2008-11-24
IETF LC End Date: 2008-11-30

Summary: The document is ready for publication as a standards track RFC.

Comments:
- I have taken the effort of validating all the XML examples included in 
the draft. I used the Xerces validator available at 
http://validate.openlaboratory.net/. I find awkward to include 39 XML 
Schema files (thanks to the OpenGML explosion of schema files), but that 
doesn't seem to be a problem (other than for humans). Other than that, 
the examples all validate.

- The short name of the draft (which is printed as a heading in every 
page) is set to "GEOPRIV PIDF-LO Profile". I think it should be set to 
"GEOPRIV PIDF-LO Usage", since neither the title nor the text refer to 
the document as a profile.

- Section 1, first paragraph, add an informative reference to GMLv3 when 
it is mentioned in the text.

- Section 2, 5th paragraph, expand "LIS" and "LCP".

- Section 5, the first paragraph on page 15. What is a "WGS84 CRS"? Is 
this something where an informative reference could be added?

/Miguel

-- 
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain
_______________________________________________
Gen-art mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/gen-art

---

From: "Thomson, Martin" <[email-masked]>
Date: Mon, 24 Nov 2008 21:00:16 -0600

Hi Miguel,

Thanks for the review.  I will rev the document today or tomorrow and address all your comments.

Regarding the examples, they are all being changed in the revision.  Unfortunately, all of the parseContents="lax" directives cause the validator to stop checking.  We missed the same errors [1].  I now use schema documents with all instances of "lax" replaced with "strict" for validation.  That method is better able to find errors than using the straightforward method.

Maybe there is a lesson to be learned there...

WGS84 is an acronym that is so well known in the location business that I guess we (wrongly) assumed that it would make sense.  This is the coordinate system used by the GPS system, and many other mapping and location systems.  It defines what latitude and longitude really mean.

Regards,
Martin

[1] The errors: the method element should be qualified with "gp:" and the timestamp element needed to be qualified with "dm:" and moved after the dm:device element.

> -----Original Message-----
> From: Miguel A. Garcia [mailto:[email-masked]]
> Sent: Monday, 24 November 2008 8:30 AM
> To: [email-masked]; geopriv-
> [email-masked]; [email-masked]
> Cc: General Area Review Team
> Subject: Gen-ART review of draft-ietf-geopriv-pdif-lo-profile-13.txt
> 

------------------------------------------------------------------------------------------------
This message is for the designated recipient only and may
contain privileged, proprietary, or otherwise private information.  
If you have received it in error, please notify the sender
immediately and delete the original.  Any unauthorized use of
this email is prohibited.
------------------------------------------------------------------------------------------------
[mf2]
_______________________________________________
Gen-art mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/gen-art

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Tue, 25 Nov 2008 08:52:25 +0100

Martin:

I noticed that the validator gave a bunch of errors, but I checked them 
and they were related to the XML Schema (mostly in OpenGML schemas), not 
to the examples you provided. I am not sure if this is the same issue you 
are referring to.

/Miguel

---

From: "Thomson, Martin" <[email-masked]>
Date: Tue, 25 Nov 2008 16:57:05 -0600

It's not.  I suspect that your GML errors came from known problems in the GML schema.  The profile referenced from this document [1] uses a set of schemas that shouldn't have any errors.

Cheers,
Martin

[1] "GML PIDF-LO Geometry Shape Application Schema for use in the IETF" <http://portal.opengeospatial.org/files/?artifact_id=21630>

> Sent: Tuesday, 25 November 2008 6:52 PM
> To: Thomson, Martin
> Cc: [email-masked]; geopriv-
> [email-masked]; [email-masked]; General Area Review
> Team; Winterbottom, James
> Subject: Re: Gen-ART review of draft-ietf-geopriv-pdif-lo-profile-
> 13.txt
> 
> Martin:
> 
> > Regarding the examples, they are all being changed in the revision.
> Unfortunately, all of the parseContents="lax" directives cause the
> validator to stop checking.  We missed the same errors [1].  I now use
> schema documents with all instances of "lax" replaced with "strict" for
> validation.  That method is better able to find errors than using the
> straightforward method.
> >
> > WGS84 is an acronym that is so well known in the location business
> that I guess we (wrongly) assumed that it would make sense.  This is
> the coordinate system used by the GPS system, and many other mapping
> and location systems.  It defines what latitude and longitude really
> mean.
> >
> > Regards,
> > Martin
> >
> > [1] The errors: the method element should be qualified with "gp:" and
> the timestamp element needed to be qualified with "dm:" and moved after
> the dm:device element.
> >
> >> - I have taken the effort of validating all the XML examples
> included
> >> in