Subject: Re: [Gen-art] Gen-ART Last Call review of draft-ietf-ospf-lls-05.txt

From: Abhay Roy <[email-masked]>
Date: Fri, 12 Dec 2008 21:19:17 -0800

Thanks for the review. Please see inline for comments..

On 11/5/2008 8:34 AM, Spencer Dawkins wrote:
> I have been selected as the General Area Review Team (Gen-ART)
> reviewer for this draft (for background on Gen-ART, please see
> http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).
> 
> Please resolve these comments along with any other Last Call comments
> you may receive.
> 
> 
> Document: draft-ietf-ospf-lls-05.txt
> Reviewer: Spencer Dawkins
> Review Date: 2008-11-05
> IETF LC End Date: 2008-11-10
> 
> Summary: This document is on the right track for publication as Proposed 
> Standard. I have a couple of 2119 questions.
> 
> Comments:
> 
>   The 16-bit LLS Data Length field contains the length (in 32-bit
>   words) of the LLS block including the header and payload.
>   Implementations MUST NOT use the Length field in the IP packet header
>   to determine the length of the LLS data block.
> 
> Spencer: I'm not sure this is a 2119 MUST NOT - aren't you just saying 
> that if you try it, you'll fail?

We discussed about it, and decided to remove the 2nd sentence above.

> 
>   The CA-TLV MUST only appear once in the the LLS block.  Also, when
>   present, this TLV SHOULD be the last TLV in the LLS block.
> 
> Spencer: Why SHOULD and not MUST? At a minimum, I would expect to see 
> some description of what should happen if CA-TLV is NOT the last TLV in 
> the LLS block - and if the expectation is that processing continues, I'm 
> not sure what this sentence means...

The thinking was we could have found the TLV at a "fixed" location to 
speed up authenticating the LLS block. But after discussing more on it, 
  we decided to get rid of this requirement.

I will make the changes in the next revision..

Regards,
-Abhay
_______________________________________________
Gen-art mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/gen-art

---

From: "Spencer Dawkins" <[email-masked]>
Date: Tue, 16 Dec 2008 11:51:10 -0600

Just as a heads-up - this document is on the agenda for the next telechat - 
I agree with Abhay's suggestions for changes that will appear in the "next 
revision", but the next revision hasn't come out yet, at least not that I've 
seen.

Thanks!

Spencer

----- Original Message ----- 
From: "Abhay Roy" <[email-masked]>
To: "Spencer Dawkins" <[email-masked]>
Cc: "Alex Zinin" <[email-masked]>; "Liem Nguyen" <[email-masked]>; "Barry 
Friedman" <[email-masked]>; "Derek Young" <[email-masked]>; 
<[email-masked]>; "General Area Review Team" <[email-masked]>; "David Ward" 
<[email-masked]>; "Acee Lindem" <[email-masked]>; "Abhay Roy" 
<[email-masked]>
Sent: Friday, December 12, 2008 11:19 PM
Subject: Re: Gen-ART Last Call review of draft-ietf-ospf-lls-05.txt

> speed up authenticating the LLS block. But after discussing more on it, we 
> decided to get rid of this requirement.
>

---

From: Liem Nguyen <[email-masked]>
Date: Wed, 17 Dec 2008 14:07:07 -0800

Abhay, Spencer:

Abhay Roy wrote:
>> Summary: This document is on the right track for publication as 
>> Proposed Standard. I have a couple of 2119 questions.
>>
>> Comments:
>>
>> Spencer: I'm not sure this is a 2119 MUST NOT - aren't you just 
>> saying that if you try it, you'll fail?
>
>> some description of what should happen if CA-TLV is NOT the last TLV 
>> in the LLS block - and if the expectation is that processing 
>> continues, I'm not sure what this sentence means...
>
> speed up authenticating the LLS block. But after discussing more on 
> it,  we decided to get rid of this requirement.

I think we should change it to MUST per Spencer's suggestion.  I.e., 
make the CA-TLV the last
in the LLS block.  This makes it much easier to authenticate the LLS 
block without including the CA-TLV.

Thanks,
Liem