Subject: Re: [Gen-art] Gen-ART review of draft-ietf-sieve-managesieve-05.txt

From: Alexey Melnikov <[email-masked]>
Date: Thu, 01 Jan 2009 19:43:26 +0300

Alexey Melnikov wrote:
> Miguel A. Garcia wrote:
>> I have been selected as the General Area Review Team (Gen-ART)
>> reviewer for this draft (for background on Gen-ART, please see
>> http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html).
>>
>> Please wait for direction from your document shepherd
>> or AD before posting a new version of the draft.
>>
>> Document: draft-ietf-sieve-managesieve-05.txt
>> Reviewer: Miguel Garcia <[email-masked]>
>> Review Date: 29 December 2008
>> IESG Telechat date: 18 December 2008
>> IETF LC End Date: 30 December 2008
>> Summary: The document is ready for publication as a proposed standard 
>> RFC.
 [...]
>> - there are a couple of "anchors" in the text. Just make sure these 
>> are deleted before publication, in particular anchor8, which 
>> describes Chris Newman's thoughts.
Actually, I would like to keep them till IESG review, because I would 
like what people like Tim Polk say about that.

_______________________________________________
Gen-art mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/gen-art

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 01 Jan 2009 22:28:11 +0300

Alexey Melnikov wrote:
>> Major issues: none
> Hi Miguel,
> Thank you for your review!
>> Minor issues:
>>
>> - Section 1.2 could be slightly improved to guide the reader over the 
>> rest of the document by describing, at the very beginning, that "this 
>> is a command-response protocol based on a client/server architecture. 
>> The client emits a command; the server processes the command and 
>> replies with a response" (or something like that).
I've added a new section on this.
>> I am also missing a sentence indicating that "the protocol runs over 
>> any connection-oriented transport protocol, although at the moment, 
>> TCP (and TCP over TLS) are the only defined transport protocols".
> Ok, I will think about adding something like this.
After thinking more about this: I would rather not say that. The 
document is quite clear that it assumes TCP.

---

From: "Miguel A. Garcia" <[email-masked]>
Date: Wed, 07 Jan 2009 08:45:43 +0100

> document is quite clear that it assumes TCP.
Sure, the document is clear about the usage of TCP, but this aspect is 
not mentioned until Section 1.9 on page 11. I thought that solving this 
question in Section 1.2 will help the reader with the understanding of 
the protocol.

/Miguel

-- 
Miguel A. Garcia
+34-91-339-3608
Ericsson Spain