Subject: [Gen-art] review of draft-ietf-pcn-architecture-09.txt

From: Francis Dupont <[email-masked]>
Date: Mon, 23 Feb 2009 17:06:26 +0100

I have been selected as the General Area Review Team (Gen-ART) 
reviewer for this draft (for background on Gen-ART, please see 
http://www.alvestrand.no/ietf/gen/art/gen-art-FAQ.html). 

Please resolve these comments along with any other Last Call comments 
you may receive. 

Document: draft-ietf-pcn-architecture-09.txt
Reviewer: Francis Dupont
Review Date: 2009-02-23
IETF LC End Date: 2009-02-24
IESG Telechat date: 2009-02-26

Summary: Ready

Major issues: none

Minor issues: 
 - you received some LC comments (addressed)
 - I support any good proposal to make the document shorter
 - IMHO the Appendix should be moved at the end of the document.

Nits/editorial comments: 
 - global spelling (IMHO to look at with the RFC Editor):
  * behaviour -> behavior
  * centralised -> centralized
  * colouring -> coloring (colour -> color)
  * minimises -> minimizes (minimising -> minimizing)
  * optimises -> optimizes
  * recognise -> recognize
  * signalling -> signaling (signalled -> signaled
  * standardised -> standardized (standardises -> standardizes)
  * tunnelling -> tunneling (tunnelled -> tunneled)
  * utilisation -> utilization
  (both are correct but the second form seems to be the RFC style one,
   i.e., British vs US... note the next one has for sure to be fixed)
 - ToC page 3: Acknowledgements -> Acknowledgments
 - 1 page 4: I propose to use the 'quality of service' at the 3rd line
  to introduce the QoS abbrev
 - 1 page 4: The PCN abbrev should be introduced the first time it is
  used (general rule for all not-trivial abbrevs which are in the body
  of the text)
 - 1 page 5: DSCP and ECN abbrevs should be introduced and IMHO you should
  add some references too (RFC 2474 and 3168 for instance?)
 - 3 page 7: even I understand you don't like the "i.e.," and "e.g.," style
  it is the RFC style (i.e., (ie) you should discuss about this in the
  ietf mailing list, or at the RFC Editor presentation Sunday 22)
 - 3 page 8: fibre -> fiber (i.e., US spelling...)
 - 4 page 10 figure: add an extra '^' on the top of the other at the first
  line (the '^' glyph is usually pretty small so hard to see)
  (same 6.3 page 18 figure 2)
 - 4 page 11: please introduce RSVP and NSIS abbrevs and add some references
  (in particular for NSIS which is not (yet) well known)
 - 7.2 page 21: add the protocol in the filter spec
 - 7.6 page 24: RSVP Path -> RSVP PATH
 - 7.7 page 25: IPSec -> IPsec (i.e., if you cite RFC 4301 you should
  remember its 1.1 :-)
 - 7.7 page 25: please introduce the ECMP abbrev and add an internal reference
 to section 8 Challenges (ECMP is its first item)
 - 9.1.1 page 32: filterspec -> filter spec
 - 9.2 page 33: probability etc -> probability, etc
 - 13 page 37: Acknowledgements -> Acknowledgments
 - 15.1 page 38: I confirm the changes are good!
 - 16 page 44: IMHO the Appendix should be at the end (i.e., between
  the Author's Address and (to be added) Copyright notice)
 - 17.2 page 52 PCN08-1: add a '(work in progress)'
 - 17.2 page 54 Style: IMHO you'll have to remove it (:-).

Regards

[email-masked]

PS: I understand why you prefer the British spelling... this is why
I suggest you negociate this point with the RFC Editor. Note that at
the exception of `Acknowledgments' this doesn't really matter and
there are already examples of RFCs in both styles.

---

From: <[email-masked]>
Date: Tue, 24 Feb 2009 10:16:31 -0000

Francis
 
thanks very much for your very close review. 
 
 On the general point of style (such as british vs american spelling), i found rfc editor guidance (i forget in which document) that basically said 'you can do what you like provided you're consistent' - although as you say, expect will have to discuss a few things with them. i'll introduce the abbreviations better. 
 
thanks
best wishes
phil

________________________________

From: Francis Dupont [mailto:[email-masked]]
Sent: Mon 23/02/2009 16:06
To: [email-masked]
Cc: Eardley,PL,Philip,CXR9 R; [email-masked]
Subject: review of draft-ietf-pcn-architecture-09.txt

Summary: Ready

Major issues: none

Minor issues:

Nits/editorial comments:

Regards