Subject: Re: [Gen-art] Gen-ART review of draft-ietf-kitten-gssapi-channel-bindings-06.txt

From: Nicolas Williams <[email-masked]>
Date: Mon, 6 Apr 2009 10:35:23 -0500

On Sun, Apr 05, 2009 at 10:30:21AM +1200, Brian E Carpenter wrote:
> Summary: Almost ready; needs one clarification.
> 
> Comments: 
> 
> I was expecting the sentence quoted below to be updated
> following Nico's comments on my Last Call comment. I think the new
> text would be
> 
>     Where the language binding of the GSS-API model's channel bindings is as 
>     single OCTET STRINGs (or the language's equivalent), then the implementation
>     SHOULD assume that the given bindings correspond only to the
>     application-data field of GSS-CHANNEL-BINDINGS as shown above.

Oops, sorry I missed that edit.  I'll submit a revised I-D shortly --
I'll s/is as/is as a/.

Nico
--

---

From: Nicolas Williams <[email-masked]>
Date: Mon, 6 Apr 2009 10:42:06 -0500

> Oops, sorry I missed that edit.  I'll submit a revised I-D shortly --

Er, no, I did update that.  I replaced the above with:

   Where a language binding of the GSS-API models channel bindings as
   OCTET STRINGs (or the language's equivalent), then the implementation
   MUST assume that the given bindings correspond only to the
   application-data field of GSS-CHANNEL-BINDINGS as shown above, rather
   than some encoding of GSS-CHANNEL-BINDINGS.

I think that's clearer.

Nico
--

---

From: Brian E Carpenter <[email-masked]>
Date: Tue, 07 Apr 2009 09:09:03 +1200

Nico,

The paragraph is identical in the -05 and -06 drafts,
so no, actually you didn't change anything after my review.
I still find the text a little unclear.

I don't feel strongly about this; Russ has just logged it
as a comment, so it's up to you and Tim whether to change
anything.

    Brian

---

From: Nicolas Williams <[email-masked]>
Date: Mon, 6 Apr 2009 16:51:13 -0500

> so no, actually you didn't change anything after my review.

It differs rather slightly.  I guess the current form still strikes me
as clear so I didn't realize that I hadn't really changed it.  I'll
re-work it.